]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- updated to 6.2.1
[packages/Mesa.git] / Mesa.spec
1 #
2 # Conditional build:
3 %bcond_with     glide   # with GLIDE (broken now)
4 %bcond_with     xlibs   # use xlibs deps
5 #
6 Summary:        Free OpenGL implementation
7 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
8 Name:           Mesa
9 Version:        6.2.1
10 Release:        1
11 License:        MIT (core), LGPL (MesaGLU), SGI (GLU,libGLw) and others - see COPYRIGHT file
12 Group:          X11/Libraries
13 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
14 # Source0-md5:  f43228cd2bf70f583ef3275c1c545421
15 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
16 # Source1-md5:  3cac74667b50bcbd4f67f594fb4224a2
17 Patch0:         %{name}-opt.patch
18 URL:            http://www.mesa3d.org/
19 %ifarch %{ix86} alpha
20 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
21 %{?with_glide:Requires: Glide3-DRI}
22 %endif
23 %if %{with xlibs}
24 BuildRequires:  libXmu-devel
25 BuildRequires:  libXp-devel
26 %else
27 BuildRequires:  XFree86-devel
28 %endif
29 BuildRequires:  autoconf >= 2.50
30 BuildRequires:  automake
31 BuildRequires:  libtool >= 2:1.4d
32 BuildRequires:  motif-devel
33 BuildRequires:  %{__perl}
34 Provides:       OpenGL = 1.5
35 Provides:       OpenGL-GLU = 1.3
36 # reports version 1.3, but supports glXGetProcAddress() from 1.4
37 Provides:       OpenGL-GLX = 1.4
38 Obsoletes:      XFree86-OpenGL-libGL
39 Obsoletes:      XFree86-OpenGL-libs
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # avoid XFree86-OpenGL* dependency
43 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
45
46 %define         _sysconfdir     /etc/X11
47
48 %description
49 Mesa is a 3-D graphics library with an API which is very similar to
50 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
51 syntax or state machine, it is being used with authorization from
52 Silicon Graphics, Inc. However, the author does not possess an OpenGL
53 license from SGI, and makes no claim that Mesa is in any way a
54 compatible replacement for OpenGL or associated with SGI.
55
56 %description -l pl
57 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
58 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
59 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
60 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
61 OpenGL ani powi±zana z SGI.
62
63 %package devel
64 Summary:        Development environment for Mesa
65 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 %if %{with xlibs}
69 Requires:       libX11-devel
70 Requires:       libXp-devel
71 %else
72 Requires:       XFree86-devel
73 %endif
74 Provides:       OpenGL-devel = 1.5
75 Provides:       OpenGL-GLU-devel = 1.3
76 Provides:       OpenGL-GLX-devel = 1.4
77 Obsoletes:      XFree86-OpenGL-devel
78 Obsoletes:      XFree86-OpenGL-devel-base
79
80 %description devel
81 Header files and documentation needed for development.
82
83 %description devel -l pl
84 Pliki nag³ówkowe i dokumentacja do Mesy.
85
86 %package static
87 Summary:        Mesa static libraries
88 Summary(pl):    Biblioteki statyczne Mesy
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Provides:       OpenGL-static = 1.5
92 Provides:       OpenGL-GLU-static = 1.3
93 Obsoletes:      XFree86-OpenGL-static
94
95 %description static
96 The static version of the Mesa libraries.
97
98 %description static -l pl
99 Biblioteki statyczne Mesy.
100
101 %package demos
102 Summary:        Mesa Demos
103 Summary(pl):    Demonstracje mo¿liwo¶ci bibliotek Mesa
104 Group:          Development/Libraries
105 Requires:       OpenGL-devel
106
107 %description demos
108 Demonstration programs for the Mesa libraries.
109
110 %description demos -l pl
111 Programy demonstracyjne dla bibliotek Mesa.
112
113 %prep
114 %setup -q -n Mesa-%{version} -b 1
115 %patch0 -p1
116
117 # fix demos
118 %{__perl} -pi -e "s,\.\./images/,%{_examplesdir}/Mesa/images/,g" progs/demos/*
119
120 %build
121 %ifarch %{ix86}
122 targ=linux-x86
123 %else
124 targ=linux
125 %endif
126
127 %{__make} ${targ}-static \
128         CC="%{__cc}" \
129         CXX="%{__cxx}" \
130         OPT="%{rpmcflags}" \
131         XLIB_DIR=/usr/X11R6/%{_lib} \
132         GLW_SOURCES="GLwDrawA.c GLwMDrawA.c"
133 mv -f lib lib-static
134 %{__make} clean
135 %{__make} ${targ} \
136         CC="%{__cc}" \
137         CXX="%{__cxx}" \
138         OPT="%{rpmcflags}" \
139         XLIB_DIR=/usr/X11R6/%{_lib}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/GL,%{_mandir}/man3,%{_examplesdir}/Mesa}
144
145 cp -df lib-static/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
146 cp -df lib/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
147 cp -rf include/GL/{gl*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
148 rm -f $RPM_BUILD_ROOT%{_includedir}/GL/glut*
149
150 for l in demos redbook samples xdemos ; do
151         %{__make} -C progs/$l clean
152 done
153 for l in demos redbook samples util xdemos images ; do
154         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/Mesa/$l
155 done
156 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/Mesa/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
167 %attr(755,root,root) %{_libdir}/libGL.so.*.*
168 %attr(755,root,root) %{_libdir}/libGL.so
169 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
170 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %doc docs/*.spec
175 %attr(755,root,root) %{_libdir}/libGLU.so
176 %attr(755,root,root) %{_libdir}/libOSMesa.so
177 %{_libdir}/libGLw.a
178 %dir %{_includedir}/GL
179 %{_includedir}/GL/GLwDrawA.h
180 %{_includedir}/GL/GLwDrawAP.h
181 %{_includedir}/GL/GLwMDrawA.h
182 %{_includedir}/GL/GLwMDrawAP.h
183 %{_includedir}/GL/gl.h
184 %{_includedir}/GL/glext.h
185 %{_includedir}/GL/gl_mangle.h
186 %{_includedir}/GL/glu.h
187 %{_includedir}/GL/glu_mangle.h
188 %{_includedir}/GL/glx.h
189 %{_includedir}/GL/glxext.h
190 %{_includedir}/GL/glx_mangle.h
191 %{_includedir}/GL/osmesa.h
192 %{_includedir}/GL/xmesa.h
193 %{_includedir}/GL/xmesa_x.h
194 %{_includedir}/GL/xmesa_xf86.h
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libGL.a
199 %{_libdir}/libGLU.a
200 %{_libdir}/libOSMesa.a
201
202 %files demos
203 %defattr(644,root,root,755)
204 %{_examplesdir}/Mesa
This page took 0.69881 seconds and 4 git commands to generate.