]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- typo
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_with     gallium_nouveau
13 %bcond_without  motif   # build static libGLw without Motif interface
14 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
15 %bcond_without  osmesa  # don't build osmesa
16 %bcond_with     static
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.19
26 %define         dri2proto_ver   1.99.3
27 %define         glproto_ver     1.4.11
28 #
29 Summary:        Free OpenGL implementation
30 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
31 Name:           Mesa
32 Version:        7.8.2
33 Release:        1%{?with_multigl:.mgl}
34 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
35 Group:          X11/Libraries
36 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
37 # Source0-md5:  6be2d343a0089bfd395ce02aaf8adb57
38 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
39 # Source1-md5:  757d9e2e06f48b1a52848be9b0307ced
40 Patch0:         %{name}-realclean.patch
41 Patch1:         %{name}-tgsi_dump.patch
42 URL:            http://www.mesa3d.org/
43 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
44 BuildRequires:  autoconf
45 BuildRequires:  automake
46 BuildRequires:  expat-devel
47 #%%{?with_demos:BuildRequires:  glew-devel}
48 BuildRequires:  libdrm-devel >= %{libdrm_ver}
49 BuildRequires:  libselinux-devel
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  libtool >= 2:1.4d
52 %{?with_motif:BuildRequires:    motif-devel}
53 BuildRequires:  pixman-devel
54 BuildRequires:  pkgconfig
55 BuildRequires:  python
56 BuildRequires:  python-modules
57 BuildRequires:  rpmbuild(macros) >= 1.470
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  xorg-lib-libXdamage-devel
60 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
61 BuildRequires:  xorg-lib-libXt-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
64 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
65 BuildRequires:  xorg-util-makedepend
66 BuildRequires:  xorg-xserver-server-devel
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %if %{without gallium}
70 %undefine       with_gallium_intel
71 %endif
72
73 %description
74 Mesa is a 3-D graphics library with an API which is very similar to
75 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
76 syntax or state machine, it is being used with authorization from
77 Silicon Graphics, Inc. However, the author does not possess an OpenGL
78 license from SGI, and makes no claim that Mesa is in any way a
79 compatible replacement for OpenGL or associated with SGI.
80
81 %description -l pl.UTF-8
82 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
83 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
84 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
85 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
86 OpenGL ani powiązana z SGI.
87
88 %package libGL
89 Summary:        Free Mesa3D implementation of libGL OpenGL library
90 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
91 License:        MIT
92 Group:          X11/Libraries
93 Requires:       libdrm >= %{libdrm_ver}
94 Provides:       OpenGL = 2.1
95 # reports version 1.3, but supports glXGetProcAddress() from 1.4
96 Provides:       OpenGL-GLX = 1.4
97 Obsoletes:      Mesa
98 Obsoletes:      Mesa-dri
99 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
100 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
101
102 %description libGL
103 Mesa is a 3-D graphics library with an API which is very similar to
104 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
105 syntax or state machine, it is being used with authorization from
106 Silicon Graphics, Inc. However, the author does not possess an OpenGL
107 license from SGI, and makes no claim that Mesa is in any way a
108 compatible replacement for OpenGL or associated with SGI.
109
110 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
111 specifications. It uses DRI for rendering.
112
113 %description libGL -l pl.UTF-8
114 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
115 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
116 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
117 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
118 OpenGL ani powiązana z SGI.
119
120 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
121 GLX 1.4. Używa DRI do renderowania.
122
123 %package libGL-devel
124 Summary:        Header files for Mesa3D libGL library
125 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
126 License:        MIT
127 Group:          X11/Development/Libraries
128 # loose dependency on libGL to use with other libGL binaries
129 Requires:       OpenGL >= 1.5
130 Requires:       libdrm-devel >= %{libdrm_ver}
131 Requires:       xorg-lib-libX11-devel
132 Requires:       xorg-lib-libXdamage-devel
133 Requires:       xorg-lib-libXext-devel
134 Requires:       xorg-lib-libXxf86vm-devel
135 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
136 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
137 Suggests:       OpenGL-doc-man
138 Provides:       OpenGL-GLX-devel = 1.4
139 Provides:       OpenGL-devel = 2.1
140 Obsoletes:      Mesa-devel
141 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
142 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
143 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
144 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
145
146 %description libGL-devel
147 Header files for Mesa3D libGL library.
148
149 %description libGL-devel -l pl.UTF-8
150 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
151
152 %package libGL-static
153 Summary:        Static Mesa3D libGL library
154 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
155 License:        MIT
156 Group:          X11/Development/Libraries
157 Requires:       %{name}-libGL-devel = %{version}-%{release}
158 Provides:       OpenGL-static = 2.1
159 Obsoletes:      Mesa-static
160 Obsoletes:      X11-OpenGL-static < 1:7.0.0
161 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
162
163 %description libGL-static
164 Static Mesa3D libGL library. It uses software renderer.
165
166 %description libGL-static -l pl.UTF-8
167 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
168 renderingu.
169
170 %package libGLU
171 Summary:        SGI implementation of libGLU OpenGL library
172 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
173 License:        SGI Free Software License B v2.0 (MIT-like)
174 Group:          Libraries
175 # loose dependency on libGL.so.1 to use with other libGL binaries
176 Requires:       OpenGL >= 1.2
177 Provides:       OpenGL-GLU = 1.3
178 Obsoletes:      Mesa-devel
179 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
180 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
181
182 %description libGLU
183 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
184 1.3 specifications.
185
186 %description libGLU -l pl.UTF-8
187 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
188 specyfikację OpenGL GLU 1.3.
189
190 %package libGLU-devel
191 Summary:        Header files for SGI libGLU library
192 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
193 License:        SGI Free Software License B v2.0 (MIT-like)
194 Group:          Development/Libraries
195 Requires:       %{name}-libGLU = %{version}-%{release}
196 Requires:       OpenGL-devel >= 1.2
197 Requires:       libstdc++-devel
198 Provides:       OpenGL-GLU-devel = 1.3
199
200 %description libGLU-devel
201 Header files for SGI libGLU library.
202
203 %description libGLU-devel -l pl.UTF-8
204 Pliki nagłówkowe biblioteki SGI libGLU.
205
206 %package libGLU-static
207 Summary:        Static SGI libGLU library
208 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
209 License:        SGI Free Software License B v2.0 (MIT-like)
210 Group:          Development/Libraries
211 Requires:       %{name}-libGLU-devel = %{version}-%{release}
212 Provides:       OpenGL-GLU-static = 1.3
213
214 %description libGLU-static
215 Static SGI libGLU library.
216
217 %description libGLU-static -l pl.UTF-8
218 Statyczna biblioteka SGI libGLU.
219
220 %package libGLw
221 Summary:        SGI OpenGL Xt widgets library
222 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
223 License:        SGI MIT-like
224 Group:          Libraries
225 # loose dependency on libGL.so.1 to use with other libGL binaries
226 Requires:       OpenGL >= 1.1
227 Provides:       OpenGL-GLw
228
229 %description libGLw
230 SGI OpenGL Xt widgets library.
231
232 %description libGLU -l pl.UTF-8
233 Biblioteka SGI widgetów Xt dla OpenGL-a.
234
235 %package libGLw-devel
236 Summary:        Header files for SGI libGLw library
237 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
238 License:        SGI MIT-like
239 Group:          Development/Libraries
240 Requires:       %{name}-libGLw = %{version}-%{release}
241 Requires:       OpenGL-devel >= 1.2
242 Provides:       OpenGL-GLw-devel
243
244 %description libGLw-devel
245 Header files for SGI libGLw library.
246
247 %description libGLw-devel -l pl.UTF-8
248 Pliki nagłówkowe biblioteki SGI libGLw.
249
250 %package libGLw-static
251 Summary:        Static SGI libGLw library
252 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
253 License:        SGI MIT-like
254 Group:          Development/Libraries
255 Requires:       %{name}-libGLw-devel = %{version}-%{release}
256 Provides:       OpenGL-GLw-static
257
258 %description libGLw-static
259 Static SGI libGLw library.
260
261 %description libGLw-static -l pl.UTF-8
262 Statyczna biblioteka SGI libGLw.
263
264 %package libOSMesa
265 Summary:        OSMesa (off-screen renderer) library
266 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
267 License:        MIT
268 Group:          Libraries
269 # doesn't require base
270
271 %description libOSMesa
272 OSMesa (off-screen renderer) library.
273
274 %description libOSMesa -l pl.UTF-8
275 Biblioteka OSMesa (renderująca bitmapy w pamięci).
276
277 %package libOSMesa-devel
278 Summary:        Header file for OSMesa (off-screen renderer) library
279 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
280 License:        MIT
281 Group:          Development/Libraries
282 Requires:       %{name}-libOSMesa = %{version}-%{release}
283 # for <GL/gl.h> only
284 Requires:       OpenGL-devel
285
286 %description libOSMesa-devel
287 Header file for OSMesa (off-screen renderer) library.
288
289 %description libOSMesa-devel -l pl.UTF-8
290 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
291
292 %package libOSMesa-static
293 Summary:        Static OSMesa (off-screen renderer) library
294 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
295 License:        MIT
296 Group:          Development/Libraries
297 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
298 # this static build of OSMesa needs static non-dri Mesa implementation
299 Requires:       %{name}-libGL-static = %{version}-%{release}
300
301 %description libOSMesa-static
302 Static OSMesa (off-screen renderer) library.
303
304 %description libOSMesa-static -l pl.UTF-8
305 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
306
307 %package utils
308 Summary:        OpenGL utilities from Mesa3D
309 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
310 License:        MIT
311 Group:          X11/Applications/Graphics
312 # loose deps on libGL/libGLU
313
314 %description utils
315 OpenGL utilities from Mesa3D: glxgears and glxinfo.
316
317 %description utils -l pl.UTF-8
318 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
319
320 %package demos
321 Summary:        Mesa Demos source code
322 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
323 License:        various (MIT, SGI, GPL - see copyright notes in sources)
324 Group:          Development/Libraries
325 Requires:       OpenGL-devel
326
327 %description demos
328 Demonstration programs for the Mesa libraries in source code form.
329
330 %description demos -l pl.UTF-8
331 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
332
333 %package dri-driver-ati-mach64
334 Summary:        X.org DRI driver for ATI Mach64 card family
335 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
336 License:        MIT
337 Group:          X11/Libraries
338 Requires:       xorg-driver-video-mach64
339 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
340 Requires:       xorg-xserver-server >= %{xserver_ver}
341
342 %description dri-driver-ati-mach64
343 X.org DRI driver for ATI Mach64 card family.
344
345 %description dri-driver-ati-mach64 -l pl.UTF-8
346 Sterownik X.org DRI dla rodziny kart ATI Mach64.
347
348 %package dri-driver-ati-radeon-R100
349 Summary:        X.org DRI driver for ATI R100 card family
350 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
351 License:        MIT
352 Group:          X11/Libraries
353 Requires:       xorg-driver-video-ati
354 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
355 Requires:       xorg-xserver-server >= %{xserver_ver}
356 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
357
358 %description dri-driver-ati-radeon-R100
359 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
360
361 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
362 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
363
364 %package dri-driver-ati-radeon-R200
365 Summary:        X.org DRI driver for ATI R200 card family
366 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
367 License:        MIT
368 Group:          X11/Libraries
369 Requires:       xorg-driver-video-ati
370 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
371 Requires:       xorg-xserver-server >= %{xserver_ver}
372 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
373
374 %description dri-driver-ati-radeon-R200
375 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
376
377 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
378 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
379
380 %package dri-driver-ati-radeon-R300
381 Summary:        X.org DRI driver for ATI R300 card family
382 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
383 License:        MIT
384 Group:          X11/Libraries
385 Requires:       xorg-driver-video-ati
386 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
387 Requires:       xorg-xserver-server >= %{xserver_ver}
388 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
389
390 %description dri-driver-ati-radeon-R300
391 X.org DRI driver for ATI R300 card family.
392
393 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
394 Sterownik X.org DRI dla rodziny kart ATI R300.
395
396 %package dri-driver-ati-radeon-R600
397 Summary:        X.org DRI driver for ATI R600 card family
398 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
399 License:        MIT
400 Group:          X11/Libraries
401 Requires:       radeon-ucode
402 Requires:       xorg-driver-video-ati
403 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
404 Requires:       xorg-xserver-server >= %{xserver_ver}
405
406 %description dri-driver-ati-radeon-R600
407 X.org DRI driver for ATI R600 card family.
408
409 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
410 Sterownik X.org DRI dla rodziny kart ATI R600.
411
412 %package dri-driver-ati-rage128
413 Summary:        X.org DRI driver for ATI Rage128 card family
414 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
415 License:        MIT
416 Group:          X11/Libraries
417 Requires:       xorg-driver-video-r128
418 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
419 Requires:       xorg-xserver-server >= %{xserver_ver}
420 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
421
422 %description dri-driver-ati-rage128
423 X.org DRI driver for ATI Rage128 card family.
424
425 %description dri-driver-ati-rage128 -l pl.UTF-8
426 Sterownik X.org DRI dla rodziny kart ATI Rage128.
427
428 %package dri-driver-ffb
429 Summary:        X.org DRI driver for Sun FFB card family
430 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
431 License:        MIT
432 Group:          X11/Libraries
433 Requires:       xorg-driver-video-sunffb
434 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
435 Requires:       xorg-xserver-server >= %{xserver_ver}
436
437 %description dri-driver-ffb
438 X.org DRI driver for SUN Creator3D and Elite3D card family.
439
440 %description dri-driver-ffb -l pl.UTF-8
441 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
442
443 %package dri-driver-glint
444 Summary:        X.org DRI driver for GLINT/Permedia card family
445 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
446 License:        MIT
447 Group:          X11/Libraries
448 Requires:       xorg-driver-video-glint
449 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
450 Requires:       xorg-xserver-server >= %{xserver_ver}
451 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
452
453 %description dri-driver-glint
454 X.org DRI driver for GLINT/Permedia card family.
455
456 %description dri-driver-glint -l pl.UTF-8
457 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
458
459 %package dri-driver-intel-i810
460 Summary:        X.org DRI driver for Intel i810 card family
461 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
462 License:        MIT
463 Group:          X11/Libraries
464 Requires:       xorg-driver-video-intel
465 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
466 Requires:       xorg-xserver-server >= %{xserver_ver}
467 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
468
469 %description dri-driver-intel-i810
470 X.org DRI driver for Intel i810 card family.
471
472 %description dri-driver-intel-i810 -l pl.UTF-8
473 Sterownik X.org DRI dla rodziny kart Intel i810.
474
475 %package dri-driver-intel-i915
476 Summary:        X.org DRI driver for Intel i915 card family
477 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
478 License:        MIT
479 Group:          X11/Libraries
480 Requires:       xorg-driver-video-intel
481 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
482 Requires:       xorg-xserver-server >= %{xserver_ver}
483 Obsoletes:      Mesa-dri-driver-intel-i830
484 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
485
486 %description dri-driver-intel-i915
487 X.org DRI driver for Intel i915 card family.
488
489 %description dri-driver-intel-i915 -l pl.UTF-8
490 Sterownik X.org DRI dla rodziny kart Intel i915.
491
492 %package dri-driver-intel-i965
493 Summary:        X.org DRI driver for Intel i965 card family
494 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
495 License:        MIT
496 Group:          X11/Libraries
497 Requires:       xorg-driver-video-intel
498 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
499 Requires:       xorg-xserver-server >= %{xserver_ver}
500 Obsoletes:      Mesa-dri-driver-intel-i830
501 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
502
503 %description dri-driver-intel-i965
504 X.org DRI driver for Intel i965 card family.
505
506 %description dri-driver-intel-i965 -l pl.UTF-8
507 Sterownik X.org DRI dla rodziny kart Intel i965.
508
509 %package dri-driver-matrox
510 Summary:        X.org DRI driver for Matrox G card family
511 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
512 License:        MIT
513 Group:          X11/Libraries
514 Requires:       xorg-driver-video-mga
515 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
516 Requires:       xorg-xserver-server >= %{xserver_ver}
517 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
518
519 %description dri-driver-matrox
520 X.org DRI drivers for Matrox G card family.
521
522 %description dri-driver-matrox -l pl.UTF-8
523 Sterowniki X.org DRI dla rodziny kart Matrox G.
524
525 %package dri-driver-nouveau
526 Summary:        X.org DRI driver for NVIDIA card family
527 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
528 License:        MIT
529 Group:          X11/Libraries
530 Requires:       xorg-driver-video-nouveau
531 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
532 Requires:       xorg-xserver-server >= %{xserver_ver}
533
534 %description dri-driver-nouveau
535 X.org DRI drivers for NVIDIA card family.
536
537 %description dri-driver-nouveau -l pl.UTF-8
538 Sterowniki X.org DRI dla rodziny kart NVIDIA.
539
540 %package dri-driver-savage
541 Summary:        X.org DRI driver for S3 Savage card family
542 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
543 License:        MIT
544 Group:          X11/Libraries
545 Requires:       xorg-driver-video-savage
546 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
547 Requires:       xorg-xserver-server >= %{xserver_ver}
548
549 %description dri-driver-savage
550 X.org DRI driver for S3 Savage card family.
551
552 %description dri-driver-savage -l pl.UTF-8
553 Sterownik X.org DRI dla rodziny kart S3 Savage.
554
555 %package dri-driver-sis
556 Summary:        X.org DRI driver for SiS card family
557 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
558 License:        MIT
559 Group:          X11/Libraries
560 Requires:       xorg-driver-video-sis
561 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
562 Requires:       xorg-xserver-server >= %{xserver_ver}
563 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
564
565 %description dri-driver-sis
566 X.org DRI driver for SiS card family.
567
568 %description dri-driver-sis -l pl.UTF-8
569 Sterownik X.org DRI dla rodziny kart SiS.
570
571 %package dri-driver-swrast
572 Summary:        X.org DRI software rasterizer driver
573 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
574 License:        MIT
575 Group:          X11/Libraries
576 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
577 Requires:       xorg-xserver-server >= %{xserver_ver}
578
579 %description dri-driver-swrast
580 X.org DRI software rasterizer driver.
581
582 %description dri-driver-swrast -l pl.UTF-8
583 Sterownik X.org DRI obsługujący rysowanie programowe.
584
585 %package dri-driver-tdfx
586 Summary:        X.org DRI driver for 3DFX Voodoo card family
587 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
588 License:        MIT
589 Group:          X11/Libraries
590 Requires:       Glide3-DRI
591 Requires:       xorg-driver-video-tdfx
592 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
593 Requires:       xorg-xserver-server >= %{xserver_ver}
594 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
595
596 %description dri-driver-tdfx
597 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
598 and Velocity 100/200).
599
600 %description dri-driver-tdfx -l pl.UTF-8
601 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
602 Banshee i Velocity 100/200).
603
604 %package dri-driver-via-unichrome
605 Summary:        X.org DRI driver for VIA Unichrome card family
606 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
607 License:        MIT
608 Group:          X11/Libraries
609 Requires:       xorg-driver-video-openchrome
610 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
611 Requires:       xorg-xserver-server >= %{xserver_ver}
612
613 %description dri-driver-via-unichrome
614 X.org DRI driver for VIA Unichrome card family.
615
616 %description dri-driver-via-unichrome -l pl.UTF-8
617 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
618
619 %package dri-driver-vmwgfx
620 Summary:        X.org DRI driver for VMware
621 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
622 License:        MIT
623 Group:          X11/Libraries
624 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
625 Requires:       xorg-xserver-server >= %{xserver_ver}
626
627 %description dri-driver-vmwgfx
628 X.org DRI driver for VMWare.
629
630 %description dri-driver-vmwgfx -l pl.UTF-8
631 Sterownik X.org DRI dla VMware.
632
633 %prep
634 %setup -q -b1
635 %patch0 -p0
636 %patch1 -p1
637
638 # fix demos
639 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
640
641 %build
642 autoreconf --install
643 #%{__aclocal}
644 #%{__autoconf}
645
646 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
647 %if %{without gallium_intel}
648 i915 \
649 %endif
650 %ifarch sparc sparcv9 sparc64
651 ffb \
652 %endif
653 %ifarch %{ix86} %{x8664}
654 sis \
655 %endif
656 swrast tdfx unichrome"
657
658 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
659
660 common_flags="\
661         --enable-shared \
662         --enable-selinux \
663         --enable-pic \
664         --enable-glx-tls \
665         --disable-glut \
666         --disable-os-mesa \
667         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
668         --with%{!?with_demos:out}-demos"
669
670 osmesa_common_flags="\
671         --with-driver=osmesa \
672         --disable-asm \
673         --disable-glu"
674
675 %if %{with osmesa}
676 # osmesa variants
677 %configure $common_flags $osmesa_common_flags \
678         --with-osmesa-bits=8
679 %{__make}
680 mv %{_lib} osmesa8
681 %{__make} clean
682
683 %configure $common_flags $osmesa_common_flags \
684         --with-osmesa-bits=16
685 %{__make}
686 mv %{_lib} osmesa16
687 %{__make} clean
688
689 %configure $common_flags $osmesa_common_flags \
690         --with-osmesa-bits=32
691 %{__make}
692 mv %{_lib} osmesa32
693 %{__make} clean
694 %endif
695
696 %configure $common_flags \
697 %if %{with gallium}
698         --enable-gallium \
699         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
700         --enable-gallium-svga \
701 %{?with_gallium_nouveau:--enable-gallium-nouveau} \
702         --with-state-trackers=dri,xorg,glx \
703 %else
704         --disable-gallium \
705 %endif
706         --with-driver=dri \
707         --with-dri-drivers=${dri_drivers} \
708         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
709
710 %{__make}
711 %{__make} -C progs/xdemos glxgears glxinfo
712 %if %{with demos}
713 %{__make} -C progs/demos
714 %endif
715
716 %install
717 rm -rf $RPM_BUILD_ROOT
718
719 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
720
721 # libs without drivers
722 %{__make} install \
723         DESTDIR=$RPM_BUILD_ROOT
724
725 %if %{with osmesa}
726 rm -f osmesa*/libGLEW.*
727 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
728 %endif
729
730 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
731 # work on copy to keep -bi --short-circuit working
732 rm -rf progs-clean
733 install -d progs-clean
734 for l in demos glsl osdemos redbook samples xdemos ; do
735         cp -a progs/$l progs-clean/$l
736         %{__make} -C progs-clean/$l clean
737         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
738 done
739 rm -rf progs-clean
740 for l in util images ; do
741         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
742 done
743 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
744
745 # strip out undesirable headers
746 olddir=$(pwd)
747 cd $RPM_BUILD_ROOT%{_includedir}/GL
748 rm [a-fh-np-wyz]*.h glf*.h
749 cd $RPM_BUILD_ROOT%{_libdir}
750 cd $olddir
751
752 %if %{with multigl}
753 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
754
755 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
756 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
757
758 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
759 %endif
760
761 %clean
762 rm -rf $RPM_BUILD_ROOT
763
764 %post   libGL -p /sbin/ldconfig
765 %postun libGL -p /sbin/ldconfig
766
767 %post   libGLU -p /sbin/ldconfig
768 %postun libGLU -p /sbin/ldconfig
769
770 %post   libGLw -p /sbin/ldconfig
771 %postun libGLw -p /sbin/ldconfig
772
773 %files libGL
774 %defattr(644,root,root,755)
775 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
776 %if %{with multigl}
777 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
778 %dir %{_libdir}/Mesa
779 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
780 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
781 %else
782 %attr(755,root,root) %{_libdir}/libGL.so.*.*
783 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
784 # symlink for binary apps which fail to conform Linux OpenGL ABI
785 # (and dlopen libGL.so instead of libGL.so.1)
786 %attr(755,root,root) %{_libdir}/libGL.so
787 %endif
788
789 %files libGL-devel
790 %defattr(644,root,root,755)
791 %doc docs/*.spec
792 %if %{with multigl}
793 %attr(755,root,root) %{_libdir}/libGL.so
794 %endif
795 %dir %{_includedir}/GL
796 %{_includedir}/GL/gl.h
797 %{_includedir}/GL/glext.h
798 %{_includedir}/GL/gl_mangle.h
799 %{_includedir}/GL/glx.h
800 %{_includedir}/GL/glxext.h
801 %{_includedir}/GL/glx_mangle.h
802 %dir %{_includedir}/GL/internal
803 %{_includedir}/GL/internal/dri_interface.h
804 %{_pkgconfigdir}/dri.pc
805 %{_pkgconfigdir}/gl.pc
806
807 %if %{with static}
808 %files libGL-static
809 %defattr(644,root,root,755)
810 %{_libdir}/libGL.a
811 %endif
812
813 %files libGLU
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
816 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
817
818 %files libGLU-devel
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libGLU.so
821 %{_includedir}/GL/glu.h
822 %{_includedir}/GL/glu_mangle.h
823 %{_pkgconfigdir}/glu.pc
824
825 %if %{with static}
826 %files libGLU-static
827 %defattr(644,root,root,755)
828 %{_libdir}/libGLU.a
829 %endif
830
831 %files libGLw
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
834 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
835
836 %files libGLw-devel
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_libdir}/libGLw.so
839 %{_includedir}/GL/GLwDrawA.h
840 %{_includedir}/GL/GLwDrawAP.h
841 %{_includedir}/GL/GLwMDrawA.h
842 %{_includedir}/GL/GLwMDrawAP.h
843 %{_pkgconfigdir}/glw.pc
844
845 %if %{with static}
846 %files libGLw-static
847 %defattr(644,root,root,755)
848 %{_libdir}/libGLw.a
849 %endif
850
851 %if %{with osmesa}
852 %files libOSMesa
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
855 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
856
857 %files libOSMesa-devel
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/libOSMesa*.so
860 %{_includedir}/GL/osmesa.h
861
862 %if %{with static}
863 %files libOSMesa-static
864 %defattr(644,root,root,755)
865 %{_libdir}/libOSMesa*.a
866 %endif
867 %endif
868
869 %files utils
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_bindir}/glxgears
872 %attr(755,root,root) %{_bindir}/glxinfo
873
874 %files dri-driver-ati-mach64
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
877
878 %files dri-driver-ati-radeon-R100
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
881
882 %files dri-driver-ati-radeon-R200
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
885
886 %files dri-driver-ati-radeon-R300
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
889
890 %files dri-driver-ati-radeon-R600
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
893
894 %files dri-driver-ati-rage128
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
897
898 # sunffb (sparc only)
899 %ifarch sparc sparcv9 sparc64
900 %files dri-driver-ffb
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
903 %endif
904
905 # glint (requires update)
906 %if 0
907 %files dri-driver-glint
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
910 %endif
911
912 %files dri-driver-intel-i810
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
915
916 %files dri-driver-intel-i915
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
919
920 %files dri-driver-intel-i965
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
923
924 %files dri-driver-matrox
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
927
928 %if %{with gallium}
929 %if %{with gallium_nouveau}
930 %files dri-driver-nouveau
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
934 %endif
935 %endif
936
937 %files dri-driver-savage
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
940
941 %ifarch %{ix86} %{x8664}
942 %files dri-driver-sis
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
945 %endif
946
947 %files dri-driver-swrast
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
950
951 %files dri-driver-tdfx
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
954
955 %files dri-driver-via-unichrome
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
958
959 %if %{with gallium}
960 %files dri-driver-vmwgfx
961 %defattr(644,root,root,755)
962 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
963 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
964 %endif
965
966 %if %{with demos}
967 %files demos
968 %defattr(644,root,root,755)
969 %{_examplesdir}/%{name}-%{version}
970 %endif
This page took 0.214633 seconds and 4 git commands to generate.