]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 20120130 (it's post 8.0rc2)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_without  gallium_nouveau # gallium nouveau driver
11 %bcond_without  motif   # build static libGLw without Motif interface
12 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
13 %bcond_without  osmesa  # don't build osmesa
14 %bcond_without  gbm     # with Graphics Buffer Manager
15 %bcond_with     static_libs     # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.30
25 %define         dri2proto_ver   2.6
26 %define         glproto_ver     1.4.11
27 #
28 %define         snap            20120130
29 #
30 Summary:        Free OpenGL implementation
31 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
32 Name:           Mesa
33 Version:        8.0
34 Release:        0.%{snap}.1%{?with_multigl:.mgl}
35 License:        MIT (core), SGI (GLU) and others - see license.html file
36 Group:          X11/Libraries
37 Source0:        %{name}Lib-%{snap}.tar.bz2
38 # Source0-md5:  3a15eb1e6b98db40aeca4ef6d54570d7
39 Patch0:         %{name}-realclean.patch
40 URL:            http://www.mesa3d.org/
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake
43 BuildRequires:  expat-devel
44 BuildRequires:  libdrm-devel >= %{libdrm_ver}
45 BuildRequires:  libselinux-devel
46 BuildRequires:  libstdc++-devel >= 5:3.3.0
47 BuildRequires:  libtalloc-devel >= 2:2.0.1
48 BuildRequires:  libtool >= 2:1.4d
49 BuildRequires:  libvdpau-devel
50 BuildRequires:  llvm-devel >= 2.9
51 %{?with_motif:BuildRequires:    motif-devel}
52 BuildRequires:  pixman-devel
53 BuildRequires:  pkgconfig
54 BuildRequires:  pkgconfig(talloc) >= 2.0.1
55 BuildRequires:  python
56 BuildRequires:  python-libxml2
57 BuildRequires:  python-modules
58 BuildRequires:  rpmbuild(macros) >= 1.470
59 BuildRequires:  sed >= 4.0
60 BuildRequires:  xorg-lib-libXdamage-devel
61 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
62 BuildRequires:  xorg-lib-libXt-devel
63 BuildRequires:  xorg-lib-libXvMC-devel
64 BuildRequires:  xorg-lib-libXxf86vm-devel
65 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
66 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
67 BuildRequires:  xorg-util-makedepend
68 BuildRequires:  xorg-xserver-server-devel
69 %if %{with egl}
70 BuildRequires:  libxcb-devel
71 BuildRequires:  udev-devel >= 150
72 %endif
73 %if %{with gallium}
74 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
75 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
76 %endif
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %if %{without gallium}
80 %undefine       with_gallium_intel
81 %endif
82
83 %if %{without egl}
84 %undefine       with_gbm
85 %endif
86
87 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
88 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.* libvdpau_nouveau.so.1.*
89
90 %description
91 Mesa is a 3-D graphics library with an API which is very similar to
92 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
93 syntax or state machine, it is being used with authorization from
94 Silicon Graphics, Inc. However, the author does not possess an OpenGL
95 license from SGI, and makes no claim that Mesa is in any way a
96 compatible replacement for OpenGL or associated with SGI.
97
98 %description -l pl.UTF-8
99 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
100 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
101 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
102 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
103 OpenGL ani powiązana z SGI.
104
105 %package libEGL
106 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
107 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
108 License:        MIT
109 Group:          Libraries
110 Requires:       OpenGL >= 1.2
111 Requires:       udev-libs >= 150
112 Provides:       EGL = 1.4
113
114 %description libEGL
115 This package contains shared libEGL - Mesa implementation of EGL
116 Native Platform Graphics Interface as specified by Khronos Group:
117 <http://www.khronos.org/egl/>.
118
119 %description libEGL -l pl.UTF-8
120 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
121 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
122 graficznego platformy natywnej) wg specyfikacji Khronos Group:
123 <http://www.khronos.org/egl/>.
124
125 %package libEGL-devel
126 Summary:        Header files for Mesa implementation of EGL library
127 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
128 License:        MIT
129 Group:          Development/Libraries
130 Requires:       %{name}-libEGL = %{version}-%{release}
131 Requires:       OpenGL-devel >= 1.2
132 Requires:       libstdc++-devel
133 Provides:       EGL-devel = 1.4
134
135 %description libEGL-devel
136 Header files for Mesa implementation of EGL library.
137
138 %description libEGL-devel -l pl.UTF-8
139 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
140
141 %package libEGL-static
142 Summary:        Static SGI libEGL library
143 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
144 License:        MIT
145 Group:          Development/Libraries
146 Requires:       %{name}-libEGL-devel = %{version}-%{release}
147 Provides:       EGL-static = 1.4
148
149 %description libEGL-static
150 Static Mesa libEGL library.
151
152 %description libEGL-static -l pl.UTF-8
153 Statyczna biblioteka Mesa libEGL.
154
155 %package libGLES
156 Summary:        Mesa libGLES runtime libraries
157 Group:          Libraries
158
159 %description libGLES
160 Mesa GLES runtime libraries.
161
162 %description libGLES -l pl.UTF-8
163 Biblioteka Mesa GLES.
164
165 %package libGLES-devel
166 Summary:        Header files for libGLES library
167 Group:          Development/Libraries
168 Requires:       %{name}-libGLES = %{version}-%{release}
169
170 %description libGLES-devel
171 Header files for libGLES library.
172
173 %description libGLES-devel -l pl.UTF-8
174 Pliki nagłówkowe biblioteki libGLES.
175
176 %package libGL
177 Summary:        Free Mesa3D implementation of libGL OpenGL library
178 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
179 License:        MIT
180 Group:          X11/Libraries
181 Requires:       libdrm >= %{libdrm_ver}
182 Provides:       OpenGL = 2.1
183 # reports version 1.3, but supports glXGetProcAddress() from 1.4
184 Provides:       OpenGL-GLX = 1.4
185 Obsoletes:      Mesa
186 Obsoletes:      Mesa-dri
187 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
188 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
189
190 %description libGL
191 Mesa is a 3-D graphics library with an API which is very similar to
192 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
193 syntax or state machine, it is being used with authorization from
194 Silicon Graphics, Inc. However, the author does not possess an OpenGL
195 license from SGI, and makes no claim that Mesa is in any way a
196 compatible replacement for OpenGL or associated with SGI.
197
198 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
199 specifications. It uses DRI for rendering.
200
201 %description libGL -l pl.UTF-8
202 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
203 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
204 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
205 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
206 OpenGL ani powiązana z SGI.
207
208 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
209 GLX 1.4. Używa DRI do renderowania.
210
211 %package libGL-devel
212 Summary:        Header files for Mesa3D libGL library
213 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
214 License:        MIT
215 Group:          X11/Development/Libraries
216 # loose dependency on libGL to use with other libGL binaries
217 Requires:       OpenGL >= 1.5
218 Requires:       libdrm-devel >= %{libdrm_ver}
219 Requires:       xorg-lib-libX11-devel
220 Requires:       xorg-lib-libXdamage-devel
221 Requires:       xorg-lib-libXext-devel
222 Requires:       xorg-lib-libXxf86vm-devel
223 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
224 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
225 Suggests:       OpenGL-doc-man
226 Provides:       OpenGL-GLX-devel = 1.4
227 Provides:       OpenGL-devel = 2.1
228 Obsoletes:      Mesa-devel
229 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
230 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
231 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
232 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
233
234 %description libGL-devel
235 Header files for Mesa3D libGL library.
236
237 %description libGL-devel -l pl.UTF-8
238 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
239
240 %package libGL-static
241 Summary:        Static Mesa3D libGL library
242 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
243 License:        MIT
244 Group:          X11/Development/Libraries
245 Requires:       %{name}-libGL-devel = %{version}-%{release}
246 Provides:       OpenGL-static = 2.1
247 Obsoletes:      Mesa-static
248 Obsoletes:      X11-OpenGL-static < 1:7.0.0
249 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
250
251 %description libGL-static
252 Static Mesa3D libGL library. It uses software renderer.
253
254 %description libGL-static -l pl.UTF-8
255 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
256 renderingu.
257
258 %package libGLU
259 Summary:        SGI implementation of libGLU OpenGL library
260 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
261 License:        SGI Free Software License B v2.0 (MIT-like)
262 Group:          Libraries
263 # loose dependency on libGL.so.1 to use with other libGL binaries
264 Requires:       OpenGL >= 1.2
265 Provides:       OpenGL-GLU = 1.3
266 Obsoletes:      Mesa-devel
267 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
268 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
269
270 %description libGLU
271 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
272 1.3 specifications.
273
274 %description libGLU -l pl.UTF-8
275 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
276 specyfikację OpenGL GLU 1.3.
277
278 %package libGLU-devel
279 Summary:        Header files for SGI libGLU library
280 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
281 License:        SGI Free Software License B v2.0 (MIT-like)
282 Group:          Development/Libraries
283 Requires:       %{name}-libGLU = %{version}-%{release}
284 Requires:       OpenGL-devel >= 1.2
285 Requires:       libstdc++-devel
286 Provides:       OpenGL-GLU-devel = 1.3
287
288 %description libGLU-devel
289 Header files for SGI libGLU library.
290
291 %description libGLU-devel -l pl.UTF-8
292 Pliki nagłówkowe biblioteki SGI libGLU.
293
294 %package libGLU-static
295 Summary:        Static SGI libGLU library
296 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
297 License:        SGI Free Software License B v2.0 (MIT-like)
298 Group:          Development/Libraries
299 Requires:       %{name}-libGLU-devel = %{version}-%{release}
300 Provides:       OpenGL-GLU-static = 1.3
301
302 %description libGLU-static
303 Static SGI libGLU library.
304
305 %description libGLU-static -l pl.UTF-8
306 Statyczna biblioteka SGI libGLU.
307
308 %package libOSMesa
309 Summary:        OSMesa (off-screen renderer) library
310 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
311 License:        MIT
312 Group:          Libraries
313 # doesn't require base
314
315 %description libOSMesa
316 OSMesa (off-screen renderer) library.
317
318 %description libOSMesa -l pl.UTF-8
319 Biblioteka OSMesa (renderująca bitmapy w pamięci).
320
321 %package libOSMesa-devel
322 Summary:        Header file for OSMesa (off-screen renderer) library
323 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
324 License:        MIT
325 Group:          Development/Libraries
326 Requires:       %{name}-libOSMesa = %{version}-%{release}
327 # for <GL/gl.h> only
328 Requires:       OpenGL-devel
329
330 %description libOSMesa-devel
331 Header file for OSMesa (off-screen renderer) library.
332
333 %description libOSMesa-devel -l pl.UTF-8
334 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
335
336 %package libOSMesa-static
337 Summary:        Static OSMesa (off-screen renderer) library
338 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
339 License:        MIT
340 Group:          Development/Libraries
341 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
342 # this static build of OSMesa needs static non-dri Mesa implementation
343 Requires:       %{name}-libGL-static = %{version}-%{release}
344
345 %description libOSMesa-static
346 Static OSMesa (off-screen renderer) library.
347
348 %description libOSMesa-static -l pl.UTF-8
349 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
350
351 %package libOpenVG
352 Summary:        OpenVG API implementation
353 Summary(pl.UTF-8):      Implementacja API OpenVG
354 License:        MIT
355 Group:          Libraries
356 # doesn't require base
357
358 %description libOpenVG
359 OpenVG API implementation.
360
361 %description libOpenVG -l pl.UTF-8
362 Implementacja API OpenVG.
363
364 %package libOpenVG-devel
365 Summary:        Header file for libOpenVG library
366 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libOpenVG
367 License:        MIT
368 Group:          Development/Libraries
369 # for <KHR/khrplatform.h>
370 Requires:       %{name}-libEGL-devel = %{version}-%{release}
371 Requires:       %{name}-libOpenVG = %{version}-%{release}
372
373 %description libOpenVG-devel
374 Header file for libOpenVG library.
375
376 %description libOpenVG-devel -l pl.UTF-8
377 Plik nagłówkowy biblioteki libOpenVG.
378
379 %package libXvMC
380 Summary:        XvMC implementations
381 Summary(pl.UTF-8):      Implementacje API XvMC
382 License:        MIT
383 Group:          Libraries
384 # doesn't require base
385
386 %description libXvMC
387 libXvMC implementations.
388
389 %description libXvMC -l pl.UTF-8
390 Implementacje API libXvMC.
391
392 %package utils
393 Summary:        OpenGL utilities from Mesa3D
394 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
395 License:        MIT
396 Group:          X11/Applications/Graphics
397 # loose deps on libGL/libGLU
398
399 %description utils
400 OpenGL utilities from Mesa3D: glxgears and glxinfo.
401
402 %description utils -l pl.UTF-8
403 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
404
405 %package dri-driver-ati-radeon-R100
406 Summary:        X.org DRI driver for ATI R100 card family
407 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
408 License:        MIT
409 Group:          X11/Libraries
410 Requires:       xorg-driver-video-ati
411 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
412 Requires:       xorg-xserver-server >= %{xserver_ver}
413 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
414
415 %description dri-driver-ati-radeon-R100
416 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
417
418 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
419 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
420
421 %package dri-driver-ati-radeon-R200
422 Summary:        X.org DRI driver for ATI R200 card family
423 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
424 License:        MIT
425 Group:          X11/Libraries
426 Requires:       xorg-driver-video-ati
427 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
428 Requires:       xorg-xserver-server >= %{xserver_ver}
429 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
430
431 %description dri-driver-ati-radeon-R200
432 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
433
434 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
435 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
436
437 %package dri-driver-ati-radeon-R300
438 Summary:        X.org DRI driver for ATI R300 card family
439 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
440 License:        MIT
441 Group:          X11/Libraries
442 Requires:       xorg-driver-video-ati
443 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
444 Requires:       xorg-xserver-server >= %{xserver_ver}
445 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
446
447 %description dri-driver-ati-radeon-R300
448 X.org DRI driver for ATI R300 card family.
449
450 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
451 Sterownik X.org DRI dla rodziny kart ATI R300.
452
453 %package dri-driver-ati-radeon-R600
454 Summary:        X.org DRI driver for ATI R600 card family
455 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
456 License:        MIT
457 Group:          X11/Libraries
458 Requires:       radeon-ucode
459 Requires:       xorg-driver-video-ati
460 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
461 Requires:       xorg-xserver-server >= %{xserver_ver}
462
463 %description dri-driver-ati-radeon-R600
464 X.org DRI driver for ATI R600 card family.
465
466 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
467 Sterownik X.org DRI dla rodziny kart ATI R600.
468
469 %package dri-driver-ffb
470 Summary:        X.org DRI driver for Sun FFB card family
471 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
472 License:        MIT
473 Group:          X11/Libraries
474 Requires:       xorg-driver-video-sunffb
475 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
476 Requires:       xorg-xserver-server >= %{xserver_ver}
477
478 %description dri-driver-ffb
479 X.org DRI driver for SUN Creator3D and Elite3D card family.
480
481 %description dri-driver-ffb -l pl.UTF-8
482 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
483
484 %package dri-driver-glint
485 Summary:        X.org DRI driver for GLINT/Permedia card family
486 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
487 License:        MIT
488 Group:          X11/Libraries
489 Requires:       xorg-driver-video-glint
490 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
491 Requires:       xorg-xserver-server >= %{xserver_ver}
492 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
493
494 %description dri-driver-glint
495 X.org DRI driver for GLINT/Permedia card family.
496
497 %description dri-driver-glint -l pl.UTF-8
498 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
499
500 %package dri-driver-intel-i915
501 Summary:        X.org DRI driver for Intel i915 card family
502 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
503 License:        MIT
504 Group:          X11/Libraries
505 Requires:       xorg-driver-video-intel
506 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
507 Requires:       xorg-xserver-server >= %{xserver_ver}
508 Obsoletes:      Mesa-dri-driver-intel-i830
509 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
510
511 %description dri-driver-intel-i915
512 X.org DRI driver for Intel i915 card family.
513
514 %description dri-driver-intel-i915 -l pl.UTF-8
515 Sterownik X.org DRI dla rodziny kart Intel i915.
516
517 %package dri-driver-intel-i965
518 Summary:        X.org DRI driver for Intel i965 card family
519 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
520 License:        MIT
521 Group:          X11/Libraries
522 Requires:       xorg-driver-video-intel
523 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
524 Requires:       xorg-xserver-server >= %{xserver_ver}
525 Obsoletes:      Mesa-dri-driver-intel-i830
526 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
527
528 %description dri-driver-intel-i965
529 X.org DRI driver for Intel i965 card family.
530
531 %description dri-driver-intel-i965 -l pl.UTF-8
532 Sterownik X.org DRI dla rodziny kart Intel i965.
533
534 %package dri-driver-nouveau
535 Summary:        X.org DRI driver for NVIDIA card family
536 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
537 License:        MIT
538 Group:          X11/Libraries
539 Requires:       xorg-driver-video-nouveau
540 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
541 Requires:       xorg-xserver-server >= %{xserver_ver}
542
543 %description dri-driver-nouveau
544 X.org DRI drivers for NVIDIA card family.
545
546 %description dri-driver-nouveau -l pl.UTF-8
547 Sterowniki X.org DRI dla rodziny kart NVIDIA.
548
549 %package dri-driver-swrast
550 Summary:        X.org DRI software rasterizer driver
551 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
552 License:        MIT
553 Group:          X11/Libraries
554 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
555 Requires:       xorg-xserver-server >= %{xserver_ver}
556
557 %description dri-driver-swrast
558 X.org DRI software rasterizer driver.
559
560 %description dri-driver-swrast -l pl.UTF-8
561 Sterownik X.org DRI obsługujący rysowanie programowe.
562
563 %package dri-driver-vmwgfx
564 Summary:        X.org DRI driver for VMware
565 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
566 License:        MIT
567 Group:          X11/Libraries
568 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
569 Requires:       xorg-xserver-server >= %{xserver_ver}
570
571 %description dri-driver-vmwgfx
572 X.org DRI driver for VMWare.
573
574 %description dri-driver-vmwgfx -l pl.UTF-8
575 Sterownik X.org DRI dla VMware.
576
577 %package -n libvdpau-driver-mesa
578 Summary:        Mesa driver for the vdpau API
579 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
580 License:        MIT
581 Group:          X11/Libraries
582
583 %description -n libvdpau-driver-mesa
584 Mesa driver for the vdpau API.
585
586 %description -n libvdpau-driver-mesa -l pl.UTF-8
587 Sterownik Mesa dla API vdpau.
588
589 # llvm build broken
590 %define         filterout_ld    -Wl,--as-needed
591
592 %prep
593 %setup -q
594 %patch0 -p0
595
596 %build
597 if [ -x autogen.sh ]; then
598         ./autogen.sh
599 else
600         %{__aclocal}
601         %{__autoconf}
602 fi
603
604 dri_drivers="r200 radeon \
605 %if %{without gallium_intel}
606 i915 i965 \
607 %endif
608 %ifarch sparc sparcv9 sparc64
609 ffb \
610 %endif
611 swrast"
612
613 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
614
615 gallium_drivers="svga swrast \
616 %if %{with gallium_intel}
617 i915 \
618 i965 \
619 %endif
620 r300 \
621 r600 \
622 %if %{with gallium_nouveau}
623 nouveau \
624 %endif
625 "
626
627 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
628
629 common_flags="\
630         --enable-shared \
631         --enable-selinux \
632         --enable-pic \
633         --enable-glx-tls \
634 %if %{with egl}
635         --enable-egl \
636         --enable-gles1 \
637         --enable-gles2 \
638 %endif
639 "
640
641 osmesa_common_flags="\
642         --with-driver=osmesa \
643         --disable-asm \
644         --disable-glu \
645         --disable-egl"
646
647 %if %{with osmesa}
648 %configure $common_flags $osmesa_common_flags \
649         --with-osmesa-bits=8
650 %{__make}
651 mv %{_lib} osmesa8
652 %{__make} clean
653 %endif
654
655 %configure $common_flags \
656         --enable-shared-glapi \
657 %if %{with egl}
658         --enable-egl \
659         --enable-gles1 \
660         --enable-gles2 \
661         %{__enable gbm} \
662 %endif
663 %if %{with gallium}
664         --enable-openvg \
665         %{__enable egl gallium-egl} \
666         %{__enable gbm gallium-gbm} \
667         --enable-vdpau \
668         --enable-xvmc \
669         --with-gallium-drivers=${gallium_drivers} \
670 %else
671         --disable-gallium \
672 %endif
673         --with-driver=dri \
674         --with-dri-drivers=${dri_drivers} \
675         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
676
677 %{__make}
678
679 %install
680 rm -rf $RPM_BUILD_ROOT
681
682 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
683
684 # libs without drivers
685 %{__make} install \
686         DESTDIR=$RPM_BUILD_ROOT
687
688 %if %{with osmesa}
689 cp -dp osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
690 %endif
691
692 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
693
694 # strip out undesirable headers
695 olddir=$(pwd)
696 cd $RPM_BUILD_ROOT%{_includedir}/GL
697 rm [a-fh-np-wyz]*.h
698 cd $RPM_BUILD_ROOT%{_libdir}
699 cd $olddir
700
701 %if %{with multigl}
702 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
703
704 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
705 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
706
707 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
708 %endif
709
710 %clean
711 rm -rf $RPM_BUILD_ROOT
712
713 %post   libEGL -p /sbin/ldconfig
714 %postun libEGL -p /sbin/ldconfig
715
716 %post   libGL -p /sbin/ldconfig
717 %postun libGL -p /sbin/ldconfig
718
719 %post   libGLES -p /sbin/ldconfig
720 %postun libGLES -p /sbin/ldconfig
721
722 %post   libGLU -p /sbin/ldconfig
723 %postun libGLU -p /sbin/ldconfig
724
725 %post   libOSMesa -p /sbin/ldconfig
726 %postun libOSMesa -p /sbin/ldconfig
727
728 %post   libOpenVG -p /sbin/ldconfig
729 %postun libOpenVG -p /sbin/ldconfig
730
731 %post   libXvMC -p /sbin/ldconfig
732 %postun libXvMC -p /sbin/ldconfig
733
734 %if %{with egl}
735 %files libEGL
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
738 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
739 %if %{with gbm}
740 %dir %{_libdir}/gbm
741 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
743 %endif
744 %if %{with gallium}
745 %dir %{_libdir}/egl
746 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
747 #%attr(755,root,root) %{_libdir}/egl/st_GL.so
748 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
749 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
750 %if %{with gbm}
751 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
752 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
753 %if %{with gallium_nouveau}
754 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
755 %endif
756 %if %{with gallium_intel}
757 %attr(755,root,root) %{_libdir}/gbm/pipe_i915.so
758 %attr(755,root,root) %{_libdir}/gbm/pipe_i965.so
759 %endif
760 %endif
761 %endif
762
763 %files libEGL-devel
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libEGL.so
766 %dir %{_includedir}/EGL
767 %{_includedir}/EGL/egl.h
768 %{_includedir}/EGL/eglext.h
769 %{_includedir}/EGL/eglmesaext.h
770 %{_includedir}/EGL/eglplatform.h
771 %dir %{_includedir}/KHR
772 %{_includedir}/KHR/khrplatform.h
773 %{_pkgconfigdir}/egl.pc
774 %if %{with gbm}
775 %attr(755,root,root) %{_libdir}/libgbm.so
776 %{_includedir}/gbm.h
777 %{_pkgconfigdir}/gbm.pc
778 %endif
779
780 %if %{with static_libs}
781 %files libEGL-static
782 %defattr(644,root,root,755)
783 %{_libdir}/libEGL.a
784 %endif
785 %endif
786
787 %files libGL
788 %defattr(644,root,root,755)
789 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
790 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
791 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
792 %if %{with multigl}
793 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
794 %dir %{_libdir}/Mesa
795 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
796 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
797 %else
798 %attr(755,root,root) %{_libdir}/libGL.so.*.*
799 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
800 # symlink for binary apps which fail to conform Linux OpenGL ABI
801 # (and dlopen libGL.so instead of libGL.so.1)
802 %attr(755,root,root) %{_libdir}/libGL.so
803 %endif
804
805 %files libGL-devel
806 %defattr(644,root,root,755)
807 %doc docs/*.spec
808 %attr(755,root,root) %{_libdir}/libglapi.so
809 %if %{with multigl}
810 %attr(755,root,root) %{_libdir}/libGL.so
811 %endif
812 %dir %{_includedir}/GL
813 %{_includedir}/GL/gl.h
814 %{_includedir}/GL/glext.h
815 %{_includedir}/GL/gl_mangle.h
816 %{_includedir}/GL/glx.h
817 %{_includedir}/GL/glxext.h
818 %{_includedir}/GL/glx_mangle.h
819 %dir %{_includedir}/GL/internal
820 %{_includedir}/GL/internal/dri_interface.h
821 %{_pkgconfigdir}/dri.pc
822 %{_pkgconfigdir}/gl.pc
823
824 %files libGLES
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_libdir}/libGLES*.so.*.*
827 %attr(755,root,root) %ghost %{_libdir}/libGLES*.so.[0-9]
828
829 %files libGLES-devel
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_libdir}/libGLES*.so
832 %{_includedir}/GLES
833 %{_includedir}/GLES2
834 %{_pkgconfigdir}/gles*.pc
835
836 %if %{with static_libs}
837 %files libGL-static
838 %defattr(644,root,root,755)
839 %{_libdir}/libGL.a
840 %endif
841
842 %files libGLU
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
845 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
846
847 %files libGLU-devel
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libGLU.so
850 %{_includedir}/GL/glu.h
851 %{_includedir}/GL/glu_mangle.h
852 %{_pkgconfigdir}/glu.pc
853
854 %if %{with static_libs}
855 %files libGLU-static
856 %defattr(644,root,root,755)
857 %{_libdir}/libGLU.a
858 %endif
859
860 %if %{with osmesa}
861 %files libOSMesa
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
864 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.8
865
866 %files libOSMesa-devel
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/libOSMesa*.so
869 %{_includedir}/GL/osmesa.h
870
871 %if %{with static_libs}
872 %files libOSMesa-static
873 %defattr(644,root,root,755)
874 %{_libdir}/libOSMesa*.a
875 %endif
876 %endif
877
878 %if %{with gallium}
879 %files libOpenVG
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
882 %attr(755,root,root) %{_libdir}/libOpenVG.so.1.0.0
883
884 %files libOpenVG-devel
885 %defattr(644,root,root,755)
886 %{_includedir}/VG
887 %{_libdir}/libOpenVG.so
888 %{_pkgconfigdir}/vg.pc
889 %endif
890
891 %files libXvMC
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
894 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
895 %attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
896 %attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
897 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
898 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
899 %attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
900 %attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
901
902 %files dri-driver-ati-radeon-R100
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
905
906 %files dri-driver-ati-radeon-R200
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
909
910 %files dri-driver-ati-radeon-R300
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
913
914 %files dri-driver-ati-radeon-R600
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
917
918 # sunffb (sparc only)
919 %ifarch sparc sparcv9 sparc64
920 %files dri-driver-ffb
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
923 %endif
924
925 # glint (requires update)
926 %if 0
927 %files dri-driver-glint
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
930 %endif
931
932 %files dri-driver-intel-i915
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
935
936 %files dri-driver-intel-i965
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
939 %if %{with gallium_intel}
940 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
941 %endif
942
943 %if %{with gallium}
944 %if %{with gallium_nouveau}
945 %files dri-driver-nouveau
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
948 %endif
949 %endif
950
951 %files dri-driver-swrast
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
954
955 %if %{with gallium}
956 %files dri-driver-vmwgfx
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
959 %endif
960
961 %files -n libvdpau-driver-mesa
962 %defattr(644,root,root,755)
963 # there is no ldconfig here
964 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
965 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
966 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
967 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
968 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
969 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
970 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
971 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
972 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
973 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1.0
974 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1
975 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
This page took 1.030542 seconds and 4 git commands to generate.