]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 6.3.2
[packages/Mesa.git] / Mesa.spec
1 #
2 # Conditional build:
3 %bcond_with     glide   # with GLIDE (broken now)
4 #
5 Summary:        Free OpenGL implementation
6 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
7 Name:           Mesa
8 Version:        6.3.2
9 Release:        1
10 License:        MIT (core), LGPL (MesaGLU), SGI (GLU,libGLw) and others - see COPYRIGHT file
11 Group:          X11/Libraries
12 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
13 # Source0-md5:  0df27701df0924d17ddf41185efa8ce1
14 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
15 # Source1-md5:  96708868450c188205e42229b5d813c4
16 URL:            http://www.mesa3d.org/
17 %ifarch %{ix86} alpha
18 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
19 %{?with_glide:Requires: Glide3-DRI}
20 %endif
21 BuildRequires:  xorg-lib-libXmu-devel
22 BuildRequires:  xorg-lib-libXp-devel
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  libtool >= 2:1.4d
26 BuildRequires:  motif-devel
27 BuildRequires:  sed >= 4.0
28 Provides:       OpenGL = 1.5
29 Provides:       OpenGL-GLU = 1.3
30 # reports version 1.3, but supports glXGetProcAddress() from 1.4
31 Provides:       OpenGL-GLX = 1.4
32 Obsoletes:      XFree86-OpenGL-libGL
33 Obsoletes:      XFree86-OpenGL-libs
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # avoid XFree86-OpenGL* dependency
37 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
38 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
39
40 %define         _sysconfdir     /etc/X11
41
42 %description
43 Mesa is a 3-D graphics library with an API which is very similar to
44 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
45 syntax or state machine, it is being used with authorization from
46 Silicon Graphics, Inc. However, the author does not possess an OpenGL
47 license from SGI, and makes no claim that Mesa is in any way a
48 compatible replacement for OpenGL or associated with SGI.
49
50 %description -l pl
51 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
52 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
53 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
54 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
55 OpenGL ani powi±zana z SGI.
56
57 %package devel
58 Summary:        Development environment for Mesa
59 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 %if %{with xlibs}
63 Requires:       libX11-devel
64 Requires:       libXp-devel
65 %else
66 Requires:       XFree86-devel
67 %endif
68 Provides:       OpenGL-devel = 1.5
69 Provides:       OpenGL-GLU-devel = 1.3
70 Provides:       OpenGL-GLX-devel = 1.4
71 Obsoletes:      XFree86-OpenGL-devel
72 Obsoletes:      XFree86-OpenGL-devel-base
73
74 %description devel
75 Header files and documentation needed for development.
76
77 %description devel -l pl
78 Pliki nag³ówkowe i dokumentacja do Mesy.
79
80 %package static
81 Summary:        Mesa static libraries
82 Summary(pl):    Biblioteki statyczne Mesy
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Provides:       OpenGL-static = 1.5
86 Provides:       OpenGL-GLU-static = 1.3
87 Obsoletes:      XFree86-OpenGL-static
88
89 %description static
90 The static version of the Mesa libraries.
91
92 %description static -l pl
93 Biblioteki statyczne Mesy.
94
95 %package demos
96 Summary:        Mesa Demos
97 Summary(pl):    Demonstracje mo¿liwo¶ci bibliotek Mesa
98 Group:          Development/Libraries
99 Requires:       OpenGL-devel
100
101 %description demos
102 Demonstration programs for the Mesa libraries.
103
104 %description demos -l pl
105 Programy demonstracyjne dla bibliotek Mesa.
106
107 %prep
108 %setup -q -n Mesa-%{version} -b 1
109
110 # fix demos
111 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/Mesa/images/,g"
112
113 %build
114 %ifarch %{ix86}
115 targ=linux-x86
116 %else
117 targ=linux
118 %endif
119
120 %{__make} ${targ}-static \
121         CC="%{__cc}" \
122         CXX="%{__cxx}" \
123         OPT_FLAGS="%{rpmcflags}" \
124         XLIB_DIR=/usr/X11R6/%{_lib} \
125         GLW_SOURCES="GLwDrawA.c GLwMDrawA.c"
126 mv -f lib lib-static
127 %{__make} clean
128 %{__make} ${targ} \
129         CC="%{__cc}" \
130         CXX="%{__cxx}" \
131         OPT_FLAGS="%{rpmcflags}" \
132         XLIB_DIR=/usr/X11R6/%{_lib}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/GL,%{_mandir}/man3,%{_examplesdir}/Mesa}
137
138 cp -df lib-static/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
139 cp -df lib/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
140 cp -rf include/GL/{gl*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
141 rm -f $RPM_BUILD_ROOT%{_includedir}/GL/glut*
142
143 for l in demos redbook samples xdemos ; do
144         %{__make} -C progs/$l clean
145 done
146 for l in demos redbook samples util xdemos images ; do
147         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/Mesa/$l
148 done
149 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/Mesa/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
160 %attr(755,root,root) %{_libdir}/libGL.so.*.*
161 %attr(755,root,root) %{_libdir}/libGL.so
162 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
163 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %doc docs/*.spec
168 %attr(755,root,root) %{_libdir}/libGLU.so
169 %attr(755,root,root) %{_libdir}/libOSMesa.so
170 %{_libdir}/libGLw.a
171 %dir %{_includedir}/GL
172 %{_includedir}/GL/GLwDrawA.h
173 %{_includedir}/GL/GLwDrawAP.h
174 %{_includedir}/GL/GLwMDrawA.h
175 %{_includedir}/GL/GLwMDrawAP.h
176 %{_includedir}/GL/gl.h
177 %{_includedir}/GL/glext.h
178 %{_includedir}/GL/gl_mangle.h
179 %{_includedir}/GL/glu.h
180 %{_includedir}/GL/glu_mangle.h
181 %{_includedir}/GL/glx.h
182 %{_includedir}/GL/glxext.h
183 %{_includedir}/GL/glx_mangle.h
184 %{_includedir}/GL/osmesa.h
185 %{_includedir}/GL/xmesa.h
186 %{_includedir}/GL/xmesa_x.h
187 %{_includedir}/GL/xmesa_xf86.h
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/libGL.a
192 %{_libdir}/libGLU.a
193 %{_libdir}/libOSMesa.a
194
195 %files demos
196 %defattr(644,root,root,755)
197 %{_examplesdir}/Mesa
This page took 0.151047 seconds and 4 git commands to generate.