]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- current snap
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_without  gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_without  gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_without  gbm     # with Graphics Buffer Manager
16 %bcond_with     static_libs     # static libraries
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.25
26 %define         dri2proto_ver   2.6
27 %define         glproto_ver     1.4.11
28 #
29 %define         snap            20110907
30 #
31 Summary:        Free OpenGL implementation
32 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
33 Name:           Mesa
34 Version:        7.12
35 Release:        0.%{snap}.1%{?with_multigl:.mgl}
36 License:        MIT (core), SGI (GLU) and others - see license.html file
37 Group:          X11/Libraries
38 Source0:        %{name}Lib-%{snap}.tar.bz2
39 # Source0-md5:  cd699279249570dbd8ba9888539631b8
40 Patch0:         %{name}-realclean.patch
41 Patch2:         %{name}-selinux.patch
42 URL:            http://www.mesa3d.org/
43 BuildRequires:  autoconf >= 2.59
44 BuildRequires:  automake
45 BuildRequires:  expat-devel
46 BuildRequires:  libdrm-devel >= %{libdrm_ver}
47 # drop when 2.4.24 is released
48 %{?with_nouveau:BuildRequires:  libdrm-devel >= 2.4.24}
49 BuildRequires:  libselinux-devel
50 BuildRequires:  libstdc++-devel >= 5:3.3.0
51 BuildRequires:  libtalloc-devel >= 2:2.0.1
52 BuildRequires:  libtool >= 2:1.4d
53 BuildRequires:  libvdpau-devel
54 BuildRequires:  llvm-devel >= 2.9
55 %{?with_motif:BuildRequires:    motif-devel}
56 BuildRequires:  pixman-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  pkgconfig(talloc) >= 2.0.1
59 BuildRequires:  python
60 BuildRequires:  python-libxml2
61 BuildRequires:  python-modules
62 BuildRequires:  rpmbuild(macros) >= 1.470
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  xorg-lib-libXdamage-devel
65 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
66 BuildRequires:  xorg-lib-libXt-devel
67 BuildRequires:  xorg-lib-libXvMC-devel
68 BuildRequires:  xorg-lib-libXxf86vm-devel
69 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
70 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
71 BuildRequires:  xorg-util-makedepend
72 BuildRequires:  xorg-xserver-server-devel
73 %if %{with egl}
74 BuildRequires:  libxcb-devel
75 BuildRequires:  udev-devel >= 150
76 %endif
77 %if %{with gallium}
78 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
79 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
80 %endif
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %if %{without gallium}
84 %undefine       with_gallium_intel
85 %undefine       with_gallium_radeon
86 %endif
87
88 %if %{without egl}
89 %undefine       with_gbm
90 %endif
91
92 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
93 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.*
94
95 %description
96 Mesa is a 3-D graphics library with an API which is very similar to
97 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
98 syntax or state machine, it is being used with authorization from
99 Silicon Graphics, Inc. However, the author does not possess an OpenGL
100 license from SGI, and makes no claim that Mesa is in any way a
101 compatible replacement for OpenGL or associated with SGI.
102
103 %description -l pl.UTF-8
104 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
105 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
106 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
107 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
108 OpenGL ani powiązana z SGI.
109
110 %package libEGL
111 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
112 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
113 License:        MIT
114 Group:          Libraries
115 Requires:       OpenGL >= 1.2
116 Requires:       udev-libs >= 150
117 Provides:       EGL = 1.4
118
119 %description libEGL
120 This package contains shared libEGL - Mesa implementation of EGL
121 Native Platform Graphics Interface as specified by Khronos Group:
122 <http://www.khronos.org/egl/>.
123
124 %description libEGL -l pl.UTF-8
125 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
126 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
127 graficznego platformy natywnej) wg specyfikacji Khronos Group:
128 <http://www.khronos.org/egl/>.
129
130 %package libEGL-devel
131 Summary:        Header files for Mesa implementation of EGL library
132 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
133 License:        MIT
134 Group:          Development/Libraries
135 Requires:       %{name}-libEGL = %{version}-%{release}
136 Requires:       OpenGL-devel >= 1.2
137 Requires:       libstdc++-devel
138 Provides:       EGL-devel = 1.4
139
140 %description libEGL-devel
141 Header files for Mesa implementation of EGL library.
142
143 %description libEGL-devel -l pl.UTF-8
144 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
145
146 %package libEGL-static
147 Summary:        Static SGI libEGL library
148 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
149 License:        MIT
150 Group:          Development/Libraries
151 Requires:       %{name}-libEGL-devel = %{version}-%{release}
152 Provides:       EGL-static = 1.4
153
154 %description libEGL-static
155 Static Mesa libEGL library.
156
157 %description libEGL-static -l pl.UTF-8
158 Statyczna biblioteka Mesa libEGL.
159
160 %package libGLES
161 Summary:        Mesa libGLES runtime libraries
162 Group:          Libraries
163
164 %description libGLES
165 Mesa GLES runtime libraries.
166
167 %description libGLES -l pl.UTF-8
168 Biblioteka Mesa GLES.
169
170 %package libGLES-devel
171 Summary:        Header files for libGLES library
172 Group:          Development/Libraries
173 Requires:       %{name}-libGLES = %{version}-%{release}
174
175 %description libGLES-devel
176 Header files for libGLES library.
177
178 %description libGLES-devel -l pl.UTF-8
179 Pliki nagłówkowe biblioteki libGLES.
180
181 %package libGL
182 Summary:        Free Mesa3D implementation of libGL OpenGL library
183 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
184 License:        MIT
185 Group:          X11/Libraries
186 Requires:       libdrm >= %{libdrm_ver}
187 Provides:       OpenGL = 2.1
188 # reports version 1.3, but supports glXGetProcAddress() from 1.4
189 Provides:       OpenGL-GLX = 1.4
190 Obsoletes:      Mesa
191 Obsoletes:      Mesa-dri
192 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
193 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
194
195 %description libGL
196 Mesa is a 3-D graphics library with an API which is very similar to
197 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
198 syntax or state machine, it is being used with authorization from
199 Silicon Graphics, Inc. However, the author does not possess an OpenGL
200 license from SGI, and makes no claim that Mesa is in any way a
201 compatible replacement for OpenGL or associated with SGI.
202
203 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
204 specifications. It uses DRI for rendering.
205
206 %description libGL -l pl.UTF-8
207 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
208 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
209 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
210 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
211 OpenGL ani powiązana z SGI.
212
213 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
214 GLX 1.4. Używa DRI do renderowania.
215
216 %package libGL-devel
217 Summary:        Header files for Mesa3D libGL library
218 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
219 License:        MIT
220 Group:          X11/Development/Libraries
221 # loose dependency on libGL to use with other libGL binaries
222 Requires:       OpenGL >= 1.5
223 Requires:       libdrm-devel >= %{libdrm_ver}
224 Requires:       xorg-lib-libX11-devel
225 Requires:       xorg-lib-libXdamage-devel
226 Requires:       xorg-lib-libXext-devel
227 Requires:       xorg-lib-libXxf86vm-devel
228 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
229 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
230 Suggests:       OpenGL-doc-man
231 Provides:       OpenGL-GLX-devel = 1.4
232 Provides:       OpenGL-devel = 2.1
233 Obsoletes:      Mesa-devel
234 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
235 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
236 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
237 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
238
239 %description libGL-devel
240 Header files for Mesa3D libGL library.
241
242 %description libGL-devel -l pl.UTF-8
243 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
244
245 %package libGL-static
246 Summary:        Static Mesa3D libGL library
247 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
248 License:        MIT
249 Group:          X11/Development/Libraries
250 Requires:       %{name}-libGL-devel = %{version}-%{release}
251 Provides:       OpenGL-static = 2.1
252 Obsoletes:      Mesa-static
253 Obsoletes:      X11-OpenGL-static < 1:7.0.0
254 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
255
256 %description libGL-static
257 Static Mesa3D libGL library. It uses software renderer.
258
259 %description libGL-static -l pl.UTF-8
260 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
261 renderingu.
262
263 %package libGLU
264 Summary:        SGI implementation of libGLU OpenGL library
265 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
266 License:        SGI Free Software License B v2.0 (MIT-like)
267 Group:          Libraries
268 # loose dependency on libGL.so.1 to use with other libGL binaries
269 Requires:       OpenGL >= 1.2
270 Provides:       OpenGL-GLU = 1.3
271 Obsoletes:      Mesa-devel
272 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
273 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
274
275 %description libGLU
276 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
277 1.3 specifications.
278
279 %description libGLU -l pl.UTF-8
280 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
281 specyfikację OpenGL GLU 1.3.
282
283 %package libGLU-devel
284 Summary:        Header files for SGI libGLU library
285 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
286 License:        SGI Free Software License B v2.0 (MIT-like)
287 Group:          Development/Libraries
288 Requires:       %{name}-libGLU = %{version}-%{release}
289 Requires:       OpenGL-devel >= 1.2
290 Requires:       libstdc++-devel
291 Provides:       OpenGL-GLU-devel = 1.3
292
293 %description libGLU-devel
294 Header files for SGI libGLU library.
295
296 %description libGLU-devel -l pl.UTF-8
297 Pliki nagłówkowe biblioteki SGI libGLU.
298
299 %package libGLU-static
300 Summary:        Static SGI libGLU library
301 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
302 License:        SGI Free Software License B v2.0 (MIT-like)
303 Group:          Development/Libraries
304 Requires:       %{name}-libGLU-devel = %{version}-%{release}
305 Provides:       OpenGL-GLU-static = 1.3
306
307 %description libGLU-static
308 Static SGI libGLU library.
309
310 %description libGLU-static -l pl.UTF-8
311 Statyczna biblioteka SGI libGLU.
312
313 %package libOSMesa
314 Summary:        OSMesa (off-screen renderer) library
315 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
316 License:        MIT
317 Group:          Libraries
318 # doesn't require base
319
320 %description libOSMesa
321 OSMesa (off-screen renderer) library.
322
323 %description libOSMesa -l pl.UTF-8
324 Biblioteka OSMesa (renderująca bitmapy w pamięci).
325
326 %package libOSMesa-devel
327 Summary:        Header file for OSMesa (off-screen renderer) library
328 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
329 License:        MIT
330 Group:          Development/Libraries
331 Requires:       %{name}-libOSMesa = %{version}-%{release}
332 # for <GL/gl.h> only
333 Requires:       OpenGL-devel
334
335 %description libOSMesa-devel
336 Header file for OSMesa (off-screen renderer) library.
337
338 %description libOSMesa-devel -l pl.UTF-8
339 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
340
341 %package libOSMesa-static
342 Summary:        Static OSMesa (off-screen renderer) library
343 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
344 License:        MIT
345 Group:          Development/Libraries
346 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
347 # this static build of OSMesa needs static non-dri Mesa implementation
348 Requires:       %{name}-libGL-static = %{version}-%{release}
349
350 %description libOSMesa-static
351 Static OSMesa (off-screen renderer) library.
352
353 %description libOSMesa-static -l pl.UTF-8
354 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
355
356 %package libOpenVG
357 Summary:        OpenVG API implementation
358 Summary(pl.UTF-8):      Implementacja API OpenVG
359 License:        MIT
360 Group:          Libraries
361 # doesn't require base
362
363 %description libOpenVG
364 OpenVG API implementation.
365
366 %description libOpenVG -l pl.UTF-8
367 Implementacja API OpenVG.
368
369 %package libOpenVG-devel
370 Summary:        Header file for libOpenVG library
371 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libOpenVG
372 License:        MIT
373 Group:          Development/Libraries
374 # for <KHR/khrplatform.h>
375 Requires:       %{name}-libEGL-devel = %{version}-%{release}
376 Requires:       %{name}-libOpenVG = %{version}-%{release}
377
378 %description libOpenVG-devel
379 Header file for libOpenVG library.
380
381 %description libOpenVG-devel -l pl.UTF-8
382 Plik nagłówkowy biblioteki libOpenVG.
383
384 %package utils
385 Summary:        OpenGL utilities from Mesa3D
386 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
387 License:        MIT
388 Group:          X11/Applications/Graphics
389 # loose deps on libGL/libGLU
390
391 %description utils
392 OpenGL utilities from Mesa3D: glxgears and glxinfo.
393
394 %description utils -l pl.UTF-8
395 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
396
397 %package dri-driver-ati-radeon-R100
398 Summary:        X.org DRI driver for ATI R100 card family
399 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
400 License:        MIT
401 Group:          X11/Libraries
402 Requires:       xorg-driver-video-ati
403 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
404 Requires:       xorg-xserver-server >= %{xserver_ver}
405 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
406
407 %description dri-driver-ati-radeon-R100
408 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
409
410 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
411 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
412
413 %package dri-driver-ati-radeon-R200
414 Summary:        X.org DRI driver for ATI R200 card family
415 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
416 License:        MIT
417 Group:          X11/Libraries
418 Requires:       xorg-driver-video-ati
419 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
420 Requires:       xorg-xserver-server >= %{xserver_ver}
421 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
422
423 %description dri-driver-ati-radeon-R200
424 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
425
426 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
427 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
428
429 %package dri-driver-ati-radeon-R300
430 Summary:        X.org DRI driver for ATI R300 card family
431 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
432 License:        MIT
433 Group:          X11/Libraries
434 Requires:       xorg-driver-video-ati
435 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
436 Requires:       xorg-xserver-server >= %{xserver_ver}
437 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
438
439 %description dri-driver-ati-radeon-R300
440 X.org DRI driver for ATI R300 card family.
441
442 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
443 Sterownik X.org DRI dla rodziny kart ATI R300.
444
445 %package dri-driver-ati-radeon-R600
446 Summary:        X.org DRI driver for ATI R600 card family
447 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
448 License:        MIT
449 Group:          X11/Libraries
450 Requires:       radeon-ucode
451 Requires:       xorg-driver-video-ati
452 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
453 Requires:       xorg-xserver-server >= %{xserver_ver}
454
455 %description dri-driver-ati-radeon-R600
456 X.org DRI driver for ATI R600 card family.
457
458 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
459 Sterownik X.org DRI dla rodziny kart ATI R600.
460
461 %package dri-driver-ffb
462 Summary:        X.org DRI driver for Sun FFB card family
463 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
464 License:        MIT
465 Group:          X11/Libraries
466 Requires:       xorg-driver-video-sunffb
467 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
468 Requires:       xorg-xserver-server >= %{xserver_ver}
469
470 %description dri-driver-ffb
471 X.org DRI driver for SUN Creator3D and Elite3D card family.
472
473 %description dri-driver-ffb -l pl.UTF-8
474 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
475
476 %package dri-driver-glint
477 Summary:        X.org DRI driver for GLINT/Permedia card family
478 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
479 License:        MIT
480 Group:          X11/Libraries
481 Requires:       xorg-driver-video-glint
482 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
483 Requires:       xorg-xserver-server >= %{xserver_ver}
484 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
485
486 %description dri-driver-glint
487 X.org DRI driver for GLINT/Permedia card family.
488
489 %description dri-driver-glint -l pl.UTF-8
490 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
491
492 %package dri-driver-intel-i915
493 Summary:        X.org DRI driver for Intel i915 card family
494 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
495 License:        MIT
496 Group:          X11/Libraries
497 Requires:       xorg-driver-video-intel
498 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
499 Requires:       xorg-xserver-server >= %{xserver_ver}
500 Obsoletes:      Mesa-dri-driver-intel-i830
501 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
502
503 %description dri-driver-intel-i915
504 X.org DRI driver for Intel i915 card family.
505
506 %description dri-driver-intel-i915 -l pl.UTF-8
507 Sterownik X.org DRI dla rodziny kart Intel i915.
508
509 %package dri-driver-intel-i965
510 Summary:        X.org DRI driver for Intel i965 card family
511 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
512 License:        MIT
513 Group:          X11/Libraries
514 Requires:       xorg-driver-video-intel
515 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
516 Requires:       xorg-xserver-server >= %{xserver_ver}
517 Obsoletes:      Mesa-dri-driver-intel-i830
518 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
519
520 %description dri-driver-intel-i965
521 X.org DRI driver for Intel i965 card family.
522
523 %description dri-driver-intel-i965 -l pl.UTF-8
524 Sterownik X.org DRI dla rodziny kart Intel i965.
525
526 %package dri-driver-nouveau
527 Summary:        X.org DRI driver for NVIDIA card family
528 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
529 License:        MIT
530 Group:          X11/Libraries
531 Requires:       xorg-driver-video-nouveau
532 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
533 Requires:       xorg-xserver-server >= %{xserver_ver}
534
535 %description dri-driver-nouveau
536 X.org DRI drivers for NVIDIA card family.
537
538 %description dri-driver-nouveau -l pl.UTF-8
539 Sterowniki X.org DRI dla rodziny kart NVIDIA.
540
541 %package dri-driver-swrast
542 Summary:        X.org DRI software rasterizer driver
543 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
544 License:        MIT
545 Group:          X11/Libraries
546 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
547 Requires:       xorg-xserver-server >= %{xserver_ver}
548
549 %description dri-driver-swrast
550 X.org DRI software rasterizer driver.
551
552 %description dri-driver-swrast -l pl.UTF-8
553 Sterownik X.org DRI obsługujący rysowanie programowe.
554
555 %package dri-driver-vmwgfx
556 Summary:        X.org DRI driver for VMware
557 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
558 License:        MIT
559 Group:          X11/Libraries
560 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
561 Requires:       xorg-xserver-server >= %{xserver_ver}
562
563 %description dri-driver-vmwgfx
564 X.org DRI driver for VMWare.
565
566 %description dri-driver-vmwgfx -l pl.UTF-8
567 Sterownik X.org DRI dla VMware.
568
569 %package -n libvdpau-driver-mesa
570 Summary:        Mesa driver for the vdpau API
571 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
572 License:        MIT
573 Group:          X11/Libraries
574
575 %description -n libvdpau-driver-mesa
576 Mesa driver for the vdpau API.
577
578 %description -n libvdpau-driver-mesa -l pl.UTF-8
579 Sterownik Mesa dla API vdpau.
580
581 %prep
582 %setup -q
583 %patch0 -p0
584 %patch2 -p1
585
586 %build
587 %{__aclocal}
588 %{__autoconf}
589
590 dri_drivers="r200 radeon \
591 %if %{without gallium_radeon}
592 r300 r600 \
593 %endif
594 %if %{without gallium_intel}
595 i915 i965 \
596 %endif
597 %ifarch sparc sparcv9 sparc64
598 ffb \
599 %endif
600 swrast"
601
602 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
603
604 gallium_drivers="svga swrast \
605 %if %{with gallium_intel}
606 i915 \
607 i965 \
608 %endif
609 %if %{with gallium_radeon}
610 r300 \
611 r600 \
612 %endif
613 %if %{with gallium_nouveau}
614 nouveau \
615 %endif
616 "
617
618 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
619
620 common_flags="\
621         --enable-shared \
622         --enable-selinux \
623         --enable-pic \
624         --enable-glx-tls \
625 %if %{with egl}
626         --enable-egl \
627         --enable-gles1 \
628         --enable-gles2 \
629 %endif
630 "
631
632 osmesa_common_flags="\
633         --with-driver=osmesa \
634         --disable-asm \
635         --disable-glu \
636         --disable-egl"
637
638 %if %{with osmesa}
639 %configure $common_flags $osmesa_common_flags \
640         --with-osmesa-bits=8
641 %{__make}
642 mv %{_lib} osmesa8
643 %{__make} clean
644 %endif
645
646 %configure $common_flags \
647         --enable-shared-glapi \
648 %if %{with egl}
649         --enable-egl \
650         --enable-gles1 \
651         --enable-gles2 \
652         %{__enable gbm} \
653 %endif
654 %if %{with gallium}
655         --enable-openvg \
656         %{__enable egl gallium-egl} \
657         %{__enable gbm gallium-gbm} \
658         --enable-vdpau \
659         --enable-xvmc \
660         --with-gallium-drivers=${gallium_drivers} \
661 %else
662         --disable-gallium \
663 %endif
664         --with-driver=dri \
665         --with-dri-drivers=${dri_drivers} \
666         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
667
668 %{__make}
669
670 %install
671 rm -rf $RPM_BUILD_ROOT
672
673 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
674
675 # libs without drivers
676 %{__make} install \
677         DESTDIR=$RPM_BUILD_ROOT
678
679 %if %{with osmesa}
680 cp -dp osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
681 %endif
682
683 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
684
685 # strip out undesirable headers
686 olddir=$(pwd)
687 cd $RPM_BUILD_ROOT%{_includedir}/GL
688 rm [a-fh-np-wyz]*.h
689 cd $RPM_BUILD_ROOT%{_libdir}
690 cd $olddir
691
692 %if %{with multigl}
693 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
694
695 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
696 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
697
698 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
699 %endif
700
701 %clean
702 rm -rf $RPM_BUILD_ROOT
703
704 %post   libEGL -p /sbin/ldconfig
705 %postun libEGL -p /sbin/ldconfig
706
707 %post   libGL -p /sbin/ldconfig
708 %postun libGL -p /sbin/ldconfig
709
710 %post   libGLES -p /sbin/ldconfig
711 %postun libGLES -p /sbin/ldconfig
712
713 %post   libGLU -p /sbin/ldconfig
714 %postun libGLU -p /sbin/ldconfig
715
716 %post   libOSMesa -p /sbin/ldconfig
717 %postun libOSMesa -p /sbin/ldconfig
718
719 %post   libOpenVG -p /sbin/ldconfig
720 %postun libOpenVG -p /sbin/ldconfig
721
722 %if %{with egl}
723 %files libEGL
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
727 %if %{with gbm}
728 %dir %{_libdir}/gbm
729 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
731 %endif
732 %if %{with gallium}
733 %dir %{_libdir}/egl
734 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
735 #%attr(755,root,root) %{_libdir}/egl/st_GL.so
736 %if %{with gbm}
737 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
738 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
739 %if %{with gallium_nouveau}
740 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
741 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.*.*
742 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1
743 %endif
744 %if %{with gallium_radeon}
745 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
746 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
747 %endif
748 %if %{with gallium_intel}
749 %attr(755,root,root) %{_libdir}/gbm/pipe_i915.so
750 %attr(755,root,root) %{_libdir}/gbm/pipe_i965.so
751 %endif
752 %endif
753 %endif
754
755 %files libEGL-devel
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/libEGL.so
758 %dir %{_includedir}/EGL
759 %{_includedir}/EGL/egl.h
760 %{_includedir}/EGL/eglext.h
761 %{_includedir}/EGL/eglplatform.h
762 %dir %{_includedir}/KHR
763 %{_includedir}/KHR/khrplatform.h
764 %{_pkgconfigdir}/egl.pc
765 %if %{with gbm}
766 %attr(755,root,root) %{_libdir}/libgbm.so
767 %{_includedir}/gbm.h
768 %{_pkgconfigdir}/gbm.pc
769 %endif
770
771 %if %{with static_libs}
772 %files libEGL-static
773 %defattr(644,root,root,755)
774 %{_libdir}/libEGL.a
775 %endif
776 %endif
777
778 %files libGL
779 %defattr(644,root,root,755)
780 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
781 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
782 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
783 %if %{with multigl}
784 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
785 %dir %{_libdir}/Mesa
786 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
787 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
788 %else
789 %attr(755,root,root) %{_libdir}/libGL.so.*.*
790 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
791 # symlink for binary apps which fail to conform Linux OpenGL ABI
792 # (and dlopen libGL.so instead of libGL.so.1)
793 %attr(755,root,root) %{_libdir}/libGL.so
794 %endif
795
796 %files libGL-devel
797 %defattr(644,root,root,755)
798 %doc docs/*.spec
799 %attr(755,root,root) %{_libdir}/libglapi.so
800 %if %{with multigl}
801 %attr(755,root,root) %{_libdir}/libGL.so
802 %endif
803 %dir %{_includedir}/GL
804 %{_includedir}/GL/gl.h
805 %{_includedir}/GL/glext.h
806 %{_includedir}/GL/gl_mangle.h
807 %{_includedir}/GL/glx.h
808 %{_includedir}/GL/glxext.h
809 %{_includedir}/GL/glx_mangle.h
810 %dir %{_includedir}/GL/internal
811 %{_includedir}/GL/internal/dri_interface.h
812 %{_pkgconfigdir}/dri.pc
813 %{_pkgconfigdir}/gl.pc
814
815 %files libGLES
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libGLES*.so.*.*
818 %attr(755,root,root) %ghost %{_libdir}/libGLES*.so.[0-9]
819
820 %files libGLES-devel
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_libdir}/libGLES*.so
823 %{_includedir}/GLES
824 %{_includedir}/GLES2
825 %{_pkgconfigdir}/gles*.pc
826
827 %if %{with static_libs}
828 %files libGL-static
829 %defattr(644,root,root,755)
830 %{_libdir}/libGL.a
831 %endif
832
833 %files libGLU
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
836 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
837
838 %files libGLU-devel
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/libGLU.so
841 %{_includedir}/GL/glu.h
842 %{_includedir}/GL/glu_mangle.h
843 %{_pkgconfigdir}/glu.pc
844
845 %if %{with static_libs}
846 %files libGLU-static
847 %defattr(644,root,root,755)
848 %{_libdir}/libGLU.a
849 %endif
850
851 %if %{with osmesa}
852 %files libOSMesa
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
855 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
856
857 %files libOSMesa-devel
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/libOSMesa*.so
860 %{_includedir}/GL/osmesa.h
861
862 %if %{with static_libs}
863 %files libOSMesa-static
864 %defattr(644,root,root,755)
865 %{_libdir}/libOSMesa*.a
866 %endif
867 %endif
868
869 %if %{with gallium}
870 %files libOpenVG
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
873 %attr(755,root,root) %{_libdir}/libOpenVG.so.1.0.0
874
875 %files libOpenVG-devel
876 %defattr(644,root,root,755)
877 %{_includedir}/VG
878 %{_libdir}/libOpenVG.so
879 %{_pkgconfigdir}/vg.pc
880 %endif
881
882 %files dri-driver-ati-radeon-R100
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
885
886 %files dri-driver-ati-radeon-R200
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
889
890 %files dri-driver-ati-radeon-R300
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
893
894 %files dri-driver-ati-radeon-R600
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
897
898 # sunffb (sparc only)
899 %ifarch sparc sparcv9 sparc64
900 %files dri-driver-ffb
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
903 %endif
904
905 # glint (requires update)
906 %if 0
907 %files dri-driver-glint
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
910 %endif
911
912 %files dri-driver-intel-i915
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
915
916 %files dri-driver-intel-i965
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
919 %if %{with gallium_intel}
920 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
921 %endif
922
923 %if %{with gallium}
924 %if %{with gallium_nouveau}
925 %files dri-driver-nouveau
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
928 %endif
929 %endif
930
931 %files dri-driver-swrast
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
934
935 %if %{with gallium}
936 %files dri-driver-vmwgfx
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
939 %endif
940
941 %files -n libvdpau-driver-mesa
942 %defattr(644,root,root,755)
943 # there is no ldconfig here
944 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
945 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
946 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
947 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
948 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
949 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
950 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
951 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
952 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
This page took 0.173405 seconds and 4 git commands to generate.