]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- updated to 6.5.1
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - package OpenGL man pages (from monolith or SGI) somewhere
5 #
6 # Conditional build:
7 %bcond_with     glide   # with GLIDE (broken now)
8 %bcond_without  motif   # build static libGLw without Motif interface
9 #
10 Summary:        Free OpenGL implementation
11 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
12 Name:           Mesa
13 Version:        6.5.1
14 Release:        1
15 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
16 Group:          X11/Libraries
17 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
18 # Source0-md5:  c46f2c6646a270911b791dd8e1c2d977
19 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
20 # Source1-md5:  0f2794baf7a9d98b22caea9f78c6942d
21 Patch0:         %{name}-realclean.patch
22 URL:            http://www.mesa3d.org/
23 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
24 BuildRequires:  expat-devel
25 BuildRequires:  libdrm-devel >= 2.0.2
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:1.4d
28 %{?with_motif:BuildRequires:    motif-devel}
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  xorg-lib-libXt-devel
31 BuildRequires:  xorg-lib-libXxf86vm-devel
32 BuildRequires:  xorg-proto-glproto-devel
33 BuildRequires:  xorg-util-makedepend
34 Obsoletes:      Mesa-dri
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # avoid XFree86-OpenGL* dependency
38 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
39 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
40
41 %define         _sysconfdir     /etc/X11
42
43 %description
44 Mesa is a 3-D graphics library with an API which is very similar to
45 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
46 syntax or state machine, it is being used with authorization from
47 Silicon Graphics, Inc. However, the author does not possess an OpenGL
48 license from SGI, and makes no claim that Mesa is in any way a
49 compatible replacement for OpenGL or associated with SGI.
50
51 %description -l pl
52 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
53 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
54 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
55 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
56 OpenGL ani powi±zana z SGI.
57
58 %package libGL
59 Summary:        Free Mesa3D implementation of libGL OpenGL library
60 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
61 License:        MIT
62 Group:          X11/Libraries
63 %{?with_glide:Requires: Glide3-DRI}
64 Provides:       OpenGL = 1.5
65 # reports version 1.3, but supports glXGetProcAddress() from 1.4
66 Provides:       OpenGL-GLX = 1.4
67 Obsoletes:      Mesa
68 Obsoletes:      X11-OpenGL-libGL
69 Obsoletes:      XFree86-OpenGL-libGL
70
71 %description libGL
72 Mesa is a 3-D graphics library with an API which is very similar to
73 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
74 syntax or state machine, it is being used with authorization from
75 Silicon Graphics, Inc. However, the author does not possess an OpenGL
76 license from SGI, and makes no claim that Mesa is in any way a
77 compatible replacement for OpenGL or associated with SGI.
78
79 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
80 specifications. It uses DRI for rendering.
81
82 %description libGL -l pl
83 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
84 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
85 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
86 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
87 OpenGL ani powi±zana z SGI.
88
89 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
90 GLX 1.4. U¿ywa DRI do renderowania.
91
92 %package libGL-devel
93 Summary:        Header files for Mesa3D libGL library
94 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
95 License:        MIT
96 Group:          X11/Development/Libraries
97 # loose dependency on libGL to use with other libGL binaries
98 Requires:       OpenGL >= 1.5
99 Requires:       xorg-lib-libX11-devel
100 Provides:       OpenGL-devel = 1.5
101 Provides:       OpenGL-GLX-devel = 1.4
102 Obsoletes:      Mesa-devel
103 Obsoletes:      X11-OpenGL-devel
104 Obsoletes:      X11-OpenGL-devel-base
105 Obsoletes:      XFree86-OpenGL-devel
106 Obsoletes:      XFree86-OpenGL-devel-base
107
108 %description libGL-devel
109 Header files for Mesa3D libGL library.
110
111 %description libGL-devel -l pl
112 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
113
114 %package libGL-static
115 Summary:        Static Mesa3D libGL library
116 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
117 License:        MIT
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-libGL-devel = %{version}-%{release}
120 Provides:       OpenGL-static = 1.5
121 Obsoletes:      Mesa-static
122 Obsoletes:      X11-OpenGL-static
123 Obsoletes:      XFree86-OpenGL-static
124
125 %description libGL-static
126 Static Mesa3D libGL library. It uses software renderer.
127
128 %description libGL-static -l pl
129 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
130 renderingu.
131
132 %package libGLU
133 Summary:        SGI implementation of libGLU OpenGL library
134 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
135 License:        SGI Free Software License B v1.1
136 Group:          Libraries
137 # loose dependency on libGL.so.1 to use with other libGL binaries
138 Requires:       OpenGL >= 1.2
139 Provides:       OpenGL-GLU = 1.3
140 Obsoletes:      Mesa-devel
141 Obsoletes:      X11-OpenGL-libs
142 Obsoletes:      XFree86-OpenGL-libs
143
144 %description libGLU
145 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
146 1.3 specifications.
147
148 %description libGLU -l pl
149 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
150 specyfikacjê OpenGL GLU 1.3.
151
152 %package libGLU-devel
153 Summary:        Header files for SGI libGLU library
154 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
155 License:        SGI Free Software License B v1.1
156 Group:          Development/Libraries
157 Requires:       %{name}-libGLU = %{version}-%{release}
158 Requires:       OpenGL-devel >= 1.2
159 Requires:       libstdc++-devel
160 Provides:       OpenGL-GLU-devel = 1.3
161
162 %description libGLU-devel
163 Header files for SGI libGLU library.
164
165 %description libGLU-devel -l pl
166 Pliki nag³ówkowe biblioteki SGI libGLU.
167
168 %package libGLU-static
169 Summary:        Static SGI libGLU library
170 Summary(pl):    Statyczna biblioteka SGI libGLU
171 License:        SGI Free Software License B v1.1
172 Group:          Development/Libraries
173 Requires:       %{name}-libGLU-devel = %{version}-%{release}
174 Provides:       OpenGL-GLU-static = 1.3
175
176 %description libGLU-static
177 Static SGI libGLU library.
178
179 %description libGLU-static -l pl
180 Statyczna biblioteka SGI libGLU.
181
182 %package libGLw
183 Summary:        SGI OpenGL Xt widgets library
184 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
185 License:        SGI MIT-like
186 Group:          Libraries
187 # loose dependency on libGL.so.1 to use with other libGL binaries
188 Requires:       OpenGL >= 1.1
189 Provides:       OpenGL-GLw
190
191 %description libGLw
192 SGI OpenGL Xt widgets library.
193
194 %description libGLU -l pl
195 Biblioteka SGI widgetów Xt dla OpenGL-a.
196
197 %package libGLw-devel
198 Summary:        Header files for SGI libGLw library
199 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
200 License:        SGI Free Software License B v1.1
201 Group:          Development/Libraries
202 Requires:       %{name}-libGLw = %{version}-%{release}
203 Requires:       OpenGL-devel >= 1.2
204 Provides:       OpenGL-GLw-devel
205
206 %description libGLw-devel
207 Header files for SGI libGLw library.
208
209 %description libGLw-devel -l pl
210 Pliki nag³ówkowe biblioteki SGI libGLw.
211
212 %package libGLw-static
213 Summary:        Static SGI libGLw library
214 Summary(pl):    Statyczna biblioteka SGI libGLw
215 License:        SGI Free Software License B v1.1
216 Group:          Development/Libraries
217 Requires:       %{name}-libGLw-devel = %{version}-%{release}
218 Provides:       OpenGL-GLw-static
219
220 %description libGLw-static
221 Static SGI libGLw library.
222
223 %description libGLw-static -l pl
224 Statyczna biblioteka SGI libGLw.
225
226 %package utils
227 Summary:        OpenGL utilities from Mesa3D
228 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
229 Group:          X11/Applications/Graphics
230 # loose deps on libGL/libGLU
231
232 %description utils
233 OpenGL utilities from Mesa3D: glxgears and glxinfo.
234
235 %description utils -l pl
236 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
237
238 %package demos
239 Summary:        Mesa Demos
240 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
241 Group:          Development/Libraries
242 Requires:       OpenGL-devel
243
244 %description demos
245 Demonstration programs for the Mesa libraries.
246
247 %description demos -l pl
248 Programy demonstracyjne dla bibliotek Mesa.
249
250 %package dri-driver-ati-mach64
251 Summary:        X.org DRI drivers
252 Summary(pl):    Sterowniki DRI dla X.org
253 Group:          X11/Libraries
254 Requires:       xorg-xserver-server
255
256 %description dri-driver-ati-mach64
257 X.org DRI drivers for ATI mach64 card family.
258
259 %description dri-driver-ati-mach64 -l pl
260 Sterowniki X.org DRI dla rodziny kart ATI mach64.
261
262 %package dri-driver-ati-radeon-R100
263 Summary:        X.org DRI drivers
264 Summary(pl):    Sterowniki DRI dla X.org
265 Group:          X11/Libraries
266 Requires:       xorg-xserver-server
267
268 %description dri-driver-ati-radeon-R100
269 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
270
271 %description dri-driver-ati-radeon-R100 -l pl
272 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
273
274 %package dri-driver-ati-radeon-R200
275 Summary:        X.org DRI drivers
276 Summary(pl):    Sterowniki DRI dla X.org
277 Group:          X11/Libraries
278 Requires:       xorg-xserver-server
279
280 %description dri-driver-ati-radeon-R200
281 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
282
283 %description dri-driver-ati-radeon-R200 -l pl
284 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
285
286 %package dri-driver-ati-radeon-R300
287 Summary:        X.org DRI drivers
288 Summary(pl):    Sterowniki DRI dla X.org
289 Group:          X11/Libraries
290 Requires:       xorg-xserver-server
291
292 %description dri-driver-ati-radeon-R300
293 X.org DRI drivers for ATI R300 card family.
294
295 %description dri-driver-ati-radeon-R300 -l pl
296 Sterowniki X.org DRI dla rodziny kart ATI R300.
297
298 %package dri-driver-ati-rage128
299 Summary:        X.org DRI drivers
300 Summary(pl):    Sterowniki DRI dla X.org
301 Group:          X11/Libraries
302 Requires:       xorg-xserver-server
303
304 %description dri-driver-ati-rage128
305 X.org DRI drivers for ATI rage128 card family.
306
307 %description dri-driver-ati-rage128 -l pl
308 Sterowniki X.org DRI dla rodziny kart ATI rage128.
309
310 %package dri-driver-ffb
311 Summary:        X.org DRI drivers
312 Summary(pl):    Sterowniki DRI dla X.org
313 Group:          X11/Libraries
314 Requires:       xorg-xserver-server
315
316 %description dri-driver-ffb
317 X.org DRI drivers for SUN Creator3D and Elite3D card family.
318
319 %description dri-driver-ffb -l pl
320 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
321
322 %package dri-driver-glint
323 Summary:        X.org DRI drivers
324 Summary(pl):    Sterowniki DRI dla X.org
325 Group:          X11/Libraries
326 Requires:       xorg-xserver-server
327
328 %description dri-driver-glint
329 X.org DRI drivers for GLINT/Permedia card family.
330
331 %description dri-driver-glint -l pl
332 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
333
334 %package dri-driver-intel-i810
335 Summary:        X.org DRI drivers
336 Summary(pl):    Sterowniki DRI dla X.org
337 Group:          X11/Libraries
338 Requires:       xorg-xserver-server
339
340 %description dri-driver-intel-i810
341 X.org DRI drivers for Intel i810 card family.
342
343 %description dri-driver-intel-i810 -l pl
344 Sterowniki X.org DRI dla rodziny kart i810.
345
346 %package dri-driver-intel-i830
347 Summary:        X.org DRI drivers
348 Summary(pl):    Sterowniki DRI dla X.org
349 Group:          X11/Libraries
350 Requires:       xorg-xserver-server
351
352 %description dri-driver-intel-i830
353 X.org DRI drivers for Intel i830 card family.
354
355 %description dri-driver-intel-i830 -l pl
356 Sterowniki X.org DRI dla rodziny kart i830.
357
358 %package dri-driver-intel-i915
359 Summary:        X.org DRI drivers
360 Summary(pl):    Sterowniki DRI dla X.org
361 Group:          X11/Libraries
362 Requires:       xorg-xserver-server
363 Obsoletes:      Mesa-dri-driver-intel-i830
364
365 %description dri-driver-intel-i915
366 X.org DRI drivers for Intel i915 card family.
367
368 %description dri-driver-intel-i915 -l pl
369 Sterowniki X.org DRI dla rodziny kart i915.
370
371 %package dri-driver-intel-i965
372 Summary:        X.org DRI drivers
373 Summary(pl):    Sterowniki DRI dla X.org
374 Group:          X11/Libraries
375 Requires:       xorg-xserver-server
376 Obsoletes:      Mesa-dri-driver-intel-i830
377 Obsoletes:      Mesa-dri-driver-intel-i915
378
379 %description dri-driver-intel-i965
380 X.org DRI drivers for Intel i965 card family.
381
382 %description dri-driver-intel-i965 -l pl
383 Sterowniki X.org DRI dla rodziny kart i965.
384
385 %package dri-driver-matrox
386 Summary:        X.org DRI drivers
387 Summary(pl):    Sterowniki DRI dla X.org
388 Group:          X11/Libraries
389 Requires:       xorg-xserver-server
390
391 %description dri-driver-matrox
392 X.org DRI drivers for Matrox G card family.
393
394 %description dri-driver-matrox -l pl
395 Sterowniki X.org DRI dla rodziny kart Matrox G.
396
397 %package dri-driver-s3virge
398 Summary:        X.org DRI drivers
399 Summary(pl):    Sterowniki DRI dla X.org
400 Group:          X11/Libraries
401 Requires:       xorg-xserver-server
402
403 %description dri-driver-s3virge
404 X.org DRI drivers for S3 Virge card family.
405
406 %description dri-driver-s3virge -l pl
407 Sterowniki X.org DRI dla rodziny kart S3 Virge.
408
409 %package dri-driver-savage
410 Summary:        X.org DRI drivers
411 Summary(pl):    Sterowniki DRI dla X.org
412 Group:          X11/Libraries
413 Requires:       xorg-xserver-server
414
415 %description dri-driver-savage
416 X.org DRI drivers for S3 Savage card family.
417
418 %description dri-driver-savage -l pl
419 Sterowniki X.org DRI dla rodziny kart S3 Savage.
420
421 %package dri-driver-sis
422 Summary:        X.org DRI drivers
423 Summary(pl):    Sterowniki DRI dla X.org
424 Group:          X11/Libraries
425 Requires:       xorg-xserver-server
426
427 %description dri-driver-sis
428 X.org DRI drivers for SiS card family.
429
430 %description dri-driver-sis -l pl
431 Sterowniki X.org DRI dla rodziny kart SiS.
432
433 %package dri-driver-tdfx
434 Summary:        X.org DRI drivers
435 Summary(pl):    Sterowniki DRI dla X.org
436 Group:          X11/Libraries
437 Requires:       xorg-xserver-server
438
439 %description dri-driver-tdfx
440 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
441 and Velocity 100/200).
442
443 %description dri-driver-tdfx -l pl
444 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
445 Banshee and Velocity 100/200).
446
447 %package dri-driver-trident
448 Summary:        X.org DRI drivers
449 Summary(pl):    Sterowniki DRI dla X.org
450 Group:          X11/Libraries
451 Requires:       xorg-xserver-server
452
453 %description dri-driver-trident
454 X.org DRI drivers for Trident card family.
455
456 %description dri-driver-trident -l pl
457 Sterowniki X.org DRI dla rodziny kart Trident.
458
459 %package dri-driver-via-unichrome
460 Summary:        X.org DRI drivers
461 Summary(pl):    Sterowniki DRI dla X.org
462 Group:          X11/Libraries
463 Requires:       xorg-xserver-server
464
465 %description dri-driver-via-unichrome
466 X.org DRI drivers for VIA Unichrome card family.
467
468 %description dri-driver-via-unichrome -l pl
469 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
470
471 %prep
472 %setup -q -b1
473 %patch0 -p0
474
475 # fix demos
476 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
477
478 %ifnarch sparc sparcv9 sparc64
479 # for sunffb driver - useful on sparc only
480 sed -i -e 's/ ffb$//' configs/linux-dri
481 %endif
482
483 %ifnarch %{ix86} %{x8664}
484 # sis needs write-memory barrier
485 sed -i -e 's/ sis / /' configs/linux-dri
486 %endif
487
488 %build
489 %ifarch %{ix86}
490 targ=-x86
491 %else
492 targ=""
493 %endif
494
495 %{__make} linux${targ}-static \
496         CC="%{__cc}" \
497         CXX="%{__cxx}" \
498         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
499         XLIB_DIR=%{_libdir} \
500         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
501         SRC_DIRS="mesa glu glw" \
502         PROGRAM_DIRS=
503 mv -f lib lib-static
504 %{__make} realclean
505
506 %{__make} linux-dri${targ} \
507         CC="%{__cc}" \
508         CXX="%{__cxx}" \
509         MKDEP=makedepend \
510         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
511         XLIB_DIR=%{_libdir} \
512         DRI_DRIVER_SEARCH_DIR=%{_libdir}/xorg/modules/dri \
513         SRC_DIRS="glx/x11 mesa glu glw" \
514         PROGRAM_DIRS=
515
516 %{__make} -C progs/xdemos \
517         CC="%{__cc}" \
518         CXX="%{__cxx}" \
519         OPT_FLAGS="%{rpmcflags}" \
520         XLIB_DIR=%{_libdir} \
521         PROGS="glxgears" \
522         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL"
523
524 %{__make} -C progs/xdemos \
525         CC="%{__cc}" \
526         CXX="%{__cxx}" \
527         OPT_FLAGS="%{rpmcflags}" \
528         XLIB_DIR=%{_libdir} \
529         PROGS="glxinfo" \
530         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL -L../../lib-dri -lGLU"
531
532 mv -f lib lib-dri
533 %{__make} clean \
534         MKDEP=makedepend
535 %{__make} realclean
536
537 %{__make} linux${targ} \
538         CC="%{__cc}" \
539         CXX="%{__cxx}" \
540         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
541         XLIB_DIR=%{_libdir} \
542         SRC_DIRS="mesa" \
543         PROGRAM_DIRS=
544
545 %install
546 rm -rf $RPM_BUILD_ROOT
547 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
548 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
549
550 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
551 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
552 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
553 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
554 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
555
556 # keep for -bi --short-circuit
557 cp -a progs progs.org
558 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
559 for l in demos redbook samples xdemos ; do
560         %{__make} -C progs/$l clean
561 done
562 for l in demos redbook samples util xdemos images ; do
563         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
564 done
565 rm -rf progs && mv -f progs.org progs
566 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %post   libGL -p /sbin/ldconfig
572 %postun libGL -p /sbin/ldconfig
573
574 %post   libGLU -p /sbin/ldconfig
575 %postun libGLU -p /sbin/ldconfig
576
577 %post   libGLw -p /sbin/ldconfig
578 %postun libGLw -p /sbin/ldconfig
579
580 %files libGL
581 %defattr(644,root,root,755)
582 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
583 %attr(755,root,root) %{_libdir}/libGL.so.*.*
584 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
585 # symlink for binary apps which fail to conform Linux OpenGL ABI
586 # (and dlopen libGL.so instead of libGL.so.1)
587 %attr(755,root,root) %{_libdir}/libGL.so
588
589 %files libGL-devel
590 %defattr(644,root,root,755)
591 %doc docs/*.spec
592 %attr(755,root,root) %{_libdir}/libOSMesa.so
593 %dir %{_includedir}/GL
594 %{_includedir}/GL/gl.h
595 %{_includedir}/GL/glext.h
596 %{_includedir}/GL/glfbdev.h
597 %{_includedir}/GL/gl_mangle.h
598 %{_includedir}/GL/glx.h
599 %{_includedir}/GL/glxext.h
600 %{_includedir}/GL/glx_mangle.h
601 %{_includedir}/GL/osmesa.h
602 %{_includedir}/GL/xmesa.h
603 %{_includedir}/GL/xmesa_x.h
604 %{_includedir}/GL/xmesa_xf86.h
605
606 %files libGL-static
607 %defattr(644,root,root,755)
608 %{_libdir}/libGL.a
609 %{_libdir}/libOSMesa.a
610
611 %files libGLU
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
614
615 %files libGLU-devel
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/libGLU.so
618 %{_includedir}/GL/glu.h
619 %{_includedir}/GL/glu_mangle.h
620
621 %files libGLU-static
622 %defattr(644,root,root,755)
623 %{_libdir}/libGLU.a
624
625 %files libGLw
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
628
629 %files libGLw-devel
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/libGLw.so
632 %{_includedir}/GL/GLwDrawA.h
633 %{_includedir}/GL/GLwDrawAP.h
634 %{_includedir}/GL/GLwMDrawA.h
635 %{_includedir}/GL/GLwMDrawAP.h
636
637 %files libGLw-static
638 %defattr(644,root,root,755)
639 %{_libdir}/libGLw.a
640
641 %files utils
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_bindir}/glxgears
644 %attr(755,root,root) %{_bindir}/glxinfo
645
646 %files dri-driver-ati-mach64
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
649
650 %files dri-driver-ati-radeon-R100
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
653
654 %files dri-driver-ati-radeon-R200
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
657
658 %files dri-driver-ati-radeon-R300
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
661
662 %files dri-driver-ati-rage128
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
665
666 # sunffb (sparc only)
667 %ifarch sparc sparcv9 sparc64
668 %files dri-driver-ffb
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
671 %endif
672
673 # glint (requires update)
674 %if 0
675 %files dri-driver-glint
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
678 %endif
679
680 %files dri-driver-intel-i810
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
683
684 %if 0
685 %files dri-driver-intel-i830
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
688 %endif
689
690 %files dri-driver-intel-i915
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
693
694 %files dri-driver-intel-i965
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
697
698 %files dri-driver-matrox
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
701
702 %files dri-driver-s3virge
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
705
706 %files dri-driver-savage
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
709
710 %ifarch %{ix86} %{x8664}
711 %files dri-driver-sis
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
714 %endif
715
716 %files dri-driver-tdfx
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
719
720 %files dri-driver-trident
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
723
724 %files dri-driver-via-unichrome
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
727
728 %files demos
729 %defattr(644,root,root,755)
730 %{_examplesdir}/%{name}-%{version}
This page took 0.382115 seconds and 4 git commands to generate.