]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 20110912
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_without  gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_without  gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_without  gbm     # with Graphics Buffer Manager
16 %bcond_with     static_libs     # static libraries
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.25
26 %define         dri2proto_ver   2.6
27 %define         glproto_ver     1.4.11
28 #
29 %define         snap            20110912
30 #
31 Summary:        Free OpenGL implementation
32 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
33 Name:           Mesa
34 Version:        7.12
35 Release:        0.%{snap}.1%{?with_multigl:.mgl}
36 License:        MIT (core), SGI (GLU) and others - see license.html file
37 Group:          X11/Libraries
38 Source0:        %{name}Lib-%{snap}.tar.bz2
39 # Source0-md5:  e03c80194279a30a4f8fe96377028dea
40 Patch0:         %{name}-realclean.patch
41 Patch2:         %{name}-selinux.patch
42 URL:            http://www.mesa3d.org/
43 BuildRequires:  autoconf >= 2.59
44 BuildRequires:  automake
45 BuildRequires:  expat-devel
46 BuildRequires:  libdrm-devel >= %{libdrm_ver}
47 # drop when 2.4.24 is released
48 %{?with_nouveau:BuildRequires:  libdrm-devel >= 2.4.24}
49 BuildRequires:  libselinux-devel
50 BuildRequires:  libstdc++-devel >= 5:3.3.0
51 BuildRequires:  libtalloc-devel >= 2:2.0.1
52 BuildRequires:  libtool >= 2:1.4d
53 BuildRequires:  libvdpau-devel
54 BuildRequires:  llvm-devel >= 2.9
55 %{?with_motif:BuildRequires:    motif-devel}
56 BuildRequires:  pixman-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  pkgconfig(talloc) >= 2.0.1
59 BuildRequires:  python
60 BuildRequires:  python-libxml2
61 BuildRequires:  python-modules
62 BuildRequires:  rpmbuild(macros) >= 1.470
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  xorg-lib-libXdamage-devel
65 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
66 BuildRequires:  xorg-lib-libXt-devel
67 BuildRequires:  xorg-lib-libXvMC-devel
68 BuildRequires:  xorg-lib-libXxf86vm-devel
69 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
70 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
71 BuildRequires:  xorg-util-makedepend
72 BuildRequires:  xorg-xserver-server-devel
73 %if %{with egl}
74 BuildRequires:  libxcb-devel
75 BuildRequires:  udev-devel >= 150
76 %endif
77 %if %{with gallium}
78 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
79 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
80 %endif
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %if %{without gallium}
84 %undefine       with_gallium_intel
85 %undefine       with_gallium_radeon
86 %endif
87
88 %if %{without egl}
89 %undefine       with_gbm
90 %endif
91
92 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
93 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.*
94
95 %description
96 Mesa is a 3-D graphics library with an API which is very similar to
97 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
98 syntax or state machine, it is being used with authorization from
99 Silicon Graphics, Inc. However, the author does not possess an OpenGL
100 license from SGI, and makes no claim that Mesa is in any way a
101 compatible replacement for OpenGL or associated with SGI.
102
103 %description -l pl.UTF-8
104 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
105 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
106 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
107 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
108 OpenGL ani powiązana z SGI.
109
110 %package libEGL
111 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
112 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
113 License:        MIT
114 Group:          Libraries
115 Requires:       OpenGL >= 1.2
116 Requires:       udev-libs >= 150
117 Provides:       EGL = 1.4
118
119 %description libEGL
120 This package contains shared libEGL - Mesa implementation of EGL
121 Native Platform Graphics Interface as specified by Khronos Group:
122 <http://www.khronos.org/egl/>.
123
124 %description libEGL -l pl.UTF-8
125 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
126 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
127 graficznego platformy natywnej) wg specyfikacji Khronos Group:
128 <http://www.khronos.org/egl/>.
129
130 %package libEGL-devel
131 Summary:        Header files for Mesa implementation of EGL library
132 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
133 License:        MIT
134 Group:          Development/Libraries
135 Requires:       %{name}-libEGL = %{version}-%{release}
136 Requires:       OpenGL-devel >= 1.2
137 Requires:       libstdc++-devel
138 Provides:       EGL-devel = 1.4
139
140 %description libEGL-devel
141 Header files for Mesa implementation of EGL library.
142
143 %description libEGL-devel -l pl.UTF-8
144 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
145
146 %package libEGL-static
147 Summary:        Static SGI libEGL library
148 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
149 License:        MIT
150 Group:          Development/Libraries
151 Requires:       %{name}-libEGL-devel = %{version}-%{release}
152 Provides:       EGL-static = 1.4
153
154 %description libEGL-static
155 Static Mesa libEGL library.
156
157 %description libEGL-static -l pl.UTF-8
158 Statyczna biblioteka Mesa libEGL.
159
160 %package libGLES
161 Summary:        Mesa libGLES runtime libraries
162 Group:          Libraries
163
164 %description libGLES
165 Mesa GLES runtime libraries.
166
167 %description libGLES -l pl.UTF-8
168 Biblioteka Mesa GLES.
169
170 %package libGLES-devel
171 Summary:        Header files for libGLES library
172 Group:          Development/Libraries
173 Requires:       %{name}-libGLES = %{version}-%{release}
174
175 %description libGLES-devel
176 Header files for libGLES library.
177
178 %description libGLES-devel -l pl.UTF-8
179 Pliki nagłówkowe biblioteki libGLES.
180
181 %package libGL
182 Summary:        Free Mesa3D implementation of libGL OpenGL library
183 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
184 License:        MIT
185 Group:          X11/Libraries
186 Requires:       libdrm >= %{libdrm_ver}
187 Provides:       OpenGL = 2.1
188 # reports version 1.3, but supports glXGetProcAddress() from 1.4
189 Provides:       OpenGL-GLX = 1.4
190 Obsoletes:      Mesa
191 Obsoletes:      Mesa-dri
192 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
193 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
194
195 %description libGL
196 Mesa is a 3-D graphics library with an API which is very similar to
197 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
198 syntax or state machine, it is being used with authorization from
199 Silicon Graphics, Inc. However, the author does not possess an OpenGL
200 license from SGI, and makes no claim that Mesa is in any way a
201 compatible replacement for OpenGL or associated with SGI.
202
203 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
204 specifications. It uses DRI for rendering.
205
206 %description libGL -l pl.UTF-8
207 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
208 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
209 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
210 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
211 OpenGL ani powiązana z SGI.
212
213 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
214 GLX 1.4. Używa DRI do renderowania.
215
216 %package libGL-devel
217 Summary:        Header files for Mesa3D libGL library
218 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
219 License:        MIT
220 Group:          X11/Development/Libraries
221 # loose dependency on libGL to use with other libGL binaries
222 Requires:       OpenGL >= 1.5
223 Requires:       libdrm-devel >= %{libdrm_ver}
224 Requires:       xorg-lib-libX11-devel
225 Requires:       xorg-lib-libXdamage-devel
226 Requires:       xorg-lib-libXext-devel
227 Requires:       xorg-lib-libXxf86vm-devel
228 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
229 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
230 Suggests:       OpenGL-doc-man
231 Provides:       OpenGL-GLX-devel = 1.4
232 Provides:       OpenGL-devel = 2.1
233 Obsoletes:      Mesa-devel
234 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
235 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
236 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
237 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
238
239 %description libGL-devel
240 Header files for Mesa3D libGL library.
241
242 %description libGL-devel -l pl.UTF-8
243 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
244
245 %package libGL-static
246 Summary:        Static Mesa3D libGL library
247 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
248 License:        MIT
249 Group:          X11/Development/Libraries
250 Requires:       %{name}-libGL-devel = %{version}-%{release}
251 Provides:       OpenGL-static = 2.1
252 Obsoletes:      Mesa-static
253 Obsoletes:      X11-OpenGL-static < 1:7.0.0
254 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
255
256 %description libGL-static
257 Static Mesa3D libGL library. It uses software renderer.
258
259 %description libGL-static -l pl.UTF-8
260 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
261 renderingu.
262
263 %package libGLU
264 Summary:        SGI implementation of libGLU OpenGL library
265 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
266 License:        SGI Free Software License B v2.0 (MIT-like)
267 Group:          Libraries
268 # loose dependency on libGL.so.1 to use with other libGL binaries
269 Requires:       OpenGL >= 1.2
270 Provides:       OpenGL-GLU = 1.3
271 Obsoletes:      Mesa-devel
272 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
273 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
274
275 %description libGLU
276 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
277 1.3 specifications.
278
279 %description libGLU -l pl.UTF-8
280 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
281 specyfikację OpenGL GLU 1.3.
282
283 %package libGLU-devel
284 Summary:        Header files for SGI libGLU library
285 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
286 License:        SGI Free Software License B v2.0 (MIT-like)
287 Group:          Development/Libraries
288 Requires:       %{name}-libGLU = %{version}-%{release}
289 Requires:       OpenGL-devel >= 1.2
290 Requires:       libstdc++-devel
291 Provides:       OpenGL-GLU-devel = 1.3
292
293 %description libGLU-devel
294 Header files for SGI libGLU library.
295
296 %description libGLU-devel -l pl.UTF-8
297 Pliki nagłówkowe biblioteki SGI libGLU.
298
299 %package libGLU-static
300 Summary:        Static SGI libGLU library
301 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
302 License:        SGI Free Software License B v2.0 (MIT-like)
303 Group:          Development/Libraries
304 Requires:       %{name}-libGLU-devel = %{version}-%{release}
305 Provides:       OpenGL-GLU-static = 1.3
306
307 %description libGLU-static
308 Static SGI libGLU library.
309
310 %description libGLU-static -l pl.UTF-8
311 Statyczna biblioteka SGI libGLU.
312
313 %package libOSMesa
314 Summary:        OSMesa (off-screen renderer) library
315 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
316 License:        MIT
317 Group:          Libraries
318 # doesn't require base
319
320 %description libOSMesa
321 OSMesa (off-screen renderer) library.
322
323 %description libOSMesa -l pl.UTF-8
324 Biblioteka OSMesa (renderująca bitmapy w pamięci).
325
326 %package libOSMesa-devel
327 Summary:        Header file for OSMesa (off-screen renderer) library
328 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
329 License:        MIT
330 Group:          Development/Libraries
331 Requires:       %{name}-libOSMesa = %{version}-%{release}
332 # for <GL/gl.h> only
333 Requires:       OpenGL-devel
334
335 %description libOSMesa-devel
336 Header file for OSMesa (off-screen renderer) library.
337
338 %description libOSMesa-devel -l pl.UTF-8
339 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
340
341 %package libOSMesa-static
342 Summary:        Static OSMesa (off-screen renderer) library
343 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
344 License:        MIT
345 Group:          Development/Libraries
346 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
347 # this static build of OSMesa needs static non-dri Mesa implementation
348 Requires:       %{name}-libGL-static = %{version}-%{release}
349
350 %description libOSMesa-static
351 Static OSMesa (off-screen renderer) library.
352
353 %description libOSMesa-static -l pl.UTF-8
354 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
355
356 %package libOpenVG
357 Summary:        OpenVG API implementation
358 Summary(pl.UTF-8):      Implementacja API OpenVG
359 License:        MIT
360 Group:          Libraries
361 # doesn't require base
362
363 %description libOpenVG
364 OpenVG API implementation.
365
366 %description libOpenVG -l pl.UTF-8
367 Implementacja API OpenVG.
368
369 %package libOpenVG-devel
370 Summary:        Header file for libOpenVG library
371 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libOpenVG
372 License:        MIT
373 Group:          Development/Libraries
374 # for <KHR/khrplatform.h>
375 Requires:       %{name}-libEGL-devel = %{version}-%{release}
376 Requires:       %{name}-libOpenVG = %{version}-%{release}
377
378 %description libOpenVG-devel
379 Header file for libOpenVG library.
380
381 %description libOpenVG-devel -l pl.UTF-8
382 Plik nagłówkowy biblioteki libOpenVG.
383
384 %package libXvMC
385 Summary:        XvMC implementations
386 Summary(pl.UTF-8):      Implementacje API XvMC
387 License:        MIT
388 Group:          Libraries
389 # doesn't require base
390
391 %description libXvMC
392 libXvMC implementations.
393
394 %description libXvMC -l pl.UTF-8
395 Implementacje API libXvMC.
396
397 %package utils
398 Summary:        OpenGL utilities from Mesa3D
399 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
400 License:        MIT
401 Group:          X11/Applications/Graphics
402 # loose deps on libGL/libGLU
403
404 %description utils
405 OpenGL utilities from Mesa3D: glxgears and glxinfo.
406
407 %description utils -l pl.UTF-8
408 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
409
410 %package dri-driver-ati-radeon-R100
411 Summary:        X.org DRI driver for ATI R100 card family
412 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
413 License:        MIT
414 Group:          X11/Libraries
415 Requires:       xorg-driver-video-ati
416 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
417 Requires:       xorg-xserver-server >= %{xserver_ver}
418 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
419
420 %description dri-driver-ati-radeon-R100
421 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
422
423 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
424 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
425
426 %package dri-driver-ati-radeon-R200
427 Summary:        X.org DRI driver for ATI R200 card family
428 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
429 License:        MIT
430 Group:          X11/Libraries
431 Requires:       xorg-driver-video-ati
432 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
433 Requires:       xorg-xserver-server >= %{xserver_ver}
434 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
435
436 %description dri-driver-ati-radeon-R200
437 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
438
439 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
440 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
441
442 %package dri-driver-ati-radeon-R300
443 Summary:        X.org DRI driver for ATI R300 card family
444 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
445 License:        MIT
446 Group:          X11/Libraries
447 Requires:       xorg-driver-video-ati
448 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
449 Requires:       xorg-xserver-server >= %{xserver_ver}
450 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
451
452 %description dri-driver-ati-radeon-R300
453 X.org DRI driver for ATI R300 card family.
454
455 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart ATI R300.
457
458 %package dri-driver-ati-radeon-R600
459 Summary:        X.org DRI driver for ATI R600 card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       radeon-ucode
464 Requires:       xorg-driver-video-ati
465 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
466 Requires:       xorg-xserver-server >= %{xserver_ver}
467
468 %description dri-driver-ati-radeon-R600
469 X.org DRI driver for ATI R600 card family.
470
471 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
472 Sterownik X.org DRI dla rodziny kart ATI R600.
473
474 %package dri-driver-ffb
475 Summary:        X.org DRI driver for Sun FFB card family
476 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
477 License:        MIT
478 Group:          X11/Libraries
479 Requires:       xorg-driver-video-sunffb
480 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
481 Requires:       xorg-xserver-server >= %{xserver_ver}
482
483 %description dri-driver-ffb
484 X.org DRI driver for SUN Creator3D and Elite3D card family.
485
486 %description dri-driver-ffb -l pl.UTF-8
487 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
488
489 %package dri-driver-glint
490 Summary:        X.org DRI driver for GLINT/Permedia card family
491 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
492 License:        MIT
493 Group:          X11/Libraries
494 Requires:       xorg-driver-video-glint
495 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
496 Requires:       xorg-xserver-server >= %{xserver_ver}
497 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
498
499 %description dri-driver-glint
500 X.org DRI driver for GLINT/Permedia card family.
501
502 %description dri-driver-glint -l pl.UTF-8
503 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
504
505 %package dri-driver-intel-i915
506 Summary:        X.org DRI driver for Intel i915 card family
507 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
508 License:        MIT
509 Group:          X11/Libraries
510 Requires:       xorg-driver-video-intel
511 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
512 Requires:       xorg-xserver-server >= %{xserver_ver}
513 Obsoletes:      Mesa-dri-driver-intel-i830
514 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
515
516 %description dri-driver-intel-i915
517 X.org DRI driver for Intel i915 card family.
518
519 %description dri-driver-intel-i915 -l pl.UTF-8
520 Sterownik X.org DRI dla rodziny kart Intel i915.
521
522 %package dri-driver-intel-i965
523 Summary:        X.org DRI driver for Intel i965 card family
524 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
525 License:        MIT
526 Group:          X11/Libraries
527 Requires:       xorg-driver-video-intel
528 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
529 Requires:       xorg-xserver-server >= %{xserver_ver}
530 Obsoletes:      Mesa-dri-driver-intel-i830
531 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
532
533 %description dri-driver-intel-i965
534 X.org DRI driver for Intel i965 card family.
535
536 %description dri-driver-intel-i965 -l pl.UTF-8
537 Sterownik X.org DRI dla rodziny kart Intel i965.
538
539 %package dri-driver-nouveau
540 Summary:        X.org DRI driver for NVIDIA card family
541 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
542 License:        MIT
543 Group:          X11/Libraries
544 Requires:       xorg-driver-video-nouveau
545 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
546 Requires:       xorg-xserver-server >= %{xserver_ver}
547
548 %description dri-driver-nouveau
549 X.org DRI drivers for NVIDIA card family.
550
551 %description dri-driver-nouveau -l pl.UTF-8
552 Sterowniki X.org DRI dla rodziny kart NVIDIA.
553
554 %package dri-driver-swrast
555 Summary:        X.org DRI software rasterizer driver
556 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
557 License:        MIT
558 Group:          X11/Libraries
559 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
560 Requires:       xorg-xserver-server >= %{xserver_ver}
561
562 %description dri-driver-swrast
563 X.org DRI software rasterizer driver.
564
565 %description dri-driver-swrast -l pl.UTF-8
566 Sterownik X.org DRI obsługujący rysowanie programowe.
567
568 %package dri-driver-vmwgfx
569 Summary:        X.org DRI driver for VMware
570 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
571 License:        MIT
572 Group:          X11/Libraries
573 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
574 Requires:       xorg-xserver-server >= %{xserver_ver}
575
576 %description dri-driver-vmwgfx
577 X.org DRI driver for VMWare.
578
579 %description dri-driver-vmwgfx -l pl.UTF-8
580 Sterownik X.org DRI dla VMware.
581
582 %package -n libvdpau-driver-mesa
583 Summary:        Mesa driver for the vdpau API
584 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
585 License:        MIT
586 Group:          X11/Libraries
587
588 %description -n libvdpau-driver-mesa
589 Mesa driver for the vdpau API.
590
591 %description -n libvdpau-driver-mesa -l pl.UTF-8
592 Sterownik Mesa dla API vdpau.
593
594 %prep
595 %setup -q
596 %patch0 -p0
597 %patch2 -p1
598
599 %build
600 %{__aclocal}
601 %{__autoconf}
602
603 dri_drivers="r200 radeon \
604 %if %{without gallium_radeon}
605 r300 r600 \
606 %endif
607 %if %{without gallium_intel}
608 i915 i965 \
609 %endif
610 %ifarch sparc sparcv9 sparc64
611 ffb \
612 %endif
613 swrast"
614
615 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
616
617 gallium_drivers="svga swrast \
618 %if %{with gallium_intel}
619 i915 \
620 i965 \
621 %endif
622 %if %{with gallium_radeon}
623 r300 \
624 r600 \
625 %endif
626 %if %{with gallium_nouveau}
627 nouveau \
628 %endif
629 "
630
631 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
632
633 common_flags="\
634         --enable-shared \
635         --enable-selinux \
636         --enable-pic \
637         --enable-glx-tls \
638 %if %{with egl}
639         --enable-egl \
640         --enable-gles1 \
641         --enable-gles2 \
642 %endif
643 "
644
645 osmesa_common_flags="\
646         --with-driver=osmesa \
647         --disable-asm \
648         --disable-glu \
649         --disable-egl"
650
651 %if %{with osmesa}
652 %configure $common_flags $osmesa_common_flags \
653         --with-osmesa-bits=8
654 %{__make}
655 mv %{_lib} osmesa8
656 %{__make} clean
657 %endif
658
659 %configure $common_flags \
660         --enable-shared-glapi \
661 %if %{with egl}
662         --enable-egl \
663         --enable-gles1 \
664         --enable-gles2 \
665         %{__enable gbm} \
666 %endif
667 %if %{with gallium}
668         --enable-openvg \
669         %{__enable egl gallium-egl} \
670         %{__enable gbm gallium-gbm} \
671         --enable-vdpau \
672         --enable-xvmc \
673         --with-gallium-drivers=${gallium_drivers} \
674 %else
675         --disable-gallium \
676 %endif
677         --with-driver=dri \
678         --with-dri-drivers=${dri_drivers} \
679         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
680
681 %{__make}
682
683 %install
684 rm -rf $RPM_BUILD_ROOT
685
686 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
687
688 # libs without drivers
689 %{__make} install \
690         DESTDIR=$RPM_BUILD_ROOT
691
692 %if %{with osmesa}
693 cp -dp osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
694 %endif
695
696 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
697
698 # strip out undesirable headers
699 olddir=$(pwd)
700 cd $RPM_BUILD_ROOT%{_includedir}/GL
701 rm [a-fh-np-wyz]*.h
702 cd $RPM_BUILD_ROOT%{_libdir}
703 cd $olddir
704
705 %if %{with multigl}
706 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
707
708 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
709 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
710
711 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
712 %endif
713
714 %clean
715 rm -rf $RPM_BUILD_ROOT
716
717 %post   libEGL -p /sbin/ldconfig
718 %postun libEGL -p /sbin/ldconfig
719
720 %post   libGL -p /sbin/ldconfig
721 %postun libGL -p /sbin/ldconfig
722
723 %post   libGLES -p /sbin/ldconfig
724 %postun libGLES -p /sbin/ldconfig
725
726 %post   libGLU -p /sbin/ldconfig
727 %postun libGLU -p /sbin/ldconfig
728
729 %post   libOSMesa -p /sbin/ldconfig
730 %postun libOSMesa -p /sbin/ldconfig
731
732 %post   libOpenVG -p /sbin/ldconfig
733 %postun libOpenVG -p /sbin/ldconfig
734
735 %post   libXvMC -p /sbin/ldconfig
736 %postun libXvMC -p /sbin/ldconfig
737
738 %if %{with egl}
739 %files libEGL
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
743 %if %{with gbm}
744 %dir %{_libdir}/gbm
745 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
747 %endif
748 %if %{with gallium}
749 %dir %{_libdir}/egl
750 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
751 #%attr(755,root,root) %{_libdir}/egl/st_GL.so
752 %if %{with gbm}
753 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
754 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
755 %if %{with gallium_nouveau}
756 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
757 %endif
758 %if %{with gallium_radeon}
759 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
760 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
761 %endif
762 %if %{with gallium_intel}
763 %attr(755,root,root) %{_libdir}/gbm/pipe_i915.so
764 %attr(755,root,root) %{_libdir}/gbm/pipe_i965.so
765 %endif
766 %endif
767 %endif
768
769 %files libEGL-devel
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libEGL.so
772 %dir %{_includedir}/EGL
773 %{_includedir}/EGL/egl.h
774 %{_includedir}/EGL/eglext.h
775 %{_includedir}/EGL/eglplatform.h
776 %dir %{_includedir}/KHR
777 %{_includedir}/KHR/khrplatform.h
778 %{_pkgconfigdir}/egl.pc
779 %if %{with gbm}
780 %attr(755,root,root) %{_libdir}/libgbm.so
781 %{_includedir}/gbm.h
782 %{_pkgconfigdir}/gbm.pc
783 %endif
784
785 %if %{with static_libs}
786 %files libEGL-static
787 %defattr(644,root,root,755)
788 %{_libdir}/libEGL.a
789 %endif
790 %endif
791
792 %files libGL
793 %defattr(644,root,root,755)
794 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
795 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
796 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
797 %if %{with multigl}
798 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
799 %dir %{_libdir}/Mesa
800 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
801 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
802 %else
803 %attr(755,root,root) %{_libdir}/libGL.so.*.*
804 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
805 # symlink for binary apps which fail to conform Linux OpenGL ABI
806 # (and dlopen libGL.so instead of libGL.so.1)
807 %attr(755,root,root) %{_libdir}/libGL.so
808 %endif
809
810 %files libGL-devel
811 %defattr(644,root,root,755)
812 %doc docs/*.spec
813 %attr(755,root,root) %{_libdir}/libglapi.so
814 %if %{with multigl}
815 %attr(755,root,root) %{_libdir}/libGL.so
816 %endif
817 %dir %{_includedir}/GL
818 %{_includedir}/GL/gl.h
819 %{_includedir}/GL/glext.h
820 %{_includedir}/GL/gl_mangle.h
821 %{_includedir}/GL/glx.h
822 %{_includedir}/GL/glxext.h
823 %{_includedir}/GL/glx_mangle.h
824 %dir %{_includedir}/GL/internal
825 %{_includedir}/GL/internal/dri_interface.h
826 %{_pkgconfigdir}/dri.pc
827 %{_pkgconfigdir}/gl.pc
828
829 %files libGLES
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_libdir}/libGLES*.so.*.*
832 %attr(755,root,root) %ghost %{_libdir}/libGLES*.so.[0-9]
833
834 %files libGLES-devel
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libGLES*.so
837 %{_includedir}/GLES
838 %{_includedir}/GLES2
839 %{_pkgconfigdir}/gles*.pc
840
841 %if %{with static_libs}
842 %files libGL-static
843 %defattr(644,root,root,755)
844 %{_libdir}/libGL.a
845 %endif
846
847 %files libGLU
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
850 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
851
852 %files libGLU-devel
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libGLU.so
855 %{_includedir}/GL/glu.h
856 %{_includedir}/GL/glu_mangle.h
857 %{_pkgconfigdir}/glu.pc
858
859 %if %{with static_libs}
860 %files libGLU-static
861 %defattr(644,root,root,755)
862 %{_libdir}/libGLU.a
863 %endif
864
865 %if %{with osmesa}
866 %files libOSMesa
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
869 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
870
871 %files libOSMesa-devel
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/libOSMesa*.so
874 %{_includedir}/GL/osmesa.h
875
876 %if %{with static_libs}
877 %files libOSMesa-static
878 %defattr(644,root,root,755)
879 %{_libdir}/libOSMesa*.a
880 %endif
881 %endif
882
883 %if %{with gallium}
884 %files libOpenVG
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
887 %attr(755,root,root) %{_libdir}/libOpenVG.so.1.0.0
888
889 %files libOpenVG-devel
890 %defattr(644,root,root,755)
891 %{_includedir}/VG
892 %{_libdir}/libOpenVG.so
893 %{_pkgconfigdir}/vg.pc
894 %endif
895
896 %files libXvMC
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
899 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
900 %attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
901 %attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
902 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
903 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
904 %attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
905 %attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
906
907 %files dri-driver-ati-radeon-R100
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
910
911 %files dri-driver-ati-radeon-R200
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
914
915 %files dri-driver-ati-radeon-R300
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
918
919 %files dri-driver-ati-radeon-R600
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
922
923 # sunffb (sparc only)
924 %ifarch sparc sparcv9 sparc64
925 %files dri-driver-ffb
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
928 %endif
929
930 # glint (requires update)
931 %if 0
932 %files dri-driver-glint
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
935 %endif
936
937 %files dri-driver-intel-i915
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
940
941 %files dri-driver-intel-i965
942 %defattr(644,root,root,755)
943 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
944 %if %{with gallium_intel}
945 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
946 %endif
947
948 %if %{with gallium}
949 %if %{with gallium_nouveau}
950 %files dri-driver-nouveau
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
953 %endif
954 %endif
955
956 %files dri-driver-swrast
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
959
960 %if %{with gallium}
961 %files dri-driver-vmwgfx
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
964 %endif
965
966 %files -n libvdpau-driver-mesa
967 %defattr(644,root,root,755)
968 # there is no ldconfig here
969 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
970 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
971 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
972 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
973 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
974 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
975 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
976 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
977 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
This page took 0.129031 seconds and 4 git commands to generate.