]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- added patch needed for glxcompmgr
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - package OpenGL man pages (from monolith or SGI) somewhere
5 #
6 # Conditional build:
7 %bcond_with     glide   # with GLIDE (broken now)
8 %bcond_without  motif   # build static libGLw without Motif interface
9 #
10 Summary:        Free OpenGL implementation
11 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
12 Name:           Mesa
13 Version:        6.4.2
14 Release:        1
15 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
16 Group:          X11/Libraries
17 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
18 # Source0-md5:  7674d2c603b5834259e4e5a820cefd5b
19 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
20 # Source1-md5:  9cae1ab874af533ce356bd7dfe2e0bb0
21 Patch0:         %{name}-modules_dir.patch
22 Patch1:         %{name}-glx-x11-render-texture.diff
23 URL:            http://www.mesa3d.org/
24 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
25 BuildRequires:  expat-devel
26 BuildRequires:  libdrm-devel >= 1.0.4-1.20051022
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:1.4d
29 %{?with_motif:BuildRequires:    motif-devel}
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  xorg-lib-libXt-devel
32 BuildRequires:  xorg-lib-libXxf86vm-devel
33 BuildRequires:  xorg-proto-glproto-devel
34 BuildRequires:  xorg-util-makedepend
35 Obsoletes:      Mesa-dri
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # avoid XFree86-OpenGL* dependency
39 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
40 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
41
42 %define         _sysconfdir     /etc/X11
43
44 %description
45 Mesa is a 3-D graphics library with an API which is very similar to
46 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
47 syntax or state machine, it is being used with authorization from
48 Silicon Graphics, Inc. However, the author does not possess an OpenGL
49 license from SGI, and makes no claim that Mesa is in any way a
50 compatible replacement for OpenGL or associated with SGI.
51
52 %description -l pl
53 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
54 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
55 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
56 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
57 OpenGL ani powi±zana z SGI.
58
59 %package libGL
60 Summary:        Free Mesa3D implementation of libGL OpenGL library
61 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
62 License:        MIT
63 Group:          X11/Libraries
64 %{?with_glide:Requires: Glide3-DRI}
65 Provides:       OpenGL = 1.5
66 # reports version 1.3, but supports glXGetProcAddress() from 1.4
67 Provides:       OpenGL-GLX = 1.4
68 Obsoletes:      Mesa
69 Obsoletes:      X11-OpenGL-libGL
70 Obsoletes:      XFree86-OpenGL-libGL
71
72 %description libGL
73 Mesa is a 3-D graphics library with an API which is very similar to
74 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
75 syntax or state machine, it is being used with authorization from
76 Silicon Graphics, Inc. However, the author does not possess an OpenGL
77 license from SGI, and makes no claim that Mesa is in any way a
78 compatible replacement for OpenGL or associated with SGI.
79
80 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
81 specifications. It uses DRI for rendering.
82
83 %description libGL -l pl
84 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
85 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
86 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
87 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
88 OpenGL ani powi±zana z SGI.
89
90 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
91 GLX 1.4. U¿ywa DRI do renderowania.
92
93 %package libGL-devel
94 Summary:        Header files for Mesa3D libGL library
95 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
96 License:        MIT
97 Group:          X11/Development/Libraries
98 # loose dependency on libGL to use with other libGL binaries
99 Requires:       OpenGL >= 1.5
100 Requires:       xorg-lib-libX11-devel
101 Provides:       OpenGL-devel = 1.5
102 Provides:       OpenGL-GLX-devel = 1.4
103 Obsoletes:      Mesa-devel
104 Obsoletes:      X11-OpenGL-devel
105 Obsoletes:      X11-OpenGL-devel-base
106 Obsoletes:      XFree86-OpenGL-devel
107 Obsoletes:      XFree86-OpenGL-devel-base
108
109 %description libGL-devel
110 Header files for Mesa3D libGL library.
111
112 %description libGL-devel -l pl
113 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
114
115 %package libGL-static
116 Summary:        Static Mesa3D libGL library
117 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
118 License:        MIT
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-libGL-devel = %{version}-%{release}
121 Provides:       OpenGL-static = 1.5
122 Obsoletes:      Mesa-static
123 Obsoletes:      X11-OpenGL-static
124 Obsoletes:      XFree86-OpenGL-static
125
126 %description libGL-static
127 Static Mesa3D libGL library. It uses software renderer.
128
129 %description libGL-static -l pl
130 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
131 renderingu.
132
133 %package libGLU
134 Summary:        SGI implementation of libGLU OpenGL library
135 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
136 License:        SGI Free Software License B v1.1
137 Group:          Libraries
138 # loose dependency on libGL.so.1 to use with other libGL binaries
139 Requires:       OpenGL >= 1.2
140 Provides:       OpenGL-GLU = 1.3
141 Obsoletes:      Mesa-devel
142 Obsoletes:      X11-OpenGL-libs
143 Obsoletes:      XFree86-OpenGL-libs
144
145 %description libGLU
146 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
147 1.3 specifications.
148
149 %description libGLU -l pl
150 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
151 specyfikacjê OpenGL GLU 1.3.
152
153 %package libGLU-devel
154 Summary:        Header files for SGI libGLU library
155 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
156 License:        SGI Free Software License B v1.1
157 Group:          Development/Libraries
158 Requires:       %{name}-libGLU = %{version}-%{release}
159 Requires:       OpenGL-devel >= 1.2
160 Requires:       libstdc++-devel
161 Provides:       OpenGL-GLU-devel = 1.3
162
163 %description libGLU-devel
164 Header files for SGI libGLU library.
165
166 %description libGLU-devel -l pl
167 Pliki nag³ówkowe biblioteki SGI libGLU.
168
169 %package libGLU-static
170 Summary:        Static SGI libGLU library
171 Summary(pl):    Statyczna biblioteka SGI libGLU
172 License:        SGI Free Software License B v1.1
173 Group:          Development/Libraries
174 Requires:       %{name}-libGLU-devel = %{version}-%{release}
175 Provides:       OpenGL-GLU-static = 1.3
176
177 %description libGLU-static
178 Static SGI libGLU library.
179
180 %description libGLU-static -l pl
181 Statyczna biblioteka SGI libGLU.
182
183 %package libGLw
184 Summary:        SGI OpenGL Xt widgets library
185 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
186 License:        SGI MIT-like
187 Group:          Libraries
188 # loose dependency on libGL.so.1 to use with other libGL binaries
189 Requires:       OpenGL >= 1.1
190 Provides:       OpenGL-GLw
191
192 %description libGLw
193 SGI OpenGL Xt widgets library.
194
195 %description libGLU -l pl
196 Biblioteka SGI widgetów Xt dla OpenGL-a.
197
198 %package libGLw-devel
199 Summary:        Header files for SGI libGLw library
200 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
201 License:        SGI Free Software License B v1.1
202 Group:          Development/Libraries
203 Requires:       %{name}-libGLw = %{version}-%{release}
204 Requires:       OpenGL-devel >= 1.2
205 Provides:       OpenGL-GLw-devel
206
207 %description libGLw-devel
208 Header files for SGI libGLw library.
209
210 %description libGLw-devel -l pl
211 Pliki nag³ówkowe biblioteki SGI libGLw.
212
213 %package libGLw-static
214 Summary:        Static SGI libGLw library
215 Summary(pl):    Statyczna biblioteka SGI libGLw
216 License:        SGI Free Software License B v1.1
217 Group:          Development/Libraries
218 Requires:       %{name}-libGLw-devel = %{version}-%{release}
219 Provides:       OpenGL-GLw-static
220
221 %description libGLw-static
222 Static SGI libGLw library.
223
224 %description libGLw-static -l pl
225 Statyczna biblioteka SGI libGLw.
226
227 %package utils
228 Summary:        OpenGL utilities from Mesa3D
229 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
230 Group:          X11/Applications/Graphics
231 # loose deps on libGL/libGLU
232
233 %description utils
234 OpenGL utilities from Mesa3D: glxgears and glxinfo.
235
236 %description utils -l pl
237 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
238
239 %package demos
240 Summary:        Mesa Demos
241 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
242 Group:          Development/Libraries
243 Requires:       OpenGL-devel
244
245 %description demos
246 Demonstration programs for the Mesa libraries.
247
248 %description demos -l pl
249 Programy demonstracyjne dla bibliotek Mesa.
250
251 %package dri-driver-ati-mach64
252 Summary:        X.org DRI drivers
253 Summary(pl):    Sterowniki DRI dla X.org
254 Group:          X11/Libraries
255 Requires:       xorg-xserver-server
256
257 %description dri-driver-ati-mach64
258 X.org DRI drivers for ATI mach64 card family.
259
260 %description dri-driver-ati-mach64 -l pl
261 Sterowniki X.org DRI dla rodziny kart ATI mach64.
262
263 %package dri-driver-ati-radeon-R100
264 Summary:        X.org DRI drivers
265 Summary(pl):    Sterowniki DRI dla X.org
266 Group:          X11/Libraries
267 Requires:       xorg-xserver-server
268
269 %description dri-driver-ati-radeon-R100
270 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
271
272 %description dri-driver-ati-radeon-R100 -l pl
273 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
274
275 %package dri-driver-ati-radeon-R200
276 Summary:        X.org DRI drivers
277 Summary(pl):    Sterowniki DRI dla X.org
278 Group:          X11/Libraries
279 Requires:       xorg-xserver-server
280
281 %description dri-driver-ati-radeon-R200
282 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
283
284 %description dri-driver-ati-radeon-R200 -l pl
285 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
286
287 %package dri-driver-ati-radeon-R300
288 Summary:        X.org DRI drivers
289 Summary(pl):    Sterowniki DRI dla X.org
290 Group:          X11/Libraries
291 Requires:       xorg-xserver-server
292
293 %description dri-driver-ati-radeon-R300
294 X.org DRI drivers for ATI R300 card family.
295
296 %description dri-driver-ati-radeon-R300 -l pl
297 Sterowniki X.org DRI dla rodziny kart ATI R300.
298
299 %package dri-driver-ati-rage128
300 Summary:        X.org DRI drivers
301 Summary(pl):    Sterowniki DRI dla X.org
302 Group:          X11/Libraries
303 Requires:       xorg-xserver-server
304
305 %description dri-driver-ati-rage128
306 X.org DRI drivers for ATI rage128 card family.
307
308 %description dri-driver-ati-rage128 -l pl
309 Sterowniki X.org DRI dla rodziny kart ATI rage128.
310
311 %package dri-driver-ffb
312 Summary:        X.org DRI drivers
313 Summary(pl):    Sterowniki DRI dla X.org
314 Group:          X11/Libraries
315 Requires:       xorg-xserver-server
316
317 %description dri-driver-ffb
318 X.org DRI drivers for SUN Creator3D and Elite3D card family.
319
320 %description dri-driver-ffb -l pl
321 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
322
323 %package dri-driver-glint
324 Summary:        X.org DRI drivers
325 Summary(pl):    Sterowniki DRI dla X.org
326 Group:          X11/Libraries
327 Requires:       xorg-xserver-server
328
329 %description dri-driver-glint
330 X.org DRI drivers for GLINT/Permedia card family.
331
332 %description dri-driver-glint -l pl
333 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
334
335 %package dri-driver-intel-i810
336 Summary:        X.org DRI drivers
337 Summary(pl):    Sterowniki DRI dla X.org
338 Group:          X11/Libraries
339 Requires:       xorg-xserver-server
340
341 %description dri-driver-intel-i810
342 X.org DRI drivers for Intel i810 card family.
343
344 %description dri-driver-intel-i810 -l pl
345 Sterowniki X.org DRI dla rodziny kart i810.
346
347 %package dri-driver-intel-i830
348 Summary:        X.org DRI drivers
349 Summary(pl):    Sterowniki DRI dla X.org
350 Group:          X11/Libraries
351 Requires:       xorg-xserver-server
352
353 %description dri-driver-intel-i830
354 X.org DRI drivers for Intel i830 card family.
355
356 %description dri-driver-intel-i830 -l pl
357 Sterowniki X.org DRI dla rodziny kart i830.
358
359 %package dri-driver-intel-i915
360 Summary:        X.org DRI drivers
361 Summary(pl):    Sterowniki DRI dla X.org
362 Group:          X11/Libraries
363 Requires:       xorg-xserver-server
364
365 %description dri-driver-intel-i915
366 X.org DRI drivers for Intel i915 card family.
367
368 %description dri-driver-intel-i915 -l pl
369 Sterowniki X.org DRI dla rodziny kart i915.
370
371 %package dri-driver-matrox
372 Summary:        X.org DRI drivers
373 Summary(pl):    Sterowniki DRI dla X.org
374 Group:          X11/Libraries
375 Requires:       xorg-xserver-server
376
377 %description dri-driver-matrox
378 X.org DRI drivers for Matrox G card family.
379
380 %description dri-driver-matrox -l pl
381 Sterowniki X.org DRI dla rodziny kart Matrox G.
382
383 %package dri-driver-s3virge
384 Summary:        X.org DRI drivers
385 Summary(pl):    Sterowniki DRI dla X.org
386 Group:          X11/Libraries
387 Requires:       xorg-xserver-server
388
389 %description dri-driver-s3virge
390 X.org DRI drivers for S3 Virge card family.
391
392 %description dri-driver-s3virge -l pl
393 Sterowniki X.org DRI dla rodziny kart S3 Virge.
394
395 %package dri-driver-savage
396 Summary:        X.org DRI drivers
397 Summary(pl):    Sterowniki DRI dla X.org
398 Group:          X11/Libraries
399 Requires:       xorg-xserver-server
400
401 %description dri-driver-savage
402 X.org DRI drivers for S3 Savage card family.
403
404 %description dri-driver-savage -l pl
405 Sterowniki X.org DRI dla rodziny kart S3 Savage.
406
407 %package dri-driver-sis
408 Summary:        X.org DRI drivers
409 Summary(pl):    Sterowniki DRI dla X.org
410 Group:          X11/Libraries
411 Requires:       xorg-xserver-server
412
413 %description dri-driver-sis
414 X.org DRI drivers for SiS card family.
415
416 %description dri-driver-sis -l pl
417 Sterowniki X.org DRI dla rodziny kart SiS.
418
419 %package dri-driver-tdfx
420 Summary:        X.org DRI drivers
421 Summary(pl):    Sterowniki DRI dla X.org
422 Group:          X11/Libraries
423 Requires:       xorg-xserver-server
424
425 %description dri-driver-tdfx
426 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
427 and Velocity 100/200).
428
429 %description dri-driver-tdfx -l pl
430 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
431 Banshee and Velocity 100/200).
432
433 %package dri-driver-trident
434 Summary:        X.org DRI drivers
435 Summary(pl):    Sterowniki DRI dla X.org
436 Group:          X11/Libraries
437 Requires:       xorg-xserver-server
438
439 %description dri-driver-trident
440 X.org DRI drivers for Trident card family.
441
442 %description dri-driver-trident -l pl
443 Sterowniki X.org DRI dla rodziny kart Trident.
444
445 %package dri-driver-via-unichrome
446 Summary:        X.org DRI drivers
447 Summary(pl):    Sterowniki DRI dla X.org
448 Group:          X11/Libraries
449 Requires:       xorg-xserver-server
450
451 %description dri-driver-via-unichrome
452 X.org DRI drivers for VIA Unichrome card family.
453
454 %description dri-driver-via-unichrome -l pl
455 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
456
457 %prep
458 %setup -q -n Mesa-%{version} -b 1
459 %patch0 -p1
460 %patch0 -p0
461
462 # fix demos
463 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
464
465 %ifnarch sparc sparcv9 sparc64
466 # for sunffb driver - useful on sparc only
467 sed -i -e 's/ ffb$//' configs/linux-dri
468 %endif
469
470 %build
471 %ifarch %{ix86}
472 targ=-x86
473 %else
474 targ=""
475 %endif
476
477 %{__make} linux${targ}-static \
478         CC="%{__cc}" \
479         CXX="%{__cxx}" \
480         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
481         XLIB_DIR=%{_libdir} \
482         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
483         SRC_DIRS="mesa glu glw" \
484         PROGRAM_DIRS=
485 mv -f lib lib-static
486 %{__make} clean
487
488 %{__make} linux-dri${targ} \
489         CC="%{__cc}" \
490         CXX="%{__cxx}" \
491         MKDEP=makedepend \
492         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
493         XLIB_DIR=%{_libdir} \
494         SRC_DIRS="glx/x11 mesa glu glw" \
495         PROGRAM_DIRS=
496
497 %{__make} -C progs/xdemos \
498         CC="%{__cc}" \
499         CXX="%{__cxx}" \
500         OPT_FLAGS="%{rpmcflags}" \
501         XLIB_DIR=%{_libdir} \
502         PROGS="glxgears" \
503         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL"
504
505 %{__make} -C progs/xdemos \
506         CC="%{__cc}" \
507         CXX="%{__cxx}" \
508         OPT_FLAGS="%{rpmcflags}" \
509         XLIB_DIR=%{_libdir} \
510         PROGS="glxinfo" \
511         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL -L../../lib-dri -lGLU"
512
513 mv -f lib lib-dri
514 %{__make} clean \
515         MKDEP=makedepend
516
517 %{__make} linux${targ} \
518         CC="%{__cc}" \
519         CXX="%{__cxx}" \
520         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
521         XLIB_DIR=%{_libdir} \
522         SRC_DIRS="mesa" \
523         PROGRAM_DIRS=
524
525 %install
526 rm -rf $RPM_BUILD_ROOT
527 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
528 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
529
530 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
531 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
532 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
533 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
534 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
535
536 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
537 for l in demos redbook samples xdemos ; do
538         %{__make} -C progs/$l clean
539 done
540 for l in demos redbook samples util xdemos images ; do
541         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
542 done
543 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
544
545 %clean
546 rm -rf $RPM_BUILD_ROOT
547
548 %post   libGL -p /sbin/ldconfig
549 %postun libGL -p /sbin/ldconfig
550
551 %post   libGLU -p /sbin/ldconfig
552 %postun libGLU -p /sbin/ldconfig
553
554 %post   libGLw -p /sbin/ldconfig
555 %postun libGLw -p /sbin/ldconfig
556
557 %files libGL
558 %defattr(644,root,root,755)
559 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
560 %attr(755,root,root) %{_libdir}/libGL.so.*.*
561 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
562 # symlink for binary apps which fail to conform Linux OpenGL ABI
563 # (and dlopen libGL.so instead of libGL.so.1)
564 %attr(755,root,root) %{_libdir}/libGL.so
565
566 %files libGL-devel
567 %defattr(644,root,root,755)
568 %doc docs/*.spec
569 %attr(755,root,root) %{_libdir}/libOSMesa.so
570 %dir %{_includedir}/GL
571 %{_includedir}/GL/gl.h
572 %{_includedir}/GL/glext.h
573 %{_includedir}/GL/gl_mangle.h
574 %{_includedir}/GL/glx.h
575 %{_includedir}/GL/glxext.h
576 %{_includedir}/GL/glx_mangle.h
577 %{_includedir}/GL/osmesa.h
578 %{_includedir}/GL/xmesa.h
579 %{_includedir}/GL/xmesa_x.h
580 %{_includedir}/GL/xmesa_xf86.h
581
582 %files libGL-static
583 %defattr(644,root,root,755)
584 %{_libdir}/libGL.a
585 %{_libdir}/libOSMesa.a
586
587 %files libGLU
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
590
591 %files libGLU-devel
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/libGLU.so
594 %{_includedir}/GL/glu.h
595 %{_includedir}/GL/glu_mangle.h
596
597 %files libGLU-static
598 %defattr(644,root,root,755)
599 %{_libdir}/libGLU.a
600
601 %files libGLw
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
604
605 %files libGLw-devel
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/libGLw.so
608 %{_includedir}/GL/GLwDrawA.h
609 %{_includedir}/GL/GLwDrawAP.h
610 %{_includedir}/GL/GLwMDrawA.h
611 %{_includedir}/GL/GLwMDrawAP.h
612
613 %files libGLw-static
614 %defattr(644,root,root,755)
615 %{_libdir}/libGLw.a
616
617 %files utils
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/glxgears
620 %attr(755,root,root) %{_bindir}/glxinfo
621
622 %files dri-driver-ati-mach64
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
625
626 %files dri-driver-ati-radeon-R100
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
629
630 %files dri-driver-ati-radeon-R200
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
633
634 %files dri-driver-ati-radeon-R300
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
637
638 %files dri-driver-ati-rage128
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
641
642 # sunffb (sparc only)
643 %ifarch sparc sparcv9 sparc64
644 %files dri-driver-ffb
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
647 %endif
648
649 # glint (requires update)
650 %if 0
651 %files dri-driver-glint
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
654 %endif
655
656 %files dri-driver-intel-i810
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
659
660 %files dri-driver-intel-i830
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
663
664 %files dri-driver-intel-i915
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
667
668 %files dri-driver-matrox
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
671
672 %files dri-driver-s3virge
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
675
676 %files dri-driver-savage
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
679
680 %files dri-driver-sis
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
683
684 %files dri-driver-tdfx
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
687
688 %files dri-driver-trident
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
691
692 %files dri-driver-via-unichrome
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
695
696 %files demos
697 %defattr(644,root,root,755)
698 %{_examplesdir}/%{name}-%{version}
This page took 3.630721 seconds and 4 git commands to generate.