]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 7.8 20100324 (final soon)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 %define         snap    20100324
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.18
26 %define         dri2proto_ver   1.99.3
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.8
32 Release:        0.%{snap}.1%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 # Source0:      ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 ## Source0-md5: e3fa64a1508bc23dd9de9dd2cea7cfb1
37 #Source1:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
38 ## Source1-md5: 6fd616b27b9826d0faa23e08e05d9435
39 # git clone git://anongit.freedesktop.org/git/mesa/mesa
40 # cd mesa && git archive master --prefix Mesa/ | bzip2 > ../Mesa-$(date +%Y%m%d).tar.bz2
41 Source0:        %{name}-%{snap}.tar.bz2
42 # Source0-md5:  d41d8cd98f00b204e9800998ecf8427e
43 Patch0:         %{name}-realclean.patch
44 Patch1:         %{name}-tgsi_dump.patch
45 URL:            http://www.mesa3d.org/
46 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  expat-devel
50 #%%{?with_demos:BuildRequires:  glew-devel}
51 BuildRequires:  libdrm-devel >= %{libdrm_ver}
52 BuildRequires:  libselinux-devel
53 BuildRequires:  libstdc++-devel
54 BuildRequires:  libtool >= 2:1.4d
55 %{?with_motif:BuildRequires:    motif-devel}
56 BuildRequires:  pixman-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  python
59 BuildRequires:  rpmbuild(macros) >= 1.470
60 BuildRequires:  sed >= 4.0
61 BuildRequires:  xorg-lib-libXdamage-devel
62 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
63 BuildRequires:  xorg-lib-libXt-devel
64 BuildRequires:  xorg-lib-libXxf86vm-devel
65 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
66 BuildRequires:  xorg-proto-glproto-devel
67 BuildRequires:  xorg-util-makedepend
68 BuildRequires:  xorg-xserver-server-devel
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %if %{without gallium}
72 %undefine       with_gallium_intel
73 %endif
74
75 %description
76 Mesa is a 3-D graphics library with an API which is very similar to
77 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
78 syntax or state machine, it is being used with authorization from
79 Silicon Graphics, Inc. However, the author does not possess an OpenGL
80 license from SGI, and makes no claim that Mesa is in any way a
81 compatible replacement for OpenGL or associated with SGI.
82
83 %description -l pl.UTF-8
84 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
85 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
86 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
87 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
88 OpenGL ani powiązana z SGI.
89
90 %package libGL
91 Summary:        Free Mesa3D implementation of libGL OpenGL library
92 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
93 License:        MIT
94 Group:          X11/Libraries
95 Requires:       libdrm >= %{libdrm_ver}
96 Provides:       OpenGL = 2.1
97 # reports version 1.3, but supports glXGetProcAddress() from 1.4
98 Provides:       OpenGL-GLX = 1.4
99 Obsoletes:      Mesa
100 Obsoletes:      Mesa-dri
101 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
102 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
103
104 %description libGL
105 Mesa is a 3-D graphics library with an API which is very similar to
106 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
107 syntax or state machine, it is being used with authorization from
108 Silicon Graphics, Inc. However, the author does not possess an OpenGL
109 license from SGI, and makes no claim that Mesa is in any way a
110 compatible replacement for OpenGL or associated with SGI.
111
112 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
113 specifications. It uses DRI for rendering.
114
115 %description libGL -l pl.UTF-8
116 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
117 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
118 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
119 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
120 OpenGL ani powiązana z SGI.
121
122 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
123 GLX 1.4. Używa DRI do renderowania.
124
125 %package libGL-devel
126 Summary:        Header files for Mesa3D libGL library
127 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
128 License:        MIT
129 Group:          X11/Development/Libraries
130 # loose dependency on libGL to use with other libGL binaries
131 Requires:       OpenGL >= 1.5
132 Requires:       libdrm-devel >= %{libdrm_ver}
133 Requires:       xorg-lib-libX11-devel
134 Requires:       xorg-lib-libXdamage-devel
135 Requires:       xorg-lib-libXext-devel
136 Requires:       xorg-lib-libXxf86vm-devel
137 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
138 Suggests:       OpenGL-doc-man
139 Provides:       OpenGL-GLX-devel = 1.4
140 Provides:       OpenGL-devel = 2.1
141 Obsoletes:      Mesa-devel
142 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
143 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
144 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
145 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
146
147 %description libGL-devel
148 Header files for Mesa3D libGL library.
149
150 %description libGL-devel -l pl.UTF-8
151 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
152
153 %package libGL-static
154 Summary:        Static Mesa3D libGL library
155 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
156 License:        MIT
157 Group:          X11/Development/Libraries
158 Requires:       %{name}-libGL-devel = %{version}-%{release}
159 Provides:       OpenGL-static = 2.1
160 Obsoletes:      Mesa-static
161 Obsoletes:      X11-OpenGL-static < 1:7.0.0
162 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
163
164 %description libGL-static
165 Static Mesa3D libGL library. It uses software renderer.
166
167 %description libGL-static -l pl.UTF-8
168 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
169 renderingu.
170
171 %package libGLU
172 Summary:        SGI implementation of libGLU OpenGL library
173 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
174 License:        SGI Free Software License B v2.0 (MIT-like)
175 Group:          Libraries
176 # loose dependency on libGL.so.1 to use with other libGL binaries
177 Requires:       OpenGL >= 1.2
178 Provides:       OpenGL-GLU = 1.3
179 Obsoletes:      Mesa-devel
180 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
181 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
182
183 %description libGLU
184 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
185 1.3 specifications.
186
187 %description libGLU -l pl.UTF-8
188 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
189 specyfikację OpenGL GLU 1.3.
190
191 %package libGLU-devel
192 Summary:        Header files for SGI libGLU library
193 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
194 License:        SGI Free Software License B v2.0 (MIT-like)
195 Group:          Development/Libraries
196 Requires:       %{name}-libGLU = %{version}-%{release}
197 Requires:       OpenGL-devel >= 1.2
198 Requires:       libstdc++-devel
199 Provides:       OpenGL-GLU-devel = 1.3
200
201 %description libGLU-devel
202 Header files for SGI libGLU library.
203
204 %description libGLU-devel -l pl.UTF-8
205 Pliki nagłówkowe biblioteki SGI libGLU.
206
207 %package libGLU-static
208 Summary:        Static SGI libGLU library
209 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
210 License:        SGI Free Software License B v2.0 (MIT-like)
211 Group:          Development/Libraries
212 Requires:       %{name}-libGLU-devel = %{version}-%{release}
213 Provides:       OpenGL-GLU-static = 1.3
214
215 %description libGLU-static
216 Static SGI libGLU library.
217
218 %description libGLU-static -l pl.UTF-8
219 Statyczna biblioteka SGI libGLU.
220
221 %package libGLw
222 Summary:        SGI OpenGL Xt widgets library
223 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
224 License:        SGI MIT-like
225 Group:          Libraries
226 # loose dependency on libGL.so.1 to use with other libGL binaries
227 Requires:       OpenGL >= 1.1
228 Provides:       OpenGL-GLw
229
230 %description libGLw
231 SGI OpenGL Xt widgets library.
232
233 %description libGLU -l pl.UTF-8
234 Biblioteka SGI widgetów Xt dla OpenGL-a.
235
236 %package libGLw-devel
237 Summary:        Header files for SGI libGLw library
238 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
239 License:        SGI MIT-like
240 Group:          Development/Libraries
241 Requires:       %{name}-libGLw = %{version}-%{release}
242 Requires:       OpenGL-devel >= 1.2
243 Provides:       OpenGL-GLw-devel
244
245 %description libGLw-devel
246 Header files for SGI libGLw library.
247
248 %description libGLw-devel -l pl.UTF-8
249 Pliki nagłówkowe biblioteki SGI libGLw.
250
251 %package libGLw-static
252 Summary:        Static SGI libGLw library
253 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
254 License:        SGI MIT-like
255 Group:          Development/Libraries
256 Requires:       %{name}-libGLw-devel = %{version}-%{release}
257 Provides:       OpenGL-GLw-static
258
259 %description libGLw-static
260 Static SGI libGLw library.
261
262 %description libGLw-static -l pl.UTF-8
263 Statyczna biblioteka SGI libGLw.
264
265 %package libOSMesa
266 Summary:        OSMesa (off-screen renderer) library
267 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
268 License:        MIT
269 Group:          Libraries
270 # doesn't require base
271
272 %description libOSMesa
273 OSMesa (off-screen renderer) library.
274
275 %description libOSMesa -l pl.UTF-8
276 Biblioteka OSMesa (renderująca bitmapy w pamięci).
277
278 %package libOSMesa-devel
279 Summary:        Header file for OSMesa (off-screen renderer) library
280 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
281 License:        MIT
282 Group:          Development/Libraries
283 Requires:       %{name}-libOSMesa = %{version}-%{release}
284 # for <GL/gl.h> only
285 Requires:       OpenGL-devel
286
287 %description libOSMesa-devel
288 Header file for OSMesa (off-screen renderer) library.
289
290 %description libOSMesa-devel -l pl.UTF-8
291 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
292
293 %package libOSMesa-static
294 Summary:        Static OSMesa (off-screen renderer) library
295 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
296 License:        MIT
297 Group:          Development/Libraries
298 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
299 # this static build of OSMesa needs static non-dri Mesa implementation
300 Requires:       %{name}-libGL-static = %{version}-%{release}
301
302 %description libOSMesa-static
303 Static OSMesa (off-screen renderer) library.
304
305 %description libOSMesa-static -l pl.UTF-8
306 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
307
308 %package utils
309 Summary:        OpenGL utilities from Mesa3D
310 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
311 License:        MIT
312 Group:          X11/Applications/Graphics
313 # loose deps on libGL/libGLU
314
315 %description utils
316 OpenGL utilities from Mesa3D: glxgears and glxinfo.
317
318 %description utils -l pl.UTF-8
319 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
320
321 %package demos
322 Summary:        Mesa Demos source code
323 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
324 License:        various (MIT, SGI, GPL - see copyright notes in sources)
325 Group:          Development/Libraries
326 Requires:       OpenGL-devel
327
328 %description demos
329 Demonstration programs for the Mesa libraries in source code form.
330
331 %description demos -l pl.UTF-8
332 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
333
334 %package dri-driver-ati-mach64
335 Summary:        X.org DRI driver for ATI Mach64 card family
336 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
337 License:        MIT
338 Group:          X11/Libraries
339 Requires:       xorg-driver-video-mach64
340 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
341 Requires:       xorg-xserver-server >= %{xserver_ver}
342
343 %description dri-driver-ati-mach64
344 X.org DRI driver for ATI Mach64 card family.
345
346 %description dri-driver-ati-mach64 -l pl.UTF-8
347 Sterownik X.org DRI dla rodziny kart ATI Mach64.
348
349 %package dri-driver-ati-radeon-R100
350 Summary:        X.org DRI driver for ATI R100 card family
351 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
352 License:        MIT
353 Group:          X11/Libraries
354 Requires:       xorg-driver-video-ati
355 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
356 Requires:       xorg-xserver-server >= %{xserver_ver}
357 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
358
359 %description dri-driver-ati-radeon-R100
360 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
361
362 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
363 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
364
365 %package dri-driver-ati-radeon-R200
366 Summary:        X.org DRI driver for ATI R200 card family
367 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
368 License:        MIT
369 Group:          X11/Libraries
370 Requires:       xorg-driver-video-ati
371 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
372 Requires:       xorg-xserver-server >= %{xserver_ver}
373 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
374
375 %description dri-driver-ati-radeon-R200
376 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
377
378 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
379 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
380
381 %package dri-driver-ati-radeon-R300
382 Summary:        X.org DRI driver for ATI R300 card family
383 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
384 License:        MIT
385 Group:          X11/Libraries
386 Requires:       xorg-driver-video-ati
387 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
388 Requires:       xorg-xserver-server >= %{xserver_ver}
389 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
390
391 %description dri-driver-ati-radeon-R300
392 X.org DRI driver for ATI R300 card family.
393
394 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
395 Sterownik X.org DRI dla rodziny kart ATI R300.
396
397 %package dri-driver-ati-radeon-R600
398 Summary:        X.org DRI driver for ATI R600 card family
399 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
400 License:        MIT
401 Group:          X11/Libraries
402 Requires:       radeon-ucode
403 Requires:       xorg-driver-video-ati
404 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
405 Requires:       xorg-xserver-server >= %{xserver_ver}
406
407 %description dri-driver-ati-radeon-R600
408 X.org DRI driver for ATI R600 card family.
409
410 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
411 Sterownik X.org DRI dla rodziny kart ATI R600.
412
413 %package dri-driver-ati-rage128
414 Summary:        X.org DRI driver for ATI Rage128 card family
415 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
416 License:        MIT
417 Group:          X11/Libraries
418 Requires:       xorg-driver-video-r128
419 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
420 Requires:       xorg-xserver-server >= %{xserver_ver}
421 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
422
423 %description dri-driver-ati-rage128
424 X.org DRI driver for ATI Rage128 card family.
425
426 %description dri-driver-ati-rage128 -l pl.UTF-8
427 Sterownik X.org DRI dla rodziny kart ATI Rage128.
428
429 %package dri-driver-ffb
430 Summary:        X.org DRI driver for Sun FFB card family
431 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
432 License:        MIT
433 Group:          X11/Libraries
434 Requires:       xorg-driver-video-sunffb
435 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
436 Requires:       xorg-xserver-server >= %{xserver_ver}
437
438 %description dri-driver-ffb
439 X.org DRI driver for SUN Creator3D and Elite3D card family.
440
441 %description dri-driver-ffb -l pl.UTF-8
442 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
443
444 %package dri-driver-glint
445 Summary:        X.org DRI driver for GLINT/Permedia card family
446 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
447 License:        MIT
448 Group:          X11/Libraries
449 Requires:       xorg-driver-video-glint
450 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
451 Requires:       xorg-xserver-server >= %{xserver_ver}
452 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
453
454 %description dri-driver-glint
455 X.org DRI driver for GLINT/Permedia card family.
456
457 %description dri-driver-glint -l pl.UTF-8
458 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
459
460 %package dri-driver-intel-i810
461 Summary:        X.org DRI driver for Intel i810 card family
462 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
463 License:        MIT
464 Group:          X11/Libraries
465 Requires:       xorg-driver-video-intel
466 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
467 Requires:       xorg-xserver-server >= %{xserver_ver}
468 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
469
470 %description dri-driver-intel-i810
471 X.org DRI driver for Intel i810 card family.
472
473 %description dri-driver-intel-i810 -l pl.UTF-8
474 Sterownik X.org DRI dla rodziny kart Intel i810.
475
476 %package dri-driver-intel-i915
477 Summary:        X.org DRI driver for Intel i915 card family
478 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
479 License:        MIT
480 Group:          X11/Libraries
481 Requires:       xorg-driver-video-intel
482 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
483 Requires:       xorg-xserver-server >= %{xserver_ver}
484 Obsoletes:      Mesa-dri-driver-intel-i830
485 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
486
487 %description dri-driver-intel-i915
488 X.org DRI driver for Intel i915 card family.
489
490 %description dri-driver-intel-i915 -l pl.UTF-8
491 Sterownik X.org DRI dla rodziny kart Intel i915.
492
493 %package dri-driver-intel-i965
494 Summary:        X.org DRI driver for Intel i965 card family
495 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
496 License:        MIT
497 Group:          X11/Libraries
498 Requires:       xorg-driver-video-intel
499 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
500 Requires:       xorg-xserver-server >= %{xserver_ver}
501 Obsoletes:      Mesa-dri-driver-intel-i830
502 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
503
504 %description dri-driver-intel-i965
505 X.org DRI driver for Intel i965 card family.
506
507 %description dri-driver-intel-i965 -l pl.UTF-8
508 Sterownik X.org DRI dla rodziny kart Intel i965.
509
510 %package dri-driver-matrox
511 Summary:        X.org DRI driver for Matrox G card family
512 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
513 License:        MIT
514 Group:          X11/Libraries
515 Requires:       xorg-driver-video-mga
516 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
517 Requires:       xorg-xserver-server >= %{xserver_ver}
518 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
519
520 %description dri-driver-matrox
521 X.org DRI drivers for Matrox G card family.
522
523 %description dri-driver-matrox -l pl.UTF-8
524 Sterowniki X.org DRI dla rodziny kart Matrox G.
525
526 %package dri-driver-nouveau
527 Summary:        X.org DRI driver for NVIDIA card family
528 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
529 License:        MIT
530 Group:          X11/Libraries
531 Requires:       xorg-driver-video-nouveau
532 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
533 Requires:       xorg-xserver-server >= %{xserver_ver}
534
535 %description dri-driver-nouveau
536 X.org DRI drivers for NVIDIA card family.
537
538 %description dri-driver-nouveau -l pl.UTF-8
539 Sterowniki X.org DRI dla rodziny kart NVIDIA.
540
541 %package dri-driver-savage
542 Summary:        X.org DRI driver for S3 Savage card family
543 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
544 License:        MIT
545 Group:          X11/Libraries
546 Requires:       xorg-driver-video-savage
547 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
548 Requires:       xorg-xserver-server >= %{xserver_ver}
549
550 %description dri-driver-savage
551 X.org DRI driver for S3 Savage card family.
552
553 %description dri-driver-savage -l pl.UTF-8
554 Sterownik X.org DRI dla rodziny kart S3 Savage.
555
556 %package dri-driver-sis
557 Summary:        X.org DRI driver for SiS card family
558 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
559 License:        MIT
560 Group:          X11/Libraries
561 Requires:       xorg-driver-video-sis
562 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
563 Requires:       xorg-xserver-server >= %{xserver_ver}
564 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
565
566 %description dri-driver-sis
567 X.org DRI driver for SiS card family.
568
569 %description dri-driver-sis -l pl.UTF-8
570 Sterownik X.org DRI dla rodziny kart SiS.
571
572 %package dri-driver-swrast
573 Summary:        X.org DRI software rasterizer driver
574 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
575 License:        MIT
576 Group:          X11/Libraries
577 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
578 Requires:       xorg-xserver-server >= %{xserver_ver}
579
580 %description dri-driver-swrast
581 X.org DRI software rasterizer driver.
582
583 %description dri-driver-swrast -l pl.UTF-8
584 Sterownik X.org DRI obsługujący rysowanie programowe.
585
586 %package dri-driver-tdfx
587 Summary:        X.org DRI driver for 3DFX Voodoo card family
588 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
589 License:        MIT
590 Group:          X11/Libraries
591 Requires:       Glide3-DRI
592 Requires:       xorg-driver-video-tdfx
593 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
594 Requires:       xorg-xserver-server >= %{xserver_ver}
595 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
596
597 %description dri-driver-tdfx
598 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
599 and Velocity 100/200).
600
601 %description dri-driver-tdfx -l pl.UTF-8
602 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
603 Banshee i Velocity 100/200).
604
605 %package dri-driver-via-unichrome
606 Summary:        X.org DRI driver for VIA Unichrome card family
607 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
608 License:        MIT
609 Group:          X11/Libraries
610 Requires:       xorg-driver-video-openchrome
611 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
612 Requires:       xorg-xserver-server >= %{xserver_ver}
613
614 %description dri-driver-via-unichrome
615 X.org DRI driver for VIA Unichrome card family.
616
617 %description dri-driver-via-unichrome -l pl.UTF-8
618 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
619
620 %package dri-driver-vmwgfx
621 Summary:        X.org DRI driver for VMware
622 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
623 License:        MIT
624 Group:          X11/Libraries
625 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
626 Requires:       xorg-xserver-server >= %{xserver_ver}
627
628 %description dri-driver-vmwgfx
629 X.org DRI driver for VMWare.
630
631 %description dri-driver-vmwgfx -l pl.UTF-8
632 Sterownik X.org DRI dla VMware.
633
634 %prep
635 %setup -q -n %{name}
636 # -b1
637 %patch0 -p0
638 %patch1 -p1
639
640 # fix demos
641 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
642
643 %build
644 autoreconf --install
645 #%{__aclocal}
646 #%{__autoconf}
647
648 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
649 %if %{without gallium_intel}
650 i915 \
651 %endif
652 %ifarch sparc sparcv9 sparc64
653 ffb \
654 %endif
655 %ifarch %{ix86} %{x8664}
656 sis \
657 %endif
658 swrast tdfx unichrome"
659
660 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
661
662 common_flags="\
663         --enable-shared \
664         --enable-selinux \
665         --enable-pic \
666         --enable-glx-tls \
667         --disable-glut \
668         --disable-os-mesa \
669         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
670         --with%{!?with_demos:out}-demos"
671
672 osmesa_common_flags="\
673         --with-driver=osmesa \
674         --disable-asm \
675         --disable-glu"
676
677 %if %{with osmesa}
678 # osmesa variants
679 %configure $common_flags $osmesa_common_flags \
680         --with-osmesa-bits=8
681 %{__make}
682 mv %{_lib} osmesa8
683 %{__make} clean
684
685 %configure $common_flags $osmesa_common_flags \
686         --with-osmesa-bits=16
687 %{__make}
688 mv %{_lib} osmesa16
689 %{__make} clean
690
691 %configure $common_flags $osmesa_common_flags \
692         --with-osmesa-bits=32
693 %{__make}
694 mv %{_lib} osmesa32
695 %{__make} clean
696 %endif
697
698 %configure $common_flags \
699 %if %{with gallium}
700         --enable-gallium \
701         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
702         --enable-gallium-svga \
703         --enable-gallium-nouveau \
704         --with-state-trackers=dri,xorg,glx \
705 %else
706         --disable-gallium \
707 %endif
708         --with-driver=dri \
709         --with-dri-drivers=${dri_drivers} \
710         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
711
712 %{__make}
713 %{__make} -C progs/xdemos glxgears glxinfo
714 %if %{with demos}
715 %{__make} -C progs/demos
716 %endif
717
718 %install
719 rm -rf $RPM_BUILD_ROOT
720
721 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
722
723 # libs without drivers
724 %{__make} install \
725         DESTDIR=$RPM_BUILD_ROOT
726
727 %if %{with osmesa}
728 rm -f osmesa*/libGLEW.*
729 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
730 %endif
731
732 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
733 # work on copy to keep -bi --short-circuit working
734 rm -rf progs-clean
735 install -d progs-clean
736 for l in demos glsl osdemos redbook samples xdemos ; do
737         cp -a progs/$l progs-clean/$l
738         %{__make} -C progs-clean/$l clean
739         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
740 done
741 rm -rf progs-clean
742 for l in util images ; do
743         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
744 done
745 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
746
747 # strip out undesirable headers
748 olddir=$(pwd)
749 cd $RPM_BUILD_ROOT%{_includedir}/GL
750 rm [a-fh-np-wyz]*.h glf*.h
751 cd $RPM_BUILD_ROOT%{_libdir}
752 cd $olddir
753
754 %if %{with multigl}
755 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
756
757 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
758 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
759
760 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
761 %endif
762
763 %clean
764 rm -rf $RPM_BUILD_ROOT
765
766 %post   libGL -p /sbin/ldconfig
767 %postun libGL -p /sbin/ldconfig
768
769 %post   libGLU -p /sbin/ldconfig
770 %postun libGLU -p /sbin/ldconfig
771
772 %post   libGLw -p /sbin/ldconfig
773 %postun libGLw -p /sbin/ldconfig
774
775 %files libGL
776 %defattr(644,root,root,755)
777 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
778 %if %{with multigl}
779 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
780 %dir %{_libdir}/Mesa
781 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
782 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
783 %else
784 %attr(755,root,root) %{_libdir}/libGL.so.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
786 # symlink for binary apps which fail to conform Linux OpenGL ABI
787 # (and dlopen libGL.so instead of libGL.so.1)
788 %attr(755,root,root) %{_libdir}/libGL.so
789 %endif
790
791 %files libGL-devel
792 %defattr(644,root,root,755)
793 %doc docs/*.spec
794 %if %{with multigl}
795 %attr(755,root,root) %{_libdir}/libGL.so
796 %endif
797 %dir %{_includedir}/GL
798 %{_includedir}/GL/gl.h
799 %{_includedir}/GL/glext.h
800 %{_includedir}/GL/gl_mangle.h
801 %{_includedir}/GL/glx.h
802 %{_includedir}/GL/glxext.h
803 %{_includedir}/GL/glx_mangle.h
804 %dir %{_includedir}/GL/internal
805 %{_includedir}/GL/internal/dri_interface.h
806 %{_pkgconfigdir}/dri.pc
807 %{_pkgconfigdir}/gl.pc
808
809 %if %{with static}
810 %files libGL-static
811 %defattr(644,root,root,755)
812 %{_libdir}/libGL.a
813 %endif
814
815 %files libGLU
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
818 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
819
820 %files libGLU-devel
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_libdir}/libGLU.so
823 %{_includedir}/GL/glu.h
824 %{_includedir}/GL/glu_mangle.h
825 %{_pkgconfigdir}/glu.pc
826
827 %if %{with static}
828 %files libGLU-static
829 %defattr(644,root,root,755)
830 %{_libdir}/libGLU.a
831 %endif
832
833 %files libGLw
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
836 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
837
838 %files libGLw-devel
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/libGLw.so
841 %{_includedir}/GL/GLwDrawA.h
842 %{_includedir}/GL/GLwDrawAP.h
843 %{_includedir}/GL/GLwMDrawA.h
844 %{_includedir}/GL/GLwMDrawAP.h
845 %{_pkgconfigdir}/glw.pc
846
847 %if %{with static}
848 %files libGLw-static
849 %defattr(644,root,root,755)
850 %{_libdir}/libGLw.a
851 %endif
852
853 %if %{with osmesa}
854 %files libOSMesa
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
857 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
858
859 %files libOSMesa-devel
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_libdir}/libOSMesa*.so
862 %{_includedir}/GL/osmesa.h
863
864 %if %{with static}
865 %files libOSMesa-static
866 %defattr(644,root,root,755)
867 %{_libdir}/libOSMesa*.a
868 %endif
869 %endif
870
871 %files utils
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_bindir}/glxgears
874 %attr(755,root,root) %{_bindir}/glxinfo
875
876 %files dri-driver-ati-mach64
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
879
880 %files dri-driver-ati-radeon-R100
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
883
884 %files dri-driver-ati-radeon-R200
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
887
888 %files dri-driver-ati-radeon-R300
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
891
892 %files dri-driver-ati-radeon-R600
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
895
896 %files dri-driver-ati-rage128
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
899
900 # sunffb (sparc only)
901 %ifarch sparc sparcv9 sparc64
902 %files dri-driver-ffb
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
905 %endif
906
907 # glint (requires update)
908 %if 0
909 %files dri-driver-glint
910 %defattr(644,root,root,755)
911 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
912 %endif
913
914 %files dri-driver-intel-i810
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
917
918 %files dri-driver-intel-i915
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
921
922 %files dri-driver-intel-i965
923 %defattr(644,root,root,755)
924 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
925
926 %files dri-driver-matrox
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
929
930 %if %{with gallium}
931 %files dri-driver-nouveau
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
935 %endif
936
937 %files dri-driver-savage
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
940
941 %ifarch %{ix86} %{x8664}
942 %files dri-driver-sis
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
945 %endif
946
947 %files dri-driver-swrast
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
950
951 %files dri-driver-tdfx
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
954
955 %files dri-driver-via-unichrome
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
958
959 %if %{with gallium}
960 %files dri-driver-vmwgfx
961 %defattr(644,root,root,755)
962 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
963 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
964 %endif
965
966 %if %{with demos}
967 %files demos
968 %defattr(644,root,root,755)
969 %{_examplesdir}/%{name}-%{version}
970 %endif
This page took 0.101338 seconds and 4 git commands to generate.