]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- dri drivers require libGL in the same version they were built with
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - package OpenGL man pages (from monolith or SGI) somewhere
5 #
6 # Conditional build:
7 %bcond_without  motif   # build static libGLw without Motif interface
8 #
9 %define snap    20061103
10 #
11 Summary:        Free OpenGL implementation
12 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
13 Name:           Mesa
14 Version:        6.5.2
15 Release:        0.1
16 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
17 Group:          X11/Libraries
18 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
19 # Source0-md5:  e4d894181f1859651658b3704633e10d
20 # Source0:      %{name}-%{snap}.tar.gz
21 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
22 # Source1-md5:  e870efe98d3a50be01ab211b9b2e25d9
23 Patch0:         %{name}-realclean.patch
24 URL:            http://www.mesa3d.org/
25 BuildRequires:  expat-devel
26 BuildRequires:  libdrm-devel >= 2.2.0
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:1.4d
29 %{?with_motif:BuildRequires:    motif-devel}
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  xorg-lib-libXt-devel
32 BuildRequires:  xorg-lib-libXxf86vm-devel
33 BuildRequires:  xorg-proto-glproto-devel
34 BuildRequires:  xorg-util-makedepend
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # avoid XFree86-OpenGL* dependency
38 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4
39
40 %define         _sysconfdir     /etc/X11
41
42 %description
43 Mesa is a 3-D graphics library with an API which is very similar to
44 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
45 syntax or state machine, it is being used with authorization from
46 Silicon Graphics, Inc. However, the author does not possess an OpenGL
47 license from SGI, and makes no claim that Mesa is in any way a
48 compatible replacement for OpenGL or associated with SGI.
49
50 %description -l pl
51 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
52 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
53 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
54 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
55 OpenGL ani powi±zana z SGI.
56
57 %package libGL
58 Summary:        Free Mesa3D implementation of libGL OpenGL library
59 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
60 License:        MIT
61 Group:          X11/Libraries
62 Requires:       libdrm >= 2.2.0
63 Provides:       OpenGL = 1.5
64 # reports version 1.3, but supports glXGetProcAddress() from 1.4
65 Provides:       OpenGL-GLX = 1.4
66 Obsoletes:      Mesa
67 Obsoletes:      Mesa-dri
68 Obsoletes:      X11-OpenGL-libGL
69 Obsoletes:      XFree86-OpenGL-libGL
70
71 %description libGL
72 Mesa is a 3-D graphics library with an API which is very similar to
73 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
74 syntax or state machine, it is being used with authorization from
75 Silicon Graphics, Inc. However, the author does not possess an OpenGL
76 license from SGI, and makes no claim that Mesa is in any way a
77 compatible replacement for OpenGL or associated with SGI.
78
79 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
80 specifications. It uses DRI for rendering.
81
82 %description libGL -l pl
83 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
84 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
85 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
86 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
87 OpenGL ani powi±zana z SGI.
88
89 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
90 GLX 1.4. U¿ywa DRI do renderowania.
91
92 %package libGL-devel
93 Summary:        Header files for Mesa3D libGL library
94 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
95 License:        MIT
96 Group:          X11/Development/Libraries
97 # loose dependency on libGL to use with other libGL binaries
98 Requires:       OpenGL >= 1.5
99 Requires:       xorg-lib-libX11-devel
100 Provides:       OpenGL-devel = 1.5
101 Provides:       OpenGL-GLX-devel = 1.4
102 Obsoletes:      Mesa-devel
103 Obsoletes:      X11-OpenGL-devel
104 Obsoletes:      X11-OpenGL-devel-base
105 Obsoletes:      XFree86-OpenGL-devel
106 Obsoletes:      XFree86-OpenGL-devel-base
107
108 %description libGL-devel
109 Header files for Mesa3D libGL library.
110
111 %description libGL-devel -l pl
112 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
113
114 %package libGL-static
115 Summary:        Static Mesa3D libGL library
116 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
117 License:        MIT
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-libGL-devel = %{version}-%{release}
120 Provides:       OpenGL-static = 1.5
121 Obsoletes:      Mesa-static
122 Obsoletes:      X11-OpenGL-static
123 Obsoletes:      XFree86-OpenGL-static
124
125 %description libGL-static
126 Static Mesa3D libGL library. It uses software renderer.
127
128 %description libGL-static -l pl
129 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
130 renderingu.
131
132 %package libGLU
133 Summary:        SGI implementation of libGLU OpenGL library
134 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
135 License:        SGI Free Software License B v1.1
136 Group:          Libraries
137 # loose dependency on libGL.so.1 to use with other libGL binaries
138 Requires:       OpenGL >= 1.2
139 Provides:       OpenGL-GLU = 1.3
140 Obsoletes:      Mesa-devel
141 Obsoletes:      X11-OpenGL-libs
142 Obsoletes:      XFree86-OpenGL-libs
143
144 %description libGLU
145 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
146 1.3 specifications.
147
148 %description libGLU -l pl
149 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
150 specyfikacjê OpenGL GLU 1.3.
151
152 %package libGLU-devel
153 Summary:        Header files for SGI libGLU library
154 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
155 License:        SGI Free Software License B v1.1
156 Group:          Development/Libraries
157 Requires:       %{name}-libGLU = %{version}-%{release}
158 Requires:       OpenGL-devel >= 1.2
159 Requires:       libstdc++-devel
160 Provides:       OpenGL-GLU-devel = 1.3
161
162 %description libGLU-devel
163 Header files for SGI libGLU library.
164
165 %description libGLU-devel -l pl
166 Pliki nag³ówkowe biblioteki SGI libGLU.
167
168 %package libGLU-static
169 Summary:        Static SGI libGLU library
170 Summary(pl):    Statyczna biblioteka SGI libGLU
171 License:        SGI Free Software License B v1.1
172 Group:          Development/Libraries
173 Requires:       %{name}-libGLU-devel = %{version}-%{release}
174 Provides:       OpenGL-GLU-static = 1.3
175
176 %description libGLU-static
177 Static SGI libGLU library.
178
179 %description libGLU-static -l pl
180 Statyczna biblioteka SGI libGLU.
181
182 %package libGLw
183 Summary:        SGI OpenGL Xt widgets library
184 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
185 License:        SGI MIT-like
186 Group:          Libraries
187 # loose dependency on libGL.so.1 to use with other libGL binaries
188 Requires:       OpenGL >= 1.1
189 Provides:       OpenGL-GLw
190
191 %description libGLw
192 SGI OpenGL Xt widgets library.
193
194 %description libGLU -l pl
195 Biblioteka SGI widgetów Xt dla OpenGL-a.
196
197 %package libGLw-devel
198 Summary:        Header files for SGI libGLw library
199 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
200 License:        SGI Free Software License B v1.1
201 Group:          Development/Libraries
202 Requires:       %{name}-libGLw = %{version}-%{release}
203 Requires:       OpenGL-devel >= 1.2
204 Provides:       OpenGL-GLw-devel
205
206 %description libGLw-devel
207 Header files for SGI libGLw library.
208
209 %description libGLw-devel -l pl
210 Pliki nag³ówkowe biblioteki SGI libGLw.
211
212 %package libGLw-static
213 Summary:        Static SGI libGLw library
214 Summary(pl):    Statyczna biblioteka SGI libGLw
215 License:        SGI Free Software License B v1.1
216 Group:          Development/Libraries
217 Requires:       %{name}-libGLw-devel = %{version}-%{release}
218 Provides:       OpenGL-GLw-static
219
220 %description libGLw-static
221 Static SGI libGLw library.
222
223 %description libGLw-static -l pl
224 Statyczna biblioteka SGI libGLw.
225
226 %package utils
227 Summary:        OpenGL utilities from Mesa3D
228 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
229 Group:          X11/Applications/Graphics
230 # loose deps on libGL/libGLU
231
232 %description utils
233 OpenGL utilities from Mesa3D: glxgears and glxinfo.
234
235 %description utils -l pl
236 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
237
238 %package demos
239 Summary:        Mesa Demos
240 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
241 Group:          Development/Libraries
242 Requires:       OpenGL-devel
243
244 %description demos
245 Demonstration programs for the Mesa libraries.
246
247 %description demos -l pl
248 Programy demonstracyjne dla bibliotek Mesa.
249
250 %package dri-driver-ati-mach64
251 Summary:        X.org DRI drivers
252 Summary(pl):    Sterowniki DRI dla X.org
253 Group:          X11/Libraries
254 Requires:       %{name}-libGL = %{version}-%{release}
255 Requires:       xorg-xserver-server
256
257 %description dri-driver-ati-mach64
258 X.org DRI drivers for ATI mach64 card family.
259
260 %description dri-driver-ati-mach64 -l pl
261 Sterowniki X.org DRI dla rodziny kart ATI mach64.
262
263 %package dri-driver-ati-radeon-R100
264 Summary:        X.org DRI drivers
265 Summary(pl):    Sterowniki DRI dla X.org
266 Group:          X11/Libraries
267 Requires:       %{name}-libGL = %{version}-%{release}
268 Requires:       xorg-xserver-server
269
270 %description dri-driver-ati-radeon-R100
271 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
272
273 %description dri-driver-ati-radeon-R100 -l pl
274 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
275
276 %package dri-driver-ati-radeon-R200
277 Summary:        X.org DRI drivers
278 Summary(pl):    Sterowniki DRI dla X.org
279 Group:          X11/Libraries
280 Requires:       %{name}-libGL = %{version}-%{release}
281 Requires:       xorg-xserver-server
282
283 %description dri-driver-ati-radeon-R200
284 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
285
286 %description dri-driver-ati-radeon-R200 -l pl
287 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
288
289 %package dri-driver-ati-radeon-R300
290 Summary:        X.org DRI drivers
291 Summary(pl):    Sterowniki DRI dla X.org
292 Group:          X11/Libraries
293 Requires:       %{name}-libGL = %{version}-%{release}
294 Requires:       xorg-xserver-server
295
296 %description dri-driver-ati-radeon-R300
297 X.org DRI drivers for ATI R300 card family.
298
299 %description dri-driver-ati-radeon-R300 -l pl
300 Sterowniki X.org DRI dla rodziny kart ATI R300.
301
302 %package dri-driver-ati-rage128
303 Summary:        X.org DRI drivers
304 Summary(pl):    Sterowniki DRI dla X.org
305 Group:          X11/Libraries
306 Requires:       %{name}-libGL = %{version}-%{release}
307 Requires:       xorg-xserver-server
308
309 %description dri-driver-ati-rage128
310 X.org DRI drivers for ATI rage128 card family.
311
312 %description dri-driver-ati-rage128 -l pl
313 Sterowniki X.org DRI dla rodziny kart ATI rage128.
314
315 %package dri-driver-ffb
316 Summary:        X.org DRI drivers
317 Summary(pl):    Sterowniki DRI dla X.org
318 Group:          X11/Libraries
319 Requires:       %{name}-libGL = %{version}-%{release}
320 Requires:       xorg-xserver-server
321
322 %description dri-driver-ffb
323 X.org DRI drivers for SUN Creator3D and Elite3D card family.
324
325 %description dri-driver-ffb -l pl
326 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
327
328 %package dri-driver-glint
329 Summary:        X.org DRI drivers
330 Summary(pl):    Sterowniki DRI dla X.org
331 Group:          X11/Libraries
332 Requires:       %{name}-libGL = %{version}-%{release}
333 Requires:       xorg-xserver-server
334
335 %description dri-driver-glint
336 X.org DRI drivers for GLINT/Permedia card family.
337
338 %description dri-driver-glint -l pl
339 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
340
341 %package dri-driver-intel-i810
342 Summary:        X.org DRI drivers
343 Summary(pl):    Sterowniki DRI dla X.org
344 Group:          X11/Libraries
345 Requires:       %{name}-libGL = %{version}-%{release}
346 Requires:       xorg-xserver-server
347
348 %description dri-driver-intel-i810
349 X.org DRI drivers for Intel i810 card family.
350
351 %description dri-driver-intel-i810 -l pl
352 Sterowniki X.org DRI dla rodziny kart i810.
353
354 %package dri-driver-intel-i830
355 Summary:        X.org DRI drivers
356 Summary(pl):    Sterowniki DRI dla X.org
357 Group:          X11/Libraries
358 Requires:       %{name}-libGL = %{version}-%{release}
359 Requires:       xorg-xserver-server
360
361 %description dri-driver-intel-i830
362 X.org DRI drivers for Intel i830 card family.
363
364 %description dri-driver-intel-i830 -l pl
365 Sterowniki X.org DRI dla rodziny kart i830.
366
367 %package dri-driver-intel-i915
368 Summary:        X.org DRI drivers
369 Summary(pl):    Sterowniki DRI dla X.org
370 Group:          X11/Libraries
371 Requires:       %{name}-libGL = %{version}-%{release}
372 Requires:       xorg-xserver-server
373 Obsoletes:      Mesa-dri-driver-intel-i830
374
375 %description dri-driver-intel-i915
376 X.org DRI drivers for Intel i915 card family.
377
378 %description dri-driver-intel-i915 -l pl
379 Sterowniki X.org DRI dla rodziny kart i915.
380
381 %package dri-driver-intel-i965
382 Summary:        X.org DRI drivers
383 Summary(pl):    Sterowniki DRI dla X.org
384 Group:          X11/Libraries
385 Requires:       %{name}-libGL = %{version}-%{release}
386 Requires:       xorg-xserver-server
387 Obsoletes:      Mesa-dri-driver-intel-i830
388 Obsoletes:      Mesa-dri-driver-intel-i915
389
390 %description dri-driver-intel-i965
391 X.org DRI drivers for Intel i965 card family.
392
393 %description dri-driver-intel-i965 -l pl
394 Sterowniki X.org DRI dla rodziny kart i965.
395
396 %package dri-driver-matrox
397 Summary:        X.org DRI drivers
398 Summary(pl):    Sterowniki DRI dla X.org
399 Group:          X11/Libraries
400 Requires:       %{name}-libGL = %{version}-%{release}
401 Requires:       xorg-xserver-server
402
403 %description dri-driver-matrox
404 X.org DRI drivers for Matrox G card family.
405
406 %description dri-driver-matrox -l pl
407 Sterowniki X.org DRI dla rodziny kart Matrox G.
408
409 %package dri-driver-s3virge
410 Summary:        X.org DRI drivers
411 Summary(pl):    Sterowniki DRI dla X.org
412 Group:          X11/Libraries
413 Requires:       %{name}-libGL = %{version}-%{release}
414 Requires:       xorg-xserver-server
415
416 %description dri-driver-s3virge
417 X.org DRI drivers for S3 Virge card family.
418
419 %description dri-driver-s3virge -l pl
420 Sterowniki X.org DRI dla rodziny kart S3 Virge.
421
422 %package dri-driver-savage
423 Summary:        X.org DRI drivers
424 Summary(pl):    Sterowniki DRI dla X.org
425 Group:          X11/Libraries
426 Requires:       %{name}-libGL = %{version}-%{release}
427 Requires:       xorg-xserver-server
428
429 %description dri-driver-savage
430 X.org DRI drivers for S3 Savage card family.
431
432 %description dri-driver-savage -l pl
433 Sterowniki X.org DRI dla rodziny kart S3 Savage.
434
435 %package dri-driver-sis
436 Summary:        X.org DRI drivers
437 Summary(pl):    Sterowniki DRI dla X.org
438 Group:          X11/Libraries
439 Requires:       %{name}-libGL = %{version}-%{release}
440 Requires:       xorg-xserver-server
441
442 %description dri-driver-sis
443 X.org DRI drivers for SiS card family.
444
445 %description dri-driver-sis -l pl
446 Sterowniki X.org DRI dla rodziny kart SiS.
447
448 %package dri-driver-tdfx
449 Summary:        X.org DRI drivers
450 Summary(pl):    Sterowniki DRI dla X.org
451 Group:          X11/Libraries
452 Requires:       %{name}-libGL = %{version}-%{release}
453 Requires:       Glide3-DRI
454 Requires:       xorg-xserver-server
455
456 %description dri-driver-tdfx
457 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
458 and Velocity 100/200).
459
460 %description dri-driver-tdfx -l pl
461 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
462 Banshee and Velocity 100/200).
463
464 %package dri-driver-trident
465 Summary:        X.org DRI drivers
466 Summary(pl):    Sterowniki DRI dla X.org
467 Group:          X11/Libraries
468 Requires:       %{name}-libGL = %{version}-%{release}
469 Requires:       xorg-xserver-server
470
471 %description dri-driver-trident
472 X.org DRI drivers for Trident card family.
473
474 %description dri-driver-trident -l pl
475 Sterowniki X.org DRI dla rodziny kart Trident.
476
477 %package dri-driver-via-unichrome
478 Summary:        X.org DRI drivers
479 Summary(pl):    Sterowniki DRI dla X.org
480 Group:          X11/Libraries
481 Requires:       %{name}-libGL = %{version}-%{release}
482 Requires:       xorg-xserver-server
483
484 %description dri-driver-via-unichrome
485 X.org DRI drivers for VIA Unichrome card family.
486
487 %description dri-driver-via-unichrome -l pl
488 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
489
490 %prep
491 %setup -q -b1
492 #%setup -q -n %{name}
493 %patch0 -p0
494
495 # fix demos
496 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
497
498 %ifnarch sparc sparcv9 sparc64
499 # for sunffb driver - useful on sparc only
500 sed -i -e 's/ ffb$//' configs/linux-dri
501 %endif
502
503 %ifnarch %{ix86} %{x8664}
504 # sis needs write-memory barrier
505 sed -i -e 's/ sis / /' configs/linux-dri
506 %endif
507
508 %build
509 %ifarch %{ix86}
510 targ=-x86
511 %else
512 targ=""
513 %endif
514
515 %{__make} linux${targ}-static \
516         CC="%{__cc}" \
517         CXX="%{__cxx}" \
518         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
519         XLIB_DIR=%{_libdir} \
520         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
521         SRC_DIRS="mesa glu glw" \
522         PROGRAM_DIRS=
523 mv -f lib lib-static
524 %{__make} realclean
525
526 %{__make} linux-dri${targ} \
527         CC="%{__cc}" \
528         CXX="%{__cxx}" \
529         MKDEP=makedepend \
530         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
531         XLIB_DIR=%{_libdir} \
532         DRI_DRIVER_SEARCH_DIR=%{_libdir}/xorg/modules/dri \
533         SRC_DIRS="glx/x11 mesa glu glw" \
534         PROGRAM_DIRS=
535
536 %{__make} -C progs/xdemos \
537         CC="%{__cc}" \
538         CXX="%{__cxx}" \
539         OPT_FLAGS="%{rpmcflags}" \
540         XLIB_DIR=%{_libdir} \
541         PROGS="glxgears" \
542         APP_LIB_DEPS="-L../../lib -lGL"
543
544 %{__make} -C progs/xdemos \
545         CC="%{__cc}" \
546         CXX="%{__cxx}" \
547         OPT_FLAGS="%{rpmcflags}" \
548         XLIB_DIR=%{_libdir} \
549         PROGS="glxinfo" \
550         APP_LIB_DEPS="-L../../lib -lGL -L../../lib-dri -lGLU"
551
552 mv -f lib lib-dri
553 %{__make} clean \
554         MKDEP=makedepend
555 %{__make} realclean
556
557 %{__make} linux${targ} \
558         CC="%{__cc}" \
559         CXX="%{__cxx}" \
560         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
561         XLIB_DIR=%{_libdir} \
562         SRC_DIRS="mesa" \
563         PROGRAM_DIRS=
564
565 %install
566 rm -rf $RPM_BUILD_ROOT
567 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
568 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
569
570 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
571 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
572 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
573 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
574 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
575
576 # keep for -bi --short-circuit
577 cp -a progs progs.org
578 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
579 for l in demos redbook samples xdemos ; do
580         %{__make} -C progs/$l clean
581 done
582 for l in demos redbook samples util xdemos images ; do
583         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
584 done
585 rm -rf progs && mv -f progs.org progs
586 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
587
588 %clean
589 rm -rf $RPM_BUILD_ROOT
590
591 %post   libGL -p /sbin/ldconfig
592 %postun libGL -p /sbin/ldconfig
593
594 %post   libGLU -p /sbin/ldconfig
595 %postun libGLU -p /sbin/ldconfig
596
597 %post   libGLw -p /sbin/ldconfig
598 %postun libGLw -p /sbin/ldconfig
599
600 %files libGL
601 %defattr(644,root,root,755)
602 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
603 %attr(755,root,root) %{_libdir}/libGL.so.*.*
604 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
605 # symlink for binary apps which fail to conform Linux OpenGL ABI
606 # (and dlopen libGL.so instead of libGL.so.1)
607 %attr(755,root,root) %{_libdir}/libGL.so
608
609 %files libGL-devel
610 %defattr(644,root,root,755)
611 %doc docs/*.spec
612 %attr(755,root,root) %{_libdir}/libOSMesa.so
613 %dir %{_includedir}/GL
614 %{_includedir}/GL/gl.h
615 %{_includedir}/GL/glext.h
616 %{_includedir}/GL/glfbdev.h
617 %{_includedir}/GL/gl_mangle.h
618 %{_includedir}/GL/glx.h
619 %{_includedir}/GL/glxext.h
620 %{_includedir}/GL/glx_mangle.h
621 %{_includedir}/GL/osmesa.h
622 %{_includedir}/GL/xmesa.h
623 %{_includedir}/GL/xmesa_x.h
624 %{_includedir}/GL/xmesa_xf86.h
625
626 %files libGL-static
627 %defattr(644,root,root,755)
628 %{_libdir}/libGL.a
629 %{_libdir}/libOSMesa.a
630
631 %files libGLU
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
634
635 %files libGLU-devel
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/libGLU.so
638 %{_includedir}/GL/glu.h
639 %{_includedir}/GL/glu_mangle.h
640
641 %files libGLU-static
642 %defattr(644,root,root,755)
643 %{_libdir}/libGLU.a
644
645 %files libGLw
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
648
649 %files libGLw-devel
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/libGLw.so
652 %{_includedir}/GL/GLwDrawA.h
653 %{_includedir}/GL/GLwDrawAP.h
654 %{_includedir}/GL/GLwMDrawA.h
655 %{_includedir}/GL/GLwMDrawAP.h
656
657 %files libGLw-static
658 %defattr(644,root,root,755)
659 %{_libdir}/libGLw.a
660
661 %files utils
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/glxgears
664 %attr(755,root,root) %{_bindir}/glxinfo
665
666 %files dri-driver-ati-mach64
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
669
670 %files dri-driver-ati-radeon-R100
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
673
674 %files dri-driver-ati-radeon-R200
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
677
678 %files dri-driver-ati-radeon-R300
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
681
682 %files dri-driver-ati-rage128
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
685
686 # sunffb (sparc only)
687 %ifarch sparc sparcv9 sparc64
688 %files dri-driver-ffb
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
691 %endif
692
693 # glint (requires update)
694 %if 0
695 %files dri-driver-glint
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
698 %endif
699
700 %files dri-driver-intel-i810
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
703
704 %if 0
705 %files dri-driver-intel-i830
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
708 %endif
709
710 %files dri-driver-intel-i915
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
713 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915tex_dri.so
714
715 %files dri-driver-intel-i965
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
718
719 %files dri-driver-matrox
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
722
723 %files dri-driver-s3virge
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
726
727 %files dri-driver-savage
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
730
731 %ifarch %{ix86} %{x8664}
732 %files dri-driver-sis
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
735 %endif
736
737 %files dri-driver-tdfx
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
740
741 %files dri-driver-trident
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
744
745 %files dri-driver-via-unichrome
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
748
749 %files demos
750 %defattr(644,root,root,755)
751 %{_examplesdir}/%{name}-%{version}
This page took 3.242202 seconds and 4 git commands to generate.