]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- rel 8; fix nouveau segfaults with libdrm 2.4.23 (from gentoo)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static  # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.21
25 %define         dri2proto_ver   1.99.3
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.9
32 Release:        8%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  82c740c49d572baa6da2b1a1eee90bca
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-selinux.patch
39 Patch2:         %{name}-git.patch
40 Patch3:         %{name}-nouveau.patch
41 URL:            http://www.mesa3d.org/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  expat-devel
45 BuildRequires:  libdrm-devel >= %{libdrm_ver}
46 BuildRequires:  libselinux-devel
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libtool >= 2:1.4d
49 %{?with_motif:BuildRequires:    motif-devel}
50 BuildRequires:  pixman-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  pkgconfig(talloc) >= 2.0.1
53 BuildRequires:  python
54 BuildRequires:  python-modules
55 BuildRequires:  rpmbuild(macros) >= 1.470
56 BuildRequires:  sed >= 4.0
57 BuildRequires:  xorg-lib-libXdamage-devel
58 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
59 BuildRequires:  xorg-lib-libXt-devel
60 BuildRequires:  xorg-lib-libXxf86vm-devel
61 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
62 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
63 BuildRequires:  xorg-util-makedepend
64 BuildRequires:  xorg-xserver-server-devel
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %if %{without gallium}
68 %undefine       with_gallium_intel
69 %undefine       with_gallium_radeon
70 %endif
71
72 %description
73 Mesa is a 3-D graphics library with an API which is very similar to
74 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
75 syntax or state machine, it is being used with authorization from
76 Silicon Graphics, Inc. However, the author does not possess an OpenGL
77 license from SGI, and makes no claim that Mesa is in any way a
78 compatible replacement for OpenGL or associated with SGI.
79
80 %description -l pl.UTF-8
81 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
82 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
83 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
84 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
85 OpenGL ani powiązana z SGI.
86
87 %package libEGL
88 Summary:        SGI implementation of libEGL OpenGL library
89 Summary(pl.UTF-8):      Implementacja SGI biblioteki libEGL ze standardu OpenGL
90 License:        SGI Free Software License B v2.0 (MIT-like)
91 Group:          Libraries
92 Requires:       OpenGL >= 1.2
93 Provides:       OpenGL-EGL = 1.0
94
95 %description libEGL
96 SGI implementation of libEGL OpenGL library.
97
98 %description libEGL -l pl.UTF-8
99 Implementacja SGI biblioteki libEGL ze standardu OpenGL.
100
101 %package libEGL-devel
102 Summary:        Header files for SGI libEGL library
103 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libEGL
104 License:        SGI Free Software License B v2.0 (MIT-like)
105 Group:          Development/Libraries
106 Requires:       %{name}-libEGL = %{version}-%{release}
107 Requires:       OpenGL-devel >= 1.2
108 Requires:       libstdc++-devel
109 Provides:       OpenGL-EGL-devel = 1.0
110
111 %description libEGL-devel
112 Header files for SGI libEGL library.
113
114 %description libEGL-devel -l pl.UTF-8
115 Pliki nagłówkowe biblioteki SGI libEGL.
116
117 %package libEGL-static
118 Summary:        Static SGI libEGL library
119 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
120 License:        SGI Free Software License B v2.0 (MIT-like)
121 Group:          Development/Libraries
122 Requires:       %{name}-libEGL-devel = %{version}-%{release}
123 Provides:       OpenGL-EGL-static = 1.0
124
125 %description libEGL-static
126 Static SGI libEGL library.
127
128 %description libEGL-static -l pl.UTF-8
129 Statyczna biblioteka SGI libEGL.
130
131 %package libGL
132 Summary:        Free Mesa3D implementation of libGL OpenGL library
133 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
134 License:        MIT
135 Group:          X11/Libraries
136 Requires:       libdrm >= %{libdrm_ver}
137 Provides:       OpenGL = 2.1
138 # reports version 1.3, but supports glXGetProcAddress() from 1.4
139 Provides:       OpenGL-GLX = 1.4
140 Obsoletes:      Mesa
141 Obsoletes:      Mesa-dri
142 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
143 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
144
145 %description libGL
146 Mesa is a 3-D graphics library with an API which is very similar to
147 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
148 syntax or state machine, it is being used with authorization from
149 Silicon Graphics, Inc. However, the author does not possess an OpenGL
150 license from SGI, and makes no claim that Mesa is in any way a
151 compatible replacement for OpenGL or associated with SGI.
152
153 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
154 specifications. It uses DRI for rendering.
155
156 %description libGL -l pl.UTF-8
157 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
158 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
159 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
160 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
161 OpenGL ani powiązana z SGI.
162
163 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
164 GLX 1.4. Używa DRI do renderowania.
165
166 %package libGL-devel
167 Summary:        Header files for Mesa3D libGL library
168 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
169 License:        MIT
170 Group:          X11/Development/Libraries
171 # loose dependency on libGL to use with other libGL binaries
172 Requires:       OpenGL >= 1.5
173 Requires:       libdrm-devel >= %{libdrm_ver}
174 Requires:       xorg-lib-libX11-devel
175 Requires:       xorg-lib-libXdamage-devel
176 Requires:       xorg-lib-libXext-devel
177 Requires:       xorg-lib-libXxf86vm-devel
178 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
179 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
180 Suggests:       OpenGL-doc-man
181 Provides:       OpenGL-GLX-devel = 1.4
182 Provides:       OpenGL-devel = 2.1
183 Obsoletes:      Mesa-devel
184 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
185 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
186 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
187 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
188
189 %description libGL-devel
190 Header files for Mesa3D libGL library.
191
192 %description libGL-devel -l pl.UTF-8
193 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
194
195 %package libGL-static
196 Summary:        Static Mesa3D libGL library
197 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
198 License:        MIT
199 Group:          X11/Development/Libraries
200 Requires:       %{name}-libGL-devel = %{version}-%{release}
201 Provides:       OpenGL-static = 2.1
202 Obsoletes:      Mesa-static
203 Obsoletes:      X11-OpenGL-static < 1:7.0.0
204 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
205
206 %description libGL-static
207 Static Mesa3D libGL library. It uses software renderer.
208
209 %description libGL-static -l pl.UTF-8
210 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
211 renderingu.
212
213 %package libGLU
214 Summary:        SGI implementation of libGLU OpenGL library
215 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
216 License:        SGI Free Software License B v2.0 (MIT-like)
217 Group:          Libraries
218 # loose dependency on libGL.so.1 to use with other libGL binaries
219 Requires:       OpenGL >= 1.2
220 Provides:       OpenGL-GLU = 1.3
221 Obsoletes:      Mesa-devel
222 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
223 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
224
225 %description libGLU
226 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
227 1.3 specifications.
228
229 %description libGLU -l pl.UTF-8
230 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
231 specyfikację OpenGL GLU 1.3.
232
233 %package libGLU-devel
234 Summary:        Header files for SGI libGLU library
235 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
236 License:        SGI Free Software License B v2.0 (MIT-like)
237 Group:          Development/Libraries
238 Requires:       %{name}-libGLU = %{version}-%{release}
239 Requires:       OpenGL-devel >= 1.2
240 Requires:       libstdc++-devel
241 Provides:       OpenGL-GLU-devel = 1.3
242
243 %description libGLU-devel
244 Header files for SGI libGLU library.
245
246 %description libGLU-devel -l pl.UTF-8
247 Pliki nagłówkowe biblioteki SGI libGLU.
248
249 %package libGLU-static
250 Summary:        Static SGI libGLU library
251 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
252 License:        SGI Free Software License B v2.0 (MIT-like)
253 Group:          Development/Libraries
254 Requires:       %{name}-libGLU-devel = %{version}-%{release}
255 Provides:       OpenGL-GLU-static = 1.3
256
257 %description libGLU-static
258 Static SGI libGLU library.
259
260 %description libGLU-static -l pl.UTF-8
261 Statyczna biblioteka SGI libGLU.
262
263 %package libGLw
264 Summary:        SGI OpenGL Xt widgets library
265 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
266 License:        SGI MIT-like
267 Group:          Libraries
268 # loose dependency on libGL.so.1 to use with other libGL binaries
269 Requires:       OpenGL >= 1.1
270 Provides:       OpenGL-GLw
271
272 %description libGLw
273 SGI OpenGL Xt widgets library.
274
275 %description libGLU -l pl.UTF-8
276 Biblioteka SGI widgetów Xt dla OpenGL-a.
277
278 %package libGLw-devel
279 Summary:        Header files for SGI libGLw library
280 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
281 License:        SGI MIT-like
282 Group:          Development/Libraries
283 Requires:       %{name}-libGLw = %{version}-%{release}
284 Requires:       OpenGL-devel >= 1.2
285 Provides:       OpenGL-GLw-devel
286
287 %description libGLw-devel
288 Header files for SGI libGLw library.
289
290 %description libGLw-devel -l pl.UTF-8
291 Pliki nagłówkowe biblioteki SGI libGLw.
292
293 %package libGLw-static
294 Summary:        Static SGI libGLw library
295 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
296 License:        SGI MIT-like
297 Group:          Development/Libraries
298 Requires:       %{name}-libGLw-devel = %{version}-%{release}
299 Provides:       OpenGL-GLw-static
300
301 %description libGLw-static
302 Static SGI libGLw library.
303
304 %description libGLw-static -l pl.UTF-8
305 Statyczna biblioteka SGI libGLw.
306
307 %package libOSMesa
308 Summary:        OSMesa (off-screen renderer) library
309 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
310 License:        MIT
311 Group:          Libraries
312 # doesn't require base
313
314 %description libOSMesa
315 OSMesa (off-screen renderer) library.
316
317 %description libOSMesa -l pl.UTF-8
318 Biblioteka OSMesa (renderująca bitmapy w pamięci).
319
320 %package libOSMesa-devel
321 Summary:        Header file for OSMesa (off-screen renderer) library
322 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
323 License:        MIT
324 Group:          Development/Libraries
325 Requires:       %{name}-libOSMesa = %{version}-%{release}
326 # for <GL/gl.h> only
327 Requires:       OpenGL-devel
328
329 %description libOSMesa-devel
330 Header file for OSMesa (off-screen renderer) library.
331
332 %description libOSMesa-devel -l pl.UTF-8
333 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
334
335 %package libOSMesa-static
336 Summary:        Static OSMesa (off-screen renderer) library
337 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
338 License:        MIT
339 Group:          Development/Libraries
340 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
341 # this static build of OSMesa needs static non-dri Mesa implementation
342 Requires:       %{name}-libGL-static = %{version}-%{release}
343
344 %description libOSMesa-static
345 Static OSMesa (off-screen renderer) library.
346
347 %description libOSMesa-static -l pl.UTF-8
348 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
349
350 %package utils
351 Summary:        OpenGL utilities from Mesa3D
352 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
353 License:        MIT
354 Group:          X11/Applications/Graphics
355 # loose deps on libGL/libGLU
356
357 %description utils
358 OpenGL utilities from Mesa3D: glxgears and glxinfo.
359
360 %description utils -l pl.UTF-8
361 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
362
363 %package dri-driver-ati-mach64
364 Summary:        X.org DRI driver for ATI Mach64 card family
365 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
366 License:        MIT
367 Group:          X11/Libraries
368 Requires:       xorg-driver-video-mach64
369 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
370 Requires:       xorg-xserver-server >= %{xserver_ver}
371
372 %description dri-driver-ati-mach64
373 X.org DRI driver for ATI Mach64 card family.
374
375 %description dri-driver-ati-mach64 -l pl.UTF-8
376 Sterownik X.org DRI dla rodziny kart ATI Mach64.
377
378 %package dri-driver-ati-radeon-R100
379 Summary:        X.org DRI driver for ATI R100 card family
380 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
381 License:        MIT
382 Group:          X11/Libraries
383 Requires:       xorg-driver-video-ati
384 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
385 Requires:       xorg-xserver-server >= %{xserver_ver}
386 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
387
388 %description dri-driver-ati-radeon-R100
389 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
390
391 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
392 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
393
394 %package dri-driver-ati-radeon-R200
395 Summary:        X.org DRI driver for ATI R200 card family
396 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
397 License:        MIT
398 Group:          X11/Libraries
399 Requires:       xorg-driver-video-ati
400 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
401 Requires:       xorg-xserver-server >= %{xserver_ver}
402 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
403
404 %description dri-driver-ati-radeon-R200
405 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
406
407 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
408 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
409
410 %package dri-driver-ati-radeon-R300
411 Summary:        X.org DRI driver for ATI R300 card family
412 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
413 License:        MIT
414 Group:          X11/Libraries
415 Requires:       xorg-driver-video-ati
416 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
417 Requires:       xorg-xserver-server >= %{xserver_ver}
418 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
419
420 %description dri-driver-ati-radeon-R300
421 X.org DRI driver for ATI R300 card family.
422
423 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
424 Sterownik X.org DRI dla rodziny kart ATI R300.
425
426 %package dri-driver-ati-radeon-R600
427 Summary:        X.org DRI driver for ATI R600 card family
428 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
429 License:        MIT
430 Group:          X11/Libraries
431 Requires:       radeon-ucode
432 Requires:       xorg-driver-video-ati
433 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
434 Requires:       xorg-xserver-server >= %{xserver_ver}
435
436 %description dri-driver-ati-radeon-R600
437 X.org DRI driver for ATI R600 card family.
438
439 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
440 Sterownik X.org DRI dla rodziny kart ATI R600.
441
442 %package dri-driver-ati-rage128
443 Summary:        X.org DRI driver for ATI Rage128 card family
444 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
445 License:        MIT
446 Group:          X11/Libraries
447 Requires:       xorg-driver-video-r128
448 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
449 Requires:       xorg-xserver-server >= %{xserver_ver}
450 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
451
452 %description dri-driver-ati-rage128
453 X.org DRI driver for ATI Rage128 card family.
454
455 %description dri-driver-ati-rage128 -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart ATI Rage128.
457
458 %package dri-driver-ffb
459 Summary:        X.org DRI driver for Sun FFB card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       xorg-driver-video-sunffb
464 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
465 Requires:       xorg-xserver-server >= %{xserver_ver}
466
467 %description dri-driver-ffb
468 X.org DRI driver for SUN Creator3D and Elite3D card family.
469
470 %description dri-driver-ffb -l pl.UTF-8
471 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
472
473 %package dri-driver-glint
474 Summary:        X.org DRI driver for GLINT/Permedia card family
475 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
476 License:        MIT
477 Group:          X11/Libraries
478 Requires:       xorg-driver-video-glint
479 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
480 Requires:       xorg-xserver-server >= %{xserver_ver}
481 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
482
483 %description dri-driver-glint
484 X.org DRI driver for GLINT/Permedia card family.
485
486 %description dri-driver-glint -l pl.UTF-8
487 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
488
489 %package dri-driver-intel-i810
490 Summary:        X.org DRI driver for Intel i810 card family
491 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
492 License:        MIT
493 Group:          X11/Libraries
494 Requires:       xorg-driver-video-intel
495 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
496 Requires:       xorg-xserver-server >= %{xserver_ver}
497 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
498
499 %description dri-driver-intel-i810
500 X.org DRI driver for Intel i810 card family.
501
502 %description dri-driver-intel-i810 -l pl.UTF-8
503 Sterownik X.org DRI dla rodziny kart Intel i810.
504
505 %package dri-driver-intel-i915
506 Summary:        X.org DRI driver for Intel i915 card family
507 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
508 License:        MIT
509 Group:          X11/Libraries
510 Requires:       xorg-driver-video-intel
511 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
512 Requires:       xorg-xserver-server >= %{xserver_ver}
513 Obsoletes:      Mesa-dri-driver-intel-i830
514 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
515
516 %description dri-driver-intel-i915
517 X.org DRI driver for Intel i915 card family.
518
519 %description dri-driver-intel-i915 -l pl.UTF-8
520 Sterownik X.org DRI dla rodziny kart Intel i915.
521
522 %package dri-driver-intel-i965
523 Summary:        X.org DRI driver for Intel i965 card family
524 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
525 License:        MIT
526 Group:          X11/Libraries
527 Requires:       xorg-driver-video-intel
528 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
529 Requires:       xorg-xserver-server >= %{xserver_ver}
530 Obsoletes:      Mesa-dri-driver-intel-i830
531 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
532
533 %description dri-driver-intel-i965
534 X.org DRI driver for Intel i965 card family.
535
536 %description dri-driver-intel-i965 -l pl.UTF-8
537 Sterownik X.org DRI dla rodziny kart Intel i965.
538
539 %package dri-driver-matrox
540 Summary:        X.org DRI driver for Matrox G card family
541 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
542 License:        MIT
543 Group:          X11/Libraries
544 Requires:       xorg-driver-video-mga
545 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
546 Requires:       xorg-xserver-server >= %{xserver_ver}
547 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
548
549 %description dri-driver-matrox
550 X.org DRI drivers for Matrox G card family.
551
552 %description dri-driver-matrox -l pl.UTF-8
553 Sterowniki X.org DRI dla rodziny kart Matrox G.
554
555 %package dri-driver-nouveau
556 Summary:        X.org DRI driver for NVIDIA card family
557 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
558 License:        MIT
559 Group:          X11/Libraries
560 Requires:       xorg-driver-video-nouveau
561 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
562 Requires:       xorg-xserver-server >= %{xserver_ver}
563
564 %description dri-driver-nouveau
565 X.org DRI drivers for NVIDIA card family.
566
567 %description dri-driver-nouveau -l pl.UTF-8
568 Sterowniki X.org DRI dla rodziny kart NVIDIA.
569
570 %package dri-driver-savage
571 Summary:        X.org DRI driver for S3 Savage card family
572 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
573 License:        MIT
574 Group:          X11/Libraries
575 Requires:       xorg-driver-video-savage
576 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
577 Requires:       xorg-xserver-server >= %{xserver_ver}
578
579 %description dri-driver-savage
580 X.org DRI driver for S3 Savage card family.
581
582 %description dri-driver-savage -l pl.UTF-8
583 Sterownik X.org DRI dla rodziny kart S3 Savage.
584
585 %package dri-driver-sis
586 Summary:        X.org DRI driver for SiS card family
587 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
588 License:        MIT
589 Group:          X11/Libraries
590 Requires:       xorg-driver-video-sis
591 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
592 Requires:       xorg-xserver-server >= %{xserver_ver}
593 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
594
595 %description dri-driver-sis
596 X.org DRI driver for SiS card family.
597
598 %description dri-driver-sis -l pl.UTF-8
599 Sterownik X.org DRI dla rodziny kart SiS.
600
601 %package dri-driver-swrast
602 Summary:        X.org DRI software rasterizer driver
603 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
604 License:        MIT
605 Group:          X11/Libraries
606 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
607 Requires:       xorg-xserver-server >= %{xserver_ver}
608
609 %description dri-driver-swrast
610 X.org DRI software rasterizer driver.
611
612 %description dri-driver-swrast -l pl.UTF-8
613 Sterownik X.org DRI obsługujący rysowanie programowe.
614
615 %package dri-driver-tdfx
616 Summary:        X.org DRI driver for 3DFX Voodoo card family
617 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
618 License:        MIT
619 Group:          X11/Libraries
620 Requires:       Glide3-DRI
621 Requires:       xorg-driver-video-tdfx
622 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
623 Requires:       xorg-xserver-server >= %{xserver_ver}
624 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
625
626 %description dri-driver-tdfx
627 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
628 and Velocity 100/200).
629
630 %description dri-driver-tdfx -l pl.UTF-8
631 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
632 Banshee i Velocity 100/200).
633
634 %package dri-driver-via-unichrome
635 Summary:        X.org DRI driver for VIA Unichrome card family
636 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
637 License:        MIT
638 Group:          X11/Libraries
639 Requires:       xorg-driver-video-openchrome
640 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
641 Requires:       xorg-xserver-server >= %{xserver_ver}
642
643 %description dri-driver-via-unichrome
644 X.org DRI driver for VIA Unichrome card family.
645
646 %description dri-driver-via-unichrome -l pl.UTF-8
647 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
648
649 %package dri-driver-vmwgfx
650 Summary:        X.org DRI driver for VMware
651 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
652 License:        MIT
653 Group:          X11/Libraries
654 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
655 Requires:       xorg-xserver-server >= %{xserver_ver}
656
657 %description dri-driver-vmwgfx
658 X.org DRI driver for VMWare.
659
660 %description dri-driver-vmwgfx -l pl.UTF-8
661 Sterownik X.org DRI dla VMware.
662
663 %prep
664 %setup -q
665 %patch0 -p0
666 %patch1 -p1
667 %patch2 -p1
668 %patch3 -p1
669
670 %build
671 %{__aclocal}
672 %{__autoconf}
673
674 dri_drivers="i810 i965 mach64 mga r128 \
675 %if %{without gallium_radeon}
676 r200 r300 r600 radeon \
677 %endif
678 savage \
679 %if %{without gallium_intel}
680 i915 \
681 %endif
682 %ifarch sparc sparcv9 sparc64
683 ffb \
684 %endif
685 %ifarch %{ix86} %{x8664}
686 sis \
687 %endif
688 swrast tdfx unichrome"
689
690 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
691
692 common_flags="\
693         --enable-shared \
694         --enable-selinux \
695         --enable-pic \
696         --enable-glx-tls \
697         --disable-glut \
698         --disable-os-mesa \
699         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
700
701 osmesa_common_flags="\
702         --with-driver=osmesa \
703         --disable-asm \
704         --disable-glu"
705
706 %if %{with osmesa}
707 # osmesa variants
708 %configure $common_flags $osmesa_common_flags \
709         --with-osmesa-bits=8
710 %{__make}
711 mv %{_lib} osmesa8
712 %{__make} clean
713
714 %configure $common_flags $osmesa_common_flags \
715         --with-osmesa-bits=16
716 %{__make}
717 mv %{_lib} osmesa16
718 %{__make} clean
719
720 %configure $common_flags $osmesa_common_flags \
721         --with-osmesa-bits=32
722 %{__make}
723 mv %{_lib} osmesa32
724 %{__make} clean
725 %endif
726
727 %configure $common_flags \
728 %if %{with gallium}
729         --enable-gallium \
730         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
731         --%{?with_gallium_radeon:en}%{!?with_gallium_radeon:dis}able-gallium-radeon \
732         --enable-gallium-svga \
733 %{?with_gallium_nouveau:--enable-gallium-nouveau} \
734         --with-state-trackers=dri,glx \
735 %else
736         --disable-gallium \
737 %endif
738         --with-driver=dri \
739         --with-dri-drivers=${dri_drivers} \
740         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
741
742 %{__make}
743
744 %install
745 rm -rf $RPM_BUILD_ROOT
746
747 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
748
749 # libs without drivers
750 %{__make} install \
751         DESTDIR=$RPM_BUILD_ROOT
752
753 %if %{with osmesa}
754 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
755 %endif
756
757 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
758
759 # strip out undesirable headers
760 olddir=$(pwd)
761 cd $RPM_BUILD_ROOT%{_includedir}/GL
762 rm [a-fh-np-wyz]*.h glf*.h
763 cd $RPM_BUILD_ROOT%{_libdir}
764 cd $olddir
765
766 %if %{with multigl}
767 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
768
769 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
770 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
771
772 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
773 %endif
774
775 %clean
776 rm -rf $RPM_BUILD_ROOT
777
778 %post   libEGL -p /sbin/ldconfig
779 %postun libEGL -p /sbin/ldconfig
780
781 %post   libGL -p /sbin/ldconfig
782 %postun libGL -p /sbin/ldconfig
783
784 %post   libGLU -p /sbin/ldconfig
785 %postun libGLU -p /sbin/ldconfig
786
787 %post   libGLw -p /sbin/ldconfig
788 %postun libGLw -p /sbin/ldconfig
789
790 %if %{with egl}
791 %files libEGL
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
794 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
795 %dir %{_libdir}/egl
796 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
797 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
798
799 %files libEGL-devel
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libEGL.so
802 %dir %{_includedir}/EGL
803 %{_includedir}/EGL/egl.h
804 %{_includedir}/EGL/eglext.h
805 %{_includedir}/EGL/eglplatform.h
806 %dir %{_includedir}/KHR
807 %{_includedir}/KHR/khrplatform.h
808 %{_pkgconfigdir}/egl.pc
809
810 %if %{with static}
811 %files libEGL-static
812 %defattr(644,root,root,755)
813 %{_libdir}/libEGL.a
814 %endif
815 %endif
816
817 %files libGL
818 %defattr(644,root,root,755)
819 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
820 %if %{with multigl}
821 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
822 %dir %{_libdir}/Mesa
823 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
824 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
825 %else
826 %attr(755,root,root) %{_libdir}/libGL.so.*.*
827 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
828 # symlink for binary apps which fail to conform Linux OpenGL ABI
829 # (and dlopen libGL.so instead of libGL.so.1)
830 %attr(755,root,root) %{_libdir}/libGL.so
831 %endif
832
833 %files libGL-devel
834 %defattr(644,root,root,755)
835 %doc docs/*.spec
836 %if %{with multigl}
837 %attr(755,root,root) %{_libdir}/libGL.so
838 %endif
839 %dir %{_includedir}/GL
840 %{_includedir}/GL/gl.h
841 %{_includedir}/GL/glext.h
842 %{_includedir}/GL/gl_mangle.h
843 %{_includedir}/GL/glx.h
844 %{_includedir}/GL/glxext.h
845 %{_includedir}/GL/glx_mangle.h
846 %dir %{_includedir}/GL/internal
847 %{_includedir}/GL/internal/dri_interface.h
848 %{_pkgconfigdir}/dri.pc
849 %{_pkgconfigdir}/gl.pc
850
851 %if %{with static}
852 %files libGL-static
853 %defattr(644,root,root,755)
854 %{_libdir}/libGL.a
855 %endif
856
857 %files libGLU
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
860 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
861
862 %files libGLU-devel
863 %defattr(644,root,root,755)
864 %attr(755,root,root) %{_libdir}/libGLU.so
865 %{_includedir}/GL/glu.h
866 %{_includedir}/GL/glu_mangle.h
867 %{_pkgconfigdir}/glu.pc
868
869 %if %{with static}
870 %files libGLU-static
871 %defattr(644,root,root,755)
872 %{_libdir}/libGLU.a
873 %endif
874
875 %files libGLw
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
878 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
879
880 %files libGLw-devel
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/libGLw.so
883 %{_includedir}/GL/GLwDrawA.h
884 %{_includedir}/GL/GLwDrawAP.h
885 %{_includedir}/GL/GLwMDrawA.h
886 %{_includedir}/GL/GLwMDrawAP.h
887 %{_pkgconfigdir}/glw.pc
888
889 %if %{with static}
890 %files libGLw-static
891 %defattr(644,root,root,755)
892 %{_libdir}/libGLw.a
893 %endif
894
895 %if %{with osmesa}
896 %files libOSMesa
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
899 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
900
901 %files libOSMesa-devel
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/libOSMesa*.so
904 %{_includedir}/GL/osmesa.h
905
906 %if %{with static}
907 %files libOSMesa-static
908 %defattr(644,root,root,755)
909 %{_libdir}/libOSMesa*.a
910 %endif
911 %endif
912
913 %files dri-driver-ati-mach64
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
916
917 %files dri-driver-ati-radeon-R100
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
920
921 %files dri-driver-ati-radeon-R200
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
924
925 %files dri-driver-ati-radeon-R300
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
928
929 %files dri-driver-ati-radeon-R600
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
932
933 %files dri-driver-ati-rage128
934 %defattr(644,root,root,755)
935 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
936
937 # sunffb (sparc only)
938 %ifarch sparc sparcv9 sparc64
939 %files dri-driver-ffb
940 %defattr(644,root,root,755)
941 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
942 %endif
943
944 # glint (requires update)
945 %if 0
946 %files dri-driver-glint
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
949 %endif
950
951 %files dri-driver-intel-i810
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
954
955 %files dri-driver-intel-i915
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
958
959 %files dri-driver-intel-i965
960 %defattr(644,root,root,755)
961 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
962
963 %files dri-driver-matrox
964 %defattr(644,root,root,755)
965 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
966
967 %if %{with gallium}
968 %if %{with gallium_nouveau}
969 %files dri-driver-nouveau
970 %defattr(644,root,root,755)
971 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
972 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
973 %endif
974 %endif
975
976 %files dri-driver-savage
977 %defattr(644,root,root,755)
978 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
979
980 %ifarch %{ix86} %{x8664}
981 %files dri-driver-sis
982 %defattr(644,root,root,755)
983 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
984 %endif
985
986 %files dri-driver-swrast
987 %defattr(644,root,root,755)
988 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
989 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
990
991 %files dri-driver-tdfx
992 %defattr(644,root,root,755)
993 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
994
995 %files dri-driver-via-unichrome
996 %defattr(644,root,root,755)
997 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
998
999 %if %{with gallium}
1000 %files dri-driver-vmwgfx
1001 %defattr(644,root,root,755)
1002 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
1003 %endif
This page took 0.289939 seconds and 4 git commands to generate.