]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- rel 2; Fixes front-buffer rendering with DRI1.
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  motif   # build static libGLw without Motif interface
8 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
9 %bcond_with     static
10 #
11 # minimal supported xserver version
12 %define         xserver_ver     1.5.0
13 # glapi version (glapi tables in dri drivers and libglx must be in sync);
14 # set to current Mesa version on ABI break, when xserver tables get regenerated
15 # (until they start to be somehow versioned themselves)
16 %define         glapi_ver       7.1.0
17 #
18 Summary:        Free OpenGL implementation
19 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
20 Name:           Mesa
21 Version:        7.4.1
22 Release:        2%{?with_multigl:.mgl}
23 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
24 Group:          X11/Libraries
25 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
26 # Source0-md5:  423260578b653818ba66c2fcbde6d7ad
27 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
28 # Source1-md5:  1e169fb6abc2b45613f1c98a82dfe690
29 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
30 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
31 Patch0:         %{name}-realclean.patch
32 Patch1:         %{name}-fixes.patch
33 URL:            http://www.mesa3d.org/
34 BuildRequires:  expat-devel
35 BuildRequires:  libdrm-devel >= 2.4.5
36 BuildRequires:  libselinux-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.4d
39 %{?with_motif:BuildRequires:    motif-devel}
40 BuildRequires:  rpmbuild(macros) >= 1.470
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  xorg-lib-libXdamage-devel
43 BuildRequires:  xorg-lib-libXt-devel
44 BuildRequires:  xorg-lib-libXxf86vm-devel
45 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
46 BuildRequires:  xorg-proto-glproto-devel
47 BuildRequires:  xorg-proto-printproto-devel
48 BuildRequires:  xorg-util-makedepend
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Mesa is a 3-D graphics library with an API which is very similar to
53 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
54 syntax or state machine, it is being used with authorization from
55 Silicon Graphics, Inc. However, the author does not possess an OpenGL
56 license from SGI, and makes no claim that Mesa is in any way a
57 compatible replacement for OpenGL or associated with SGI.
58
59 %description -l pl.UTF-8
60 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
61 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
62 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
63 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
64 OpenGL ani powiązana z SGI.
65
66 %package libGL
67 Summary:        Free Mesa3D implementation of libGL OpenGL library
68 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
69 License:        MIT
70 Group:          X11/Libraries
71 Requires:       libdrm >= 2.4.5
72 Provides:       OpenGL = 2.1
73 # reports version 1.3, but supports glXGetProcAddress() from 1.4
74 Provides:       OpenGL-GLX = 1.4
75 Obsoletes:      Mesa
76 Obsoletes:      Mesa-dri
77 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
78 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
79
80 %description libGL
81 Mesa is a 3-D graphics library with an API which is very similar to
82 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
83 syntax or state machine, it is being used with authorization from
84 Silicon Graphics, Inc. However, the author does not possess an OpenGL
85 license from SGI, and makes no claim that Mesa is in any way a
86 compatible replacement for OpenGL or associated with SGI.
87
88 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
89 specifications. It uses DRI for rendering.
90
91 %description libGL -l pl.UTF-8
92 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
93 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
94 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
95 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
96 OpenGL ani powiązana z SGI.
97
98 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
99 GLX 1.4. Używa DRI do renderowania.
100
101 %package libGL-devel
102 Summary:        Header files for Mesa3D libGL library
103 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
104 License:        MIT
105 Group:          X11/Development/Libraries
106 # loose dependency on libGL to use with other libGL binaries
107 Requires:       OpenGL >= 1.5
108 Requires:       xorg-lib-libX11-devel
109 Provides:       OpenGL-devel = 2.1
110 Provides:       OpenGL-GLX-devel = 1.4
111 Obsoletes:      Mesa-devel
112 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
113 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
114 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
115 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
116
117 %description libGL-devel
118 Header files for Mesa3D libGL library.
119
120 %description libGL-devel -l pl.UTF-8
121 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
122
123 %package libGL-static
124 Summary:        Static Mesa3D libGL library
125 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
126 License:        MIT
127 Group:          X11/Development/Libraries
128 Requires:       %{name}-libGL-devel = %{version}-%{release}
129 Provides:       OpenGL-static = 2.1
130 Obsoletes:      Mesa-static
131 Obsoletes:      X11-OpenGL-static < 1:7.0.0
132 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
133
134 %description libGL-static
135 Static Mesa3D libGL library. It uses software renderer.
136
137 %description libGL-static -l pl.UTF-8
138 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
139 renderingu.
140
141 %package libGLU
142 Summary:        SGI implementation of libGLU OpenGL library
143 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
144 License:        SGI Free Software License B v2.0 (MIT-like)
145 Group:          Libraries
146 # loose dependency on libGL.so.1 to use with other libGL binaries
147 Requires:       OpenGL >= 1.2
148 Provides:       OpenGL-GLU = 1.3
149 Obsoletes:      Mesa-devel
150 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
151 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
152
153 %description libGLU
154 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
155 1.3 specifications.
156
157 %description libGLU -l pl.UTF-8
158 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
159 specyfikację OpenGL GLU 1.3.
160
161 %package libGLU-devel
162 Summary:        Header files for SGI libGLU library
163 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
164 License:        SGI Free Software License B v2.0 (MIT-like)
165 Group:          Development/Libraries
166 Requires:       %{name}-libGLU = %{version}-%{release}
167 Requires:       OpenGL-devel >= 1.2
168 Requires:       libstdc++-devel
169 Provides:       OpenGL-GLU-devel = 1.3
170
171 %description libGLU-devel
172 Header files for SGI libGLU library.
173
174 %description libGLU-devel -l pl.UTF-8
175 Pliki nagłówkowe biblioteki SGI libGLU.
176
177 %package libGLU-static
178 Summary:        Static SGI libGLU library
179 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
180 License:        SGI Free Software License B v2.0 (MIT-like)
181 Group:          Development/Libraries
182 Requires:       %{name}-libGLU-devel = %{version}-%{release}
183 Provides:       OpenGL-GLU-static = 1.3
184
185 %description libGLU-static
186 Static SGI libGLU library.
187
188 %description libGLU-static -l pl.UTF-8
189 Statyczna biblioteka SGI libGLU.
190
191 %package libGLw
192 Summary:        SGI OpenGL Xt widgets library
193 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
194 License:        SGI MIT-like
195 Group:          Libraries
196 # loose dependency on libGL.so.1 to use with other libGL binaries
197 Requires:       OpenGL >= 1.1
198 Provides:       OpenGL-GLw
199
200 %description libGLw
201 SGI OpenGL Xt widgets library.
202
203 %description libGLU -l pl.UTF-8
204 Biblioteka SGI widgetów Xt dla OpenGL-a.
205
206 %package libGLw-devel
207 Summary:        Header files for SGI libGLw library
208 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
209 License:        SGI MIT-like
210 Group:          Development/Libraries
211 Requires:       %{name}-libGLw = %{version}-%{release}
212 Requires:       OpenGL-devel >= 1.2
213 Provides:       OpenGL-GLw-devel
214
215 %description libGLw-devel
216 Header files for SGI libGLw library.
217
218 %description libGLw-devel -l pl.UTF-8
219 Pliki nagłówkowe biblioteki SGI libGLw.
220
221 %package libGLw-static
222 Summary:        Static SGI libGLw library
223 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
224 License:        SGI MIT-like
225 Group:          Development/Libraries
226 Requires:       %{name}-libGLw-devel = %{version}-%{release}
227 Provides:       OpenGL-GLw-static
228
229 %description libGLw-static
230 Static SGI libGLw library.
231
232 %description libGLw-static -l pl.UTF-8
233 Statyczna biblioteka SGI libGLw.
234
235 %package libOSMesa
236 Summary:        OSMesa (off-screen renderer) library
237 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
238 License:        MIT
239 Group:          Libraries
240 # doesn't require base
241
242 %description libOSMesa
243 OSMesa (off-screen renderer) library.
244
245 %description libOSMesa -l pl.UTF-8
246 Biblioteka OSMesa (renderująca bitmapy w pamięci).
247
248 %package libOSMesa-devel
249 Summary:        Header file for OSMesa (off-screen renderer) library
250 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
251 License:        MIT
252 Group:          Development/Libraries
253 Requires:       %{name}-libOSMesa = %{version}-%{release}
254 # for <GL/gl.h> only
255 Requires:       OpenGL-devel
256
257 %description libOSMesa-devel
258 Header file for OSMesa (off-screen renderer) library.
259
260 %description libOSMesa-devel -l pl.UTF-8
261 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
262
263 %package libOSMesa-static
264 Summary:        Static OSMesa (off-screen renderer) library
265 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
266 License:        MIT
267 Group:          Development/Libraries
268 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
269 # this static build of OSMesa needs static non-dri Mesa implementation
270 Requires:       %{name}-libGL-static = %{version}-%{release}
271
272 %description libOSMesa-static
273 Static OSMesa (off-screen renderer) library.
274
275 %description libOSMesa-static -l pl.UTF-8
276 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
277
278 %package utils
279 Summary:        OpenGL utilities from Mesa3D
280 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
281 License:        MIT
282 Group:          X11/Applications/Graphics
283 # loose deps on libGL/libGLU
284
285 %description utils
286 OpenGL utilities from Mesa3D: glxgears and glxinfo.
287
288 %description utils -l pl.UTF-8
289 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
290
291 %package demos
292 Summary:        Mesa Demos source code
293 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
294 License:        various (MIT, SGI, GPL - see copyright notes in sources)
295 Group:          Development/Libraries
296 Requires:       OpenGL-devel
297
298 %description demos
299 Demonstration programs for the Mesa libraries in source code form.
300
301 %description demos -l pl.UTF-8
302 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
303
304 %package dri-driver-ati-mach64
305 Summary:        X.org DRI driver for ATI Mach64 card family
306 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
307 License:        MIT
308 Group:          X11/Libraries
309 Requires:       xorg-driver-video-mach64
310 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
311 Requires:       xorg-xserver-server >= %{xserver_ver}
312
313 %description dri-driver-ati-mach64
314 X.org DRI driver for ATI Mach64 card family.
315
316 %description dri-driver-ati-mach64 -l pl.UTF-8
317 Sterownik X.org DRI dla rodziny kart ATI Mach64.
318
319 %package dri-driver-ati-radeon-R100
320 Summary:        X.org DRI driver for ATI R100 card family
321 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
322 License:        MIT
323 Group:          X11/Libraries
324 Requires:       xorg-driver-video-ati
325 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
326 Requires:       xorg-xserver-server >= %{xserver_ver}
327 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
328
329 %description dri-driver-ati-radeon-R100
330 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
331
332 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
333 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
334
335 %package dri-driver-ati-radeon-R200
336 Summary:        X.org DRI driver for ATI R200 card family
337 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
338 License:        MIT
339 Group:          X11/Libraries
340 Requires:       xorg-driver-video-ati
341 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
342 Requires:       xorg-xserver-server >= %{xserver_ver}
343 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
344
345 %description dri-driver-ati-radeon-R200
346 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
347
348 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
349 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
350
351 %package dri-driver-ati-radeon-R300
352 Summary:        X.org DRI driver for ATI R300 card family
353 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
354 License:        MIT
355 Group:          X11/Libraries
356 Requires:       xorg-driver-video-ati
357 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
358 Requires:       xorg-xserver-server >= %{xserver_ver}
359 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
360
361 %description dri-driver-ati-radeon-R300
362 X.org DRI driver for ATI R300 card family.
363
364 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
365 Sterownik X.org DRI dla rodziny kart ATI R300.
366
367 %package dri-driver-ati-rage128
368 Summary:        X.org DRI driver for ATI Rage128 card family
369 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
370 License:        MIT
371 Group:          X11/Libraries
372 Requires:       xorg-driver-video-r128
373 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
374 Requires:       xorg-xserver-server >= %{xserver_ver}
375 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
376
377 %description dri-driver-ati-rage128
378 X.org DRI driver for ATI Rage128 card family.
379
380 %description dri-driver-ati-rage128 -l pl.UTF-8
381 Sterownik X.org DRI dla rodziny kart ATI Rage128.
382
383 %package dri-driver-ffb
384 Summary:        X.org DRI driver for Sun FFB card family
385 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
386 License:        MIT
387 Group:          X11/Libraries
388 Requires:       xorg-driver-video-sunffb
389 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
390 Requires:       xorg-xserver-server >= %{xserver_ver}
391
392 %description dri-driver-ffb
393 X.org DRI driver for SUN Creator3D and Elite3D card family.
394
395 %description dri-driver-ffb -l pl.UTF-8
396 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
397
398 %package dri-driver-glint
399 Summary:        X.org DRI driver for GLINT/Permedia card family
400 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
401 License:        MIT
402 Group:          X11/Libraries
403 Requires:       xorg-driver-video-glint
404 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
405 Requires:       xorg-xserver-server >= %{xserver_ver}
406 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
407
408 %description dri-driver-glint
409 X.org DRI driver for GLINT/Permedia card family.
410
411 %description dri-driver-glint -l pl.UTF-8
412 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
413
414 %package dri-driver-intel-i810
415 Summary:        X.org DRI driver for Intel i810 card family
416 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
417 License:        MIT
418 Group:          X11/Libraries
419 Requires:       xorg-driver-video-intel
420 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
421 Requires:       xorg-xserver-server >= %{xserver_ver}
422 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
423
424 %description dri-driver-intel-i810
425 X.org DRI driver for Intel i810 card family.
426
427 %description dri-driver-intel-i810 -l pl.UTF-8
428 Sterownik X.org DRI dla rodziny kart Intel i810.
429
430 %package dri-driver-intel-i915
431 Summary:        X.org DRI driver for Intel i915 card family
432 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
433 License:        MIT
434 Group:          X11/Libraries
435 Requires:       xorg-driver-video-intel
436 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
437 Requires:       xorg-xserver-server >= %{xserver_ver}
438 Obsoletes:      Mesa-dri-driver-intel-i830
439 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
440
441 %description dri-driver-intel-i915
442 X.org DRI driver for Intel i915 card family.
443
444 %description dri-driver-intel-i915 -l pl.UTF-8
445 Sterownik X.org DRI dla rodziny kart Intel i915.
446
447 %package dri-driver-intel-i965
448 Summary:        X.org DRI driver for Intel i965 card family
449 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
450 License:        MIT
451 Group:          X11/Libraries
452 Requires:       xorg-driver-video-intel
453 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
454 Requires:       xorg-xserver-server >= %{xserver_ver}
455 Obsoletes:      Mesa-dri-driver-intel-i830
456 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
457
458 %description dri-driver-intel-i965
459 X.org DRI driver for Intel i965 card family.
460
461 %description dri-driver-intel-i965 -l pl.UTF-8
462 Sterownik X.org DRI dla rodziny kart Intel i965.
463
464 %package dri-driver-matrox
465 Summary:        X.org DRI driver for Matrox G card family
466 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
467 License:        MIT
468 Group:          X11/Libraries
469 Requires:       xorg-driver-video-mga
470 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
471 Requires:       xorg-xserver-server >= %{xserver_ver}
472 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
473
474 %description dri-driver-matrox
475 X.org DRI drivers for Matrox G card family.
476
477 %description dri-driver-matrox -l pl.UTF-8
478 Sterowniki X.org DRI dla rodziny kart Matrox G.
479
480 %package dri-driver-s3virge
481 Summary:        X.org DRI driver for S3 Virge card family
482 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
483 License:        MIT
484 Group:          X11/Libraries
485 Requires:       xorg-driver-video-s3virge
486 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
487 Requires:       xorg-xserver-server >= %{xserver_ver}
488
489 %description dri-driver-s3virge
490 X.org DRI driver for S3 Virge card family.
491
492 %description dri-driver-s3virge -l pl.UTF-8
493 Sterownik X.org DRI dla rodziny kart S3 Virge.
494
495 %package dri-driver-savage
496 Summary:        X.org DRI driver for S3 Savage card family
497 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
498 License:        MIT
499 Group:          X11/Libraries
500 Requires:       xorg-driver-video-savage
501 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
502 Requires:       xorg-xserver-server >= %{xserver_ver}
503
504 %description dri-driver-savage
505 X.org DRI driver for S3 Savage card family.
506
507 %description dri-driver-savage -l pl.UTF-8
508 Sterownik X.org DRI dla rodziny kart S3 Savage.
509
510 %package dri-driver-sis
511 Summary:        X.org DRI driver for SiS card family
512 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
513 License:        MIT
514 Group:          X11/Libraries
515 Requires:       xorg-driver-video-sis
516 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
517 Requires:       xorg-xserver-server >= %{xserver_ver}
518 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
519
520 %description dri-driver-sis
521 X.org DRI driver for SiS card family.
522
523 %description dri-driver-sis -l pl.UTF-8
524 Sterownik X.org DRI dla rodziny kart SiS.
525
526 %package dri-driver-swrast
527 Summary:        X.org DRI software rasterizer driver
528 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
529 License:        MIT
530 Group:          X11/Libraries
531 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
532 Requires:       xorg-xserver-server >= %{xserver_ver}
533
534 %description dri-driver-swrast
535 X.org DRI software rasterizer driver.
536
537 %description dri-driver-swrast -l pl.UTF-8
538 Sterownik X.org DRI obsługujący rysowanie programowe.
539
540 %package dri-driver-tdfx
541 Summary:        X.org DRI driver for 3DFX Voodoo card family
542 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
543 License:        MIT
544 Group:          X11/Libraries
545 Requires:       Glide3-DRI
546 Requires:       xorg-driver-video-tdfx
547 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
548 Requires:       xorg-xserver-server >= %{xserver_ver}
549 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
550
551 %description dri-driver-tdfx
552 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
553 and Velocity 100/200).
554
555 %description dri-driver-tdfx -l pl.UTF-8
556 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
557 Banshee i Velocity 100/200).
558
559 %package dri-driver-trident
560 Summary:        X.org DRI driver for Trident card family
561 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
562 License:        MIT
563 Group:          X11/Libraries
564 Requires:       xorg-driver-video-trident
565 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
566 Requires:       xorg-xserver-server >= %{xserver_ver}
567
568 %description dri-driver-trident
569 X.org DRI drivers for Trident card family.
570
571 %description dri-driver-trident -l pl.UTF-8
572 Sterowniki X.org DRI dla rodziny kart Trident.
573
574 %package dri-driver-via-unichrome
575 Summary:        X.org DRI driver for VIA Unichrome card family
576 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
577 License:        MIT
578 Group:          X11/Libraries
579 Requires:       xorg-driver-video-openchrome
580 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
581 Requires:       xorg-xserver-server >= %{xserver_ver}
582
583 %description dri-driver-via-unichrome
584 X.org DRI driver for VIA Unichrome card family.
585
586 %description dri-driver-via-unichrome -l pl.UTF-8
587 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
588
589 %prep
590 %setup -q -b1 -a2
591 %patch0 -p0
592 %patch1 -p1
593
594 # fix demos
595 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
596
597 %build
598 dri_drivers="i810 i915 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
599 %ifarch sparc sparcv9 sparc64
600 ffb \
601 %endif
602 %ifarch %{ix86} %{x8664}
603 sis \
604 %endif
605 swrast tdfx unichrome"
606
607 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
608
609 common_flags="\
610         --enable-shared \
611         --enable-selinux \
612         --enable-pic"
613
614 # osmesa variants
615 %configure $common_flags \
616         --with-driver=osmesa \
617         --disable-asm \
618         --with-osmesa-bits=8
619 %{__make} \
620         SRC_DIRS=mesa
621 mv %{_lib} osmesa8
622 %{__make} clean
623
624 %configure $common_flags \
625         --with-driver=osmesa \
626         --disable-asm \
627         --with-osmesa-bits=16
628 %{__make} \
629         SRC_DIRS=mesa
630 mv %{_lib} osmesa16
631 %{__make} clean
632
633 %configure $common_flags \
634         --with-driver=osmesa \
635         --disable-asm \
636         --with-osmesa-bits=32
637 %{__make} \
638         SRC_DIRS=mesa
639 mv %{_lib} osmesa32
640 %{__make} clean
641
642 %configure $common_flags \
643         --enable-glu \
644         --enable-glw \
645         --disable-glut \
646         --with-driver=dri \
647         --with-dri-drivers=${dri_drivers} \
648         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
649
650 %{__make}
651 %{__make} -C progs/xdemos glxgears glxinfo
652 %{__make} -C progs/demos
653
654 cd gl-manpages-*
655 %configure
656 %{__make}
657
658 %install
659 rm -rf $RPM_BUILD_ROOT
660
661 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
662
663 # libs without drivers
664 %{__make} install \
665         DESTDIR=$RPM_BUILD_ROOT
666
667 cd gl-manpages-*
668 %{__make} install \
669         DESTDIR=$RPM_BUILD_ROOT
670 cd ..
671
672 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
673
674 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
675 # work on copy to keep -bi --short-circuit working
676 rm -rf progs-clean
677 install -d progs-clean
678 for l in demos glsl osdemos redbook samples xdemos ; do
679         cp -a progs/$l progs-clean/$l
680         %{__make} -C progs-clean/$l clean
681         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
682 done
683 rm -rf progs-clean
684 for l in util images ; do
685         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
686 done
687 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
688
689 # strip out undesirable headers
690 olddir=$(pwd)
691 cd $RPM_BUILD_ROOT%{_includedir}/GL 
692 rm [a-fh-np-wyz]*.h gg*.h glf*.h
693 cd $olddir
694
695 %if %{with multigl}
696 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
697
698 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
699 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
700
701 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
702 %endif
703
704 %clean
705 rm -rf $RPM_BUILD_ROOT
706
707 %post   libGL -p /sbin/ldconfig
708 %postun libGL -p /sbin/ldconfig
709
710 %post   libGLU -p /sbin/ldconfig
711 %postun libGLU -p /sbin/ldconfig
712
713 %post   libGLw -p /sbin/ldconfig
714 %postun libGLw -p /sbin/ldconfig
715
716 %files libGL
717 %defattr(644,root,root,755)
718 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
719 %if %{with multigl}
720 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
721 %dir %{_libdir}/Mesa
722 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
723 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
724 %else
725 %attr(755,root,root) %{_libdir}/libGL.so.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
727 # symlink for binary apps which fail to conform Linux OpenGL ABI
728 # (and dlopen libGL.so instead of libGL.so.1)
729 %attr(755,root,root) %{_libdir}/libGL.so
730 %endif
731
732 %files libGL-devel
733 %defattr(644,root,root,755)
734 %doc docs/*.spec
735 %if %{with multigl}
736 %attr(755,root,root) %{_libdir}/libGL.so
737 %endif
738 %dir %{_includedir}/GL
739 %{_includedir}/GL/gl.h
740 %{_includedir}/GL/glext.h
741 %{_includedir}/GL/gl_mangle.h
742 %{_includedir}/GL/glx.h
743 %{_includedir}/GL/glxext.h
744 %{_includedir}/GL/glx_mangle.h
745 %dir %{_includedir}/GL/internal
746 %{_includedir}/GL/internal/dri_interface.h
747 %{_pkgconfigdir}/dri.pc
748 %{_pkgconfigdir}/gl.pc
749 %{_datadir}/man/man3/gl[^uX]*.3gl*
750 %{_datadir}/man/man3/glX*.3gl*
751
752 %if %{with static}
753 %files libGL-static
754 %defattr(644,root,root,755)
755 %{_libdir}/libGL.a
756 %endif
757
758 %files libGLU
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
762
763 %files libGLU-devel
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libGLU.so
766 %{_includedir}/GL/glu.h
767 %{_includedir}/GL/glu_mangle.h
768 %{_pkgconfigdir}/glu.pc
769 %{_datadir}/man/man3/glu*.3gl*
770
771 %if %{with static}
772 %files libGLU-static
773 %defattr(644,root,root,755)
774 %{_libdir}/libGLU.a
775 %endif
776
777 %files libGLw
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
780 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
781
782 %files libGLw-devel
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libGLw.so
785 %{_includedir}/GL/GLwDrawA.h
786 %{_includedir}/GL/GLwDrawAP.h
787 %{_includedir}/GL/GLwMDrawA.h
788 %{_includedir}/GL/GLwMDrawAP.h
789 %{_pkgconfigdir}/glw.pc
790
791 %if %{with static}
792 %files libGLw-static
793 %defattr(644,root,root,755)
794 %{_libdir}/libGLw.a
795 %endif
796
797 %files libOSMesa
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
800 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
801
802 %files libOSMesa-devel
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_libdir}/libOSMesa*.so
805 %{_includedir}/GL/osmesa.h
806
807 %if %{with static}
808 %files libOSMesa-static
809 %defattr(644,root,root,755)
810 %{_libdir}/libOSMesa*.a
811 %endif
812
813 %files utils
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_bindir}/glxgears
816 %attr(755,root,root) %{_bindir}/glxinfo
817
818 %files dri-driver-ati-mach64
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
821
822 %files dri-driver-ati-radeon-R100
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
825
826 %files dri-driver-ati-radeon-R200
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
829
830 %files dri-driver-ati-radeon-R300
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
833
834 %files dri-driver-ati-rage128
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
837
838 # sunffb (sparc only)
839 %ifarch sparc sparcv9 sparc64
840 %files dri-driver-ffb
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
843 %endif
844
845 # glint (requires update)
846 %if 0
847 %files dri-driver-glint
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
850 %endif
851
852 %files dri-driver-intel-i810
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
855
856 %files dri-driver-intel-i915
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
859
860 %files dri-driver-intel-i965
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
863
864 %files dri-driver-matrox
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
867
868 %files dri-driver-s3virge
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
871
872 %files dri-driver-savage
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
875
876 %ifarch %{ix86} %{x8664}
877 %files dri-driver-sis
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
880 %endif
881
882 %files dri-driver-swrast
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
885
886 %files dri-driver-tdfx
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
889
890 %files dri-driver-trident
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
893
894 %files dri-driver-via-unichrome
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
897
898 %files demos
899 %defattr(644,root,root,755)
900 %{_examplesdir}/%{name}-%{version}
This page took 0.121398 seconds and 3 git commands to generate.