]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- obsolete
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_without  gallium_nouveau
11 %bcond_without  motif   # build static libGLw without Motif interface
12 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
13 %bcond_without  osmesa  # don't build osmesa
14 %bcond_with     static
15 #
16 # minimal supported xserver version
17 %define         xserver_ver     1.5.0
18 # glapi version (glapi tables in dri drivers and libglx must be in sync);
19 # set to current Mesa version on ABI break, when xserver tables get regenerated
20 # (until they start to be somehow versioned themselves)
21 %define         glapi_ver       7.1.0
22 #
23 %define         libdrm_ver      2.4.21
24 %define         dri2proto_ver   1.99.3
25 %define         glproto_ver     1.4.11
26 #
27 Summary:        Free OpenGL implementation
28 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
29 Name:           Mesa
30 Version:        7.9
31 Release:        1%{?with_multigl:.mgl}
32 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
33 Group:          X11/Libraries
34 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
35 # Source0-md5:  82c740c49d572baa6da2b1a1eee90bca
36 Patch0:         %{name}-realclean.patch
37 Patch1:         %{name}-selinux.patch
38 URL:            http://www.mesa3d.org/
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  expat-devel
42 BuildRequires:  libdrm-devel >= %{libdrm_ver}
43 BuildRequires:  libselinux-devel
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool >= 2:1.4d
46 %{?with_motif:BuildRequires:    motif-devel}
47 BuildRequires:  pixman-devel
48 BuildRequires:  pkgconfig
49 BuildRequires:  pkgconfig(talloc) >= 2.0.1
50 BuildRequires:  python
51 BuildRequires:  python-modules
52 BuildRequires:  rpmbuild(macros) >= 1.470
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  xorg-lib-libXdamage-devel
55 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
56 BuildRequires:  xorg-lib-libXt-devel
57 BuildRequires:  xorg-lib-libXxf86vm-devel
58 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
59 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
60 BuildRequires:  xorg-util-makedepend
61 BuildRequires:  xorg-xserver-server-devel
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %if %{without gallium}
65 %undefine       with_gallium_intel
66 %endif
67
68 %description
69 Mesa is a 3-D graphics library with an API which is very similar to
70 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
71 syntax or state machine, it is being used with authorization from
72 Silicon Graphics, Inc. However, the author does not possess an OpenGL
73 license from SGI, and makes no claim that Mesa is in any way a
74 compatible replacement for OpenGL or associated with SGI.
75
76 %description -l pl.UTF-8
77 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
78 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
79 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
80 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
81 OpenGL ani powiązana z SGI.
82
83 %package libEGL
84 Summary:        SGI implementation of libEGL OpenGL library
85 Summary(pl.UTF-8):      Implementacja SGI biblioteki libEGL ze standardu OpenGL
86 License:        SGI Free Software License B v2.0 (MIT-like)
87 Group:          Libraries
88 Requires:       OpenGL >= 1.2
89 Provides:       OpenGL-EGL = 1.0
90
91 %description libEGL
92 SGI implementation of libEGL OpenGL library.
93
94 %description libEGL -l pl.UTF-8
95 Implementacja SGI biblioteki libEGL ze standardu OpenGL.
96
97 %package libEGL-devel
98 Summary:        Header files for SGI libEGL library
99 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libEGL
100 License:        SGI Free Software License B v2.0 (MIT-like)
101 Group:          Development/Libraries
102 Requires:       %{name}-libEGL = %{version}-%{release}
103 Requires:       OpenGL-devel >= 1.2
104 Requires:       libstdc++-devel
105 Provides:       OpenGL-EGL-devel = 1.0
106
107 %description libEGL-devel
108 Header files for SGI libEGL library.
109
110 %description libEGL-devel -l pl.UTF-8
111 Pliki nagłówkowe biblioteki SGI libEGL.
112
113 %package libEGL-static
114 Summary:        Static SGI libEGL library
115 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
116 License:        SGI Free Software License B v2.0 (MIT-like)
117 Group:          Development/Libraries
118 Requires:       %{name}-libEGL-devel = %{version}-%{release}
119 Provides:       OpenGL-EGL-static = 1.0
120
121 %description libEGL-static
122 Static SGI libEGL library.
123
124 %description libEGL-static -l pl.UTF-8
125 Statyczna biblioteka SGI libEGL.
126
127 %package libGL
128 Summary:        Free Mesa3D implementation of libGL OpenGL library
129 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
130 License:        MIT
131 Group:          X11/Libraries
132 Requires:       libdrm >= %{libdrm_ver}
133 Provides:       OpenGL = 2.1
134 # reports version 1.3, but supports glXGetProcAddress() from 1.4
135 Provides:       OpenGL-GLX = 1.4
136 Obsoletes:      Mesa
137 Obsoletes:      Mesa-dri
138 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
139 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
140
141 %description libGL
142 Mesa is a 3-D graphics library with an API which is very similar to
143 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
144 syntax or state machine, it is being used with authorization from
145 Silicon Graphics, Inc. However, the author does not possess an OpenGL
146 license from SGI, and makes no claim that Mesa is in any way a
147 compatible replacement for OpenGL or associated with SGI.
148
149 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
150 specifications. It uses DRI for rendering.
151
152 %description libGL -l pl.UTF-8
153 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
154 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
155 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
156 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
157 OpenGL ani powiązana z SGI.
158
159 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
160 GLX 1.4. Używa DRI do renderowania.
161
162 %package libGL-devel
163 Summary:        Header files for Mesa3D libGL library
164 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
165 License:        MIT
166 Group:          X11/Development/Libraries
167 # loose dependency on libGL to use with other libGL binaries
168 Requires:       OpenGL >= 1.5
169 Requires:       libdrm-devel >= %{libdrm_ver}
170 Requires:       xorg-lib-libX11-devel
171 Requires:       xorg-lib-libXdamage-devel
172 Requires:       xorg-lib-libXext-devel
173 Requires:       xorg-lib-libXxf86vm-devel
174 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
175 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
176 Suggests:       OpenGL-doc-man
177 Provides:       OpenGL-GLX-devel = 1.4
178 Provides:       OpenGL-devel = 2.1
179 Obsoletes:      Mesa-devel
180 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
181 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
182 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
183 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
184
185 %description libGL-devel
186 Header files for Mesa3D libGL library.
187
188 %description libGL-devel -l pl.UTF-8
189 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
190
191 %package libGL-static
192 Summary:        Static Mesa3D libGL library
193 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
194 License:        MIT
195 Group:          X11/Development/Libraries
196 Requires:       %{name}-libGL-devel = %{version}-%{release}
197 Provides:       OpenGL-static = 2.1
198 Obsoletes:      Mesa-static
199 Obsoletes:      X11-OpenGL-static < 1:7.0.0
200 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
201
202 %description libGL-static
203 Static Mesa3D libGL library. It uses software renderer.
204
205 %description libGL-static -l pl.UTF-8
206 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
207 renderingu.
208
209 %package libGLU
210 Summary:        SGI implementation of libGLU OpenGL library
211 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
212 License:        SGI Free Software License B v2.0 (MIT-like)
213 Group:          Libraries
214 # loose dependency on libGL.so.1 to use with other libGL binaries
215 Requires:       OpenGL >= 1.2
216 Provides:       OpenGL-GLU = 1.3
217 Obsoletes:      Mesa-devel
218 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
219 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
220
221 %description libGLU
222 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
223 1.3 specifications.
224
225 %description libGLU -l pl.UTF-8
226 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
227 specyfikację OpenGL GLU 1.3.
228
229 %package libGLU-devel
230 Summary:        Header files for SGI libGLU library
231 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
232 License:        SGI Free Software License B v2.0 (MIT-like)
233 Group:          Development/Libraries
234 Requires:       %{name}-libGLU = %{version}-%{release}
235 Requires:       OpenGL-devel >= 1.2
236 Requires:       libstdc++-devel
237 Provides:       OpenGL-GLU-devel = 1.3
238
239 %description libGLU-devel
240 Header files for SGI libGLU library.
241
242 %description libGLU-devel -l pl.UTF-8
243 Pliki nagłówkowe biblioteki SGI libGLU.
244
245 %package libGLU-static
246 Summary:        Static SGI libGLU library
247 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
248 License:        SGI Free Software License B v2.0 (MIT-like)
249 Group:          Development/Libraries
250 Requires:       %{name}-libGLU-devel = %{version}-%{release}
251 Provides:       OpenGL-GLU-static = 1.3
252
253 %description libGLU-static
254 Static SGI libGLU library.
255
256 %description libGLU-static -l pl.UTF-8
257 Statyczna biblioteka SGI libGLU.
258
259 %package libGLw
260 Summary:        SGI OpenGL Xt widgets library
261 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
262 License:        SGI MIT-like
263 Group:          Libraries
264 # loose dependency on libGL.so.1 to use with other libGL binaries
265 Requires:       OpenGL >= 1.1
266 Provides:       OpenGL-GLw
267
268 %description libGLw
269 SGI OpenGL Xt widgets library.
270
271 %description libGLU -l pl.UTF-8
272 Biblioteka SGI widgetów Xt dla OpenGL-a.
273
274 %package libGLw-devel
275 Summary:        Header files for SGI libGLw library
276 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
277 License:        SGI MIT-like
278 Group:          Development/Libraries
279 Requires:       %{name}-libGLw = %{version}-%{release}
280 Requires:       OpenGL-devel >= 1.2
281 Provides:       OpenGL-GLw-devel
282
283 %description libGLw-devel
284 Header files for SGI libGLw library.
285
286 %description libGLw-devel -l pl.UTF-8
287 Pliki nagłówkowe biblioteki SGI libGLw.
288
289 %package libGLw-static
290 Summary:        Static SGI libGLw library
291 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
292 License:        SGI MIT-like
293 Group:          Development/Libraries
294 Requires:       %{name}-libGLw-devel = %{version}-%{release}
295 Provides:       OpenGL-GLw-static
296
297 %description libGLw-static
298 Static SGI libGLw library.
299
300 %description libGLw-static -l pl.UTF-8
301 Statyczna biblioteka SGI libGLw.
302
303 %package libOSMesa
304 Summary:        OSMesa (off-screen renderer) library
305 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
306 License:        MIT
307 Group:          Libraries
308 # doesn't require base
309
310 %description libOSMesa
311 OSMesa (off-screen renderer) library.
312
313 %description libOSMesa -l pl.UTF-8
314 Biblioteka OSMesa (renderująca bitmapy w pamięci).
315
316 %package libOSMesa-devel
317 Summary:        Header file for OSMesa (off-screen renderer) library
318 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
319 License:        MIT
320 Group:          Development/Libraries
321 Requires:       %{name}-libOSMesa = %{version}-%{release}
322 # for <GL/gl.h> only
323 Requires:       OpenGL-devel
324
325 %description libOSMesa-devel
326 Header file for OSMesa (off-screen renderer) library.
327
328 %description libOSMesa-devel -l pl.UTF-8
329 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
330
331 %package libOSMesa-static
332 Summary:        Static OSMesa (off-screen renderer) library
333 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
334 License:        MIT
335 Group:          Development/Libraries
336 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
337 # this static build of OSMesa needs static non-dri Mesa implementation
338 Requires:       %{name}-libGL-static = %{version}-%{release}
339
340 %description libOSMesa-static
341 Static OSMesa (off-screen renderer) library.
342
343 %description libOSMesa-static -l pl.UTF-8
344 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
345
346 %package utils
347 Summary:        OpenGL utilities from Mesa3D
348 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
349 License:        MIT
350 Group:          X11/Applications/Graphics
351 # loose deps on libGL/libGLU
352
353 %description utils
354 OpenGL utilities from Mesa3D: glxgears and glxinfo.
355
356 %description utils -l pl.UTF-8
357 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
358
359 %package dri-driver-ati-mach64
360 Summary:        X.org DRI driver for ATI Mach64 card family
361 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
362 License:        MIT
363 Group:          X11/Libraries
364 Requires:       xorg-driver-video-mach64
365 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
366 Requires:       xorg-xserver-server >= %{xserver_ver}
367
368 %description dri-driver-ati-mach64
369 X.org DRI driver for ATI Mach64 card family.
370
371 %description dri-driver-ati-mach64 -l pl.UTF-8
372 Sterownik X.org DRI dla rodziny kart ATI Mach64.
373
374 %package dri-driver-ati-radeon-R100
375 Summary:        X.org DRI driver for ATI R100 card family
376 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
377 License:        MIT
378 Group:          X11/Libraries
379 Requires:       xorg-driver-video-ati
380 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
381 Requires:       xorg-xserver-server >= %{xserver_ver}
382 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
383
384 %description dri-driver-ati-radeon-R100
385 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
386
387 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
388 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
389
390 %package dri-driver-ati-radeon-R200
391 Summary:        X.org DRI driver for ATI R200 card family
392 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
393 License:        MIT
394 Group:          X11/Libraries
395 Requires:       xorg-driver-video-ati
396 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
397 Requires:       xorg-xserver-server >= %{xserver_ver}
398 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
399
400 %description dri-driver-ati-radeon-R200
401 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
402
403 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
404 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
405
406 %package dri-driver-ati-radeon-R300
407 Summary:        X.org DRI driver for ATI R300 card family
408 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
409 License:        MIT
410 Group:          X11/Libraries
411 Requires:       xorg-driver-video-ati
412 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
413 Requires:       xorg-xserver-server >= %{xserver_ver}
414 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
415
416 %description dri-driver-ati-radeon-R300
417 X.org DRI driver for ATI R300 card family.
418
419 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
420 Sterownik X.org DRI dla rodziny kart ATI R300.
421
422 %package dri-driver-ati-radeon-R600
423 Summary:        X.org DRI driver for ATI R600 card family
424 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
425 License:        MIT
426 Group:          X11/Libraries
427 Requires:       radeon-ucode
428 Requires:       xorg-driver-video-ati
429 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
430 Requires:       xorg-xserver-server >= %{xserver_ver}
431
432 %description dri-driver-ati-radeon-R600
433 X.org DRI driver for ATI R600 card family.
434
435 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
436 Sterownik X.org DRI dla rodziny kart ATI R600.
437
438 %package dri-driver-ati-rage128
439 Summary:        X.org DRI driver for ATI Rage128 card family
440 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
441 License:        MIT
442 Group:          X11/Libraries
443 Requires:       xorg-driver-video-r128
444 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
445 Requires:       xorg-xserver-server >= %{xserver_ver}
446 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
447
448 %description dri-driver-ati-rage128
449 X.org DRI driver for ATI Rage128 card family.
450
451 %description dri-driver-ati-rage128 -l pl.UTF-8
452 Sterownik X.org DRI dla rodziny kart ATI Rage128.
453
454 %package dri-driver-ffb
455 Summary:        X.org DRI driver for Sun FFB card family
456 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
457 License:        MIT
458 Group:          X11/Libraries
459 Requires:       xorg-driver-video-sunffb
460 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
461 Requires:       xorg-xserver-server >= %{xserver_ver}
462
463 %description dri-driver-ffb
464 X.org DRI driver for SUN Creator3D and Elite3D card family.
465
466 %description dri-driver-ffb -l pl.UTF-8
467 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
468
469 %package dri-driver-glint
470 Summary:        X.org DRI driver for GLINT/Permedia card family
471 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
472 License:        MIT
473 Group:          X11/Libraries
474 Requires:       xorg-driver-video-glint
475 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
476 Requires:       xorg-xserver-server >= %{xserver_ver}
477 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
478
479 %description dri-driver-glint
480 X.org DRI driver for GLINT/Permedia card family.
481
482 %description dri-driver-glint -l pl.UTF-8
483 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
484
485 %package dri-driver-intel-i810
486 Summary:        X.org DRI driver for Intel i810 card family
487 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
488 License:        MIT
489 Group:          X11/Libraries
490 Requires:       xorg-driver-video-intel
491 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
492 Requires:       xorg-xserver-server >= %{xserver_ver}
493 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
494
495 %description dri-driver-intel-i810
496 X.org DRI driver for Intel i810 card family.
497
498 %description dri-driver-intel-i810 -l pl.UTF-8
499 Sterownik X.org DRI dla rodziny kart Intel i810.
500
501 %package dri-driver-intel-i915
502 Summary:        X.org DRI driver for Intel i915 card family
503 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
504 License:        MIT
505 Group:          X11/Libraries
506 Requires:       xorg-driver-video-intel
507 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
508 Requires:       xorg-xserver-server >= %{xserver_ver}
509 Obsoletes:      Mesa-dri-driver-intel-i830
510 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
511
512 %description dri-driver-intel-i915
513 X.org DRI driver for Intel i915 card family.
514
515 %description dri-driver-intel-i915 -l pl.UTF-8
516 Sterownik X.org DRI dla rodziny kart Intel i915.
517
518 %package dri-driver-intel-i965
519 Summary:        X.org DRI driver for Intel i965 card family
520 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
521 License:        MIT
522 Group:          X11/Libraries
523 Requires:       xorg-driver-video-intel
524 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
525 Requires:       xorg-xserver-server >= %{xserver_ver}
526 Obsoletes:      Mesa-dri-driver-intel-i830
527 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
528
529 %description dri-driver-intel-i965
530 X.org DRI driver for Intel i965 card family.
531
532 %description dri-driver-intel-i965 -l pl.UTF-8
533 Sterownik X.org DRI dla rodziny kart Intel i965.
534
535 %package dri-driver-matrox
536 Summary:        X.org DRI driver for Matrox G card family
537 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
538 License:        MIT
539 Group:          X11/Libraries
540 Requires:       xorg-driver-video-mga
541 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
542 Requires:       xorg-xserver-server >= %{xserver_ver}
543 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
544
545 %description dri-driver-matrox
546 X.org DRI drivers for Matrox G card family.
547
548 %description dri-driver-matrox -l pl.UTF-8
549 Sterowniki X.org DRI dla rodziny kart Matrox G.
550
551 %package dri-driver-nouveau
552 Summary:        X.org DRI driver for NVIDIA card family
553 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
554 License:        MIT
555 Group:          X11/Libraries
556 Requires:       xorg-driver-video-nouveau
557 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
558 Requires:       xorg-xserver-server >= %{xserver_ver}
559
560 %description dri-driver-nouveau
561 X.org DRI drivers for NVIDIA card family.
562
563 %description dri-driver-nouveau -l pl.UTF-8
564 Sterowniki X.org DRI dla rodziny kart NVIDIA.
565
566 %package dri-driver-savage
567 Summary:        X.org DRI driver for S3 Savage card family
568 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
569 License:        MIT
570 Group:          X11/Libraries
571 Requires:       xorg-driver-video-savage
572 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
573 Requires:       xorg-xserver-server >= %{xserver_ver}
574
575 %description dri-driver-savage
576 X.org DRI driver for S3 Savage card family.
577
578 %description dri-driver-savage -l pl.UTF-8
579 Sterownik X.org DRI dla rodziny kart S3 Savage.
580
581 %package dri-driver-sis
582 Summary:        X.org DRI driver for SiS card family
583 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
584 License:        MIT
585 Group:          X11/Libraries
586 Requires:       xorg-driver-video-sis
587 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
588 Requires:       xorg-xserver-server >= %{xserver_ver}
589 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
590
591 %description dri-driver-sis
592 X.org DRI driver for SiS card family.
593
594 %description dri-driver-sis -l pl.UTF-8
595 Sterownik X.org DRI dla rodziny kart SiS.
596
597 %package dri-driver-swrast
598 Summary:        X.org DRI software rasterizer driver
599 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
600 License:        MIT
601 Group:          X11/Libraries
602 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
603 Requires:       xorg-xserver-server >= %{xserver_ver}
604
605 %description dri-driver-swrast
606 X.org DRI software rasterizer driver.
607
608 %description dri-driver-swrast -l pl.UTF-8
609 Sterownik X.org DRI obsługujący rysowanie programowe.
610
611 %package dri-driver-tdfx
612 Summary:        X.org DRI driver for 3DFX Voodoo card family
613 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
614 License:        MIT
615 Group:          X11/Libraries
616 Requires:       Glide3-DRI
617 Requires:       xorg-driver-video-tdfx
618 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
619 Requires:       xorg-xserver-server >= %{xserver_ver}
620 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
621
622 %description dri-driver-tdfx
623 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
624 and Velocity 100/200).
625
626 %description dri-driver-tdfx -l pl.UTF-8
627 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
628 Banshee i Velocity 100/200).
629
630 %package dri-driver-via-unichrome
631 Summary:        X.org DRI driver for VIA Unichrome card family
632 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
633 License:        MIT
634 Group:          X11/Libraries
635 Requires:       xorg-driver-video-openchrome
636 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
637 Requires:       xorg-xserver-server >= %{xserver_ver}
638
639 %description dri-driver-via-unichrome
640 X.org DRI driver for VIA Unichrome card family.
641
642 %description dri-driver-via-unichrome -l pl.UTF-8
643 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
644
645 %package dri-driver-vmwgfx
646 Summary:        X.org DRI driver for VMware
647 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
648 License:        MIT
649 Group:          X11/Libraries
650 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
651 Requires:       xorg-xserver-server >= %{xserver_ver}
652
653 %description dri-driver-vmwgfx
654 X.org DRI driver for VMWare.
655
656 %description dri-driver-vmwgfx -l pl.UTF-8
657 Sterownik X.org DRI dla VMware.
658
659 %prep
660 %setup -q
661 %patch0 -p0
662 %patch1 -p0
663
664 %build
665 #autoreconf --install
666 %{__aclocal}
667 %{__autoconf}
668
669 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
670 %if %{without gallium_intel}
671 i915 \
672 %endif
673 %ifarch sparc sparcv9 sparc64
674 ffb \
675 %endif
676 %ifarch %{ix86} %{x8664}
677 sis \
678 %endif
679 swrast tdfx unichrome"
680
681 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
682
683 common_flags="\
684         --enable-shared \
685         --enable-selinux \
686         --enable-pic \
687         --enable-glx-tls \
688         --disable-glut \
689         --disable-os-mesa \
690         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
691
692 osmesa_common_flags="\
693         --with-driver=osmesa \
694         --disable-asm \
695         --disable-glu"
696
697 %if %{with osmesa}
698 # osmesa variants
699 %configure $common_flags $osmesa_common_flags \
700         --with-osmesa-bits=8
701 %{__make}
702 mv %{_lib} osmesa8
703 %{__make} clean
704
705 %configure $common_flags $osmesa_common_flags \
706         --with-osmesa-bits=16
707 %{__make}
708 mv %{_lib} osmesa16
709 %{__make} clean
710
711 %configure $common_flags $osmesa_common_flags \
712         --with-osmesa-bits=32
713 %{__make}
714 mv %{_lib} osmesa32
715 %{__make} clean
716 %endif
717
718 %configure $common_flags \
719 %if %{with gallium}
720         --enable-gallium \
721         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
722         --enable-gallium-svga \
723 %{?with_gallium_nouveau:--enable-gallium-nouveau} \
724         --with-state-trackers=dri,glx \
725 %else
726         --disable-gallium \
727 %endif
728         --with-driver=dri \
729         --with-dri-drivers=${dri_drivers} \
730         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
731
732 %{__make}
733
734 %install
735 rm -rf $RPM_BUILD_ROOT
736
737 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
738
739 # libs without drivers
740 %{__make} install \
741         DESTDIR=$RPM_BUILD_ROOT
742
743 %if %{with osmesa}
744 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
745 %endif
746
747 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
748
749 # strip out undesirable headers
750 olddir=$(pwd)
751 cd $RPM_BUILD_ROOT%{_includedir}/GL
752 rm [a-fh-np-wyz]*.h glf*.h
753 cd $RPM_BUILD_ROOT%{_libdir}
754 cd $olddir
755
756 %if %{with multigl}
757 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
758
759 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
760 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
761
762 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
763 %endif
764
765 %clean
766 rm -rf $RPM_BUILD_ROOT
767
768 %post   libEGL -p /sbin/ldconfig
769 %postun libEGL -p /sbin/ldconfig
770
771 %post   libGL -p /sbin/ldconfig
772 %postun libGL -p /sbin/ldconfig
773
774 %post   libGLU -p /sbin/ldconfig
775 %postun libGLU -p /sbin/ldconfig
776
777 %post   libGLw -p /sbin/ldconfig
778 %postun libGLw -p /sbin/ldconfig
779
780 %if %{with egl}
781 %files libEGL
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
784 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.?
785 %dir %{_libdir}/egl
786 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
787 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
788
789 %files libEGL-devel
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libEGL.so
792 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.?
793 %dir %{_includedir}/EGL
794 %{_includedir}/EGL/egl.h
795 %{_includedir}/EGL/eglext.h
796 %{_includedir}/EGL/eglplatform.h
797 %dir %{_includedir}/KHR
798 %{_includedir}/KHR/khrplatform.h
799 %{_pkgconfigdir}/egl.pc
800
801 %if %{with static}
802 %files libEGL-static
803 %defattr(644,root,root,755)
804 %{_libdir}/libEGL.a
805 %endif
806 %endif
807
808 %files libGL
809 %defattr(644,root,root,755)
810 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
811 %if %{with multigl}
812 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
813 %dir %{_libdir}/Mesa
814 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
815 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
816 %else
817 %attr(755,root,root) %{_libdir}/libGL.so.*.*
818 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
819 # symlink for binary apps which fail to conform Linux OpenGL ABI
820 # (and dlopen libGL.so instead of libGL.so.1)
821 %attr(755,root,root) %{_libdir}/libGL.so
822 %endif
823
824 %files libGL-devel
825 %defattr(644,root,root,755)
826 %doc docs/*.spec
827 %if %{with multigl}
828 %attr(755,root,root) %{_libdir}/libGL.so
829 %endif
830 %dir %{_includedir}/GL
831 %{_includedir}/GL/gl.h
832 %{_includedir}/GL/glext.h
833 %{_includedir}/GL/gl_mangle.h
834 %{_includedir}/GL/glx.h
835 %{_includedir}/GL/glxext.h
836 %{_includedir}/GL/glx_mangle.h
837 %dir %{_includedir}/GL/internal
838 %{_includedir}/GL/internal/dri_interface.h
839 %{_pkgconfigdir}/dri.pc
840 %{_pkgconfigdir}/gl.pc
841
842 %if %{with static}
843 %files libGL-static
844 %defattr(644,root,root,755)
845 %{_libdir}/libGL.a
846 %endif
847
848 %files libGLU
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
851 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.?
852
853 %files libGLU-devel
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/libGLU.so
856 %{_includedir}/GL/glu.h
857 %{_includedir}/GL/glu_mangle.h
858 %{_pkgconfigdir}/glu.pc
859
860 %if %{with static}
861 %files libGLU-static
862 %defattr(644,root,root,755)
863 %{_libdir}/libGLU.a
864 %endif
865
866 %files libGLw
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
869 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.?
870
871 %files libGLw-devel
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/libGLw.so
874 %{_includedir}/GL/GLwDrawA.h
875 %{_includedir}/GL/GLwDrawAP.h
876 %{_includedir}/GL/GLwMDrawA.h
877 %{_includedir}/GL/GLwMDrawAP.h
878 %{_pkgconfigdir}/glw.pc
879
880 %if %{with static}
881 %files libGLw-static
882 %defattr(644,root,root,755)
883 %{_libdir}/libGLw.a
884 %endif
885
886 %if %{with osmesa}
887 %files libOSMesa
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
890 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
891
892 %files libOSMesa-devel
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/libOSMesa*.so
895 %{_includedir}/GL/osmesa.h
896
897 %if %{with static}
898 %files libOSMesa-static
899 %defattr(644,root,root,755)
900 %{_libdir}/libOSMesa*.a
901 %endif
902 %endif
903
904 %files dri-driver-ati-mach64
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
907
908 %files dri-driver-ati-radeon-R100
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
911
912 %files dri-driver-ati-radeon-R200
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
915
916 %files dri-driver-ati-radeon-R300
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
919
920 %files dri-driver-ati-radeon-R600
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
923
924 %files dri-driver-ati-rage128
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
927
928 # sunffb (sparc only)
929 %ifarch sparc sparcv9 sparc64
930 %files dri-driver-ffb
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
933 %endif
934
935 # glint (requires update)
936 %if 0
937 %files dri-driver-glint
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
940 %endif
941
942 %files dri-driver-intel-i810
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
945
946 %files dri-driver-intel-i915
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
949
950 %files dri-driver-intel-i965
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
953
954 %files dri-driver-matrox
955 %defattr(644,root,root,755)
956 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
957
958 %if %{with gallium}
959 %if %{with gallium_nouveau}
960 %files dri-driver-nouveau
961 %defattr(644,root,root,755)
962 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
963 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
964 %endif
965 %endif
966
967 %files dri-driver-savage
968 %defattr(644,root,root,755)
969 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
970
971 %ifarch %{ix86} %{x8664}
972 %files dri-driver-sis
973 %defattr(644,root,root,755)
974 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
975 %endif
976
977 %files dri-driver-swrast
978 %defattr(644,root,root,755)
979 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
980 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
981
982 %files dri-driver-tdfx
983 %defattr(644,root,root,755)
984 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
985
986 %files dri-driver-via-unichrome
987 %defattr(644,root,root,755)
988 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
989
990 %if %{with gallium}
991 %files dri-driver-vmwgfx
992 %defattr(644,root,root,755)
993 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
994 %endif
This page took 0.116369 seconds and 3 git commands to generate.