]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- BR: autoconf, automake, pkgconfig
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 Summary:        Free OpenGL implementation
25 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
26 Name:           Mesa
27 Version:        7.6
28 Release:        5%{?with_multigl:.mgl}
29 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
30 Group:          X11/Libraries
31 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
32 # Source0-md5:  8c75f90cd0303cfac9e4b6d54f6759ca
33 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
34 # Source1-md5:  0ede7adf217951acd90dbe4551210c07
35 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
36 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-sparc64.patch
39 Patch2:         %{name}-git.patch
40 URL:            http://www.mesa3d.org/
41 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  expat-devel
45 %{?with_demos:BuildRequires:    glew-devel}
46 BuildRequires:  libdrm-devel >= 2.4.12-3
47 BuildRequires:  libselinux-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtool >= 2:1.4d
50 %{?with_motif:BuildRequires:    motif-devel}
51 BuildRequires:  pkgconfig
52 BuildRequires:  rpmbuild(macros) >= 1.470
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  xorg-lib-libXdamage-devel
55 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
56 BuildRequires:  xorg-lib-libXt-devel
57 BuildRequires:  xorg-lib-libXxf86vm-devel
58 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
59 BuildRequires:  xorg-proto-glproto-devel
60 BuildRequires:  xorg-proto-printproto-devel
61 BuildRequires:  xorg-util-makedepend
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %if %{without gallium}
65 %undefine       with_gallium_intel
66 %endif
67
68 %description
69 Mesa is a 3-D graphics library with an API which is very similar to
70 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
71 syntax or state machine, it is being used with authorization from
72 Silicon Graphics, Inc. However, the author does not possess an OpenGL
73 license from SGI, and makes no claim that Mesa is in any way a
74 compatible replacement for OpenGL or associated with SGI.
75
76 %description -l pl.UTF-8
77 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
78 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
79 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
80 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
81 OpenGL ani powiązana z SGI.
82
83 %package libGL
84 Summary:        Free Mesa3D implementation of libGL OpenGL library
85 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
86 License:        MIT
87 Group:          X11/Libraries
88 Requires:       libdrm >= 2.4.5
89 Provides:       OpenGL = 2.1
90 # reports version 1.3, but supports glXGetProcAddress() from 1.4
91 Provides:       OpenGL-GLX = 1.4
92 Obsoletes:      Mesa
93 Obsoletes:      Mesa-dri
94 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
95 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
96
97 %description libGL
98 Mesa is a 3-D graphics library with an API which is very similar to
99 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
100 syntax or state machine, it is being used with authorization from
101 Silicon Graphics, Inc. However, the author does not possess an OpenGL
102 license from SGI, and makes no claim that Mesa is in any way a
103 compatible replacement for OpenGL or associated with SGI.
104
105 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
106 specifications. It uses DRI for rendering.
107
108 %description libGL -l pl.UTF-8
109 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
110 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
111 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
112 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
113 OpenGL ani powiązana z SGI.
114
115 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
116 GLX 1.4. Używa DRI do renderowania.
117
118 %package libGL-devel
119 Summary:        Header files for Mesa3D libGL library
120 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
121 License:        MIT
122 Group:          X11/Development/Libraries
123 # loose dependency on libGL to use with other libGL binaries
124 Requires:       OpenGL >= 1.5
125 Requires:       xorg-lib-libX11-devel
126 Provides:       OpenGL-GLX-devel = 1.4
127 Provides:       OpenGL-devel = 2.1
128 Obsoletes:      Mesa-devel
129 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
130 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
131 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
132 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
133
134 %description libGL-devel
135 Header files for Mesa3D libGL library.
136
137 %description libGL-devel -l pl.UTF-8
138 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
139
140 %package libGL-static
141 Summary:        Static Mesa3D libGL library
142 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
143 License:        MIT
144 Group:          X11/Development/Libraries
145 Requires:       %{name}-libGL-devel = %{version}-%{release}
146 Provides:       OpenGL-static = 2.1
147 Obsoletes:      Mesa-static
148 Obsoletes:      X11-OpenGL-static < 1:7.0.0
149 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
150
151 %description libGL-static
152 Static Mesa3D libGL library. It uses software renderer.
153
154 %description libGL-static -l pl.UTF-8
155 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
156 renderingu.
157
158 %package libGLU
159 Summary:        SGI implementation of libGLU OpenGL library
160 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
161 License:        SGI Free Software License B v2.0 (MIT-like)
162 Group:          Libraries
163 # loose dependency on libGL.so.1 to use with other libGL binaries
164 Requires:       OpenGL >= 1.2
165 Provides:       OpenGL-GLU = 1.3
166 Obsoletes:      Mesa-devel
167 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
168 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
169
170 %description libGLU
171 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
172 1.3 specifications.
173
174 %description libGLU -l pl.UTF-8
175 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
176 specyfikację OpenGL GLU 1.3.
177
178 %package libGLU-devel
179 Summary:        Header files for SGI libGLU library
180 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
181 License:        SGI Free Software License B v2.0 (MIT-like)
182 Group:          Development/Libraries
183 Requires:       %{name}-libGLU = %{version}-%{release}
184 Requires:       OpenGL-devel >= 1.2
185 Requires:       libstdc++-devel
186 Provides:       OpenGL-GLU-devel = 1.3
187
188 %description libGLU-devel
189 Header files for SGI libGLU library.
190
191 %description libGLU-devel -l pl.UTF-8
192 Pliki nagłówkowe biblioteki SGI libGLU.
193
194 %package libGLU-static
195 Summary:        Static SGI libGLU library
196 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
197 License:        SGI Free Software License B v2.0 (MIT-like)
198 Group:          Development/Libraries
199 Requires:       %{name}-libGLU-devel = %{version}-%{release}
200 Provides:       OpenGL-GLU-static = 1.3
201
202 %description libGLU-static
203 Static SGI libGLU library.
204
205 %description libGLU-static -l pl.UTF-8
206 Statyczna biblioteka SGI libGLU.
207
208 %package libGLw
209 Summary:        SGI OpenGL Xt widgets library
210 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
211 License:        SGI MIT-like
212 Group:          Libraries
213 # loose dependency on libGL.so.1 to use with other libGL binaries
214 Requires:       OpenGL >= 1.1
215 Provides:       OpenGL-GLw
216
217 %description libGLw
218 SGI OpenGL Xt widgets library.
219
220 %description libGLU -l pl.UTF-8
221 Biblioteka SGI widgetów Xt dla OpenGL-a.
222
223 %package libGLw-devel
224 Summary:        Header files for SGI libGLw library
225 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
226 License:        SGI MIT-like
227 Group:          Development/Libraries
228 Requires:       %{name}-libGLw = %{version}-%{release}
229 Requires:       OpenGL-devel >= 1.2
230 Provides:       OpenGL-GLw-devel
231
232 %description libGLw-devel
233 Header files for SGI libGLw library.
234
235 %description libGLw-devel -l pl.UTF-8
236 Pliki nagłówkowe biblioteki SGI libGLw.
237
238 %package libGLw-static
239 Summary:        Static SGI libGLw library
240 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
241 License:        SGI MIT-like
242 Group:          Development/Libraries
243 Requires:       %{name}-libGLw-devel = %{version}-%{release}
244 Provides:       OpenGL-GLw-static
245
246 %description libGLw-static
247 Static SGI libGLw library.
248
249 %description libGLw-static -l pl.UTF-8
250 Statyczna biblioteka SGI libGLw.
251
252 %package libOSMesa
253 Summary:        OSMesa (off-screen renderer) library
254 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
255 License:        MIT
256 Group:          Libraries
257 # doesn't require base
258
259 %description libOSMesa
260 OSMesa (off-screen renderer) library.
261
262 %description libOSMesa -l pl.UTF-8
263 Biblioteka OSMesa (renderująca bitmapy w pamięci).
264
265 %package libOSMesa-devel
266 Summary:        Header file for OSMesa (off-screen renderer) library
267 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
268 License:        MIT
269 Group:          Development/Libraries
270 Requires:       %{name}-libOSMesa = %{version}-%{release}
271 # for <GL/gl.h> only
272 Requires:       OpenGL-devel
273
274 %description libOSMesa-devel
275 Header file for OSMesa (off-screen renderer) library.
276
277 %description libOSMesa-devel -l pl.UTF-8
278 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
279
280 %package libOSMesa-static
281 Summary:        Static OSMesa (off-screen renderer) library
282 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
283 License:        MIT
284 Group:          Development/Libraries
285 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
286 # this static build of OSMesa needs static non-dri Mesa implementation
287 Requires:       %{name}-libGL-static = %{version}-%{release}
288
289 %description libOSMesa-static
290 Static OSMesa (off-screen renderer) library.
291
292 %description libOSMesa-static -l pl.UTF-8
293 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
294
295 %package utils
296 Summary:        OpenGL utilities from Mesa3D
297 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
298 License:        MIT
299 Group:          X11/Applications/Graphics
300 # loose deps on libGL/libGLU
301
302 %description utils
303 OpenGL utilities from Mesa3D: glxgears and glxinfo.
304
305 %description utils -l pl.UTF-8
306 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
307
308 %package demos
309 Summary:        Mesa Demos source code
310 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
311 License:        various (MIT, SGI, GPL - see copyright notes in sources)
312 Group:          Development/Libraries
313 Requires:       OpenGL-devel
314
315 %description demos
316 Demonstration programs for the Mesa libraries in source code form.
317
318 %description demos -l pl.UTF-8
319 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
320
321 %package dri-driver-ati-mach64
322 Summary:        X.org DRI driver for ATI Mach64 card family
323 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
324 License:        MIT
325 Group:          X11/Libraries
326 Requires:       xorg-driver-video-mach64
327 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
328 Requires:       xorg-xserver-server >= %{xserver_ver}
329
330 %description dri-driver-ati-mach64
331 X.org DRI driver for ATI Mach64 card family.
332
333 %description dri-driver-ati-mach64 -l pl.UTF-8
334 Sterownik X.org DRI dla rodziny kart ATI Mach64.
335
336 %package dri-driver-ati-radeon-R100
337 Summary:        X.org DRI driver for ATI R100 card family
338 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
339 License:        MIT
340 Group:          X11/Libraries
341 Requires:       xorg-driver-video-ati
342 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
343 Requires:       xorg-xserver-server >= %{xserver_ver}
344 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
345
346 %description dri-driver-ati-radeon-R100
347 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
348
349 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
350 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
351
352 %package dri-driver-ati-radeon-R200
353 Summary:        X.org DRI driver for ATI R200 card family
354 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
355 License:        MIT
356 Group:          X11/Libraries
357 Requires:       xorg-driver-video-ati
358 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
359 Requires:       xorg-xserver-server >= %{xserver_ver}
360 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
361
362 %description dri-driver-ati-radeon-R200
363 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
364
365 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
366 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
367
368 %package dri-driver-ati-radeon-R300
369 Summary:        X.org DRI driver for ATI R300 card family
370 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
371 License:        MIT
372 Group:          X11/Libraries
373 Requires:       xorg-driver-video-ati
374 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
375 Requires:       xorg-xserver-server >= %{xserver_ver}
376 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
377
378 %description dri-driver-ati-radeon-R300
379 X.org DRI driver for ATI R300 card family.
380
381 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
382 Sterownik X.org DRI dla rodziny kart ATI R300.
383
384 %package dri-driver-ati-rage128
385 Summary:        X.org DRI driver for ATI Rage128 card family
386 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
387 License:        MIT
388 Group:          X11/Libraries
389 Requires:       xorg-driver-video-r128
390 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
391 Requires:       xorg-xserver-server >= %{xserver_ver}
392 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
393
394 %description dri-driver-ati-rage128
395 X.org DRI driver for ATI Rage128 card family.
396
397 %description dri-driver-ati-rage128 -l pl.UTF-8
398 Sterownik X.org DRI dla rodziny kart ATI Rage128.
399
400 %package dri-driver-ffb
401 Summary:        X.org DRI driver for Sun FFB card family
402 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
403 License:        MIT
404 Group:          X11/Libraries
405 Requires:       xorg-driver-video-sunffb
406 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
407 Requires:       xorg-xserver-server >= %{xserver_ver}
408
409 %description dri-driver-ffb
410 X.org DRI driver for SUN Creator3D and Elite3D card family.
411
412 %description dri-driver-ffb -l pl.UTF-8
413 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
414
415 %package dri-driver-glint
416 Summary:        X.org DRI driver for GLINT/Permedia card family
417 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
418 License:        MIT
419 Group:          X11/Libraries
420 Requires:       xorg-driver-video-glint
421 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
422 Requires:       xorg-xserver-server >= %{xserver_ver}
423 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
424
425 %description dri-driver-glint
426 X.org DRI driver for GLINT/Permedia card family.
427
428 %description dri-driver-glint -l pl.UTF-8
429 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
430
431 %package dri-driver-intel-i810
432 Summary:        X.org DRI driver for Intel i810 card family
433 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
434 License:        MIT
435 Group:          X11/Libraries
436 Requires:       xorg-driver-video-intel
437 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
438 Requires:       xorg-xserver-server >= %{xserver_ver}
439 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
440
441 %description dri-driver-intel-i810
442 X.org DRI driver for Intel i810 card family.
443
444 %description dri-driver-intel-i810 -l pl.UTF-8
445 Sterownik X.org DRI dla rodziny kart Intel i810.
446
447 %package dri-driver-intel-i915
448 Summary:        X.org DRI driver for Intel i915 card family
449 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
450 License:        MIT
451 Group:          X11/Libraries
452 Requires:       xorg-driver-video-intel
453 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
454 Requires:       xorg-xserver-server >= %{xserver_ver}
455 Obsoletes:      Mesa-dri-driver-intel-i830
456 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
457
458 %description dri-driver-intel-i915
459 X.org DRI driver for Intel i915 card family.
460
461 %description dri-driver-intel-i915 -l pl.UTF-8
462 Sterownik X.org DRI dla rodziny kart Intel i915.
463
464 %package dri-driver-intel-i965
465 Summary:        X.org DRI driver for Intel i965 card family
466 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
467 License:        MIT
468 Group:          X11/Libraries
469 Requires:       xorg-driver-video-intel
470 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
471 Requires:       xorg-xserver-server >= %{xserver_ver}
472 Obsoletes:      Mesa-dri-driver-intel-i830
473 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
474
475 %description dri-driver-intel-i965
476 X.org DRI driver for Intel i965 card family.
477
478 %description dri-driver-intel-i965 -l pl.UTF-8
479 Sterownik X.org DRI dla rodziny kart Intel i965.
480
481 %package dri-driver-matrox
482 Summary:        X.org DRI driver for Matrox G card family
483 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
484 License:        MIT
485 Group:          X11/Libraries
486 Requires:       xorg-driver-video-mga
487 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
488 Requires:       xorg-xserver-server >= %{xserver_ver}
489 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
490
491 %description dri-driver-matrox
492 X.org DRI drivers for Matrox G card family.
493
494 %description dri-driver-matrox -l pl.UTF-8
495 Sterowniki X.org DRI dla rodziny kart Matrox G.
496
497 %package dri-driver-nouveau
498 Summary:        X.org DRI driver for NVIDIA card family
499 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
500 License:        MIT
501 Group:          X11/Libraries
502 Requires:       xorg-driver-video-nouveau
503 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
504 Requires:       xorg-xserver-server >= %{xserver_ver}
505
506 %description dri-driver-nouveau
507 X.org DRI drivers for NVIDIA card family.
508
509 %description dri-driver-nouveau -l pl.UTF-8
510 Sterowniki X.org DRI dla rodziny kart NVIDIA.
511
512 %package dri-driver-s3virge
513 Summary:        X.org DRI driver for S3 Virge card family
514 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
515 License:        MIT
516 Group:          X11/Libraries
517 Requires:       xorg-driver-video-s3virge
518 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
519 Requires:       xorg-xserver-server >= %{xserver_ver}
520
521 %description dri-driver-s3virge
522 X.org DRI driver for S3 Virge card family.
523
524 %description dri-driver-s3virge -l pl.UTF-8
525 Sterownik X.org DRI dla rodziny kart S3 Virge.
526
527 %package dri-driver-savage
528 Summary:        X.org DRI driver for S3 Savage card family
529 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
530 License:        MIT
531 Group:          X11/Libraries
532 Requires:       xorg-driver-video-savage
533 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
534 Requires:       xorg-xserver-server >= %{xserver_ver}
535
536 %description dri-driver-savage
537 X.org DRI driver for S3 Savage card family.
538
539 %description dri-driver-savage -l pl.UTF-8
540 Sterownik X.org DRI dla rodziny kart S3 Savage.
541
542 %package dri-driver-sis
543 Summary:        X.org DRI driver for SiS card family
544 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
545 License:        MIT
546 Group:          X11/Libraries
547 Requires:       xorg-driver-video-sis
548 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
549 Requires:       xorg-xserver-server >= %{xserver_ver}
550 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
551
552 %description dri-driver-sis
553 X.org DRI driver for SiS card family.
554
555 %description dri-driver-sis -l pl.UTF-8
556 Sterownik X.org DRI dla rodziny kart SiS.
557
558 %package dri-driver-swrast
559 Summary:        X.org DRI software rasterizer driver
560 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
561 License:        MIT
562 Group:          X11/Libraries
563 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
564 Requires:       xorg-xserver-server >= %{xserver_ver}
565
566 %description dri-driver-swrast
567 X.org DRI software rasterizer driver.
568
569 %description dri-driver-swrast -l pl.UTF-8
570 Sterownik X.org DRI obsługujący rysowanie programowe.
571
572 %package dri-driver-tdfx
573 Summary:        X.org DRI driver for 3DFX Voodoo card family
574 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
575 License:        MIT
576 Group:          X11/Libraries
577 Requires:       Glide3-DRI
578 Requires:       xorg-driver-video-tdfx
579 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
580 Requires:       xorg-xserver-server >= %{xserver_ver}
581 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
582
583 %description dri-driver-tdfx
584 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
585 and Velocity 100/200).
586
587 %description dri-driver-tdfx -l pl.UTF-8
588 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
589 Banshee i Velocity 100/200).
590
591 %package dri-driver-trident
592 Summary:        X.org DRI driver for Trident card family
593 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
594 License:        MIT
595 Group:          X11/Libraries
596 Requires:       xorg-driver-video-trident
597 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
598 Requires:       xorg-xserver-server >= %{xserver_ver}
599
600 %description dri-driver-trident
601 X.org DRI drivers for Trident card family.
602
603 %description dri-driver-trident -l pl.UTF-8
604 Sterowniki X.org DRI dla rodziny kart Trident.
605
606 %package dri-driver-via-unichrome
607 Summary:        X.org DRI driver for VIA Unichrome card family
608 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
609 License:        MIT
610 Group:          X11/Libraries
611 Requires:       xorg-driver-video-openchrome
612 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
613 Requires:       xorg-xserver-server >= %{xserver_ver}
614
615 %description dri-driver-via-unichrome
616 X.org DRI driver for VIA Unichrome card family.
617
618 %description dri-driver-via-unichrome -l pl.UTF-8
619 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
620
621 %prep
622 %setup -q -b1 -a2
623 %patch0 -p0
624 %patch1 -p1
625 %patch2 -p1
626
627 # fix demos
628 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
629
630 %build
631 %{__aclocal}
632 %{__autoconf}
633
634 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
635 %if %{without gallium_intel}
636 i915 \
637 %endif
638 %ifarch sparc sparcv9 sparc64
639 ffb \
640 %endif
641 %ifarch %{ix86} %{x8664}
642 sis \
643 %endif
644 swrast tdfx unichrome"
645
646 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
647
648 common_flags="\
649         --enable-shared \
650         --enable-selinux \
651         --enable-pic \
652         --enable-glx-tls \
653         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
654         --with%{!?with_demos:out}-demos"
655
656 %if %{with osmesa}
657 # osmesa variants
658 %configure $common_flags \
659         --with-driver=osmesa \
660         --disable-asm \
661         --with-osmesa-bits=8
662 %{__make} \
663         SRC_DIRS=mesa
664 mv %{_lib} osmesa8
665 %{__make} clean
666
667 %configure $common_flags \
668         --with-driver=osmesa \
669         --disable-asm \
670         --with-osmesa-bits=16
671 %{__make} \
672         SRC_DIRS=mesa
673 mv %{_lib} osmesa16
674 %{__make} clean
675
676 %configure $common_flags \
677         --with-driver=osmesa \
678         --disable-asm \
679         --with-osmesa-bits=32
680 %{__make} \
681         SRC_DIRS=mesa
682 mv %{_lib} osmesa32
683 %{__make} clean
684 %endif
685
686 %configure $common_flags \
687         --enable-glu \
688         --enable-glw \
689         --disable-glut \
690 %if %{with gallium}
691         --enable-gallium \
692         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
693         --enable-gallium-nouveau \
694         --with-state-trackers=dri \
695 %else
696         --disable-gallium \
697 %endif
698         --with-driver=dri \
699         --with-dri-drivers=${dri_drivers} \
700         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
701
702 %{__make}
703 %{__make} -C progs/xdemos glxgears glxinfo
704 %if %{with demos}
705 %{__make} -C progs/demos
706 %endif
707
708 cd gl-manpages-*
709 %configure
710 %{__make}
711
712 %install
713 rm -rf $RPM_BUILD_ROOT
714
715 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
716
717 # libs without drivers
718 %{__make} install \
719         DESTDIR=$RPM_BUILD_ROOT
720
721 cd gl-manpages-*
722 %{__make} install \
723         DESTDIR=$RPM_BUILD_ROOT
724 cd ..
725
726 %if %{with osmesa}
727 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
728 %endif
729
730 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
731 # work on copy to keep -bi --short-circuit working
732 rm -rf progs-clean
733 install -d progs-clean
734 for l in demos glsl osdemos redbook samples xdemos ; do
735         cp -a progs/$l progs-clean/$l
736         %{__make} -C progs-clean/$l clean
737         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
738 done
739 rm -rf progs-clean
740 for l in util images ; do
741         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
742 done
743 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
744
745 # strip out undesirable headers
746 olddir=$(pwd)
747 cd $RPM_BUILD_ROOT%{_includedir}/GL
748 rm [a-fh-np-wyz]*.h gg*.h glf*.h
749 cd $RPM_BUILD_ROOT%{_libdir}
750 cd $olddir
751
752 %if %{with multigl}
753 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
754
755 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
756 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
757
758 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
759 %endif
760
761 %clean
762 rm -rf $RPM_BUILD_ROOT
763
764 %post   libGL -p /sbin/ldconfig
765 %postun libGL -p /sbin/ldconfig
766
767 %post   libGLU -p /sbin/ldconfig
768 %postun libGLU -p /sbin/ldconfig
769
770 %post   libGLw -p /sbin/ldconfig
771 %postun libGLw -p /sbin/ldconfig
772
773 %files libGL
774 %defattr(644,root,root,755)
775 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
776 %if %{with multigl}
777 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
778 %dir %{_libdir}/Mesa
779 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
780 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
781 %else
782 %attr(755,root,root) %{_libdir}/libGL.so.*.*
783 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
784 # symlink for binary apps which fail to conform Linux OpenGL ABI
785 # (and dlopen libGL.so instead of libGL.so.1)
786 %attr(755,root,root) %{_libdir}/libGL.so
787 %endif
788
789 %files libGL-devel
790 %defattr(644,root,root,755)
791 %doc docs/*.spec
792 %if %{with multigl}
793 %attr(755,root,root) %{_libdir}/libGL.so
794 %endif
795 %dir %{_includedir}/GL
796 %{_includedir}/GL/gl.h
797 %{_includedir}/GL/glext.h
798 %{_includedir}/GL/gl_mangle.h
799 %{_includedir}/GL/glx.h
800 %{_includedir}/GL/glxext.h
801 %{_includedir}/GL/glx_mangle.h
802 %dir %{_includedir}/GL/internal
803 %{_includedir}/GL/internal/dri_interface.h
804 %{_pkgconfigdir}/dri.pc
805 %{_pkgconfigdir}/gl.pc
806 %{_mandir}/man3/gl[^uX]*.3gl*
807 %{_mandir}/man3/glX*.3gl*
808
809 %if %{with static}
810 %files libGL-static
811 %defattr(644,root,root,755)
812 %{_libdir}/libGL.a
813 %endif
814
815 %files libGLU
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
818 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
819
820 %files libGLU-devel
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_libdir}/libGLU.so
823 %{_includedir}/GL/glu.h
824 %{_includedir}/GL/glu_mangle.h
825 %{_pkgconfigdir}/glu.pc
826 %{_mandir}/man3/glu*.3gl*
827
828 %if %{with static}
829 %files libGLU-static
830 %defattr(644,root,root,755)
831 %{_libdir}/libGLU.a
832 %endif
833
834 %files libGLw
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
837 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
838
839 %files libGLw-devel
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_libdir}/libGLw.so
842 %{_includedir}/GL/GLwDrawA.h
843 %{_includedir}/GL/GLwDrawAP.h
844 %{_includedir}/GL/GLwMDrawA.h
845 %{_includedir}/GL/GLwMDrawAP.h
846 %{_pkgconfigdir}/glw.pc
847
848 %if %{with static}
849 %files libGLw-static
850 %defattr(644,root,root,755)
851 %{_libdir}/libGLw.a
852 %endif
853
854 %if %{with osmesa}
855 %files libOSMesa
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
858 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
859
860 %files libOSMesa-devel
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/libOSMesa*.so
863 %{_includedir}/GL/osmesa.h
864
865 %if %{with static}
866 %files libOSMesa-static
867 %defattr(644,root,root,755)
868 %{_libdir}/libOSMesa*.a
869 %endif
870 %endif
871
872 %files utils
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_bindir}/glxgears
875 %attr(755,root,root) %{_bindir}/glxinfo
876
877 %files dri-driver-ati-mach64
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
880
881 %files dri-driver-ati-radeon-R100
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
884
885 %files dri-driver-ati-radeon-R200
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
888
889 %files dri-driver-ati-radeon-R300
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
892
893 %files dri-driver-ati-rage128
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
896
897 # sunffb (sparc only)
898 %ifarch sparc sparcv9 sparc64
899 %files dri-driver-ffb
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
902 %endif
903
904 # glint (requires update)
905 %if 0
906 %files dri-driver-glint
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
909 %endif
910
911 %files dri-driver-intel-i810
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
914
915 %files dri-driver-intel-i915
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
918
919 %files dri-driver-intel-i965
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
922
923 %files dri-driver-matrox
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
926
927 %if %{with gallium}
928 %files dri-driver-nouveau
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
931 %endif
932
933 %files dri-driver-s3virge
934 %defattr(644,root,root,755)
935 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
936
937 %files dri-driver-savage
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
940
941 %ifarch %{ix86} %{x8664}
942 %files dri-driver-sis
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
945 %endif
946
947 %files dri-driver-swrast
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
950
951 %files dri-driver-tdfx
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
954
955 %files dri-driver-trident
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
958
959 %files dri-driver-via-unichrome
960 %defattr(644,root,root,755)
961 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
962
963 %if %{with demos}
964 %files demos
965 %defattr(644,root,root,755)
966 %{_examplesdir}/%{name}-%{version}
967 %endif
This page took 0.097315 seconds and 3 git commands to generate.