]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
56960bfeec350fc3973eccaab278728968ea5165
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  motif   # build static libGLw without Motif interface
8 %bcond_without  gallium
9 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
10 %bcond_with     static
11 #
12 # minimal supported xserver version
13 %define         xserver_ver     1.5.0
14 # glapi version (glapi tables in dri drivers and libglx must be in sync);
15 # set to current Mesa version on ABI break, when xserver tables get regenerated
16 # (until they start to be somehow versioned themselves)
17 %define         glapi_ver       7.1.0
18 #
19 Summary:        Free OpenGL implementation
20 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
21 Name:           Mesa
22 Version:        7.5
23 Release:        4%{?with_multigl:.mgl}
24 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
25 Group:          X11/Libraries
26 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
27 # Source0-md5:  459f332551f6ebb86f384d21dd15e1f0
28 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
29 # Source1-md5:  398ee8801814a00e47f6c2314e3dfddc
30 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
31 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
32 Patch0:         %{name}-realclean.patch
33 URL:            http://www.mesa3d.org/
34 BuildRequires:  expat-devel
35 BuildRequires:  glew-devel
36 BuildRequires:  libdrm-devel >= 2.4.5
37 BuildRequires:  libselinux-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.4d
40 %{?with_motif:BuildRequires:    motif-devel}
41 BuildRequires:  rpmbuild(macros) >= 1.470
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  xorg-lib-libXdamage-devel
44 BuildRequires:  xorg-lib-libXt-devel
45 BuildRequires:  xorg-lib-libXxf86vm-devel
46 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
47 BuildRequires:  xorg-proto-glproto-devel
48 BuildRequires:  xorg-proto-printproto-devel
49 BuildRequires:  xorg-util-makedepend
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Mesa is a 3-D graphics library with an API which is very similar to
54 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
55 syntax or state machine, it is being used with authorization from
56 Silicon Graphics, Inc. However, the author does not possess an OpenGL
57 license from SGI, and makes no claim that Mesa is in any way a
58 compatible replacement for OpenGL or associated with SGI.
59
60 %description -l pl.UTF-8
61 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
62 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
63 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
64 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
65 OpenGL ani powiązana z SGI.
66
67 %package libGL
68 Summary:        Free Mesa3D implementation of libGL OpenGL library
69 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
70 License:        MIT
71 Group:          X11/Libraries
72 Requires:       libdrm >= 2.4.5
73 Provides:       OpenGL = 2.1
74 # reports version 1.3, but supports glXGetProcAddress() from 1.4
75 Provides:       OpenGL-GLX = 1.4
76 Obsoletes:      Mesa
77 Obsoletes:      Mesa-dri
78 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
79 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
80
81 %description libGL
82 Mesa is a 3-D graphics library with an API which is very similar to
83 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
84 syntax or state machine, it is being used with authorization from
85 Silicon Graphics, Inc. However, the author does not possess an OpenGL
86 license from SGI, and makes no claim that Mesa is in any way a
87 compatible replacement for OpenGL or associated with SGI.
88
89 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
90 specifications. It uses DRI for rendering.
91
92 %description libGL -l pl.UTF-8
93 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
94 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
95 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
96 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
97 OpenGL ani powiązana z SGI.
98
99 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
100 GLX 1.4. Używa DRI do renderowania.
101
102 %package libGL-devel
103 Summary:        Header files for Mesa3D libGL library
104 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
105 License:        MIT
106 Group:          X11/Development/Libraries
107 # loose dependency on libGL to use with other libGL binaries
108 Requires:       OpenGL >= 1.5
109 Requires:       xorg-lib-libX11-devel
110 Provides:       OpenGL-GLX-devel = 1.4
111 Provides:       OpenGL-devel = 2.1
112 Obsoletes:      Mesa-devel
113 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
114 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
115 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
116 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
117
118 %description libGL-devel
119 Header files for Mesa3D libGL library.
120
121 %description libGL-devel -l pl.UTF-8
122 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
123
124 %package libGL-static
125 Summary:        Static Mesa3D libGL library
126 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
127 License:        MIT
128 Group:          X11/Development/Libraries
129 Requires:       %{name}-libGL-devel = %{version}-%{release}
130 Provides:       OpenGL-static = 2.1
131 Obsoletes:      Mesa-static
132 Obsoletes:      X11-OpenGL-static < 1:7.0.0
133 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
134
135 %description libGL-static
136 Static Mesa3D libGL library. It uses software renderer.
137
138 %description libGL-static -l pl.UTF-8
139 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
140 renderingu.
141
142 %package libGLU
143 Summary:        SGI implementation of libGLU OpenGL library
144 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
145 License:        SGI Free Software License B v2.0 (MIT-like)
146 Group:          Libraries
147 # loose dependency on libGL.so.1 to use with other libGL binaries
148 Requires:       OpenGL >= 1.2
149 Provides:       OpenGL-GLU = 1.3
150 Obsoletes:      Mesa-devel
151 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
152 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
153
154 %description libGLU
155 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
156 1.3 specifications.
157
158 %description libGLU -l pl.UTF-8
159 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
160 specyfikację OpenGL GLU 1.3.
161
162 %package libGLU-devel
163 Summary:        Header files for SGI libGLU library
164 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
165 License:        SGI Free Software License B v2.0 (MIT-like)
166 Group:          Development/Libraries
167 Requires:       %{name}-libGLU = %{version}-%{release}
168 Requires:       OpenGL-devel >= 1.2
169 Requires:       libstdc++-devel
170 Provides:       OpenGL-GLU-devel = 1.3
171
172 %description libGLU-devel
173 Header files for SGI libGLU library.
174
175 %description libGLU-devel -l pl.UTF-8
176 Pliki nagłówkowe biblioteki SGI libGLU.
177
178 %package libGLU-static
179 Summary:        Static SGI libGLU library
180 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
181 License:        SGI Free Software License B v2.0 (MIT-like)
182 Group:          Development/Libraries
183 Requires:       %{name}-libGLU-devel = %{version}-%{release}
184 Provides:       OpenGL-GLU-static = 1.3
185
186 %description libGLU-static
187 Static SGI libGLU library.
188
189 %description libGLU-static -l pl.UTF-8
190 Statyczna biblioteka SGI libGLU.
191
192 %package libGLw
193 Summary:        SGI OpenGL Xt widgets library
194 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
195 License:        SGI MIT-like
196 Group:          Libraries
197 # loose dependency on libGL.so.1 to use with other libGL binaries
198 Requires:       OpenGL >= 1.1
199 Provides:       OpenGL-GLw
200
201 %description libGLw
202 SGI OpenGL Xt widgets library.
203
204 %description libGLU -l pl.UTF-8
205 Biblioteka SGI widgetów Xt dla OpenGL-a.
206
207 %package libGLw-devel
208 Summary:        Header files for SGI libGLw library
209 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
210 License:        SGI MIT-like
211 Group:          Development/Libraries
212 Requires:       %{name}-libGLw = %{version}-%{release}
213 Requires:       OpenGL-devel >= 1.2
214 Provides:       OpenGL-GLw-devel
215
216 %description libGLw-devel
217 Header files for SGI libGLw library.
218
219 %description libGLw-devel -l pl.UTF-8
220 Pliki nagłówkowe biblioteki SGI libGLw.
221
222 %package libGLw-static
223 Summary:        Static SGI libGLw library
224 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
225 License:        SGI MIT-like
226 Group:          Development/Libraries
227 Requires:       %{name}-libGLw-devel = %{version}-%{release}
228 Provides:       OpenGL-GLw-static
229
230 %description libGLw-static
231 Static SGI libGLw library.
232
233 %description libGLw-static -l pl.UTF-8
234 Statyczna biblioteka SGI libGLw.
235
236 %package libOSMesa
237 Summary:        OSMesa (off-screen renderer) library
238 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
239 License:        MIT
240 Group:          Libraries
241 # doesn't require base
242
243 %description libOSMesa
244 OSMesa (off-screen renderer) library.
245
246 %description libOSMesa -l pl.UTF-8
247 Biblioteka OSMesa (renderująca bitmapy w pamięci).
248
249 %package libOSMesa-devel
250 Summary:        Header file for OSMesa (off-screen renderer) library
251 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
252 License:        MIT
253 Group:          Development/Libraries
254 Requires:       %{name}-libOSMesa = %{version}-%{release}
255 # for <GL/gl.h> only
256 Requires:       OpenGL-devel
257
258 %description libOSMesa-devel
259 Header file for OSMesa (off-screen renderer) library.
260
261 %description libOSMesa-devel -l pl.UTF-8
262 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
263
264 %package libOSMesa-static
265 Summary:        Static OSMesa (off-screen renderer) library
266 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
267 License:        MIT
268 Group:          Development/Libraries
269 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
270 # this static build of OSMesa needs static non-dri Mesa implementation
271 Requires:       %{name}-libGL-static = %{version}-%{release}
272
273 %description libOSMesa-static
274 Static OSMesa (off-screen renderer) library.
275
276 %description libOSMesa-static -l pl.UTF-8
277 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
278
279 %package utils
280 Summary:        OpenGL utilities from Mesa3D
281 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
282 License:        MIT
283 Group:          X11/Applications/Graphics
284 # loose deps on libGL/libGLU
285
286 %description utils
287 OpenGL utilities from Mesa3D: glxgears and glxinfo.
288
289 %description utils -l pl.UTF-8
290 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
291
292 %package demos
293 Summary:        Mesa Demos source code
294 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
295 License:        various (MIT, SGI, GPL - see copyright notes in sources)
296 Group:          Development/Libraries
297 Requires:       OpenGL-devel
298
299 %description demos
300 Demonstration programs for the Mesa libraries in source code form.
301
302 %description demos -l pl.UTF-8
303 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
304
305 %package dri-driver-ati-mach64
306 Summary:        X.org DRI driver for ATI Mach64 card family
307 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
308 License:        MIT
309 Group:          X11/Libraries
310 Requires:       xorg-driver-video-mach64
311 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
312 Requires:       xorg-xserver-server >= %{xserver_ver}
313
314 %description dri-driver-ati-mach64
315 X.org DRI driver for ATI Mach64 card family.
316
317 %description dri-driver-ati-mach64 -l pl.UTF-8
318 Sterownik X.org DRI dla rodziny kart ATI Mach64.
319
320 %package dri-driver-ati-radeon-R100
321 Summary:        X.org DRI driver for ATI R100 card family
322 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
323 License:        MIT
324 Group:          X11/Libraries
325 Requires:       xorg-driver-video-ati
326 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
327 Requires:       xorg-xserver-server >= %{xserver_ver}
328 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
329
330 %description dri-driver-ati-radeon-R100
331 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
332
333 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
334 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
335
336 %package dri-driver-ati-radeon-R200
337 Summary:        X.org DRI driver for ATI R200 card family
338 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
339 License:        MIT
340 Group:          X11/Libraries
341 Requires:       xorg-driver-video-ati
342 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
343 Requires:       xorg-xserver-server >= %{xserver_ver}
344 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
345
346 %description dri-driver-ati-radeon-R200
347 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
348
349 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
350 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
351
352 %package dri-driver-ati-radeon-R300
353 Summary:        X.org DRI driver for ATI R300 card family
354 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
355 License:        MIT
356 Group:          X11/Libraries
357 Requires:       xorg-driver-video-ati
358 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
359 Requires:       xorg-xserver-server >= %{xserver_ver}
360 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
361
362 %description dri-driver-ati-radeon-R300
363 X.org DRI driver for ATI R300 card family.
364
365 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
366 Sterownik X.org DRI dla rodziny kart ATI R300.
367
368 %package dri-driver-ati-rage128
369 Summary:        X.org DRI driver for ATI Rage128 card family
370 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
371 License:        MIT
372 Group:          X11/Libraries
373 Requires:       xorg-driver-video-r128
374 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
375 Requires:       xorg-xserver-server >= %{xserver_ver}
376 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
377
378 %description dri-driver-ati-rage128
379 X.org DRI driver for ATI Rage128 card family.
380
381 %description dri-driver-ati-rage128 -l pl.UTF-8
382 Sterownik X.org DRI dla rodziny kart ATI Rage128.
383
384 %package dri-driver-ffb
385 Summary:        X.org DRI driver for Sun FFB card family
386 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
387 License:        MIT
388 Group:          X11/Libraries
389 Requires:       xorg-driver-video-sunffb
390 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
391 Requires:       xorg-xserver-server >= %{xserver_ver}
392
393 %description dri-driver-ffb
394 X.org DRI driver for SUN Creator3D and Elite3D card family.
395
396 %description dri-driver-ffb -l pl.UTF-8
397 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
398
399 %package dri-driver-glint
400 Summary:        X.org DRI driver for GLINT/Permedia card family
401 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
402 License:        MIT
403 Group:          X11/Libraries
404 Requires:       xorg-driver-video-glint
405 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
406 Requires:       xorg-xserver-server >= %{xserver_ver}
407 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
408
409 %description dri-driver-glint
410 X.org DRI driver for GLINT/Permedia card family.
411
412 %description dri-driver-glint -l pl.UTF-8
413 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
414
415 %package dri-driver-intel-i810
416 Summary:        X.org DRI driver for Intel i810 card family
417 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
418 License:        MIT
419 Group:          X11/Libraries
420 Requires:       xorg-driver-video-intel
421 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
422 Requires:       xorg-xserver-server >= %{xserver_ver}
423 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
424
425 %description dri-driver-intel-i810
426 X.org DRI driver for Intel i810 card family.
427
428 %description dri-driver-intel-i810 -l pl.UTF-8
429 Sterownik X.org DRI dla rodziny kart Intel i810.
430
431 %package dri-driver-intel-i915
432 Summary:        X.org DRI driver for Intel i915 card family
433 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
434 License:        MIT
435 Group:          X11/Libraries
436 Requires:       xorg-driver-video-intel
437 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
438 Requires:       xorg-xserver-server >= %{xserver_ver}
439 Obsoletes:      Mesa-dri-driver-intel-i830
440 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
441
442 %description dri-driver-intel-i915
443 X.org DRI driver for Intel i915 card family.
444
445 %description dri-driver-intel-i915 -l pl.UTF-8
446 Sterownik X.org DRI dla rodziny kart Intel i915.
447
448 %package dri-driver-intel-i965
449 Summary:        X.org DRI driver for Intel i965 card family
450 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
451 License:        MIT
452 Group:          X11/Libraries
453 Requires:       xorg-driver-video-intel
454 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
455 Requires:       xorg-xserver-server >= %{xserver_ver}
456 Obsoletes:      Mesa-dri-driver-intel-i830
457 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
458
459 %description dri-driver-intel-i965
460 X.org DRI driver for Intel i965 card family.
461
462 %description dri-driver-intel-i965 -l pl.UTF-8
463 Sterownik X.org DRI dla rodziny kart Intel i965.
464
465 %package dri-driver-matrox
466 Summary:        X.org DRI driver for Matrox G card family
467 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
468 License:        MIT
469 Group:          X11/Libraries
470 Requires:       xorg-driver-video-mga
471 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
472 Requires:       xorg-xserver-server >= %{xserver_ver}
473 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
474
475 %description dri-driver-matrox
476 X.org DRI drivers for Matrox G card family.
477
478 %description dri-driver-matrox -l pl.UTF-8
479 Sterowniki X.org DRI dla rodziny kart Matrox G.
480
481 %package dri-driver-nouveau
482 Summary:        X.org DRI driver for NVIDIA card family
483 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
484 License:        MIT
485 Group:          X11/Libraries
486 Requires:       xorg-driver-video-nouveau
487 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
488 Requires:       xorg-xserver-server >= %{xserver_ver}
489
490 %description dri-driver-nouveau
491 X.org DRI drivers for NVIDIA card family.
492
493 %description dri-driver-nouveau -l pl.UTF-8
494 Sterowniki X.org DRI dla rodziny kart NVIDIA.
495
496 %package dri-driver-s3virge
497 Summary:        X.org DRI driver for S3 Virge card family
498 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
499 License:        MIT
500 Group:          X11/Libraries
501 Requires:       xorg-driver-video-s3virge
502 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
503 Requires:       xorg-xserver-server >= %{xserver_ver}
504
505 %description dri-driver-s3virge
506 X.org DRI driver for S3 Virge card family.
507
508 %description dri-driver-s3virge -l pl.UTF-8
509 Sterownik X.org DRI dla rodziny kart S3 Virge.
510
511 %package dri-driver-savage
512 Summary:        X.org DRI driver for S3 Savage card family
513 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
514 License:        MIT
515 Group:          X11/Libraries
516 Requires:       xorg-driver-video-savage
517 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
518 Requires:       xorg-xserver-server >= %{xserver_ver}
519
520 %description dri-driver-savage
521 X.org DRI driver for S3 Savage card family.
522
523 %description dri-driver-savage -l pl.UTF-8
524 Sterownik X.org DRI dla rodziny kart S3 Savage.
525
526 %package dri-driver-sis
527 Summary:        X.org DRI driver for SiS card family
528 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
529 License:        MIT
530 Group:          X11/Libraries
531 Requires:       xorg-driver-video-sis
532 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
533 Requires:       xorg-xserver-server >= %{xserver_ver}
534 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
535
536 %description dri-driver-sis
537 X.org DRI driver for SiS card family.
538
539 %description dri-driver-sis -l pl.UTF-8
540 Sterownik X.org DRI dla rodziny kart SiS.
541
542 %package dri-driver-swrast
543 Summary:        X.org DRI software rasterizer driver
544 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
545 License:        MIT
546 Group:          X11/Libraries
547 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
548 Requires:       xorg-xserver-server >= %{xserver_ver}
549
550 %description dri-driver-swrast
551 X.org DRI software rasterizer driver.
552
553 %description dri-driver-swrast -l pl.UTF-8
554 Sterownik X.org DRI obsługujący rysowanie programowe.
555
556 %package dri-driver-tdfx
557 Summary:        X.org DRI driver for 3DFX Voodoo card family
558 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
559 License:        MIT
560 Group:          X11/Libraries
561 Requires:       Glide3-DRI
562 Requires:       xorg-driver-video-tdfx
563 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
564 Requires:       xorg-xserver-server >= %{xserver_ver}
565 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
566
567 %description dri-driver-tdfx
568 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
569 and Velocity 100/200).
570
571 %description dri-driver-tdfx -l pl.UTF-8
572 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
573 Banshee i Velocity 100/200).
574
575 %package dri-driver-trident
576 Summary:        X.org DRI driver for Trident card family
577 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
578 License:        MIT
579 Group:          X11/Libraries
580 Requires:       xorg-driver-video-trident
581 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
582 Requires:       xorg-xserver-server >= %{xserver_ver}
583
584 %description dri-driver-trident
585 X.org DRI drivers for Trident card family.
586
587 %description dri-driver-trident -l pl.UTF-8
588 Sterowniki X.org DRI dla rodziny kart Trident.
589
590 %package dri-driver-via-unichrome
591 Summary:        X.org DRI driver for VIA Unichrome card family
592 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
593 License:        MIT
594 Group:          X11/Libraries
595 Requires:       xorg-driver-video-openchrome
596 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
597 Requires:       xorg-xserver-server >= %{xserver_ver}
598
599 %description dri-driver-via-unichrome
600 X.org DRI driver for VIA Unichrome card family.
601
602 %description dri-driver-via-unichrome -l pl.UTF-8
603 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
604
605 %prep
606 %setup -q -b1 -a2
607 %patch0 -p0
608
609 # fix demos
610 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
611
612 %build
613 [ ! -f configure ] && ./autogen.sh
614
615 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
616 %if %{without gallium}
617 i915 \
618 %endif
619 %ifarch sparc sparcv9 sparc64
620 ffb \
621 %endif
622 %ifarch %{ix86} %{x8664}
623 sis \
624 %endif
625 swrast tdfx unichrome"
626
627 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
628
629 common_flags="\
630         --enable-shared \
631         --enable-selinux \
632         --enable-pic \
633         --disable-egl"
634
635 # osmesa variants
636 %configure $common_flags \
637         --with-driver=osmesa \
638         --disable-asm \
639         --with-osmesa-bits=8
640 %{__make} \
641         SRC_DIRS=mesa
642 mv %{_lib} osmesa8
643 %{__make} clean
644
645 %configure $common_flags \
646         --with-driver=osmesa \
647         --disable-asm \
648         --with-osmesa-bits=16
649 %{__make} \
650         SRC_DIRS=mesa
651 mv %{_lib} osmesa16
652 %{__make} clean
653
654 %configure $common_flags \
655         --with-driver=osmesa \
656         --disable-asm \
657         --with-osmesa-bits=32
658 %{__make} \
659         SRC_DIRS=mesa
660 mv %{_lib} osmesa32
661 %{__make} clean
662
663 %configure $common_flags \
664         --enable-glu \
665         --enable-glw \
666         --disable-glut \
667 %if %{with gallium}
668         --enable-gallium \
669         --enable-gallium-intel \
670         --enable-gallium-nouveau \
671         --with-state-trackers=dri \
672 %else
673         --disable-gallium \
674 %endif
675         --with-driver=dri \
676         --with-dri-drivers=${dri_drivers} \
677         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
678
679 %{__make}
680 %{__make} -C progs/xdemos glxgears glxinfo
681 %{__make} -C progs/demos
682
683 cd gl-manpages-*
684 %configure
685 %{__make}
686
687 %install
688 rm -rf $RPM_BUILD_ROOT
689
690 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
691
692 # libs without drivers
693 %{__make} install \
694         DESTDIR=$RPM_BUILD_ROOT
695
696 cd gl-manpages-*
697 %{__make} install \
698         DESTDIR=$RPM_BUILD_ROOT
699 cd ..
700
701 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
702
703 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
704 # work on copy to keep -bi --short-circuit working
705 rm -rf progs-clean
706 install -d progs-clean
707 for l in demos glsl osdemos redbook samples xdemos ; do
708         cp -a progs/$l progs-clean/$l
709         %{__make} -C progs-clean/$l clean
710         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
711 done
712 rm -rf progs-clean
713 for l in util images ; do
714         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
715 done
716 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
717
718 # strip out undesirable headers
719 olddir=$(pwd)
720 cd $RPM_BUILD_ROOT%{_includedir}/GL
721 rm [a-fh-np-wyz]*.h gg*.h glf*.h
722 cd $RPM_BUILD_ROOT%{_libdir}
723 cd $olddir
724
725 %if %{with multigl}
726 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
727
728 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
729 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
730
731 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
732 %endif
733
734 %clean
735 rm -rf $RPM_BUILD_ROOT
736
737 %post   libGL -p /sbin/ldconfig
738 %postun libGL -p /sbin/ldconfig
739
740 %post   libGLU -p /sbin/ldconfig
741 %postun libGLU -p /sbin/ldconfig
742
743 %post   libGLw -p /sbin/ldconfig
744 %postun libGLw -p /sbin/ldconfig
745
746 %files libGL
747 %defattr(644,root,root,755)
748 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
749 %if %{with multigl}
750 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
751 %dir %{_libdir}/Mesa
752 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
753 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
754 %else
755 %attr(755,root,root) %{_libdir}/libGL.so.*.*
756 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
757 # symlink for binary apps which fail to conform Linux OpenGL ABI
758 # (and dlopen libGL.so instead of libGL.so.1)
759 %attr(755,root,root) %{_libdir}/libGL.so
760 %endif
761
762 %files libGL-devel
763 %defattr(644,root,root,755)
764 %doc docs/*.spec
765 %if %{with multigl}
766 %attr(755,root,root) %{_libdir}/libGL.so
767 %endif
768 %dir %{_includedir}/GL
769 %{_includedir}/GL/gl.h
770 %{_includedir}/GL/glext.h
771 %{_includedir}/GL/gl_mangle.h
772 %{_includedir}/GL/glx.h
773 %{_includedir}/GL/glxext.h
774 %{_includedir}/GL/glx_mangle.h
775 %dir %{_includedir}/GL/internal
776 %{_includedir}/GL/internal/dri_interface.h
777 %{_pkgconfigdir}/dri.pc
778 %{_pkgconfigdir}/gl.pc
779 %{_mandir}/man3/gl[^uX]*.3gl*
780 %{_mandir}/man3/glX*.3gl*
781
782 %if %{with static}
783 %files libGL-static
784 %defattr(644,root,root,755)
785 %{_libdir}/libGL.a
786 %endif
787
788 %files libGLU
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
791 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
792
793 %files libGLU-devel
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_libdir}/libGLU.so
796 %{_includedir}/GL/glu.h
797 %{_includedir}/GL/glu_mangle.h
798 %{_pkgconfigdir}/glu.pc
799 %{_mandir}/man3/glu*.3gl*
800
801 %if %{with static}
802 %files libGLU-static
803 %defattr(644,root,root,755)
804 %{_libdir}/libGLU.a
805 %endif
806
807 %files libGLw
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
810 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
811
812 %files libGLw-devel
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libGLw.so
815 %{_includedir}/GL/GLwDrawA.h
816 %{_includedir}/GL/GLwDrawAP.h
817 %{_includedir}/GL/GLwMDrawA.h
818 %{_includedir}/GL/GLwMDrawAP.h
819 %{_pkgconfigdir}/glw.pc
820
821 %if %{with static}
822 %files libGLw-static
823 %defattr(644,root,root,755)
824 %{_libdir}/libGLw.a
825 %endif
826
827 %files libOSMesa
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
830 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
831
832 %files libOSMesa-devel
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libOSMesa*.so
835 %{_includedir}/GL/osmesa.h
836
837 %if %{with static}
838 %files libOSMesa-static
839 %defattr(644,root,root,755)
840 %{_libdir}/libOSMesa*.a
841 %endif
842
843 %files utils
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_bindir}/glxgears
846 %attr(755,root,root) %{_bindir}/glxinfo
847
848 %files dri-driver-ati-mach64
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
851
852 %files dri-driver-ati-radeon-R100
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
855
856 %files dri-driver-ati-radeon-R200
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
859
860 %files dri-driver-ati-radeon-R300
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
863
864 %files dri-driver-ati-rage128
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
867
868 # sunffb (sparc only)
869 %ifarch sparc sparcv9 sparc64
870 %files dri-driver-ffb
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
873 %endif
874
875 # glint (requires update)
876 %if 0
877 %files dri-driver-glint
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
880 %endif
881
882 %files dri-driver-intel-i810
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
885
886 %files dri-driver-intel-i915
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
889
890 %files dri-driver-intel-i965
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
893
894 %files dri-driver-matrox
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
897
898 %if %{with gallium}
899 %files dri-driver-nouveau
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
902 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri2.so
903 %endif
904
905 %files dri-driver-s3virge
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
908
909 %files dri-driver-savage
910 %defattr(644,root,root,755)
911 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
912
913 %ifarch %{ix86} %{x8664}
914 %files dri-driver-sis
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
917 %endif
918
919 %files dri-driver-swrast
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
922
923 %files dri-driver-tdfx
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
926
927 %files dri-driver-trident
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
930
931 %files dri-driver-via-unichrome
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
934
935 %files demos
936 %defattr(644,root,root,755)
937 %{_examplesdir}/%{name}-%{version}
This page took 0.095335 seconds and 2 git commands to generate.