]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
3948cb17ba4e6b77ead055bc7e82bafc42fde616
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  motif   # build static libGLw without Motif interface
8 %bcond_without  gallium
9 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
11 %bcond_with     static
12 #
13 # minimal supported xserver version
14 %define         xserver_ver     1.5.0
15 # glapi version (glapi tables in dri drivers and libglx must be in sync);
16 # set to current Mesa version on ABI break, when xserver tables get regenerated
17 # (until they start to be somehow versioned themselves)
18 %define         glapi_ver       7.1.0
19 #
20 Summary:        Free OpenGL implementation
21 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
22 Name:           Mesa
23 Version:        7.5
24 Release:        5%{?with_multigl:.mgl}
25 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
26 Group:          X11/Libraries
27 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
28 # Source0-md5:  459f332551f6ebb86f384d21dd15e1f0
29 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
30 # Source1-md5:  398ee8801814a00e47f6c2314e3dfddc
31 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
32 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
33 Patch0:         %{name}-realclean.patch
34 URL:            http://www.mesa3d.org/
35 BuildRequires:  expat-devel
36 BuildRequires:  glew-devel
37 BuildRequires:  libdrm-devel >= 2.4.5
38 BuildRequires:  libselinux-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.4d
41 %{?with_motif:BuildRequires:    motif-devel}
42 BuildRequires:  rpmbuild(macros) >= 1.470
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  xorg-lib-libXdamage-devel
45 BuildRequires:  xorg-lib-libXt-devel
46 BuildRequires:  xorg-lib-libXxf86vm-devel
47 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
48 BuildRequires:  xorg-proto-glproto-devel
49 BuildRequires:  xorg-proto-printproto-devel
50 BuildRequires:  xorg-util-makedepend
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %if %{without gallium}
54 %undefine       with_gallium_intel
55 %endif
56
57 %description
58 Mesa is a 3-D graphics library with an API which is very similar to
59 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
60 syntax or state machine, it is being used with authorization from
61 Silicon Graphics, Inc. However, the author does not possess an OpenGL
62 license from SGI, and makes no claim that Mesa is in any way a
63 compatible replacement for OpenGL or associated with SGI.
64
65 %description -l pl.UTF-8
66 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
67 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
68 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
69 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
70 OpenGL ani powiązana z SGI.
71
72 %package libGL
73 Summary:        Free Mesa3D implementation of libGL OpenGL library
74 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
75 License:        MIT
76 Group:          X11/Libraries
77 Requires:       libdrm >= 2.4.5
78 Provides:       OpenGL = 2.1
79 # reports version 1.3, but supports glXGetProcAddress() from 1.4
80 Provides:       OpenGL-GLX = 1.4
81 Obsoletes:      Mesa
82 Obsoletes:      Mesa-dri
83 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
84 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
85
86 %description libGL
87 Mesa is a 3-D graphics library with an API which is very similar to
88 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
89 syntax or state machine, it is being used with authorization from
90 Silicon Graphics, Inc. However, the author does not possess an OpenGL
91 license from SGI, and makes no claim that Mesa is in any way a
92 compatible replacement for OpenGL or associated with SGI.
93
94 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
95 specifications. It uses DRI for rendering.
96
97 %description libGL -l pl.UTF-8
98 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
99 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
100 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
101 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
102 OpenGL ani powiązana z SGI.
103
104 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
105 GLX 1.4. Używa DRI do renderowania.
106
107 %package libGL-devel
108 Summary:        Header files for Mesa3D libGL library
109 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
110 License:        MIT
111 Group:          X11/Development/Libraries
112 # loose dependency on libGL to use with other libGL binaries
113 Requires:       OpenGL >= 1.5
114 Requires:       xorg-lib-libX11-devel
115 Provides:       OpenGL-GLX-devel = 1.4
116 Provides:       OpenGL-devel = 2.1
117 Obsoletes:      Mesa-devel
118 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
119 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
120 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
121 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
122
123 %description libGL-devel
124 Header files for Mesa3D libGL library.
125
126 %description libGL-devel -l pl.UTF-8
127 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
128
129 %package libGL-static
130 Summary:        Static Mesa3D libGL library
131 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
132 License:        MIT
133 Group:          X11/Development/Libraries
134 Requires:       %{name}-libGL-devel = %{version}-%{release}
135 Provides:       OpenGL-static = 2.1
136 Obsoletes:      Mesa-static
137 Obsoletes:      X11-OpenGL-static < 1:7.0.0
138 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
139
140 %description libGL-static
141 Static Mesa3D libGL library. It uses software renderer.
142
143 %description libGL-static -l pl.UTF-8
144 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
145 renderingu.
146
147 %package libGLU
148 Summary:        SGI implementation of libGLU OpenGL library
149 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
150 License:        SGI Free Software License B v2.0 (MIT-like)
151 Group:          Libraries
152 # loose dependency on libGL.so.1 to use with other libGL binaries
153 Requires:       OpenGL >= 1.2
154 Provides:       OpenGL-GLU = 1.3
155 Obsoletes:      Mesa-devel
156 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
157 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
158
159 %description libGLU
160 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
161 1.3 specifications.
162
163 %description libGLU -l pl.UTF-8
164 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
165 specyfikację OpenGL GLU 1.3.
166
167 %package libGLU-devel
168 Summary:        Header files for SGI libGLU library
169 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
170 License:        SGI Free Software License B v2.0 (MIT-like)
171 Group:          Development/Libraries
172 Requires:       %{name}-libGLU = %{version}-%{release}
173 Requires:       OpenGL-devel >= 1.2
174 Requires:       libstdc++-devel
175 Provides:       OpenGL-GLU-devel = 1.3
176
177 %description libGLU-devel
178 Header files for SGI libGLU library.
179
180 %description libGLU-devel -l pl.UTF-8
181 Pliki nagłówkowe biblioteki SGI libGLU.
182
183 %package libGLU-static
184 Summary:        Static SGI libGLU library
185 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
186 License:        SGI Free Software License B v2.0 (MIT-like)
187 Group:          Development/Libraries
188 Requires:       %{name}-libGLU-devel = %{version}-%{release}
189 Provides:       OpenGL-GLU-static = 1.3
190
191 %description libGLU-static
192 Static SGI libGLU library.
193
194 %description libGLU-static -l pl.UTF-8
195 Statyczna biblioteka SGI libGLU.
196
197 %package libGLw
198 Summary:        SGI OpenGL Xt widgets library
199 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
200 License:        SGI MIT-like
201 Group:          Libraries
202 # loose dependency on libGL.so.1 to use with other libGL binaries
203 Requires:       OpenGL >= 1.1
204 Provides:       OpenGL-GLw
205
206 %description libGLw
207 SGI OpenGL Xt widgets library.
208
209 %description libGLU -l pl.UTF-8
210 Biblioteka SGI widgetów Xt dla OpenGL-a.
211
212 %package libGLw-devel
213 Summary:        Header files for SGI libGLw library
214 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
215 License:        SGI MIT-like
216 Group:          Development/Libraries
217 Requires:       %{name}-libGLw = %{version}-%{release}
218 Requires:       OpenGL-devel >= 1.2
219 Provides:       OpenGL-GLw-devel
220
221 %description libGLw-devel
222 Header files for SGI libGLw library.
223
224 %description libGLw-devel -l pl.UTF-8
225 Pliki nagłówkowe biblioteki SGI libGLw.
226
227 %package libGLw-static
228 Summary:        Static SGI libGLw library
229 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
230 License:        SGI MIT-like
231 Group:          Development/Libraries
232 Requires:       %{name}-libGLw-devel = %{version}-%{release}
233 Provides:       OpenGL-GLw-static
234
235 %description libGLw-static
236 Static SGI libGLw library.
237
238 %description libGLw-static -l pl.UTF-8
239 Statyczna biblioteka SGI libGLw.
240
241 %package libOSMesa
242 Summary:        OSMesa (off-screen renderer) library
243 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
244 License:        MIT
245 Group:          Libraries
246 # doesn't require base
247
248 %description libOSMesa
249 OSMesa (off-screen renderer) library.
250
251 %description libOSMesa -l pl.UTF-8
252 Biblioteka OSMesa (renderująca bitmapy w pamięci).
253
254 %package libOSMesa-devel
255 Summary:        Header file for OSMesa (off-screen renderer) library
256 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
257 License:        MIT
258 Group:          Development/Libraries
259 Requires:       %{name}-libOSMesa = %{version}-%{release}
260 # for <GL/gl.h> only
261 Requires:       OpenGL-devel
262
263 %description libOSMesa-devel
264 Header file for OSMesa (off-screen renderer) library.
265
266 %description libOSMesa-devel -l pl.UTF-8
267 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
268
269 %package libOSMesa-static
270 Summary:        Static OSMesa (off-screen renderer) library
271 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
272 License:        MIT
273 Group:          Development/Libraries
274 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
275 # this static build of OSMesa needs static non-dri Mesa implementation
276 Requires:       %{name}-libGL-static = %{version}-%{release}
277
278 %description libOSMesa-static
279 Static OSMesa (off-screen renderer) library.
280
281 %description libOSMesa-static -l pl.UTF-8
282 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
283
284 %package utils
285 Summary:        OpenGL utilities from Mesa3D
286 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
287 License:        MIT
288 Group:          X11/Applications/Graphics
289 # loose deps on libGL/libGLU
290
291 %description utils
292 OpenGL utilities from Mesa3D: glxgears and glxinfo.
293
294 %description utils -l pl.UTF-8
295 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
296
297 %package demos
298 Summary:        Mesa Demos source code
299 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
300 License:        various (MIT, SGI, GPL - see copyright notes in sources)
301 Group:          Development/Libraries
302 Requires:       OpenGL-devel
303
304 %description demos
305 Demonstration programs for the Mesa libraries in source code form.
306
307 %description demos -l pl.UTF-8
308 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
309
310 %package dri-driver-ati-mach64
311 Summary:        X.org DRI driver for ATI Mach64 card family
312 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
313 License:        MIT
314 Group:          X11/Libraries
315 Requires:       xorg-driver-video-mach64
316 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
317 Requires:       xorg-xserver-server >= %{xserver_ver}
318
319 %description dri-driver-ati-mach64
320 X.org DRI driver for ATI Mach64 card family.
321
322 %description dri-driver-ati-mach64 -l pl.UTF-8
323 Sterownik X.org DRI dla rodziny kart ATI Mach64.
324
325 %package dri-driver-ati-radeon-R100
326 Summary:        X.org DRI driver for ATI R100 card family
327 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
328 License:        MIT
329 Group:          X11/Libraries
330 Requires:       xorg-driver-video-ati
331 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
332 Requires:       xorg-xserver-server >= %{xserver_ver}
333 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
334
335 %description dri-driver-ati-radeon-R100
336 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
337
338 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
339 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
340
341 %package dri-driver-ati-radeon-R200
342 Summary:        X.org DRI driver for ATI R200 card family
343 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
344 License:        MIT
345 Group:          X11/Libraries
346 Requires:       xorg-driver-video-ati
347 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
348 Requires:       xorg-xserver-server >= %{xserver_ver}
349 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
350
351 %description dri-driver-ati-radeon-R200
352 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
353
354 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
355 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
356
357 %package dri-driver-ati-radeon-R300
358 Summary:        X.org DRI driver for ATI R300 card family
359 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
360 License:        MIT
361 Group:          X11/Libraries
362 Requires:       xorg-driver-video-ati
363 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
364 Requires:       xorg-xserver-server >= %{xserver_ver}
365 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
366
367 %description dri-driver-ati-radeon-R300
368 X.org DRI driver for ATI R300 card family.
369
370 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
371 Sterownik X.org DRI dla rodziny kart ATI R300.
372
373 %package dri-driver-ati-rage128
374 Summary:        X.org DRI driver for ATI Rage128 card family
375 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
376 License:        MIT
377 Group:          X11/Libraries
378 Requires:       xorg-driver-video-r128
379 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
380 Requires:       xorg-xserver-server >= %{xserver_ver}
381 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
382
383 %description dri-driver-ati-rage128
384 X.org DRI driver for ATI Rage128 card family.
385
386 %description dri-driver-ati-rage128 -l pl.UTF-8
387 Sterownik X.org DRI dla rodziny kart ATI Rage128.
388
389 %package dri-driver-ffb
390 Summary:        X.org DRI driver for Sun FFB card family
391 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
392 License:        MIT
393 Group:          X11/Libraries
394 Requires:       xorg-driver-video-sunffb
395 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
396 Requires:       xorg-xserver-server >= %{xserver_ver}
397
398 %description dri-driver-ffb
399 X.org DRI driver for SUN Creator3D and Elite3D card family.
400
401 %description dri-driver-ffb -l pl.UTF-8
402 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
403
404 %package dri-driver-glint
405 Summary:        X.org DRI driver for GLINT/Permedia card family
406 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
407 License:        MIT
408 Group:          X11/Libraries
409 Requires:       xorg-driver-video-glint
410 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
411 Requires:       xorg-xserver-server >= %{xserver_ver}
412 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
413
414 %description dri-driver-glint
415 X.org DRI driver for GLINT/Permedia card family.
416
417 %description dri-driver-glint -l pl.UTF-8
418 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
419
420 %package dri-driver-intel-i810
421 Summary:        X.org DRI driver for Intel i810 card family
422 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
423 License:        MIT
424 Group:          X11/Libraries
425 Requires:       xorg-driver-video-intel
426 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
427 Requires:       xorg-xserver-server >= %{xserver_ver}
428 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
429
430 %description dri-driver-intel-i810
431 X.org DRI driver for Intel i810 card family.
432
433 %description dri-driver-intel-i810 -l pl.UTF-8
434 Sterownik X.org DRI dla rodziny kart Intel i810.
435
436 %package dri-driver-intel-i915
437 Summary:        X.org DRI driver for Intel i915 card family
438 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
439 License:        MIT
440 Group:          X11/Libraries
441 Requires:       xorg-driver-video-intel
442 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
443 Requires:       xorg-xserver-server >= %{xserver_ver}
444 Obsoletes:      Mesa-dri-driver-intel-i830
445 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
446
447 %description dri-driver-intel-i915
448 X.org DRI driver for Intel i915 card family.
449
450 %description dri-driver-intel-i915 -l pl.UTF-8
451 Sterownik X.org DRI dla rodziny kart Intel i915.
452
453 %package dri-driver-intel-i965
454 Summary:        X.org DRI driver for Intel i965 card family
455 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
456 License:        MIT
457 Group:          X11/Libraries
458 Requires:       xorg-driver-video-intel
459 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
460 Requires:       xorg-xserver-server >= %{xserver_ver}
461 Obsoletes:      Mesa-dri-driver-intel-i830
462 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
463
464 %description dri-driver-intel-i965
465 X.org DRI driver for Intel i965 card family.
466
467 %description dri-driver-intel-i965 -l pl.UTF-8
468 Sterownik X.org DRI dla rodziny kart Intel i965.
469
470 %package dri-driver-matrox
471 Summary:        X.org DRI driver for Matrox G card family
472 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
473 License:        MIT
474 Group:          X11/Libraries
475 Requires:       xorg-driver-video-mga
476 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
477 Requires:       xorg-xserver-server >= %{xserver_ver}
478 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
479
480 %description dri-driver-matrox
481 X.org DRI drivers for Matrox G card family.
482
483 %description dri-driver-matrox -l pl.UTF-8
484 Sterowniki X.org DRI dla rodziny kart Matrox G.
485
486 %package dri-driver-nouveau
487 Summary:        X.org DRI driver for NVIDIA card family
488 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
489 License:        MIT
490 Group:          X11/Libraries
491 Requires:       xorg-driver-video-nouveau
492 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
493 Requires:       xorg-xserver-server >= %{xserver_ver}
494
495 %description dri-driver-nouveau
496 X.org DRI drivers for NVIDIA card family.
497
498 %description dri-driver-nouveau -l pl.UTF-8
499 Sterowniki X.org DRI dla rodziny kart NVIDIA.
500
501 %package dri-driver-s3virge
502 Summary:        X.org DRI driver for S3 Virge card family
503 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
504 License:        MIT
505 Group:          X11/Libraries
506 Requires:       xorg-driver-video-s3virge
507 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
508 Requires:       xorg-xserver-server >= %{xserver_ver}
509
510 %description dri-driver-s3virge
511 X.org DRI driver for S3 Virge card family.
512
513 %description dri-driver-s3virge -l pl.UTF-8
514 Sterownik X.org DRI dla rodziny kart S3 Virge.
515
516 %package dri-driver-savage
517 Summary:        X.org DRI driver for S3 Savage card family
518 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
519 License:        MIT
520 Group:          X11/Libraries
521 Requires:       xorg-driver-video-savage
522 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
523 Requires:       xorg-xserver-server >= %{xserver_ver}
524
525 %description dri-driver-savage
526 X.org DRI driver for S3 Savage card family.
527
528 %description dri-driver-savage -l pl.UTF-8
529 Sterownik X.org DRI dla rodziny kart S3 Savage.
530
531 %package dri-driver-sis
532 Summary:        X.org DRI driver for SiS card family
533 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
534 License:        MIT
535 Group:          X11/Libraries
536 Requires:       xorg-driver-video-sis
537 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
538 Requires:       xorg-xserver-server >= %{xserver_ver}
539 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
540
541 %description dri-driver-sis
542 X.org DRI driver for SiS card family.
543
544 %description dri-driver-sis -l pl.UTF-8
545 Sterownik X.org DRI dla rodziny kart SiS.
546
547 %package dri-driver-swrast
548 Summary:        X.org DRI software rasterizer driver
549 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
550 License:        MIT
551 Group:          X11/Libraries
552 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
553 Requires:       xorg-xserver-server >= %{xserver_ver}
554
555 %description dri-driver-swrast
556 X.org DRI software rasterizer driver.
557
558 %description dri-driver-swrast -l pl.UTF-8
559 Sterownik X.org DRI obsługujący rysowanie programowe.
560
561 %package dri-driver-tdfx
562 Summary:        X.org DRI driver for 3DFX Voodoo card family
563 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
564 License:        MIT
565 Group:          X11/Libraries
566 Requires:       Glide3-DRI
567 Requires:       xorg-driver-video-tdfx
568 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
569 Requires:       xorg-xserver-server >= %{xserver_ver}
570 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
571
572 %description dri-driver-tdfx
573 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
574 and Velocity 100/200).
575
576 %description dri-driver-tdfx -l pl.UTF-8
577 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
578 Banshee i Velocity 100/200).
579
580 %package dri-driver-trident
581 Summary:        X.org DRI driver for Trident card family
582 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
583 License:        MIT
584 Group:          X11/Libraries
585 Requires:       xorg-driver-video-trident
586 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
587 Requires:       xorg-xserver-server >= %{xserver_ver}
588
589 %description dri-driver-trident
590 X.org DRI drivers for Trident card family.
591
592 %description dri-driver-trident -l pl.UTF-8
593 Sterowniki X.org DRI dla rodziny kart Trident.
594
595 %package dri-driver-via-unichrome
596 Summary:        X.org DRI driver for VIA Unichrome card family
597 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
598 License:        MIT
599 Group:          X11/Libraries
600 Requires:       xorg-driver-video-openchrome
601 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
602 Requires:       xorg-xserver-server >= %{xserver_ver}
603
604 %description dri-driver-via-unichrome
605 X.org DRI driver for VIA Unichrome card family.
606
607 %description dri-driver-via-unichrome -l pl.UTF-8
608 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
609
610 %prep
611 %setup -q -b1 -a2
612 %patch0 -p0
613
614 # fix demos
615 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
616
617 %build
618 [ ! -f configure ] && ./autogen.sh
619
620 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
621 %if %{without gallium_intel}
622 i915 \
623 %endif
624 %ifarch sparc sparcv9 sparc64
625 ffb \
626 %endif
627 %ifarch %{ix86} %{x8664}
628 sis \
629 %endif
630 swrast tdfx unichrome"
631
632 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
633
634 common_flags="\
635         --enable-shared \
636         --enable-selinux \
637         --enable-pic \
638         --disable-egl"
639
640 # osmesa variants
641 %configure $common_flags \
642         --with-driver=osmesa \
643         --disable-asm \
644         --with-osmesa-bits=8
645 %{__make} \
646         SRC_DIRS=mesa
647 mv %{_lib} osmesa8
648 %{__make} clean
649
650 %configure $common_flags \
651         --with-driver=osmesa \
652         --disable-asm \
653         --with-osmesa-bits=16
654 %{__make} \
655         SRC_DIRS=mesa
656 mv %{_lib} osmesa16
657 %{__make} clean
658
659 %configure $common_flags \
660         --with-driver=osmesa \
661         --disable-asm \
662         --with-osmesa-bits=32
663 %{__make} \
664         SRC_DIRS=mesa
665 mv %{_lib} osmesa32
666 %{__make} clean
667
668 %configure $common_flags \
669         --enable-glu \
670         --enable-glw \
671         --disable-glut \
672 %if %{with gallium}
673         --enable-gallium \
674         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
675         --enable-gallium-nouveau \
676         --with-state-trackers=dri \
677 %else
678         --disable-gallium \
679 %endif
680         --with-driver=dri \
681         --with-dri-drivers=${dri_drivers} \
682         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
683
684 %{__make}
685 %{__make} -C progs/xdemos glxgears glxinfo
686 %{__make} -C progs/demos
687
688 cd gl-manpages-*
689 %configure
690 %{__make}
691
692 %install
693 rm -rf $RPM_BUILD_ROOT
694
695 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
696
697 # libs without drivers
698 %{__make} install \
699         DESTDIR=$RPM_BUILD_ROOT
700
701 cd gl-manpages-*
702 %{__make} install \
703         DESTDIR=$RPM_BUILD_ROOT
704 cd ..
705
706 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
707
708 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
709 # work on copy to keep -bi --short-circuit working
710 rm -rf progs-clean
711 install -d progs-clean
712 for l in demos glsl osdemos redbook samples xdemos ; do
713         cp -a progs/$l progs-clean/$l
714         %{__make} -C progs-clean/$l clean
715         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
716 done
717 rm -rf progs-clean
718 for l in util images ; do
719         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
720 done
721 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
722
723 # strip out undesirable headers
724 olddir=$(pwd)
725 cd $RPM_BUILD_ROOT%{_includedir}/GL
726 rm [a-fh-np-wyz]*.h gg*.h glf*.h
727 cd $RPM_BUILD_ROOT%{_libdir}
728 cd $olddir
729
730 %if %{with multigl}
731 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
732
733 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
734 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
735
736 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
737 %endif
738
739 %clean
740 rm -rf $RPM_BUILD_ROOT
741
742 %post   libGL -p /sbin/ldconfig
743 %postun libGL -p /sbin/ldconfig
744
745 %post   libGLU -p /sbin/ldconfig
746 %postun libGLU -p /sbin/ldconfig
747
748 %post   libGLw -p /sbin/ldconfig
749 %postun libGLw -p /sbin/ldconfig
750
751 %files libGL
752 %defattr(644,root,root,755)
753 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
754 %if %{with multigl}
755 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
756 %dir %{_libdir}/Mesa
757 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
758 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
759 %else
760 %attr(755,root,root) %{_libdir}/libGL.so.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
762 # symlink for binary apps which fail to conform Linux OpenGL ABI
763 # (and dlopen libGL.so instead of libGL.so.1)
764 %attr(755,root,root) %{_libdir}/libGL.so
765 %endif
766
767 %files libGL-devel
768 %defattr(644,root,root,755)
769 %doc docs/*.spec
770 %if %{with multigl}
771 %attr(755,root,root) %{_libdir}/libGL.so
772 %endif
773 %dir %{_includedir}/GL
774 %{_includedir}/GL/gl.h
775 %{_includedir}/GL/glext.h
776 %{_includedir}/GL/gl_mangle.h
777 %{_includedir}/GL/glx.h
778 %{_includedir}/GL/glxext.h
779 %{_includedir}/GL/glx_mangle.h
780 %dir %{_includedir}/GL/internal
781 %{_includedir}/GL/internal/dri_interface.h
782 %{_pkgconfigdir}/dri.pc
783 %{_pkgconfigdir}/gl.pc
784 %{_mandir}/man3/gl[^uX]*.3gl*
785 %{_mandir}/man3/glX*.3gl*
786
787 %if %{with static}
788 %files libGL-static
789 %defattr(644,root,root,755)
790 %{_libdir}/libGL.a
791 %endif
792
793 %files libGLU
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
796 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
797
798 %files libGLU-devel
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libGLU.so
801 %{_includedir}/GL/glu.h
802 %{_includedir}/GL/glu_mangle.h
803 %{_pkgconfigdir}/glu.pc
804 %{_mandir}/man3/glu*.3gl*
805
806 %if %{with static}
807 %files libGLU-static
808 %defattr(644,root,root,755)
809 %{_libdir}/libGLU.a
810 %endif
811
812 %files libGLw
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
815 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
816
817 %files libGLw-devel
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libGLw.so
820 %{_includedir}/GL/GLwDrawA.h
821 %{_includedir}/GL/GLwDrawAP.h
822 %{_includedir}/GL/GLwMDrawA.h
823 %{_includedir}/GL/GLwMDrawAP.h
824 %{_pkgconfigdir}/glw.pc
825
826 %if %{with static}
827 %files libGLw-static
828 %defattr(644,root,root,755)
829 %{_libdir}/libGLw.a
830 %endif
831
832 %files libOSMesa
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
835 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
836
837 %files libOSMesa-devel
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_libdir}/libOSMesa*.so
840 %{_includedir}/GL/osmesa.h
841
842 %if %{with static}
843 %files libOSMesa-static
844 %defattr(644,root,root,755)
845 %{_libdir}/libOSMesa*.a
846 %endif
847
848 %files utils
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_bindir}/glxgears
851 %attr(755,root,root) %{_bindir}/glxinfo
852
853 %files dri-driver-ati-mach64
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
856
857 %files dri-driver-ati-radeon-R100
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
860
861 %files dri-driver-ati-radeon-R200
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
864
865 %files dri-driver-ati-radeon-R300
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
868
869 %files dri-driver-ati-rage128
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
872
873 # sunffb (sparc only)
874 %ifarch sparc sparcv9 sparc64
875 %files dri-driver-ffb
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
878 %endif
879
880 # glint (requires update)
881 %if 0
882 %files dri-driver-glint
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
885 %endif
886
887 %files dri-driver-intel-i810
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
890
891 %files dri-driver-intel-i915
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
894
895 %files dri-driver-intel-i965
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
898
899 %files dri-driver-matrox
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
902
903 %if %{with gallium}
904 %files dri-driver-nouveau
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
907 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri2.so
908 %endif
909
910 %files dri-driver-s3virge
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
913
914 %files dri-driver-savage
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
917
918 %ifarch %{ix86} %{x8664}
919 %files dri-driver-sis
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
922 %endif
923
924 %files dri-driver-swrast
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
927
928 %files dri-driver-tdfx
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
931
932 %files dri-driver-trident
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
935
936 %files dri-driver-via-unichrome
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
939
940 %files demos
941 %defattr(644,root,root,755)
942 %{_examplesdir}/%{name}-%{version}
This page took 0.101728 seconds and 3 git commands to generate.