]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
06c25b1aa747ba2b264545ff4d6f67dc7dc83c1f
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static  # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.23
25 %define         dri2proto_ver   2.1
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.10.1
32 Release:        1%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  efe8da4d80c2a5d32a800770b8ce5dfa
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-selinux.patch
39 Patch2:         %{name}-git.patch
40 Patch3:         %{name}-nouveau-updates.patch
41 Patch4:         %{name}-nouveau-revert.patch
42 Patch5:         %{name}-nouveau-classic-libdrm.patch
43 URL:            http://www.mesa3d.org/
44 BuildRequires:  autoconf >= 2.59
45 BuildRequires:  automake
46 BuildRequires:  expat-devel
47 BuildRequires:  libdrm-devel >= %{libdrm_ver}
48 BuildRequires:  libselinux-devel
49 BuildRequires:  libstdc++-devel >= 5:3.3.0
50 BuildRequires:  libtalloc-devel >= 2:2.0.1
51 BuildRequires:  libtool >= 2:1.4d
52 %{?with_motif:BuildRequires:    motif-devel}
53 BuildRequires:  pixman-devel
54 BuildRequires:  pkgconfig
55 BuildRequires:  python
56 BuildRequires:  python-modules
57 BuildRequires:  rpmbuild(macros) >= 1.470
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  xorg-lib-libXdamage-devel
60 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
61 BuildRequires:  xorg-lib-libXt-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
64 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
65 BuildRequires:  xorg-util-makedepend
66 BuildRequires:  xorg-xserver-server-devel
67 %if %{with egl}
68 BuildRequires:  libxcb-devel
69 BuildRequires:  udev-devel >= 150
70 %endif
71 %if %{with gallium}
72 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
73 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
74 %endif
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{without gallium}
78 %undefine       with_gallium_intel
79 %undefine       with_gallium_radeon
80 %endif
81
82 %description
83 Mesa is a 3-D graphics library with an API which is very similar to
84 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
85 syntax or state machine, it is being used with authorization from
86 Silicon Graphics, Inc. However, the author does not possess an OpenGL
87 license from SGI, and makes no claim that Mesa is in any way a
88 compatible replacement for OpenGL or associated with SGI.
89
90 %description -l pl.UTF-8
91 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
92 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
93 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
94 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
95 OpenGL ani powiązana z SGI.
96
97 %package libEGL
98 Summary:        SGI implementation of libEGL OpenGL library
99 Summary(pl.UTF-8):      Implementacja SGI biblioteki libEGL ze standardu OpenGL
100 License:        SGI Free Software License B v2.0 (MIT-like)
101 Group:          Libraries
102 Requires:       OpenGL >= 1.2
103 Requires:       udev-libs >= 150
104 Provides:       OpenGL-EGL = 1.0
105
106 %description libEGL
107 SGI implementation of libEGL OpenGL library.
108
109 %description libEGL -l pl.UTF-8
110 Implementacja SGI biblioteki libEGL ze standardu OpenGL.
111
112 %package libEGL-devel
113 Summary:        Header files for SGI libEGL library
114 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libEGL
115 License:        SGI Free Software License B v2.0 (MIT-like)
116 Group:          Development/Libraries
117 Requires:       %{name}-libEGL = %{version}-%{release}
118 Requires:       OpenGL-devel >= 1.2
119 Requires:       libstdc++-devel
120 Provides:       OpenGL-EGL-devel = 1.0
121
122 %description libEGL-devel
123 Header files for SGI libEGL library.
124
125 %description libEGL-devel -l pl.UTF-8
126 Pliki nagłówkowe biblioteki SGI libEGL.
127
128 %package libEGL-static
129 Summary:        Static SGI libEGL library
130 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
131 License:        SGI Free Software License B v2.0 (MIT-like)
132 Group:          Development/Libraries
133 Requires:       %{name}-libEGL-devel = %{version}-%{release}
134 Provides:       OpenGL-EGL-static = 1.0
135
136 %description libEGL-static
137 Static SGI libEGL library.
138
139 %description libEGL-static -l pl.UTF-8
140 Statyczna biblioteka SGI libEGL.
141
142 %package libGL
143 Summary:        Free Mesa3D implementation of libGL OpenGL library
144 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
145 License:        MIT
146 Group:          X11/Libraries
147 Requires:       libdrm >= %{libdrm_ver}
148 Provides:       OpenGL = 2.1
149 # reports version 1.3, but supports glXGetProcAddress() from 1.4
150 Provides:       OpenGL-GLX = 1.4
151 Obsoletes:      Mesa
152 Obsoletes:      Mesa-dri
153 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
154 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
155
156 %description libGL
157 Mesa is a 3-D graphics library with an API which is very similar to
158 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
159 syntax or state machine, it is being used with authorization from
160 Silicon Graphics, Inc. However, the author does not possess an OpenGL
161 license from SGI, and makes no claim that Mesa is in any way a
162 compatible replacement for OpenGL or associated with SGI.
163
164 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
165 specifications. It uses DRI for rendering.
166
167 %description libGL -l pl.UTF-8
168 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
169 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
170 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
171 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
172 OpenGL ani powiązana z SGI.
173
174 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
175 GLX 1.4. Używa DRI do renderowania.
176
177 %package libGL-devel
178 Summary:        Header files for Mesa3D libGL library
179 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
180 License:        MIT
181 Group:          X11/Development/Libraries
182 # loose dependency on libGL to use with other libGL binaries
183 Requires:       OpenGL >= 1.5
184 Requires:       libdrm-devel >= %{libdrm_ver}
185 Requires:       xorg-lib-libX11-devel
186 Requires:       xorg-lib-libXdamage-devel
187 Requires:       xorg-lib-libXext-devel
188 Requires:       xorg-lib-libXxf86vm-devel
189 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
190 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
191 Suggests:       OpenGL-doc-man
192 Provides:       OpenGL-GLX-devel = 1.4
193 Provides:       OpenGL-devel = 2.1
194 Obsoletes:      Mesa-devel
195 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
196 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
197 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
198 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
199
200 %description libGL-devel
201 Header files for Mesa3D libGL library.
202
203 %description libGL-devel -l pl.UTF-8
204 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
205
206 %package libGL-static
207 Summary:        Static Mesa3D libGL library
208 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
209 License:        MIT
210 Group:          X11/Development/Libraries
211 Requires:       %{name}-libGL-devel = %{version}-%{release}
212 Provides:       OpenGL-static = 2.1
213 Obsoletes:      Mesa-static
214 Obsoletes:      X11-OpenGL-static < 1:7.0.0
215 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
216
217 %description libGL-static
218 Static Mesa3D libGL library. It uses software renderer.
219
220 %description libGL-static -l pl.UTF-8
221 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
222 renderingu.
223
224 %package libGLU
225 Summary:        SGI implementation of libGLU OpenGL library
226 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
227 License:        SGI Free Software License B v2.0 (MIT-like)
228 Group:          Libraries
229 # loose dependency on libGL.so.1 to use with other libGL binaries
230 Requires:       OpenGL >= 1.2
231 Provides:       OpenGL-GLU = 1.3
232 Obsoletes:      Mesa-devel
233 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
234 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
235
236 %description libGLU
237 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
238 1.3 specifications.
239
240 %description libGLU -l pl.UTF-8
241 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
242 specyfikację OpenGL GLU 1.3.
243
244 %package libGLU-devel
245 Summary:        Header files for SGI libGLU library
246 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
247 License:        SGI Free Software License B v2.0 (MIT-like)
248 Group:          Development/Libraries
249 Requires:       %{name}-libGLU = %{version}-%{release}
250 Requires:       OpenGL-devel >= 1.2
251 Requires:       libstdc++-devel
252 Provides:       OpenGL-GLU-devel = 1.3
253
254 %description libGLU-devel
255 Header files for SGI libGLU library.
256
257 %description libGLU-devel -l pl.UTF-8
258 Pliki nagłówkowe biblioteki SGI libGLU.
259
260 %package libGLU-static
261 Summary:        Static SGI libGLU library
262 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
263 License:        SGI Free Software License B v2.0 (MIT-like)
264 Group:          Development/Libraries
265 Requires:       %{name}-libGLU-devel = %{version}-%{release}
266 Provides:       OpenGL-GLU-static = 1.3
267
268 %description libGLU-static
269 Static SGI libGLU library.
270
271 %description libGLU-static -l pl.UTF-8
272 Statyczna biblioteka SGI libGLU.
273
274 %package libGLw
275 Summary:        SGI OpenGL Xt widgets library
276 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
277 License:        SGI MIT-like
278 Group:          Libraries
279 # loose dependency on libGL.so.1 to use with other libGL binaries
280 Requires:       OpenGL >= 1.1
281 Provides:       OpenGL-GLw
282
283 %description libGLw
284 SGI OpenGL Xt widgets library.
285
286 %description libGLw -l pl.UTF-8
287 Biblioteka SGI widgetów Xt dla OpenGL-a.
288
289 %package libGLw-devel
290 Summary:        Header files for SGI libGLw library
291 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
292 License:        SGI MIT-like
293 Group:          Development/Libraries
294 Requires:       %{name}-libGLw = %{version}-%{release}
295 Requires:       OpenGL-devel >= 1.2
296 Provides:       OpenGL-GLw-devel
297
298 %description libGLw-devel
299 Header files for SGI libGLw library.
300
301 %description libGLw-devel -l pl.UTF-8
302 Pliki nagłówkowe biblioteki SGI libGLw.
303
304 %package libGLw-static
305 Summary:        Static SGI libGLw library
306 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
307 License:        SGI MIT-like
308 Group:          Development/Libraries
309 Requires:       %{name}-libGLw-devel = %{version}-%{release}
310 Provides:       OpenGL-GLw-static
311
312 %description libGLw-static
313 Static SGI libGLw library.
314
315 %description libGLw-static -l pl.UTF-8
316 Statyczna biblioteka SGI libGLw.
317
318 %package libOSMesa
319 Summary:        OSMesa (off-screen renderer) library
320 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
321 License:        MIT
322 Group:          Libraries
323 # doesn't require base
324
325 %description libOSMesa
326 OSMesa (off-screen renderer) library.
327
328 %description libOSMesa -l pl.UTF-8
329 Biblioteka OSMesa (renderująca bitmapy w pamięci).
330
331 %package libOSMesa-devel
332 Summary:        Header file for OSMesa (off-screen renderer) library
333 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
334 License:        MIT
335 Group:          Development/Libraries
336 Requires:       %{name}-libOSMesa = %{version}-%{release}
337 # for <GL/gl.h> only
338 Requires:       OpenGL-devel
339
340 %description libOSMesa-devel
341 Header file for OSMesa (off-screen renderer) library.
342
343 %description libOSMesa-devel -l pl.UTF-8
344 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
345
346 %package libOSMesa-static
347 Summary:        Static OSMesa (off-screen renderer) library
348 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
349 License:        MIT
350 Group:          Development/Libraries
351 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
352 # this static build of OSMesa needs static non-dri Mesa implementation
353 Requires:       %{name}-libGL-static = %{version}-%{release}
354
355 %description libOSMesa-static
356 Static OSMesa (off-screen renderer) library.
357
358 %description libOSMesa-static -l pl.UTF-8
359 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
360
361 %package utils
362 Summary:        OpenGL utilities from Mesa3D
363 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
364 License:        MIT
365 Group:          X11/Applications/Graphics
366 # loose deps on libGL/libGLU
367
368 %description utils
369 OpenGL utilities from Mesa3D: glxgears and glxinfo.
370
371 %description utils -l pl.UTF-8
372 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
373
374 %package dri-driver-ati-mach64
375 Summary:        X.org DRI driver for ATI Mach64 card family
376 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
377 License:        MIT
378 Group:          X11/Libraries
379 Requires:       xorg-driver-video-mach64
380 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
381 Requires:       xorg-xserver-server >= %{xserver_ver}
382
383 %description dri-driver-ati-mach64
384 X.org DRI driver for ATI Mach64 card family.
385
386 %description dri-driver-ati-mach64 -l pl.UTF-8
387 Sterownik X.org DRI dla rodziny kart ATI Mach64.
388
389 %package dri-driver-ati-radeon-R100
390 Summary:        X.org DRI driver for ATI R100 card family
391 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
392 License:        MIT
393 Group:          X11/Libraries
394 Requires:       xorg-driver-video-ati
395 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
396 Requires:       xorg-xserver-server >= %{xserver_ver}
397 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
398
399 %description dri-driver-ati-radeon-R100
400 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
401
402 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
403 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
404
405 %package dri-driver-ati-radeon-R200
406 Summary:        X.org DRI driver for ATI R200 card family
407 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
408 License:        MIT
409 Group:          X11/Libraries
410 Requires:       xorg-driver-video-ati
411 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
412 Requires:       xorg-xserver-server >= %{xserver_ver}
413 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
414
415 %description dri-driver-ati-radeon-R200
416 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
417
418 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
419 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
420
421 %package dri-driver-ati-radeon-R300
422 Summary:        X.org DRI driver for ATI R300 card family
423 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
424 License:        MIT
425 Group:          X11/Libraries
426 Requires:       xorg-driver-video-ati
427 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
428 Requires:       xorg-xserver-server >= %{xserver_ver}
429 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
430
431 %description dri-driver-ati-radeon-R300
432 X.org DRI driver for ATI R300 card family.
433
434 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
435 Sterownik X.org DRI dla rodziny kart ATI R300.
436
437 %package dri-driver-ati-radeon-R600
438 Summary:        X.org DRI driver for ATI R600 card family
439 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
440 License:        MIT
441 Group:          X11/Libraries
442 Requires:       radeon-ucode
443 Requires:       xorg-driver-video-ati
444 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
445 Requires:       xorg-xserver-server >= %{xserver_ver}
446
447 %description dri-driver-ati-radeon-R600
448 X.org DRI driver for ATI R600 card family.
449
450 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
451 Sterownik X.org DRI dla rodziny kart ATI R600.
452
453 %package dri-driver-ati-rage128
454 Summary:        X.org DRI driver for ATI Rage128 card family
455 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
456 License:        MIT
457 Group:          X11/Libraries
458 Requires:       xorg-driver-video-r128
459 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
460 Requires:       xorg-xserver-server >= %{xserver_ver}
461 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
462
463 %description dri-driver-ati-rage128
464 X.org DRI driver for ATI Rage128 card family.
465
466 %description dri-driver-ati-rage128 -l pl.UTF-8
467 Sterownik X.org DRI dla rodziny kart ATI Rage128.
468
469 %package dri-driver-ffb
470 Summary:        X.org DRI driver for Sun FFB card family
471 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
472 License:        MIT
473 Group:          X11/Libraries
474 Requires:       xorg-driver-video-sunffb
475 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
476 Requires:       xorg-xserver-server >= %{xserver_ver}
477
478 %description dri-driver-ffb
479 X.org DRI driver for SUN Creator3D and Elite3D card family.
480
481 %description dri-driver-ffb -l pl.UTF-8
482 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
483
484 %package dri-driver-glint
485 Summary:        X.org DRI driver for GLINT/Permedia card family
486 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
487 License:        MIT
488 Group:          X11/Libraries
489 Requires:       xorg-driver-video-glint
490 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
491 Requires:       xorg-xserver-server >= %{xserver_ver}
492 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
493
494 %description dri-driver-glint
495 X.org DRI driver for GLINT/Permedia card family.
496
497 %description dri-driver-glint -l pl.UTF-8
498 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
499
500 %package dri-driver-intel-i810
501 Summary:        X.org DRI driver for Intel i810 card family
502 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
503 License:        MIT
504 Group:          X11/Libraries
505 Requires:       xorg-driver-video-intel
506 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
507 Requires:       xorg-xserver-server >= %{xserver_ver}
508 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
509
510 %description dri-driver-intel-i810
511 X.org DRI driver for Intel i810 card family.
512
513 %description dri-driver-intel-i810 -l pl.UTF-8
514 Sterownik X.org DRI dla rodziny kart Intel i810.
515
516 %package dri-driver-intel-i915
517 Summary:        X.org DRI driver for Intel i915 card family
518 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
519 License:        MIT
520 Group:          X11/Libraries
521 Requires:       xorg-driver-video-intel
522 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
523 Requires:       xorg-xserver-server >= %{xserver_ver}
524 Obsoletes:      Mesa-dri-driver-intel-i830
525 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
526
527 %description dri-driver-intel-i915
528 X.org DRI driver for Intel i915 card family.
529
530 %description dri-driver-intel-i915 -l pl.UTF-8
531 Sterownik X.org DRI dla rodziny kart Intel i915.
532
533 %package dri-driver-intel-i965
534 Summary:        X.org DRI driver for Intel i965 card family
535 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
536 License:        MIT
537 Group:          X11/Libraries
538 Requires:       xorg-driver-video-intel
539 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
540 Requires:       xorg-xserver-server >= %{xserver_ver}
541 Obsoletes:      Mesa-dri-driver-intel-i830
542 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
543
544 %description dri-driver-intel-i965
545 X.org DRI driver for Intel i965 card family.
546
547 %description dri-driver-intel-i965 -l pl.UTF-8
548 Sterownik X.org DRI dla rodziny kart Intel i965.
549
550 %package dri-driver-matrox
551 Summary:        X.org DRI driver for Matrox G card family
552 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
553 License:        MIT
554 Group:          X11/Libraries
555 Requires:       xorg-driver-video-mga
556 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
557 Requires:       xorg-xserver-server >= %{xserver_ver}
558 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
559
560 %description dri-driver-matrox
561 X.org DRI drivers for Matrox G card family.
562
563 %description dri-driver-matrox -l pl.UTF-8
564 Sterowniki X.org DRI dla rodziny kart Matrox G.
565
566 %package dri-driver-nouveau
567 Summary:        X.org DRI driver for NVIDIA card family
568 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
569 License:        MIT
570 Group:          X11/Libraries
571 Requires:       xorg-driver-video-nouveau
572 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
573 Requires:       xorg-xserver-server >= %{xserver_ver}
574
575 %description dri-driver-nouveau
576 X.org DRI drivers for NVIDIA card family.
577
578 %description dri-driver-nouveau -l pl.UTF-8
579 Sterowniki X.org DRI dla rodziny kart NVIDIA.
580
581 %package dri-driver-savage
582 Summary:        X.org DRI driver for S3 Savage card family
583 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
584 License:        MIT
585 Group:          X11/Libraries
586 Requires:       xorg-driver-video-savage
587 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
588 Requires:       xorg-xserver-server >= %{xserver_ver}
589
590 %description dri-driver-savage
591 X.org DRI driver for S3 Savage card family.
592
593 %description dri-driver-savage -l pl.UTF-8
594 Sterownik X.org DRI dla rodziny kart S3 Savage.
595
596 %package dri-driver-sis
597 Summary:        X.org DRI driver for SiS card family
598 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
599 License:        MIT
600 Group:          X11/Libraries
601 Requires:       xorg-driver-video-sis
602 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
603 Requires:       xorg-xserver-server >= %{xserver_ver}
604 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
605
606 %description dri-driver-sis
607 X.org DRI driver for SiS card family.
608
609 %description dri-driver-sis -l pl.UTF-8
610 Sterownik X.org DRI dla rodziny kart SiS.
611
612 %package dri-driver-swrast
613 Summary:        X.org DRI software rasterizer driver
614 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
615 License:        MIT
616 Group:          X11/Libraries
617 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
618 Requires:       xorg-xserver-server >= %{xserver_ver}
619
620 %description dri-driver-swrast
621 X.org DRI software rasterizer driver.
622
623 %description dri-driver-swrast -l pl.UTF-8
624 Sterownik X.org DRI obsługujący rysowanie programowe.
625
626 %package dri-driver-tdfx
627 Summary:        X.org DRI driver for 3DFX Voodoo card family
628 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
629 License:        MIT
630 Group:          X11/Libraries
631 Requires:       Glide3-DRI
632 Requires:       xorg-driver-video-tdfx
633 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
634 Requires:       xorg-xserver-server >= %{xserver_ver}
635 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
636
637 %description dri-driver-tdfx
638 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
639 and Velocity 100/200).
640
641 %description dri-driver-tdfx -l pl.UTF-8
642 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
643 Banshee i Velocity 100/200).
644
645 %package dri-driver-via-unichrome
646 Summary:        X.org DRI driver for VIA Unichrome card family
647 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
648 License:        MIT
649 Group:          X11/Libraries
650 Requires:       xorg-driver-video-openchrome
651 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
652 Requires:       xorg-xserver-server >= %{xserver_ver}
653
654 %description dri-driver-via-unichrome
655 X.org DRI driver for VIA Unichrome card family.
656
657 %description dri-driver-via-unichrome -l pl.UTF-8
658 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
659
660 %package dri-driver-vmwgfx
661 Summary:        X.org DRI driver for VMware
662 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
663 License:        MIT
664 Group:          X11/Libraries
665 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
666 Requires:       xorg-xserver-server >= %{xserver_ver}
667
668 %description dri-driver-vmwgfx
669 X.org DRI driver for VMWare.
670
671 %description dri-driver-vmwgfx -l pl.UTF-8
672 Sterownik X.org DRI dla VMware.
673
674 %prep
675 %setup -q
676 %patch0 -p0
677 %patch1 -p1
678 #patch2 -p1
679 %patch3 -p1
680 %patch4 -p1
681 %patch5 -p1
682
683 %build
684 %{__aclocal}
685 %{__autoconf}
686
687 dri_drivers="i810 i965 mach64 mga r128 \
688 %if %{without gallium_radeon}
689 r200 r300 r600 radeon \
690 %endif
691 savage \
692 %if %{without gallium_intel}
693 i915 \
694 %endif
695 %ifarch sparc sparcv9 sparc64
696 ffb \
697 %endif
698 %ifarch %{ix86} %{x8664}
699 sis \
700 %endif
701 swrast tdfx unichrome"
702
703 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
704
705 common_flags="\
706         --enable-shared \
707         --enable-selinux \
708         --enable-pic \
709         --enable-glx-tls \
710         --disable-glut \
711         --disable-os-mesa \
712         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
713
714 osmesa_common_flags="\
715         --with-driver=osmesa \
716         --disable-asm \
717         --disable-glu"
718
719 %if %{with osmesa}
720 # osmesa variants
721 %configure $common_flags $osmesa_common_flags \
722         --with-osmesa-bits=8
723 %{__make}
724 mv %{_lib} osmesa8
725 %{__make} clean
726
727 %configure $common_flags $osmesa_common_flags \
728         --with-osmesa-bits=16
729 %{__make}
730 mv %{_lib} osmesa16
731 %{__make} clean
732
733 %configure $common_flags $osmesa_common_flags \
734         --with-osmesa-bits=32
735 %{__make}
736 mv %{_lib} osmesa32
737 %{__make} clean
738 %endif
739
740 %configure $common_flags \
741 %if %{with gallium}
742         --enable-gallium \
743         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
744         --%{?with_gallium_radeon:en}%{!?with_gallium_radeon:dis}able-gallium-radeon \
745         --enable-gallium-svga \
746         %{?with_gallium_nouveau:--enable-gallium-nouveau} \
747         --with-state-trackers=dri,glx \
748 %else
749         --disable-gallium \
750 %endif
751         --with-driver=dri \
752         --with-dri-drivers=${dri_drivers} \
753         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
754
755 %{__make}
756
757 %install
758 rm -rf $RPM_BUILD_ROOT
759
760 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
761
762 # libs without drivers
763 %{__make} install \
764         DESTDIR=$RPM_BUILD_ROOT
765
766 %if %{with osmesa}
767 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
768 %endif
769
770 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
771
772 # strip out undesirable headers
773 olddir=$(pwd)
774 cd $RPM_BUILD_ROOT%{_includedir}/GL
775 rm [a-fh-np-wyz]*.h glf*.h
776 cd $RPM_BUILD_ROOT%{_libdir}
777 cd $olddir
778
779 %if %{with multigl}
780 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
781
782 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
783 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
784
785 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
786 %endif
787
788 %clean
789 rm -rf $RPM_BUILD_ROOT
790
791 %post   libEGL -p /sbin/ldconfig
792 %postun libEGL -p /sbin/ldconfig
793
794 %post   libGL -p /sbin/ldconfig
795 %postun libGL -p /sbin/ldconfig
796
797 %post   libGLU -p /sbin/ldconfig
798 %postun libGLU -p /sbin/ldconfig
799
800 %post   libGLw -p /sbin/ldconfig
801 %postun libGLw -p /sbin/ldconfig
802
803 %if %{with egl}
804 %files libEGL
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
807 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
808 %dir %{_libdir}/egl
809 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
810 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
811
812 %files libEGL-devel
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libEGL.so
815 %dir %{_includedir}/EGL
816 %{_includedir}/EGL/egl.h
817 %{_includedir}/EGL/eglext.h
818 %{_includedir}/EGL/eglplatform.h
819 %dir %{_includedir}/KHR
820 %{_includedir}/KHR/khrplatform.h
821 %{_pkgconfigdir}/egl.pc
822
823 %if %{with static}
824 %files libEGL-static
825 %defattr(644,root,root,755)
826 %{_libdir}/libEGL.a
827 %endif
828 %endif
829
830 %files libGL
831 %defattr(644,root,root,755)
832 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
833 %if %{with multigl}
834 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
835 %dir %{_libdir}/Mesa
836 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
837 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
838 %else
839 %attr(755,root,root) %{_libdir}/libGL.so.*.*
840 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
841 # symlink for binary apps which fail to conform Linux OpenGL ABI
842 # (and dlopen libGL.so instead of libGL.so.1)
843 %attr(755,root,root) %{_libdir}/libGL.so
844 %endif
845
846 %files libGL-devel
847 %defattr(644,root,root,755)
848 %doc docs/*.spec
849 %if %{with multigl}
850 %attr(755,root,root) %{_libdir}/libGL.so
851 %endif
852 %dir %{_includedir}/GL
853 %{_includedir}/GL/gl.h
854 %{_includedir}/GL/glext.h
855 %{_includedir}/GL/gl_mangle.h
856 %{_includedir}/GL/glx.h
857 %{_includedir}/GL/glxext.h
858 %{_includedir}/GL/glx_mangle.h
859 %dir %{_includedir}/GL/internal
860 %{_includedir}/GL/internal/dri_interface.h
861 %{_pkgconfigdir}/dri.pc
862 %{_pkgconfigdir}/gl.pc
863
864 %if %{with static}
865 %files libGL-static
866 %defattr(644,root,root,755)
867 %{_libdir}/libGL.a
868 %endif
869
870 %files libGLU
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
873 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
874
875 %files libGLU-devel
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/libGLU.so
878 %{_includedir}/GL/glu.h
879 %{_includedir}/GL/glu_mangle.h
880 %{_pkgconfigdir}/glu.pc
881
882 %if %{with static}
883 %files libGLU-static
884 %defattr(644,root,root,755)
885 %{_libdir}/libGLU.a
886 %endif
887
888 %files libGLw
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
891 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
892
893 %files libGLw-devel
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_libdir}/libGLw.so
896 %{_includedir}/GL/GLwDrawA.h
897 %{_includedir}/GL/GLwDrawAP.h
898 %{_includedir}/GL/GLwMDrawA.h
899 %{_includedir}/GL/GLwMDrawAP.h
900 %{_pkgconfigdir}/glw.pc
901
902 %if %{with static}
903 %files libGLw-static
904 %defattr(644,root,root,755)
905 %{_libdir}/libGLw.a
906 %endif
907
908 %if %{with osmesa}
909 %files libOSMesa
910 %defattr(644,root,root,755)
911 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
912 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
913
914 %files libOSMesa-devel
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/libOSMesa*.so
917 %{_includedir}/GL/osmesa.h
918
919 %if %{with static}
920 %files libOSMesa-static
921 %defattr(644,root,root,755)
922 %{_libdir}/libOSMesa*.a
923 %endif
924 %endif
925
926 %files dri-driver-ati-mach64
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
929
930 %files dri-driver-ati-radeon-R100
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
933
934 %files dri-driver-ati-radeon-R200
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
937
938 %files dri-driver-ati-radeon-R300
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
941
942 %files dri-driver-ati-radeon-R600
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
945
946 %files dri-driver-ati-rage128
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
949
950 # sunffb (sparc only)
951 %ifarch sparc sparcv9 sparc64
952 %files dri-driver-ffb
953 %defattr(644,root,root,755)
954 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
955 %endif
956
957 # glint (requires update)
958 %if 0
959 %files dri-driver-glint
960 %defattr(644,root,root,755)
961 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
962 %endif
963
964 %files dri-driver-intel-i810
965 %defattr(644,root,root,755)
966 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
967
968 %files dri-driver-intel-i915
969 %defattr(644,root,root,755)
970 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
971
972 %files dri-driver-intel-i965
973 %defattr(644,root,root,755)
974 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
975
976 %files dri-driver-matrox
977 %defattr(644,root,root,755)
978 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
979
980 %if %{with gallium}
981 %if %{with gallium_nouveau}
982 %files dri-driver-nouveau
983 %defattr(644,root,root,755)
984 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
985 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
986 %endif
987 %endif
988
989 %files dri-driver-savage
990 %defattr(644,root,root,755)
991 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
992
993 %ifarch %{ix86} %{x8664}
994 %files dri-driver-sis
995 %defattr(644,root,root,755)
996 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
997 %endif
998
999 %files dri-driver-swrast
1000 %defattr(644,root,root,755)
1001 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
1002 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
1003
1004 %files dri-driver-tdfx
1005 %defattr(644,root,root,755)
1006 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
1007
1008 %files dri-driver-via-unichrome
1009 %defattr(644,root,root,755)
1010 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
1011
1012 %if %{with gallium}
1013 %files dri-driver-vmwgfx
1014 %defattr(644,root,root,755)
1015 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
1016 %endif
This page took 0.09262 seconds and 3 git commands to generate.