]> git.pld-linux.org Git - packages/MagickWandForPHP.git/blob - MagickWandForPHP.spec
a58a9f68506501261937bc9ea9fbd2148bf1769e
[packages/MagickWandForPHP.git] / MagickWandForPHP.spec
1 Summary:        MagickWand ImageMagick API for PHP
2 Name:           MagickWandForPHP
3 Version:        1.0.5
4 Release:        1
5 License:        see LICENSE file
6 Group:          Libraries
7 Source0:        http://www.magickwand.org/download/php/%{name}-%{version}.tar.bz2
8 # Source0-md5:  b52a5b7cf4db7078fa3db4cb6e55ecf4
9 Source1:        %{name}.ini
10 URL:            http://www.magickwand.org/
11 BuildRequires:  ImageMagick-devel >= 6.3.5.9
12 BuildRequires:  php-devel >= 3:5.0.0
13 BuildRequires:  rpmbuild(macros) >= 1.344
14 %requires_eq    php-common
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _webapps        /etc/webapps
20 %define         _webapp         %{_name}
21 %define         _sysconfdir     %{_webapps}/%{_webapp}
22 %define         _appdir         %{_datadir}/%{_webapp}
23
24 %description
25 The MagickWand API is the recommended interface between the C programming
26 language and the ImageMagick image processing libraries. Unlike the
27 MagickCore C API, MagickWand uses only a few opaque types. Accessors are
28 available to set or get important wand properties.
29
30 %prep
31 %setup -q
32
33 %build
34 phpize
35 %configure \
36         --with-php-config=%{_bindir}/php-config
37
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{php_extensiondir},%{php_sysconfdir}/conf.d}
43
44 install modules/magickwand.so $RPM_BUILD_ROOT%{php_extensiondir}
45 install %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_name}.ini
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 %php_webserver_restart
52
53 %postun
54 if [ "$1" = 0 ]; then
55         %php_webserver_restart
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc AUTHOR CREDITS ChangeLog LICENSE README TODO run-tests.php
61 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_name}.ini
62 %attr(755,root,root) %{php_extensiondir}/magickwand.so
This page took 0.018961 seconds and 2 git commands to generate.