]> git.pld-linux.org Git - packages/Lunchbox.git/blob - Lunchbox.spec
- updated to 1.17.0 (note: new soname)
[packages/Lunchbox.git] / Lunchbox.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     mpi             # MPI support
5
6 Summary:        Lunchbox - C++ library for multi-threading programming
7 Summary(pl.UTF-8):      Lunchbox - biblioteka C++ do programowania wielowątkowego
8 Name:           Lunchbox
9 Version:        1.17.0
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Libraries
13 #Source0Download: https://github.com/Eyescale/Lunchbox/releases
14 Source0:        https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  76bcd79003c9b9d58d5f772cfdd812c7
16 Patch2:         cxx.patch
17 URL:            http://pogl.wordpress.com/category/lunchbox/
18 BuildRequires:  Eyescale-CMake >= 2018.02
19 BuildRequires:  Servus-devel >= 1.5.0
20 BuildRequires:  avahi-devel
21 BuildRequires:  boost-devel >= 1.41.0
22 BuildRequires:  cmake >= 3.1
23 %{?with_apidocs:BuildRequires:  doxygen}
24 BuildRequires:  hwloc-devel >= 1.3
25 BuildRequires:  libstdc++-devel
26 %{?with_mpi:BuildRequires:      mpi-devel}
27 BuildRequires:  pkgconfig
28 Requires:       Servus >= 1.5.0
29 Requires:       hwloc-libs >= 1.3
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
34 formerly known as eq::base or co::base, the foundation for the
35 Equalizer parallel rendering framework and the Collage network
36 library. It is intended for all application developers creating
37 high-performance multi-threaded programs.
38
39 %description -l pl.UTF-8
40 Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
41 była znana jako eq::base lub co::base - podstawa szkieletu do
42 renderowania wielowątkowego Equalizer lub biblioteki sieciowej
43 Collage. Biblioteka jest przeznaczona dla wszystkich programistów
44 tworzących wysoko wydajne, wielowątkowe aplikacje.
45
46 %package devel
47 Summary:        Header files for Lunchbox library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lunchbox
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       Servus-devel >= 1.5.0
52 Requires:       boost-devel >= 1.41.0
53 Requires:       libstdc++-devel
54
55 %description devel
56 Header files for Lunchbox library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki Lunchbox.
60
61 %package apidocs
62 Summary:        Lunchbox API documentation
63 Summary(pl.UTF-8):      Dokumentacja API biblioteki Lunchbox
64 Group:          Documentation
65 %if "%{_rpmversion}" >= "5"
66 BuildArch:      noarch
67 %endif
68
69 %description apidocs
70 API documentation for Lunchbox library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki Lunchbox.
74
75 %prep
76 %setup -q
77
78 rmdir CMake/common
79 ln -s %{_datadir}/Eyescale-CMake CMake/common
80
81 %patch2 -p1
82
83 %build
84 install -d build
85 cd build
86 %cmake .. \
87         -DCOMMON_DISABLE_WERROR:BOOL=ON \
88         %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
89
90 %{__make}
91
92 %if %{with apidocs}
93 doxygen doc/Doxyfile
94 %endif
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
113 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
115 %dir %{_datadir}/Lunchbox
116 %{_datadir}/Lunchbox/benchmarks
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libLunchbox.so
121 %{_includedir}/lunchbox
122 %{_datadir}/Lunchbox/CMake
123
124 %if %{with apidocs}
125 %files apidocs
126 %defattr(644,root,root,755)
127 %doc build/doc/html/*
128 %endif
This page took 0.048781 seconds and 3 git commands to generate.