]> git.pld-linux.org Git - packages/LPRng.git/blob - LPRng.spec
- new version 3.7.5
[packages/LPRng.git] / LPRng.spec
1 Summary:        A next-generation printing system for UNIX
2 Summary(pl):    System drukowania nowej generacji
3 Name:           LPRng
4 Version:        3.7.5
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Group(de):      Applikationen/System
9 Group(pl):      Aplikacje/System
10 Source0:        ftp://ftp.astart.com/pub/LPRng/LPRng/%{name}-%{version}.tgz
11 Source1:        %{name}.init
12 Source2:        %{name}.conf
13 Patch0:         %{name}-jobfilescan.patch
14 Patch1:         %{name}-ac_fixes.patch
15 Patch2:         %{name}-inet_ntop.patch
16 Patch3:         %{name}-direct.patch
17 Patch4:         %{name}-manpage.patch
18 Patch5:         %{name}-shutdown.patch
19 Patch6:         %{name}-lockfile.patch
20 Patch7:         %{name}-setgroups.patch
21 BuildRequires:  autoconf
22 BuildRequires:  gettext-devel
23 BuildRequires:  ncurses-devel >= 5.0
24 Prereq:         /sbin/chkconfig
25 Prereq:         rc-scripts >= 0.2.0
26 URL:            http://www.astart.com/lprng/LPRng.html
27 Provides:       lpr
28 Obsoletes:      lpr
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31
32 %description
33 The LPRng software is an enhanced, extended, and portable
34 implementation of the Berkeley LPR print spooler functionality. While
35 providing the same interface and meeting RFC1179 requirements, the
36 implementation is completely new and provides support for the
37 following features: lightweight (no databases needed) lpr, lpc, and
38 lprm programs; dynamic redirection of print queues; automatic job
39 holding; highly verbose diagnostics; multiple printers serving a
40 single queue; client programs do not need to run SUID root; greatly
41 enhanced security checks; and a greatly improved permission and
42 authorization mechanism.
43
44 The source software compiles and runs on a wide variety of UNIX
45 systems, and is compatible with other print spoolers and network
46 printers that use the LPR interface and meet RFC1179 requirements.
47 LPRng provides emulation packages for the SVR4 lp and lpstat programs,
48 eliminating the need for another print spooler package. These
49 emulation packages can be modified according to local requirements, in
50 order to support vintage printing systems.
51
52 For users that require secure and/or authenticated printing support,
53 LPRng supports Kerberos V, MIT Kerberos IV Print Support, and PGP
54 authentication. LPRng is being adopted by MIT for use as their Campus
55 Wide printing support system. Additional authentication support is
56 extremely simple to add. LPRng is Open Source Software, and the
57 current public distribution is available from the listed FTP and Web
58 Sites.
59
60 %description -l pl
61 LPRng jest systemem drukowania nowej generacji zwiêkszaj±cym
62 niezawodno¶æ i bezpieczeñstwo.
63
64 %prep
65 %setup  -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70 %patch4 -p1
71 %patch5 -p1
72 %patch6 -p1
73 %patch7 -p1
74
75 %build
76 rm -f missing
77 gettextize --copy --force
78 aclocal
79 autoconf
80 %configure \
81         --disable-setuid \
82         --with-userid=lp \
83         --with-groupid=lp \
84         --with-filterdir=%{_libdir}/lpfilters \
85         --with-lockfile=%{_var}/spool/lpd/lpd
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d  $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_var}/spool/lpd}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/lpd
97 # yes, overwrite distribution lpd.conf
98 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lpd.conf
99 echo "default_printer = lp" >>$RPM_BUILD_ROOT%{_sysconfdir}/lpd.conf
100 install printcap.in $RPM_BUILD_ROOT%{_sysconfdir}/printcap
101 install lpd.perms $RPM_BUILD_ROOT%{_sysconfdir}/
102 # default spool
103 install -d $RPM_BUILD_ROOT%{_var}/spool/lpd/lp
104
105 rm -fr TESTSUPPORT/{Makefile*,LPD}
106 mv -f lpd.conf TESTSUPPORT/lpd.conf.distrib
107
108 gzip -9nf CHANGES CONTRIBUTORS README* TESTSUPPORT/*
109
110 %find_lang %{name}
111
112 %post
113 /sbin/chkconfig --add lpd
114 if [ -f /var/lock/subsys/lpd ]; then
115         /etc/rc.d/init.d/lpd restart 1>&2
116 else
117         echo "Run \"/etc/rc.d/init.d/lpd start\" to start LPRng lpd daemon."
118 fi
119
120 %preun
121 if [ "$1" = "0" ]; then
122         if [ -f /var/lock/subsys/lpd ]; then
123                 /etc/rc.d/init.d/lpd stop 1>&2
124         fi
125         /sbin/chkconfig --del lpd
126 fi
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc *.gz TESTSUPPORT HOWTO/LPRng-HOWTO.html
134 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lpd.conf
135 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lpd.perms
136 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/printcap
137 %attr(754,root,root) /etc/rc.d/init.d/lpd
138 %attr(755,root,root) %{_bindir}/*
139 %attr(755,root,root) %{_sbindir}/*
140 %dir %{_libdir}/lpfilters
141 %attr(755,root,root) %{_libdir}/lpfilters/*
142 %dir %attr(750,root,lp) %{_var}/spool/lpd
143 %dir %attr(770,root,lp) %{_var}/spool/lpd/lp
144 %{_mandir}/man[158]/*
This page took 0.033409 seconds and 4 git commands to generate.