]> git.pld-linux.org Git - packages/JADE.git/blob - JADE.spec
- changed sp version to 1.3.3.
[packages/JADE.git] / JADE.spec
1 Summary:        Jade -- DSSSL parser
2 Summary(pl):    Jade -- parser DSSSL
3 Name:           jade
4 Version:        1.2.1
5 Release:        3
6 Serial:         6
7 Vendor:         James Clark
8 Group:          Applications/Publishing/SGML
9 Group(pl):      Aplikacje/Publikowanie/SGML
10 Copyright:      (C) 1997 James Clark (free)
11 Source0:        ftp://ftp.jclark.com/pub/jade/%{name}-%{version}.tar.gz
12 Source1:        unicode.cat
13 Source2:        dsssl.cat
14 Source3:        sp-html.cat
15 patch:          jade-DESTDIR.patch
16 Provides:       dssslparser
17 URL:            http://www.jclark.com/jade/
18 Prereq:         /usr/sbin/install-catalog
19 Requires:       sgml-common
20 Requires:       sp
21 BuildRoot:      /tmp/%{name}-%{version}-root
22
23 %description
24 Jade (James' DSSSL Engine) is an implementation of the DSSSL style language. 
25
26 %description -l pl
27 Jade (James' DSSSL Engine) jest implementacj± parsera DSSSL.
28
29 %package -n sp
30 Summary:        SP -- parser and tools for SGML
31 Summary(pl):    SP -- parser and tools for SGML
32 Group:          Applications/Publishing/SGML
33 Group(pl):      Aplikacje/Publikowanie/SGML
34 Version:        1.3.3
35 URL:            http://www.jclark.com/sp/
36 Prereq:         /usr/sbin/install-catalog
37 Provides:       sgmlparser
38 Requires:       sgml-common
39
40 %description -n sp
41 SGML parser called sp (replacement of sgmls).
42
43 %description -n sp -l pl
44 Parser SGML (bêd±cy nastêpc± pisanego w C sgmls) oraz narzêdzia
45 do normalizacji SGML-a (sgmlnorm), konwersji tego¿ do XMLa (sx).
46
47 %prep
48 %setup -q  
49 %patch -p1
50
51 %build
52 LDFLAGS="-s"; export LDFLAGS
53 CXXFLAGS="$RPM_OPT_FLAGS -fno-rtti"
54 export CXXFLAGS
55 %configure \
56         --prefix=%{_prefix} \
57         --sharedstatedir=%{_datadir} \
58         --enable-default-catalog=%{_datadir}/sgml/CATALOG  \
59         --enable-shared \
60         --with-gnu-ld \
61         --enable-mif
62
63 make  
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{_datadir}/sgml/{dsssl/jade,html}
68
69 make install DESTDIR="$RPM_BUILD_ROOT"
70
71 cp -ar pubtext/* $RPM_BUILD_ROOT%{_datadir}/sgml/html
72 cp -ar unicode $RPM_BUILD_ROOT%{_datadir}/sgml
73
74 install $RPM_SOURCE_DIR/{dsssl,sp-html,unicode}.cat \
75         $RPM_BUILD_ROOT/usr/share/sgml
76
77 cp -ar dsssl/catalog $RPM_BUILD_ROOT%{_datadir}/sgml/dsssl/jade
78 cp -ar dsssl/dsssl.dtd dsssl/style-sheet.dtd dsssl/fot.dtd \
79         $RPM_BUILD_ROOT%{_datadir}/sgml/dsssl/jade
80
81 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
82
83 %post
84 /usr/sbin/install-catalog --install dsssl  --version  %{jadever}-%{release}
85
86 %preun
87 if [ "$1" = "0" ]; then
88         /usr/sbin/install-catalog --remove dsssl   --version  %{jadever}-%{release}
89 fi
90
91 %post -n sp
92 /usr/sbin/install-catalog --install sp-html --version %{spver}-%{release}
93 /usr/sbin/install-catalog --install unicode --version %{spver}-%{release}
94
95 %preun -n sp
96 if [ "$1" = "0" ]; then
97         /usr/sbin/install-catalog --remove sp-html --version %{spver}-%{release} 
98         /usr/sbin/install-catalog --remove unicode --version %{spver}-%{release}
99 fi
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc jadedoc/ dsssl/ README COPYING VERSION
107
108 %attr(755,root,root) %{_bindir}/jade
109 %attr(755,root,root) %{_libdir}/libstyle.so*
110 %attr(755,root,root) %{_libdir}/libgrove.so*
111 %attr(755,root,root) %{_libdir}/libspgrove.so*
112
113 %config %{_datadir}/sgml/dsssl.cat
114 %{_datadir}/sgml/dsssl/*
115
116 %files -n sp
117 %defattr(644,root,root,755)
118 %doc doc/
119
120 %attr(755,root,root) %{_bindir}/s*
121 %attr(755,root,root) %{_bindir}/nsgmls
122 %attr(755,root,root) %{_libdir}/libsp.so*
123
124 %config %{_datadir}/sgml/sp-html.cat
125 %{_datadir}/sgml/html
126
127 %config %{_datadir}/sgml/unicode.cat
128 %{_datadir}/sgml/unicode
129
130 %changelog
131 * Thu Oct 26 1998 Ziemek Borowski <ziembor@faq-bot.ziembor.waw.pl>
132   [1.2.1-1] 
133 - upgrade to 1.2.1 (with dynamic libraries -- changes in %files part)
134 - corrects to *.cat files (not dynamicaly generated). 
135 - (I`m not sure if we ought to include *.la files -- not included).  
136 - added --enable-mif (but it does`t working ;-( 
137 - some cosmetic changes in spec: (new group, new prereq) 
138 - simplifications in %post{un}
139
140 * Thu Sep 26 1998 Ziemek Borowski <ziembor@faq-bot.ziembor.waw.pl>
141   [1_2-4]
142 - updated new version
143 - added  -Dsig_atomic_t=int to make (against glibc-2.x --
144   required in glibc-2.0.93 but its help in 2.0.7 too)
145
146 * Thu Sep 10 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
147   [1_1_1-3]
148 - patch against glibc 2.0.93  (quick & dirty)   (not nessessary in 1_2)
149
150 * Mon Sep 07 1998 Ziemek Borowski <ziembor@faq-bot.ziembor.waw.pl>
151   [1_1_1-2]
152 - added Polish .spec tranlation
153 - more detailed .spec
154 - separated to: jade, and sp  packages
155 - based od Mark Gallasi works ftp://ftp.cygnus.com/pub/home/rozalia/docware
This page took 0.068639 seconds and 4 git commands to generate.