]> git.pld-linux.org Git - SPECS.git/blob - HdrHistogram_c.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / HdrHistogram_c.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        C port of High Dynamic Range (HDR) histogram
6 Summary(pl.UTF-8):      Port C biblioteki histogramów HDR (High Dynamic Range)
7 Name:           HdrHistogram_c
8 Version:        0.11.8
9 Release:        1
10 License:        Public Domain/CC0 v1.0 or BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/HdrHistogram/HdrHistogram_c/releases
13 Source0:        https://github.com/HdrHistogram/HdrHistogram_c/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  01ad863daaecea56a93f25de3065dcac
15 URL:            https://github.com/HdrHistogram/HdrHistogram_c
16 BuildRequires:  cmake >= 3.12
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 C port of High Dynamic Range (HDR) histogram.
23
24 %description -l pl.UTF-8
25 Port C biblioteki histogramów HDR (High Dynamic Range).
26
27 %package devel
28 Summary:        Header files for HdrHistogram library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HdrHistogram
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       zlib-devel
33
34 %description devel
35 Header files for HdrHistogram library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki HdrHistogram.
39
40 %package static
41 Summary:        Static HdrHistogram library
42 Summary(pl.UTF-8):      Statyczna biblioteka HdrHistogram
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static HdrHistogram library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka HdrHistogram.
51
52 %prep
53 %setup -q
54
55 %build
56 install -d build
57 cd build
58 %cmake ..
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %{__rm} $RPM_BUILD_ROOT%{_bindir}/hdr_*_test
69 %{__rm} $RPM_BUILD_ROOT%{_bindir}/hdr_histogram_perf
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc LICENSE.txt README.md
80 %attr(755,root,root) %{_bindir}/hdr_decoder
81 %attr(755,root,root) %{_bindir}/hiccup
82 %attr(755,root,root) %{_libdir}/libhdr_histogram.so.*.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libhdr_histogram.so.6
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/libhdr_histogram.so
88 %dir %{_includedir}/hdr
89 %{_includedir}/hdr/hdr_*.h
90 %{_libdir}/cmake/hdr_histogram
91 %{_pkgconfigdir}/hdr_histogram.pc
92
93 %if %{with static_libs}
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/libhdr_histogram_static.a
97 %endif
This page took 1.198464 seconds and 3 git commands to generate.