]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
- allow to enable mmx/sse2 on other subarchs (like i686)
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es):    Terminal para Enlightenment
14 Summary(pl):    Terminal dla Enlightenmenta
15 Summary(pt_BR): Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.4
18 Release:        1
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  b8869ee9c9b9516231af9eefa595cee3
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 URL:            http://www.eterm.org/
31 BuildRequires:  autoconf >= 2.53
32 BuildRequires:  automake
33 BuildRequires:  freetype1-devel
34 BuildRequires:  imlib2-devel >= 1.0.3
35 BuildRequires:  libast-devel >= 0.6
36 BuildRequires:  libltdl-devel
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel
39 BuildRequires:  pcre-devel
40 BuildRequires:  screen
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  twin-devel
43 BuildRequires:  utempter-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Eterm is a color vt102 terminal emulator intended as an xterm(1)
48 replacement for users who want a term program integrated with
49 Enlightenment, or simply want a little more "eye candy". Eterm uses
50 Imlib for advanced graphic abilities.
51
52 %description -l es
53 Eterm es un emulador de terminal vt102 con soporte para colores,
54 desarrollado como un sustituto para el emulador xterm, para los
55 usuarios que deseen un emulador de terminal integrado con la
56 iluminación, o simplemente deseen algo más agradable visualmente. El
57 emulador Eterm usa Imlib para trabajar con gráficos.
58
59 %description -l pl
60 Eterm jest kolorowym emulatorem terminala vt102 mog±cym byæ
61 zamiennikiem xterm(1) dla u¿ytkowników chc±cych mieæ program
62 terminalowy zintegrowany z zarz±dc± okienek o nazwie Enlightenment lub
63 dla tych którzy chc± mieæ trochê bardziej urozmaicony wygl±d tego typu
64 programu. Eterm u¿ywa biblioteki IMlib do zaawansowanego operowania na
65 grafice.
66
67 %description -l pt_BR
68 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
69 suporte a cores, desenvolvido para ser um substituto para o xterm,
70 para os usuários que queiram um emulador de terminal integrado com o
71 Enlightenment, ou simplesmente queiram algo mais agradável para os
72 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
73
74 %package -n Esetroot
75 Summary:        Sets root pixmap
76 Summary(pl):    Aplikacja ustawiaj±ca t³o nadrzêdnego okna
77 Group:          X11/Window Managers/Tools
78  
79 %description -n Esetroot
80 This program enables non-Enlightenment users to use pseudotransparency.
81
82 %description -n Esetroot -l pl
83 Program ten umo¿liwia u¿ytkownikom zarz±dców okien innych ni¿ Enlightenment
84 korzystanie z pseudo-przezroczysto¶ci.
85
86 %prep
87 %setup -q -a1
88 %patch0 -p1
89 %patch1 -p1
90 find themes/ -name "*.cfg*" -exec \
91         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__automake}
98 %configure \
99         --disable-static        \
100         --enable-shared         \
101         --enable-escreen        \
102         --enable-etwin          \
103         --enable-escreen-fx     \
104         --enable-profile        \
105         --enable-trans          \
106 %if %{with mmx}
107         --enable-mmx            \
108 %else
109         --disable-mmx           \
110 %endif
111 %if %{with sse2}
112         --enable-sse2           \
113 %else
114         --disable-sse2          \
115 %endif
116         --enable-utmp           \
117         --enable-auto-encoding  \
118         --enable-multi-charset  \
119         --disable-stack-trace   \
120         --enable-name-reporting-escapes \
121         --without-debugging
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
132 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
133 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc doc/*.html ReleaseNotes* ChangeLog
144 %attr(755,root,root) %{_bindir}/Eterm
145 %attr(755,root,root) %{_bindir}/Etbg
146 %attr(755,root,root) %{_bindir}/Etcolors
147 %attr(755,root,root) %{_bindir}/Ettable
148 %attr(755,root,root) %{_bindir}/Etbg_update_list
149 %attr(755,root,root) %{_bindir}/Etsearch
150 %attr(755,root,root) %{_libdir}/lib*.so
151 %{_libdir}/lib*.la
152 %{_mandir}/man1/*
153 %{_datadir}/Eterm
154 %{_desktopdir}/*
155 %{_pixmapsdir}/*
156
157 %files -n Esetroot
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/Esetroot
160 %attr(755,root,root) %{_bindir}/kEsetroot
161  
This page took 0.058757 seconds and 3 git commands to generate.