]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
- dropped ugly i2c workaround; glibc-kernel-headers contain proper fix
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 %bcond_without  mpg     # don't build support for MPG/MPEG3
4 #
5 Summary:        DirectFB - Hardware graphics acceleration
6 Summary(pl):    DirectFB - Wspomaganie grafiki
7 Name:           DirectFB
8 Version:        0.9.20
9 Release:        3
10 Epoch:          1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  e42e8ae43f0ad873643f73cc0a9ae7d0
15 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
16 # Source1-md5:  13e443a64bddd68835b574045d9025e9
17 Patch0:         %{name}-am.patch
18 Patch1:         %{name}-pmake.patch
19 URL:            http://www.directfb.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  freetype-devel >= 2.0.2
24 BuildRequires:  libjpeg-devel >= 6b
25 %{?with_mpg:BuildRequires:      libmpeg3-devel}
26 BuildRequires:  libpng-devel >= 1.0
27 BuildRequires:  libtool
28 BuildRequires:  zlib-devel >= 1.1.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         dfbdir  %{_libdir}/directfb-%{version}
32
33 %description
34 DirectFB hardware graphics acceleration - libraries.
35
36 %description -l pl
37 Wspomaganie grafiki DirectFB - biblioteki.
38
39 %package devel
40 Summary:        DirectFB - development package
41 Summary(pl):    DirectFB - pliki nag³ówkowe
42 Group:          Development/Libraries
43 Requires:       %{name} = %{epoch}:%{version}
44
45 %description devel
46 DirectFB header files.
47
48 %description devel -l pl
49 Pliki nag³ówkowe dla DirectFB.
50
51 %package static
52 Summary:        DirectFB static libraries
53 Summary(pl):    Statyczne biblioteki DirectFB
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{epoch}:%{version}
56
57 %description static
58 DirectFB static libraries.
59
60 %description static -l pl
61 Statyczne biblioteki DirectFB.
62
63 %package doc
64 Summary:        DirectFB - documentation
65 Summary(pl):    DirectFB - dokumentacja
66 Group:          Development/Libraries
67
68 %description doc
69 DirectFB documentation and tutorials.
70
71 %description doc -l pl
72 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
73
74 %package core-sdl
75 Summary:        SDL core system for DirectFB
76 Summary(pl):    System SDL dla DirectFB
77 Group:          Libraries
78 Requires:       %{name} = %{epoch}:%{version}
79
80 %description core-sdl
81 This package contains SDL core system module for DirectFB.
82
83 %description core-sdl -l pl
84 Ten pakiet zawiera modu³ systemu SDL dla DirectFB.
85
86 %package font-ft2
87 Summary:        FreeType2 font provider for DirectFB
88 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
89 Group:          Libraries
90 Requires:       %{name} = %{epoch}:%{version}
91
92 %description font-ft2
93 This package contains FreeType2 font provider for DirectFB.
94
95 %description font-ft2 -l pl
96 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
97 bibliotekê FreeType2.
98
99 %package image-jpeg
100 Summary:        JPEG image provider for DirectFB
101 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
102 Group:          Libraries
103 Requires:       %{name} = %{epoch}:%{version}
104
105 %description image-jpeg
106 This package contains JPEG image provider for DirectFB.
107
108 %description image-jpeg -l pl
109 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
110
111 %package image-png
112 Summary:        PNG image provider for DirectFB
113 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
114 Group:          Libraries
115 Requires:       %{name} = %{epoch}:%{version}
116
117 %description image-png
118 This package contains PNG image provider for DirectFB.
119
120 %description image-png -l pl
121 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
122
123 %package video-libmpeg3
124 Summary:        MPEG video provider for DirectFB
125 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
126 Group:          Libraries
127 Requires:       %{name} = %{epoch}:%{version}
128
129 %description video-libmpeg3
130 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
131 DirectFB. It uses libmpeg3 library.
132
133 %description video-libmpeg3 -l pl
134 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
135 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3.
136
137 %prep
138 %setup -q -a1
139 %patch0 -p1
140 %patch1 -p1
141
142 %build
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__automake}
147 CPPFLAGS="-I/usr/include/libmpeg3"
148 # MMX and SSE are detected at runtime, so it's safe to enable
149 %configure \
150         --disable-maintainer-mode \
151         --enable-shared \
152         --enable-static \
153         --enable-fast-install \
154         --disable-debug \
155         %{!?with_mpg:--disable-libmpeg3} \
156         --enable-sdl \
157 %ifarch i586 i686 athlon
158         --enable-mmx \
159 %endif
160 %ifarch i686 athlon
161         --enable-sse
162 %endif
163
164 %{__make}
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 # dbfdump and dfbg require multi-application core - useless now
184 %attr(755,root,root) %{_bindir}/dfbinfo
185 %attr(755,root,root) %{_libdir}/lib*.so.*.*
186 %dir %{dfbdir}
187 %dir %{dfbdir}/gfxdrivers
188 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
189 %dir %{dfbdir}/inputdrivers
190 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
191 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
192 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
193 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
194 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
195 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
196 %dir %{dfbdir}/interfaces
197 %dir %{dfbdir}/interfaces/IDirectFBFont
198 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
199 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
200 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
201 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
202 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
203 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
204 %dir %{dfbdir}/systems
205 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
206 %{_datadir}/directfb-%{version}
207 %{_mandir}/man5/*
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/directfb-config
212 %attr(755,root,root) %{_bindir}/directfb-csource
213 %attr(755,root,root) %{_libdir}/*.so
214 %{_libdir}/*.la
215 %{_includedir}/directfb
216 %{_includedir}/directfb-internal
217 %{_pkgconfigdir}/*
218 %{_mandir}/man1/directfb-csource.1*
219
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/lib*.a
223 %{dfbdir}/gfxdrivers/*.*a
224 %{dfbdir}/inputdrivers/*.*a
225 %{dfbdir}/interfaces/*/*.*a
226 %{dfbdir}/systems/*.*a
227
228 %files doc
229 %defattr(644,root,root,755)
230 %doc docs/html/*
231 %{_examplesdir}/%{name}-%{version}
232
233 %files core-sdl
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
236 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
237
238 %files font-ft2
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
241
242 %files image-jpeg
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
245
246 %files image-png
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
249
250 %if %{with mpg}
251 %files video-libmpeg3
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
254 %endif
This page took 0.048731 seconds and 4 git commands to generate.