]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
- cosmetics
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # TODO:
3 #       - fix x86-64 int32<->ptr64 casts.
4 #
5 #       tree.c:88: warning: cast from pointer to integer of different size
6 #       tree.c:102: warning: cast from pointer to integer of different size
7 #       fonts.c:144: warning: cast to pointer from integer of different size
8 #       fonts.c:211: warning: cast to pointer from integer of different size
9 #       gfxcard.c:1451: warning: cast to pointer from integer of different size
10 #       fbdev.c:459: warning: cast from pointer to integer of different size
11 #       fbdev.c:578: warning: cast from pointer to integer of different size
12 #       fbdev.c:708: warning: cast from pointer to integer of different size
13 #       idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
14 #       idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
15 #       idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
16 #
17 # Conditional build:
18 %bcond_with     multi           # build Multi-application core (requires working /dev/fusion*)
19 #
20 Summary:        DirectFB - Hardware graphics acceleration
21 Summary(pl.UTF-8):      DirectFB - Wspomaganie grafiki
22 Name:           DirectFB
23 Version:        1.0.0
24 Release:        1
25 Epoch:          1
26 License:        LGPL v2+
27 Group:          Libraries
28 Source0:        http://www.directfb.org/downloads/Core/%{name}-%{version}.tar.gz
29 # Source0-md5:  ad746c49dc89ba6f99df71b17bbb1dc8
30 Source1:        http://www.directfb.org/downloads/Extras/DFBTutorials-0.5.0.tar.gz
31 # Source1-md5:  13e443a64bddd68835b574045d9025e9
32 Patch0:         %{name}-am.patch
33 Patch1:         %{name}-pmake.patch
34 Patch2:         %{name}-fix.patch
35 Patch3:         %{name}-gcc4.patch
36 Patch4:         %{name}-llh-ppc.patch
37 Patch5:         %{name}-link.patch
38 URL:            http://www.directfb.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  autoconf >= 2.52
41 BuildRequires:  automake
42 BuildRequires:  freetype-devel >= 2.0.2
43 BuildRequires:  libjpeg-devel >= 6b
44 BuildRequires:  libpng-devel >= 1.0
45 BuildRequires:  libtool
46 BuildRequires:  libvncserver-devel
47 %{?with_multi:BuildRequires:    linux-fusion-devel >= 3.0}
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sysfsutils-devel >= 1.3.0-3
50 BuildRequires:  xorg-lib-libXext-devel
51 BuildRequires:  zlib-devel >= 1.1.3
52 %{?with_multi:Provides: DirectFB(multi)}
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         dfbdir  %{_libdir}/directfb-1.0-0
56
57 %define         specflags       -fno-strict-aliasing
58
59 %ifarch %{ix86}
60 # gcc running out of registers with -O0 in generic_mmx.h
61 %define         debugcflags     -O1 -g
62 %endif
63
64 %description
65 DirectFB hardware graphics acceleration - libraries.
66
67 %description -l pl.UTF-8
68 Wspomaganie grafiki DirectFB - biblioteki.
69
70 %package devel
71 Summary:        DirectFB - development package
72 Summary(pl.UTF-8):      DirectFB - pliki nagłówkowe
73 Group:          Development/Libraries
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75 Requires:       zlib-devel >= 1.1.3
76
77 %description devel
78 DirectFB header files.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe dla DirectFB.
82
83 %package static
84 Summary:        DirectFB static libraries
85 Summary(pl.UTF-8):      Statyczne biblioteki DirectFB
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
88
89 %description static
90 DirectFB static libraries.
91
92 %description static -l pl.UTF-8
93 Statyczne biblioteki DirectFB.
94
95 %package doc
96 Summary:        DirectFB - documentation
97 Summary(pl.UTF-8):      DirectFB - dokumentacja
98 Group:          Documentation
99
100 %description doc
101 DirectFB documentation and tutorials.
102
103 %description doc -l pl.UTF-8
104 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
105
106 %package core-sdl
107 Summary:        SDL core system for DirectFB
108 Summary(pl.UTF-8):      System SDL dla DirectFB
109 Group:          Libraries
110 Requires:       %{name} = %{epoch}:%{version}-%{release}
111
112 %description core-sdl
113 This package contains SDL core system module for DirectFB.
114
115 %description core-sdl -l pl.UTF-8
116 Ten pakiet zawiera moduł systemu SDL dla DirectFB.
117
118 %package core-vnc
119 Summary:        VNC core system for DirectFB
120 Summary(pl.UTF-8):      System VNC dla DirectFB
121 Group:          Libraries
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123
124 %description core-vnc
125 This package contains VNC core system module for DirectFB.
126
127 %description core-vnc -l pl.UTF-8
128 Ten pakiet zawiera moduł systemu VNC dla DirectFB.
129
130 %package core-x11
131 Summary:        X11 core system for DirectFB
132 Summary(pl.UTF-8):      System X11 dla DirectFB
133 Group:          Libraries
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135
136 %description core-x11
137 This package contains X11 core system module for DirectFB.
138
139 %description core-x11 -l pl.UTF-8
140 Ten pakiet zawiera moduł systemu X11 dla DirectFB.
141
142 %package font-ft2
143 Summary:        FreeType2 font provider for DirectFB
144 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca fonty poprzez FreeType2
145 Group:          Libraries
146 Requires:       %{name} = %{epoch}:%{version}-%{release}
147
148 %description font-ft2
149 This package contains FreeType2 font provider for DirectFB.
150
151 %description font-ft2 -l pl.UTF-8
152 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą fonty poprzez
153 bibliotekę FreeType2.
154
155 %package image-jpeg
156 Summary:        JPEG image provider for DirectFB
157 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę JPEG
158 Group:          Libraries
159 Requires:       %{name} = %{epoch}:%{version}-%{release}
160
161 %description image-jpeg
162 This package contains JPEG image provider for DirectFB.
163
164 %description image-jpeg -l pl.UTF-8
165 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę JPEG.
166
167 %package image-png
168 Summary:        PNG image provider for DirectFB
169 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę PNG
170 Group:          Libraries
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172
173 %description image-png
174 This package contains PNG image provider for DirectFB.
175
176 %description image-png -l pl.UTF-8
177 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę PNG.
178
179 %package input-dynapro
180 Summary:        Dynapro touchscreen input driver for DirectFB
181 Summary(pl.UTF-8):      Sterownik wejściowy do touchscreenów Dynapro dla DirectFB
182 Group:          Libraries
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description input-dynapro
186 Dynapro touchscreen input driver for DirectFB.
187
188 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
189 unless you don't have Dynapro device connected to this port. It can
190 mess with other devices connected to this port (mouse, modem etc.).
191
192 %description input-dynapro -l pl.UTF-8
193 Sterownik wejściowy do touchscreenów Dynapro dla DirectFB.
194
195 UWAGA: aktualnie używa zakodowanego na stałe portu /dev/ttyS0, więc
196 nie należy go instalować, jeśli urządzenie Dynapro nie jest podłączone
197 do tego portu. Sterownik może utrudnić współpracę z innymi
198 urządzeniami podłączonymi do /dev/ttyS0 (jak mysz, modem itp.).
199
200 %package input-elo
201 Summary:        ELO touchscreen input driver for DirectFB
202 Summary(pl.UTF-8):      Sterownik wejściowy do touchscreenów ELO dla DirectFB
203 Group:          Libraries
204 Requires:       %{name} = %{epoch}:%{version}-%{release}
205
206 %description input-elo
207 ELO touchscreen input driver for DirectFB.
208
209 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
210 unless you have ELO device connected to this port. It can mess with
211 other devices connected to this port (mouse, modem etc.).
212
213 %description input-elo -l pl.UTF-8
214 Sterownik wejściowy do touchscreenów ELO dla DirectFB.
215
216 UWAGA: aktualnie używa zakodowanego na stałe portu /dev/ttyS0, więc
217 nie należy go instalować, jeśli urządzenie ELO nie jest podłączone do
218 tego portu. Sterownik może utrudnić współpracę z innymi urządzeniami
219 podłączonymi do /dev/ttyS0 (jak mysz, modem itp.).
220
221 %package input-gunze
222 Summary:        Gunze touchscreen input driver for DirectFB
223 Summary(pl.UTF-8):      Sterownik wejściowy do touchscreenów Gunze dla DirectFB
224 Group:          Libraries
225 Requires:       %{name} = %{epoch}:%{version}-%{release}
226
227 %description input-gunze
228 Gunze touchscreen input driver for DirectFB.
229
230 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
231 unless you don't have Gunze device connected to this port. It can mess
232 with other devices connected to this port (mouse, modem etc.).
233
234 %description input-gunze -l pl.UTF-8
235 Sterownik wejściowy do touchscreenów Gunze dla DirectFB.
236
237 UWAGA: aktualnie używa zakodowanego na stałe portu /dev/ttyS0, więc
238 nie należy go instalować, jeśli urządzenie Gunze nie jest podłączone
239 do tego portu. Sterownik może utrudnić współpracę z innymi
240 urządzeniami podłączonymi do /dev/ttyS0 (jak mysz, modem itp.).
241
242 %package input-mutouch
243 Summary:        MuTouch touchscreen input driver for DirectFB
244 Summary(pl.UTF-8):      Sterownik wejściowy do touchscreenów MuTouch dla DirectFB
245 Group:          Libraries
246 Requires:       %{name} = %{epoch}:%{version}-%{release}
247
248 %description input-mutouch
249 MuTouch touchscreen input driver for DirectFB.
250
251 NOTE: it needs "mut-device" setting in directfbrc in order to work.
252
253 %description input-mutouch -l pl.UTF-8
254 Sterownik wejściowy do touchscreenów MuTouch dla DirectFB.
255
256 UWAGA: do działania potrzebuje ustawienia "mut-device" w directfbrc.
257
258 %package input-ucb1x00
259 Summary:        UCB1x00 touchscreen input driver for DirectFB
260 Summary(pl.UTF-8):      Sterownik wejściowy do touchscreenów UCB1x00 dla DirectFB
261 Group:          Libraries
262 Requires:       %{name} = %{epoch}:%{version}-%{release}
263
264 %description input-ucb1x00
265 UCB1x00 touchscreen input driver for DirectFB.
266
267 %description input-ucb1x00 -l pl.UTF-8
268 Sterownik wejściowy do touchscreenów UCB1x00 dla DirectFB.
269
270 %package input-wm97xx
271 Summary:        WM97xx touchscreen input driver for DirectFB
272 Summary(pl.UTF-8):      Sterownik wejściowy do touchscreenów WM97xx dla DirectFB
273 Group:          Libraries
274 Requires:       %{name} = %{epoch}:%{version}-%{release}
275
276 %description input-wm97xx
277 WM97xx touchscreen input driver for DirectFB.
278
279 %description input-wm97xx -l pl.UTF-8
280 Sterownik wejściowy do touchscreenów WM97xx dla DirectFB.
281
282 %prep
283 %setup -q -a1
284 %patch0 -p1
285 %patch1 -p1
286 %patch2 -p1
287 %patch3 -p1
288 %patch4 -p1
289 %patch5 -p1
290
291 %build
292 %{__libtoolize}
293 %{__aclocal}
294 %{__autoconf}
295 %{__automake}
296 # MMX and SSE are detected at runtime, so it's safe to enable
297 %configure \
298         %{!?debug:--disable-debug} \
299         --disable-maintainer-mode \
300         --enable-fast-install \
301         %{?with_multi:--enable-multi} \
302         --enable-sdl \
303         --enable-shared \
304         --enable-static \
305         --enable-unique \
306         --enable-video4linux2 \
307         --enable-voodoo \
308         --enable-x11 \
309         --enable-zlib \
310 %ifarch %{ix86} %{x8664}
311 %ifnarch i386 i486
312         --enable-mmx \
313 %endif
314 %ifnarch i386 i486 i586
315         --enable-sse \
316 %endif
317 %endif
318         --with-inputdrivers=dynapro,elo-input,gunze,joystick,keyboard,linuxinput,lirc,mutouch,penmount,ps2mouse,serialmouse,sonypijogdial,ucb1x00,wm97xx
319
320 %{__make} \
321         X11_CFLAGS= \
322         X11_LIBS="-lX11 -lXext"
323
324 %install
325 rm -rf $RPM_BUILD_ROOT
326 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_sysconfdir}}
327
328 %{__make} install \
329         DESTDIR=$RPM_BUILD_ROOT
330
331 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
332
333 touch $RPM_BUILD_ROOT%{_sysconfdir}/directfbrc
334
335 %clean
336 rm -rf $RPM_BUILD_ROOT
337
338 %post   -p /sbin/ldconfig
339 %postun -p /sbin/ldconfig
340
341 %files
342 %defattr(644,root,root,755)
343 %doc AUTHORS ChangeLog NEWS README TODO
344 %attr(755,root,root) %{_bindir}/dfbdump
345 %attr(755,root,root) %{_bindir}/dfbg
346 %attr(755,root,root) %{_bindir}/dfbinfo
347 %attr(755,root,root) %{_bindir}/dfbinput
348 %attr(755,root,root) %{_bindir}/dfblayer
349 %attr(755,root,root) %{_bindir}/dfbpenmount
350 %attr(755,root,root) %{_bindir}/dfbproxy
351 %attr(755,root,root) %{_bindir}/dfbscreen
352 %attr(755,root,root) %{_bindir}/dfbsummon
353 %attr(755,root,root) %{_bindir}/mkdfiff
354 %attr(755,root,root) %{_bindir}/mkdgiff
355 %attr(755,root,root) %{_bindir}/uwmdump
356 %attr(755,root,root) %{_libdir}/libdirect-*.so.*.*.*
357 %attr(755,root,root) %{_libdir}/libdirectfb-*.so.*.*.*
358 %attr(755,root,root) %{_libdir}/libfusion-*.so.*.*.*
359 %attr(755,root,root) %{_libdir}/libuniquewm-*.so.*.*.*
360 %attr(755,root,root) %{_libdir}/libvoodoo-*.so.*.*.*
361 %dir %{dfbdir}
362 %dir %{dfbdir}/gfxdrivers
363 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
364 %dir %{dfbdir}/inputdrivers
365 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
366 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
367 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_linux_input.so
368 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
369 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_penmount.so
370 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
371 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
372 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
373 %dir %{dfbdir}/interfaces
374 %dir %{dfbdir}/interfaces/IDirectFB
375 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFB/lib*.so
376 %dir %{dfbdir}/interfaces/IDirectFBDataBuffer
377 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDataBuffer/lib*.so
378 %dir %{dfbdir}/interfaces/IDirectFBDisplayLayer
379 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDisplayLayer/lib*.so
380 %dir %{dfbdir}/interfaces/IDirectFBEventBuffer
381 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBEventBuffer/lib*.so
382 %dir %{dfbdir}/interfaces/IDirectFBFont
383 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
384 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dgiff.so
385 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dispatcher.so
386 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_requestor.so
387 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
388 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.so
389 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dispatcher.so
390 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
391 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
392 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_requestor.so
393 %dir %{dfbdir}/interfaces/IDirectFBInputDevice
394 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBInputDevice/lib*.so
395 %dir %{dfbdir}/interfaces/IDirectFBPalette
396 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBPalette/lib*.so
397 %dir %{dfbdir}/interfaces/IDirectFBScreen
398 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBScreen/lib*.so
399 %dir %{dfbdir}/interfaces/IDirectFBSurface
400 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBSurface/lib*.so
401 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
402 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.so
403 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
404 %dir %{dfbdir}/interfaces/IDirectFBWindow
405 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBWindow/lib*.so
406 %dir %{dfbdir}/systems
407 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
408 %dir %{dfbdir}/wm
409 %attr(755,root,root) %{dfbdir}/wm/*.so
410 %{_datadir}/directfb-%{version}
411 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/directfbrc
412 %{_mandir}/man1/dfbg.1*
413 %{_mandir}/man5/*
414
415 %files devel
416 %defattr(644,root,root,755)
417 %attr(755,root,root) %{_bindir}/directfb-config
418 %attr(755,root,root) %{_bindir}/directfb-csource
419 %attr(755,root,root) %{_libdir}/libdirect.so
420 %attr(755,root,root) %{_libdir}/libdirectfb.so
421 %attr(755,root,root) %{_libdir}/libfusion.so
422 %attr(755,root,root) %{_libdir}/libuniquewm.so
423 %attr(755,root,root) %{_libdir}/libvoodoo.so
424 %{_libdir}/libdirect.la
425 %{_libdir}/libdirectfb.la
426 %{_libdir}/libfusion.la
427 %{_libdir}/libuniquewm.la
428 %{_libdir}/libvoodoo.la
429 %{_includedir}/directfb
430 %{_includedir}/directfb-internal
431 %{_pkgconfigdir}/*.pc
432 %{_mandir}/man1/directfb-csource.1*
433
434 %files static
435 %defattr(644,root,root,755)
436 %{_libdir}/lib*.a
437 %{dfbdir}/gfxdrivers/*.[alo]*
438 %{dfbdir}/inputdrivers/*.[alo]*
439 %{dfbdir}/interfaces/*/*.[alo]*
440 %{dfbdir}/systems/*.[alo]*
441 %{dfbdir}/wm/*.[alo]*
442
443 %files doc
444 %defattr(644,root,root,755)
445 %doc docs/html/*.{html,png}
446 %{_examplesdir}/%{name}-%{version}
447
448 %files core-sdl
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
451 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
452
453 %files core-vnc
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_vncinput.so
456 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_vnc.so
457
458 %files core-x11
459 %defattr(644,root,root,755)
460 %doc systems/x11/README
461 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_x11input.so
462 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_x11.so
463
464 %files font-ft2
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
467
468 %files image-jpeg
469 %defattr(644,root,root,755)
470 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
471
472 %files image-png
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
475
476 %files input-dynapro
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_dynapro.so
479
480 %files input-elo
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_elo.so
483
484 %files input-gunze
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_gunze.so
487
488 %files input-mutouch
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_mutouch.so
491
492 %files input-ucb1x00
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ucb1x00_ts.so
495
496 %files input-wm97xx
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_wm97xx_ts.so
This page took 0.070509 seconds and 4 git commands to generate.