]> git.pld-linux.org Git - packages/DirectFB-extra.git/blob - DirectFB-extra.spec
- added updates patch (from dfb CVS) to build with 0.9.20 API
[packages/DirectFB-extra.git] / DirectFB-extra.spec
1 #
2 # Conditional build:
3 %bcond_without  flash   # don't build FLASH video provider
4 #
5 Summary:        Additional providers and drivers for DirectFB
6 Summary(pl):    DirectFB - dodatkowe wtyczki i sterowniki do DirectFB
7 Name:           DirectFB-extra
8 Version:        0.9.16
9 Release:        2
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://www.directfb.org/download/DirectFB-extra/%{name}-%{version}.tar.gz
13 # Source0-md5:  e5084d213dfd309987d139f816930340
14 Patch0:         %{name}-acfix.patch
15 Patch1:         %{name}-updates.patch
16 URL:            http://www.directfb.org/
17 #BuildRequires: DirectFB-devel >= %{version}
18 BuildRequires:  DirectFB-devel >= 0.9.20
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_flash:BuildRequires:    flash-devel >= 0.4.10-5}
22 BuildRequires:  imlib2-devel
23 BuildRequires:  libtool
24 BuildRequires:  openquicktime-devel
25 BuildRequires:  pkgconfig >= 0.5
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         dfbdir          %(pkg-config --variable=moduledir directfb-internal)
29
30 %description
31 This package contains additional image/video/font providers and
32 graphics/input drivers (currently Imlib2 image provider and
33 OpenQuicktime video provider).
34
35 %description -l pl
36 Ten pakiet zawiera dodatkowe wtyczki dostarczaj±ce grafikê, obraz i
37 fonty oraz sterowniki grafiki i wej¶ciowe (aktualnie: wtyczkê
38 dostarczaj±c± grafikê poprzez Imlib2 oraz wtyczkê dostarczaj±c± obraz
39 OpenQuicktime).
40
41 %package -n DirectFB-image-imlib2
42 Summary:        Imlib2 image provider for DirectFB
43 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê poprzez Imlib2
44 Group:          Libraries
45 %requires_eq    DirectFB
46
47 %description -n DirectFB-image-imlib2
48 This package contains image provider based on Imlib2 for DirectFB.
49
50 %description -n DirectFB-image-imlib2 -l pl
51 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê poprzez
52 bibliotekê Imlib2.
53
54 %package -n DirectFB-video-openquicktime
55 Summary:        OpenQuicktime video provider for DirectFB
56 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz OpenQuicktime
57 Group:          Libraries
58 %requires_eq    DirectFB
59
60 %description -n DirectFB-video-openquicktime
61 This package contains OpenQuicktime video provider for DirectFB.
62
63 %description -n DirectFB-video-openquicktime -l pl
64 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± obraz
65 OpenQuicktime.
66
67 %package -n DirectFB-video-swf
68 Summary:        ShockWave Flash video provider for DirectFB
69 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz ShockWave Flash
70 Group:          Libraries
71 %requires_eq    DirectFB
72
73 %description -n DirectFB-video-swf
74 This package contains SWF (ShockWave Flash) video provider for
75 DirectFB. It uses flash library.
76
77 %description -n DirectFB-video-swf -l pl
78 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± obraz SWF
79 (ShockWave Flash) przy u¿yciu biblioteki flash.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85
86 %build
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 # paths for libflash
93 CPPFLAGS="-I/usr/X11R6/include"
94 LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
95 %configure \
96         --disable-avifile \
97         %{!?with_flash:--disable-flash}
98
99 %{__make} \
100         MODULEDIR=%{dfbdir}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         MODULEDIR=%{dfbdir}
108
109 rm -f $RPM_BUILD_ROOT%{dfbdir}/interfaces/*/*.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files -n DirectFB-image-imlib2
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog README
117 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_imlib2.so
118
119 %files -n DirectFB-video-openquicktime
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog README
122 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_openquicktime.so
123
124 %if %{with flash}
125 %files -n DirectFB-video-swf
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swf.so
128 %endif
This page took 0.067866 seconds and 4 git commands to generate.