]> git.pld-linux.org Git - packages/CGAL.git/blob - CGAL.spec
- qt3 parts has been removed in 4.8
[packages/CGAL.git] / CGAL.spec
1 # TODO
2 # - optflags
3 # - move qt stuff to subpackages?
4 #
5 # Conditional build:
6 %bcond_with     examples        # demo+examples build
7
8 %define boost_ver       1.48
9 %define qt5_ver         5.3
10 Summary:        Computational Geometry Algorithms Library
11 Summary(pl.UTF-8):      Computational Geometry Algorithms Library - biblioteka algorytmów geometrii obliczeniowej
12 Name:           CGAL
13 Version:        4.9
14 Release:        1
15 License:        GPL v3+ and LGPL v3+
16 Group:          Libraries
17 Source0:        https://github.com/CGAL/releases/archive/%{name}-%{version}.tar.gz
18 # Source0-md5:  eea6dbcaecac52f42124572d839d0e5b
19 Patch0:         %{name}-buildtype.patch
20 URL:            http://www.cgal.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  Qt5Core-devel >= %{qt5_ver}
23 BuildRequires:  Qt5Gui-devel >= %{qt5_ver}
24 BuildRequires:  Qt5OpenGL-devel >= %{qt5_ver}
25 BuildRequires:  Qt5Svg-devel >= %{qt5_ver}
26 BuildRequires:  Qt5Widgets-devel >= %{qt5_ver}
27 BuildRequires:  boost-devel >= %{boost_ver}
28 BuildRequires:  cmake >= 2.8.11
29 BuildRequires:  gmp-devel >= 4.1.4
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  mpfr-devel >= 2.2.1
32 BuildRequires:  qt5-build >= %{qt5_ver}
33 BuildRequires:  qt5-qmake >= %{qt5_ver}
34 BuildRequires:  rpmbuild(macros) >= 1.605
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  zlib-devel
37 %if %{with examples}
38 BuildRequires:  blas-devel
39 BuildRequires:  eigen3 >= 3.1.91
40 BuildRequires:  gmp-c++-devel >= 4.1.4
41 BuildRequires:  lapack-devel
42 BuildRequires:  tbb
43 #TODO: mpfi QGLViewer ipelib 
44 %endif
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Libraries for CGAL applications. CGAL is a collaborative effort of
49 several sites in Europe and Israel. The goal is to make the most
50 important of the solutions and methods developed in computational
51 geometry available to users in industry and academia in a C++ library.
52 The goal is to provide easy access to useful, reliable geometric
53 algorithms.
54
55 %description -l pl.UTF-8
56 Biblioteka dla aplikacji CGAL (Computational Geometry Algorithms
57 Library). CGAL to wspólny projekt kilku placówek w Europie i Izraelu.
58 Celem jest udostępnienie najważniejszych rozwiązań i metod powstałych
59 w geometrii obliczeniowej dla użytkowników przemysłowych i naukowych w
60 postaci biblioteki C++. Ma ona za zadanie zapewniać łatwy dostęp do
61 przydatnych, wiarygodnych algorytmów geometrycznych.
62
63 %package devel
64 Summary:        Development files and tools for CGAL applications
65 Summary(pl.UTF-8):      Pliki i narzędzia programistyczne dla aplikacji CGAL
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       boost-devel >= %{boost_ver}
69 Requires:       libstdc++-devel
70 # for Qt5 component
71 Requires:       Qt5Core-devel >= %{qt5_ver}
72 Requires:       Qt5Gui-devel >= %{qt5_ver}
73 Requires:       Qt5OpenGL-devel >= %{qt5_ver}
74 Requires:       Qt5Widgets-devel >= %{qt5_ver}
75 # CGAL header interfaces for (using their headers) - use Suggests?
76 Requires:       gmp-c++-devel >= 4.1.4
77 Requires:       gmp-devel >= 4.1.4
78 Requires:       mpfr-devel >= 2.2.1
79 #Suggests: eigen3 >= 3.1 gsl-devel tbb-devel vtk-devel
80 #Suggests(TODO): <rs_exports.h> <rs3_fncts.h> <taucs.h> <OpenMesh/Core/Mesh/PolyMesh_ArrayKernelT.hh> <NTL/ZZX.h> <mpfi.h> <LEDA/*.h> <ipelib.h>
81 Requires:       zlib-devel
82 # CGAL header interfaces for (without using their headers) - use Suggests?
83 Requires:       blas-devel
84 Requires:       lapack-devel
85
86 %description devel
87 This package provides the header files and tools you may need to
88 develop applications using CGAL.
89
90 %description devel -l pl.UTF-8
91 Ten pakiet zawiera pliki nagłówkowe i narzędzia potrzebne do tworzenia
92 aplikacji wykorzystujących CGAL.
93
94 %package demos-source
95 Summary:        Examples and demos of CGAL algorithms
96 Summary(pl.UTF-8):      Przykłady i programy demonstracyjne do algorytmów CGAL
97 Group:          Documentation
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description demos-source
101 This package provides the sources of examples and demos of CGAL
102 algorithms.
103
104 %description demos-source -l pl.UTF-8
105 Ten pakiet zawiera kod źrodłowy programów przykładowych i
106 demonstracyjnych do algorytmów CGAL.
107
108 %prep
109 %setup -q -n releases-%{name}-%{version}
110 %patch0 -p1
111
112 %build
113 install -d build
114 cd build
115 # override build type, because:
116 # PLD is not a valid build type: only Release or Debug is allowed
117 %cmake .. \
118         -DCGAL_CXX_FLAGS="%{rpmcxxflags} %{rpmcppflags}" \
119         -DCGAL_SHARED_LINKER_FLAGS="%{rpmldflags}" \
120         -DCGAL_INSTALL_LIB_DIR=%{_lib} \
121         -DCGAL_INSTALL_DOC_DIR= \
122 %if %{with examples}
123         -DWITH_demos=ON \
124         -DWITH_examples=ON
125 %endif
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} -C build install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 # useless in binary package
135 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{cgal_create_CMakeLists,cgal_create_cmake_script,cgal_make_macosx_app}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS CHANGES LICENSE LICENSE.BSL LICENSE.FREE_USE LICENSE.LGPL
146 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libCGAL.so.12
148 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.12
150 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.12
152 %attr(755,root,root) %{_libdir}/libCGAL_Qt5.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt5.so.12
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libCGAL.so
158 %attr(755,root,root) %{_libdir}/libCGAL_Core.so
159 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so
160 %attr(755,root,root) %{_libdir}/libCGAL_Qt5.so
161 %{_includedir}/CGAL
162 %{_libdir}/CGAL
163 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.060049 seconds and 4 git commands to generate.