]> git.pld-linux.org Git - packages/CGAL.git/blob - CGAL.spec
- update BR, why qt3?
[packages/CGAL.git] / CGAL.spec
1 # TODO
2 # - force use of qt4, otherwise it may pick qt3! add bcond?
3 # - check these:
4 #   blas-devel may be superfluous !
5 #   gmp-c++-devel may be superfluous !
6 #   lapack-devel may be superfluous !
7 # - cleanup?
8 #   warning: Installed (but unpackaged) file(s) found:
9 #   /usr/bin/cgal_make_macosx_app
10
11 %define boost_version 1.32
12 Summary:        Computational Geometry Algorithms Library
13 Name:           CGAL
14 Version:        4.6
15 Release:        1
16 License:        GPLv3+ and LGPLv3+
17 Group:          Libraries
18 Source0:        https://gforge.inria.fr/frs/download.php/file/34705/%{name}-%{version}.tar.xz
19 # Source0-md5:  65fa7e17cd654ef68da47df608000007
20 URL:            http://www.cgal.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  QtCore-devel
23 BuildRequires:  QtGui-devel
24 BuildRequires:  QtOpenGL-devel
25 BuildRequires:  QtSvg-devel
26 BuildRequires:  blas-devel
27 BuildRequires:  boost-devel >= %{boost_version}
28 BuildRequires:  cmake
29 BuildRequires:  gmp-c++-devel
30 BuildRequires:  gmp-devel
31 BuildRequires:  lapack-devel
32 BuildRequires:  mpfr-devel
33 BuildRequires:  qt4-build
34 BuildRequires:  qt4-qmake
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  zlib-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Libraries for CGAL applications. CGAL is a collaborative effort of
41 several sites in Europe and Israel. The goal is to make the most
42 important of the solutions and methods developed in computational
43 geometry available to users in industry and academia in a C++ library.
44 The goal is to provide easy access to useful, reliable geometric
45 algorithms.
46
47 %package devel
48 Summary:        Development files and tools for CGAL applications
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       blas-devel
52 Requires:       boost-devel >= %{boost_version}
53 Requires:       gmp-c++-devel
54 Requires:       gmp-devel
55 Requires:       lapack-devel
56 Requires:       mpfr-devel
57 Requires:       qt-devel
58 Requires:       zlib-devel
59
60 %description devel
61 The %{name}-devel package provides the headers files and tools you may
62 need to develop applications using CGAL.
63
64 %package demos-source
65 Summary:        Examples and demos of CGAL algorithms
66 Group:          Documentation
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description demos-source
70 The %{name}-demos-source package provides the sources of examples and
71 demos of CGAL algorithms.
72
73
74 %prep
75 %setup -q
76
77 %build
78 install -d build
79 cd build
80 # override build type, because:
81 # PLD is not a valid build type: only Release or Debug is allowed
82
83 # XXX: what is ${CHANGE_SOVERSION} here?
84 %cmake \
85         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
86         -DCGAL_INSTALL_LIB_DIR=%{_lib} \
87         -DCGAL_INSTALL_DOC_DIR= ${CHANGE_SOVERSION} \
88         ..
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %{__make} -C build install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS LICENSE LICENSE.FREE_USE LICENSE.LGPL CHANGES
106 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libCGAL.so.11
108 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.11
110 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.11
112 %attr(755,root,root) %{_libdir}/libCGAL_Qt4.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt4.so.11
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
118 %attr(755,root,root) %{_bindir}/cgal_create_cmake_script
119 %{_includedir}/CGAL
120 %{_libdir}/CGAL
121 %attr(755,root,root) %{_libdir}/libCGAL*.so
122 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.089781 seconds and 4 git commands to generate.