]> git.pld-linux.org Git - packages/CGAL.git/blob - CGAL.spec
- updated to 4.14.3
[packages/CGAL.git] / CGAL.spec
1 # TODO
2 # - move qt stuff to subpackages? (libCGAL_Qt5.so, include/CGAL/Qt, some cmake files)
3 # - MPFI (>= 1.5.2, mpfr >= 4.0.0)
4 # - LEDA, RS, RS3 (rather old, non-free; no longer available?)
5 #
6 # Conditional build:
7 %bcond_with     examples        # demo+examples build
8
9 %define boost_ver       1.48
10 %define qt5_ver         5.3
11 Summary:        Computational Geometry Algorithms Library
12 Summary(pl.UTF-8):      Computational Geometry Algorithms Library - biblioteka algorytmów geometrii obliczeniowej
13 Name:           CGAL
14 Version:        4.14.3
15 Release:        1
16 License:        GPL v3+ and LGPL v3+
17 Group:          Libraries
18 #Source0Download: https://github.com/CGAL/cgal/releases
19 Source0:        https://github.com/CGAL/cgal/releases/download/releases/%{name}-%{version}/%{name}-%{version}.tar.xz
20 # Source0-md5:  41c56ad048ce882aae6ff5b56256fe95
21 Patch0:         %{name}-buildtype.patch
22 URL:            https://www.cgal.org/
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  Qt5Core-devel >= %{qt5_ver}
25 BuildRequires:  Qt5Gui-devel >= %{qt5_ver}
26 BuildRequires:  Qt5OpenGL-devel >= %{qt5_ver}
27 BuildRequires:  Qt5Svg-devel >= %{qt5_ver}
28 BuildRequires:  Qt5Widgets-devel >= %{qt5_ver}
29 BuildRequires:  boost-devel >= %{boost_ver}
30 BuildRequires:  cmake >= 3.1
31 BuildRequires:  gmp-devel >= 4.1.4
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  mpfr-devel >= 2.2.1
34 BuildRequires:  qt5-build >= %{qt5_ver}
35 BuildRequires:  qt5-qmake >= %{qt5_ver}
36 BuildRequires:  rpmbuild(macros) >= 1.605
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  sed >= 4.0
39 BuildRequires:  xz
40 BuildRequires:  zlib-devel
41 %if %{with examples}
42 BuildRequires:  blas-devel
43 BuildRequires:  eigen3 >= 3.1.91
44 BuildRequires:  gmp-c++-devel >= 4.1.4
45 BuildRequires:  ipe-devel >= 7
46 BuildRequires:  lapack-devel
47 BuildRequires:  tbb
48 %endif
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Libraries for CGAL applications. CGAL is a collaborative effort of
53 several sites in Europe and Israel. The goal is to make the most
54 important of the solutions and methods developed in computational
55 geometry available to users in industry and academia in a C++ library.
56 The goal is to provide easy access to useful, reliable geometric
57 algorithms.
58
59 %description -l pl.UTF-8
60 Biblioteka dla aplikacji CGAL (Computational Geometry Algorithms
61 Library). CGAL to wspólny projekt kilku placówek w Europie i Izraelu.
62 Celem jest udostępnienie najważniejszych rozwiązań i metod powstałych
63 w geometrii obliczeniowej dla użytkowników przemysłowych i naukowych w
64 postaci biblioteki C++. Ma ona za zadanie zapewniać łatwy dostęp do
65 przydatnych, wiarygodnych algorytmów geometrycznych.
66
67 %package devel
68 Summary:        Development files and tools for CGAL applications
69 Summary(pl.UTF-8):      Pliki i narzędzia programistyczne dla aplikacji CGAL
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       boost-devel >= %{boost_ver}
73 Requires:       libstdc++-devel
74 # for Qt5 component
75 Requires:       Qt5Core-devel >= %{qt5_ver}
76 Requires:       Qt5Gui-devel >= %{qt5_ver}
77 Requires:       Qt5OpenGL-devel >= %{qt5_ver}
78 Requires:       Qt5Widgets-devel >= %{qt5_ver}
79 # CGAL header interfaces for (using their headers) - use Suggests?
80 Requires:       gmp-c++-devel >= 4.1.4
81 Requires:       gmp-devel >= 4.1.4
82 Requires:       mpfr-devel >= 2.2.1
83 #Suggests: eigen3 >= 3.1 gsl-devel tbb-devel vtk-devel
84 #Suggests(TODO): <rs_exports.h> <rs3_fncts.h> <taucs.h> <OpenMesh/Core/Mesh/PolyMesh_ArrayKernelT.hh> <NTL/ZZX.h> <mpfi.h> <LEDA/*.h> <ipelib.h>
85 Requires:       zlib-devel
86 # CGAL header interfaces for (without using their headers) - use Suggests?
87 Requires:       blas-devel
88 Requires:       lapack-devel
89
90 %description devel
91 This package provides the header files and tools you may need to
92 develop applications using CGAL.
93
94 %description devel -l pl.UTF-8
95 Ten pakiet zawiera pliki nagłówkowe i narzędzia potrzebne do tworzenia
96 aplikacji wykorzystujących CGAL.
97
98 %package demos-source
99 Summary:        Examples and demos of CGAL algorithms
100 Summary(pl.UTF-8):      Przykłady i programy demonstracyjne do algorytmów CGAL
101 Group:          Documentation
102 Requires:       %{name}-devel = %{version}-%{release}
103
104 %description demos-source
105 This package provides the sources of examples and demos of CGAL
106 algorithms.
107
108 %description demos-source -l pl.UTF-8
109 Ten pakiet zawiera kod źrodłowy programów przykładowych i
110 demonstracyjnych do algorytmów CGAL.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 install -d build
118 cd build
119 %cmake .. \
120         -DCGAL_CXX_FLAGS="%{rpmcxxflags} %{rpmcppflags}" \
121         -DCGAL_SHARED_LINKER_FLAGS="%{rpmldflags}" \
122         -DCGAL_INSTALL_LIB_DIR=%{_lib} \
123         -DCGAL_INSTALL_DOC_DIR= \
124 %if %{with examples}
125         -DWITH_demos=ON \
126         -DWITH_examples=ON
127 %endif
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} -C build install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 # useless for Linux
138 %{__rm} $RPM_BUILD_ROOT%{_bindir}/cgal_make_macosx_app
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS CHANGES.md LICENSE LICENSE.BSL LICENSE.FREE_USE README
149 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libCGAL.so.13
151 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.13
153 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.14
155 %attr(755,root,root) %{_libdir}/libCGAL_Qt5.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt5.so.14
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
161 %attr(755,root,root) %{_bindir}/cgal_create_cmake_script
162 %attr(755,root,root) %{_libdir}/libCGAL.so
163 %attr(755,root,root) %{_libdir}/libCGAL_Core.so
164 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so
165 %attr(755,root,root) %{_libdir}/libCGAL_Qt5.so
166 %{_includedir}/CGAL
167 %{_libdir}/cmake/CGAL
168 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.042453 seconds and 4 git commands to generate.