]> git.pld-linux.org Git - packages/CGAL.git/blob - CGAL.spec
ba7abb80d61a4e090738a1e9c714743c91bef19c
[packages/CGAL.git] / CGAL.spec
1 # TODO
2 # - force use of qt5, otherwise it may pick qt4! add bcond?
3 # - check these:
4 #   blas-devel may be superfluous !
5 #   gmp-c++-devel may be superfluous !
6 #   lapack-devel may be superfluous !
7 # - cleanup?
8 #   warning: Installed (but unpackaged) file(s) found:
9 #   /usr/bin/cgal_make_macosx_app
10 # - move qt stuff to subpackages?
11
12 %define boost_version 1.32
13 Summary:        Computational Geometry Algorithms Library
14 Summary(pl.UTF-8):      Computational Geometry Algorithms Library - biblioteka algorytmów geometrii obliczeniowej
15 Name:           CGAL
16 Version:        4.7
17 Release:        1
18 License:        GPLv3+ and LGPLv3+
19 Group:          Libraries
20 Source0:        https://github.com/CGAL/releases/archive/%{name}-%{version}.tar.gz
21 # Source0-md5:  50b29d3f3372cd93aaa31d01f0e45036
22 URL:            http://www.cgal.org/
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  Qt5Core-devel
25 BuildRequires:  Qt5Gui-devel
26 BuildRequires:  Qt5OpenGL-devel
27 BuildRequires:  Qt5Svg-devel
28 BuildRequires:  blas-devel
29 BuildRequires:  boost-devel >= %{boost_version}
30 BuildRequires:  cmake
31 BuildRequires:  gmp-c++-devel
32 BuildRequires:  gmp-devel
33 BuildRequires:  lapack-devel
34 BuildRequires:  mpfr-devel
35 BuildRequires:  qt4-build
36 BuildRequires:  qt4-qmake
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Libraries for CGAL applications. CGAL is a collaborative effort of
43 several sites in Europe and Israel. The goal is to make the most
44 important of the solutions and methods developed in computational
45 geometry available to users in industry and academia in a C++ library.
46 The goal is to provide easy access to useful, reliable geometric
47 algorithms.
48
49 %description -l pl.UTF-8
50 Biblioteka dla aplikacji CGAL (Computational Geometry Algorithms
51 Library). CGAL to wspólny projekt kilku placówek w Europie i Izraelu.
52 Celem jest udostępnienie najważniejszych rozwiązań i metod powstałych
53 w geometrii obliczeniowej dla użytkowników przemysłowych i naukowych w
54 postaci biblioteki C++. Ma ona za zadanie zapewniać łatwy dostęp do
55 przydatnych, wiarygodnych algorytmów geometrycznych.
56
57 %package devel
58 Summary:        Development files and tools for CGAL applications
59 Summary(pl.UTF-8):      Pliki i narzędzia programistyczne dla aplikacji CGAL
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       blas-devel
63 Requires:       boost-devel >= %{boost_version}
64 Requires:       gmp-c++-devel
65 Requires:       gmp-devel
66 Requires:       lapack-devel
67 Requires:       mpfr-devel
68 Requires:       qt-devel
69 Requires:       zlib-devel
70
71 %description devel
72 This package provides the header files and tools you may need to
73 develop applications using CGAL.
74
75 %description devel -l pl.UTF-8
76 Ten pakiet zawiera pliki nagłówkowe i narzędzia potrzebne do tworzenia
77 aplikacji wykorzystujących CGAL.
78
79 %package demos-source
80 Summary:        Examples and demos of CGAL algorithms
81 Summary(pl.UTF-8):      Przykłady i programy demonstracyjne do algorytmów CGAL
82 Group:          Documentation
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description demos-source
86 This package provides the sources of examples and demos of CGAL
87 algorithms.
88
89 %description demos-source -l pl.UTF-8
90 Ten pakiet zawiera kod źrodłowy programów przykładowych i
91 demonstracyjnych do algorytmów CGAL.
92
93 %prep
94 %setup -q -n releases-%{name}-%{version}
95
96 %build
97 install -d build
98 cd build
99 # override build type, because:
100 # PLD is not a valid build type: only Release or Debug is allowed
101
102 # XXX: what is ${CHANGE_SOVERSION} here?
103 %cmake \
104         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
105         -DCGAL_INSTALL_LIB_DIR=%{_lib} \
106         -DCGAL_INSTALL_DOC_DIR= ${CHANGE_SOVERSION} \
107         ..
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 %{__make} -C build install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS LICENSE LICENSE.FREE_USE LICENSE.LGPL CHANGES
125 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libCGAL.so.11
127 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.11
129 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.11
131 %attr(755,root,root) %{_libdir}/libCGAL_Qt5.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt5.so.11
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
137 %attr(755,root,root) %{_bindir}/cgal_create_cmake_script
138 %attr(755,root,root) %{_libdir}/libCGAL*.so
139 %{_includedir}/CGAL
140 %{_libdir}/CGAL
141 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.031073 seconds and 3 git commands to generate.