]> git.pld-linux.org Git - packages/CGAL.git/blob - CGAL.spec
qt split?
[packages/CGAL.git] / CGAL.spec
1 # TODO
2 # - force use of qt4, otherwise it may pick qt3! add bcond?
3 # - check these:
4 #   blas-devel may be superfluous !
5 #   gmp-c++-devel may be superfluous !
6 #   lapack-devel may be superfluous !
7 # - cleanup?
8 #   warning: Installed (but unpackaged) file(s) found:
9 #   /usr/bin/cgal_make_macosx_app
10 # - move qt stuff to subpackages?
11
12 %define boost_version 1.32
13 Summary:        Computational Geometry Algorithms Library
14 Name:           CGAL
15 Version:        4.6
16 Release:        1
17 License:        GPLv3+ and LGPLv3+
18 Group:          Libraries
19 Source0:        https://gforge.inria.fr/frs/download.php/file/34705/%{name}-%{version}.tar.xz
20 # Source0-md5:  65fa7e17cd654ef68da47df608000007
21 URL:            http://www.cgal.org/
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  QtCore-devel
24 BuildRequires:  QtGui-devel
25 BuildRequires:  QtOpenGL-devel
26 BuildRequires:  QtSvg-devel
27 BuildRequires:  blas-devel
28 BuildRequires:  boost-devel >= %{boost_version}
29 BuildRequires:  cmake
30 BuildRequires:  gmp-c++-devel
31 BuildRequires:  gmp-devel
32 BuildRequires:  lapack-devel
33 BuildRequires:  mpfr-devel
34 BuildRequires:  qt4-build
35 BuildRequires:  qt4-qmake
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  zlib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Libraries for CGAL applications. CGAL is a collaborative effort of
42 several sites in Europe and Israel. The goal is to make the most
43 important of the solutions and methods developed in computational
44 geometry available to users in industry and academia in a C++ library.
45 The goal is to provide easy access to useful, reliable geometric
46 algorithms.
47
48 %package devel
49 Summary:        Development files and tools for CGAL applications
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       blas-devel
53 Requires:       boost-devel >= %{boost_version}
54 Requires:       gmp-c++-devel
55 Requires:       gmp-devel
56 Requires:       lapack-devel
57 Requires:       mpfr-devel
58 Requires:       qt-devel
59 Requires:       zlib-devel
60
61 %description devel
62 The %{name}-devel package provides the headers files and tools you may
63 need to develop applications using CGAL.
64
65 %package demos-source
66 Summary:        Examples and demos of CGAL algorithms
67 Group:          Documentation
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description demos-source
71 The %{name}-demos-source package provides the sources of examples and
72 demos of CGAL algorithms.
73
74 %prep
75 %setup -q
76
77 %build
78 install -d build
79 cd build
80 # override build type, because:
81 # PLD is not a valid build type: only Release or Debug is allowed
82
83 # XXX: what is ${CHANGE_SOVERSION} here?
84 %cmake \
85         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
86         -DCGAL_INSTALL_LIB_DIR=%{_lib} \
87         -DCGAL_INSTALL_DOC_DIR= ${CHANGE_SOVERSION} \
88         ..
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %{__make} -C build install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS LICENSE LICENSE.FREE_USE LICENSE.LGPL CHANGES
106 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libCGAL.so.11
108 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.11
110 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.11
112 %attr(755,root,root) %{_libdir}/libCGAL_Qt4.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt4.so.11
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
118 %attr(755,root,root) %{_bindir}/cgal_create_cmake_script
119 %{_includedir}/CGAL
120 %{_libdir}/CGAL
121 %attr(755,root,root) %{_libdir}/libCGAL*.so
122 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.036903 seconds and 3 git commands to generate.