]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- use more macros, some cosmetics, added missing "rm -f missing" and use new %doc
[packages/Atlas-C++.git] / Atlas-C++.spec
1 Summary:        C++ reference implementation of the Atlas protocol
2 Summary(pl):    Implementacja protoko³u Atlas
3 Name:           Atlas-C++
4 Version:        0.4.4
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/%{name}-%{version}.tar.gz
9 BuildRequires:  autoconf
10 BuildRequires:  automake
11 BuildRequires:  libtool
12 BuildRequires:  libstdc++-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
17 communications layer designed to be used in the WorldForge MMORPG
18 gaming system. This library is suitable for linking to either clients
19 xor servers.
20
21 %description -l pl
22 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
23 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
24 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
25
26 %package devel
27 Summary:        Header files for Atlas-C++ development
28 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}
31 Requires:       libstdc++-devel
32
33 %description devel
34 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
35 communications layer designed to be used in the WorldForge MMORPG
36 gaming system. This library is suitable for linking to either clients
37 or servers.
38
39 This package contains the header files needed to develop programs that
40 use these Atlas-C++
41
42 %description devel -l pl
43 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
44 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
45 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
46
47 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
48 u¿ywaj±cych bibliotek Atlas-C++.
49
50 %package static
51 Summary:        Static libraries for Atlas-C++ development
52 Summary(pl):    Statyczne biblioteki Atlas-C++
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
58 communications layer designed to be used in the WorldForge MMORPG
59 gaming system. This library is suitable for linking to either clients
60 or servers.
61
62 This package contains the static Atlas-C++ libraries.
63
64 %description static -l pl
65 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
66 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
67 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
68
69 Pakiet zawiera statyczne biblioteki Atlas-C++.
70
71 %prep
72 %setup -q
73
74 %build
75 rm -f missing
76 %{__aclocal}
77 %{__autoheader}
78 %{__libtoolize}
79 %{__automake}
80 %{__autoconf}
81 %configure
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS ChangeLog NEWS README
98 %attr(755,root,root) %{_libdir}/lib*.so.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_bindir}/atlas-config
103 %{_includedir}/Atlas
104 %attr(755,root,root) %{_libdir}/lib*.la
105 %{_libdir}/lib*.so
106 %{_aclocaldir}/atlas.m4
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/lib*.a
This page took 0.079762 seconds and 4 git commands to generate.