]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- R: pkgconfig for -devel
[packages/Atlas-C++.git] / Atlas-C++.spec
1 Summary:        C++ reference implementation of the Atlas protocol
2 Summary(pl):    Implementacja protoko³u Atlas
3 Name:           Atlas-C++
4 Version:        0.4.6
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        ftp://ftp.worldforge.org/pub/worldforge/libs/Atlas-C++/%{name}-%{version}.tar.bz2
9 # Source0-md5:  5ef0a12001d3924baa2742171af31ed3
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  libtool >= 2:1.5
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
18 communications layer designed to be used in the WorldForge MMORPG
19 gaming system. This library is suitable for linking to either clients
20 xor servers.
21
22 %description -l pl
23 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
24 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
25 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
26
27 %package devel
28 Summary:        Header files for Atlas-C++ development
29 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       libstdc++-devel
33 Requires:       pkgconfig
34
35 %description devel
36 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
37 communications layer designed to be used in the WorldForge MMORPG
38 gaming system. This library is suitable for linking to either clients
39 or servers.
40
41 This package contains the header files needed to develop programs that
42 use these Atlas-C++
43
44 %description devel -l pl
45 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
46 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
47 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
48
49 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
50 u¿ywaj±cych bibliotek Atlas-C++.
51
52 %package static
53 Summary:        Static libraries for Atlas-C++ development
54 Summary(pl):    Statyczne biblioteki Atlas-C++
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
60 communications layer designed to be used in the WorldForge MMORPG
61 gaming system. This library is suitable for linking to either clients
62 or servers.
63
64 This package contains the static Atlas-C++ libraries.
65
66 %description static -l pl
67 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
68 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
69 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
70
71 Pakiet zawiera statyczne biblioteki Atlas-C++.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoheader}
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         --enable-static
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS ChangeLog NEWS README
101 %attr(755,root,root) %{_libdir}/lib*.so.*.*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/atlas-config
106 %attr(755,root,root) %{_libdir}/lib*.so
107 %{_libdir}/lib*.la
108 %{_includedir}/Atlas*
109 %{_aclocaldir}/atlas.m4
110 %{_pkgconfigdir}/atlascpp*.pc
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.a
This page took 0.06973 seconds and 4 git commands to generate.