]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- xor->or ;)
[packages/Atlas-C++.git] / Atlas-C++.spec
1 # TODO:
2 # add tutorial subpackage
3 # libAtlasFilters.so should be linked with -lz -lbz2
4 Summary:        C++ reference implementation of the Atlas protocol
5 Summary(pl):    Implementacja protoko³u Atlas
6 Name:           Atlas-C++
7 Version:        0.6.0rc2
8 Release:        0.2
9 License:        LGPL
10 Group:          Libraries
11 Source0:        http://dl.sourceforge.net/worldforge/%{name}-%{version}.tar.bz2
12 # Source0-md5:  4b1d3094f17bb01a9460278897dc17cd
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  bzip2-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
23 communications layer designed to be used in the WorldForge MMORPG
24 gaming system. This library is suitable for linking to either clients
25 or servers.
26
27 %description -l pl
28 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
29 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
30 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
31
32 %package devel
33 Summary:        Header files for Atlas-C++ development
34 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38
39 %description devel
40 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
41 communications layer designed to be used in the WorldForge MMORPG
42 gaming system. This library is suitable for linking to either clients
43 or servers.
44
45 This package contains the header files needed to develop programs that
46 use these Atlas-C++
47
48 %description devel -l pl
49 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
50 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
51 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
52
53 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
54 u¿ywaj±cych bibliotek Atlas-C++.
55
56 %package static
57 Summary:        Static libraries for Atlas-C++ development
58 Summary(pl):    Statyczne biblioteki Atlas-C++
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
64 communications layer designed to be used in the WorldForge MMORPG
65 gaming system. This library is suitable for linking to either clients
66 or servers.
67
68 This package contains the static Atlas-C++ libraries.
69
70 %description static -l pl
71 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
72 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
73 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
74
75 Pakiet zawiera statyczne biblioteki Atlas-C++.
76
77 %prep
78 %setup -q
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoheader}
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         --enable-static
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog NEWS README
105 %attr(755,root,root) %{_bindir}/atlas_convert
106 %attr(755,root,root) %{_libdir}/libAtlas*.so.*.*.*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libAtlas*.so
111 %{_libdir}/libAtlas*.la
112 %{_includedir}/Atlas*
113 %{_pkgconfigdir}/atlascpp*.pc
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libAtlas*.a
This page took 0.04207 seconds and 4 git commands to generate.