]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
- added description to base, empty package - it's used in SRPM
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 # _with_license_agreement - with unzipped ROM files instead of xf25.zip
4 #
5 Summary:        Atari 800 Emulator
6 Summary(pl):    Emulator Atari 800
7 Name:           Atari800
8 %define         ver_short       107
9 Version:        1.0.7
10 Release:        2
11 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
12 Group:          Applications/Emulators
13 Group(de):      Applikationen/Emulators
14 Group(pl):      Aplikacje/Emulatory
15 Source0:        ftp://ftp.sophics.cz/pub/Atari800/src/a800s%{ver_short}.zip
16 # NOTE: ROMs probably can be redistributed only in original XF25 archive
17 Source1:        http://joy.sophics.cz/www/xf25.zip
18 Source2:        %{name}-chooser
19 URL:            http://atari800.atari.org/
20 BuildRequires:  unzip
21 BuildRequires:  svgalib-devel
22 BuildRequires:  XFree86-devel
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _xbindir        %{_prefix}/X11R6/bin
27
28 %description
29 This is Atari 800, 800XL, 130XE and 5200 emulator.
30
31 %description -l pl
32 To jest emulator Atari 800, 800XL, 130XE i 5200.
33
34 %package common
35 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
36 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
37 Group:          Applications/Emulators
38 Group(de):      Applikationen/Emulators
39 Group(pl):      Aplikacje/Emulatory
40 Obsoletes:      Atari800
41 %{!?_with_license_agreement:Prereq:     unzip}
42
43 %description common
44 This is Atari 800, 800XL, 130XE and 5200 emulator.
45
46 This package contains common files for both svgalib and X11 versions
47 of Atari800.
48
49 %{!?_with_license_agreement:Note: because of license problems we had to include whole X-Former}
50 %{!?_with_license_agreement:archive (xf25.zip). If you don't want it - rebuild Atari800 by:}
51 %{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld.org.pl/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
52
53 %description common -l pl
54 To jest emulator Atari 800, 800XL, 130XE i 5200.
55
56 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
57 oraz X11.
58
59 %{!?_with_license_agreement:Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê}
60 %{!?_with_license_agreement:z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -}
61 %{!?_with_license_agreement:przebuduj pakiet poleceniem:}
62 %{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld.org.pl/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
63
64 %package svga
65 Summary:        Atari 800 Emulator - svgalib version
66 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
67 Group:          Applications/Emulators
68 Group(de):      Applikationen/Emulators
69 Group(pl):      Aplikacje/Emulatory
70 License:        GPL
71 Requires:       %{name}-common = %{version}
72
73 %description svga
74 This is Atari 800, 800XL, 130XE and 5200 emulator.
75
76 This package contains Atari800 executable file configured for svgalib
77 with sound and joystick support.
78
79 %description svga -l pl
80 To jest emulator Atari 800, 800XL, 130XE i 5200.
81
82 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
83 svgalib z obs³ug± d¼wiêku i joysticka.
84
85 %package x11
86 Summary:        Atari 800 Emulator - X Window version
87 Summary(pl):    Emulator Atari 800 - wersja pod X Window
88 Group:          Applications/Emulators
89 Group(de):      Applikationen/Emulators
90 Group(pl):      Aplikacje/Emulatory
91 License:        GPL
92 Requires:       %{name}-common = %{version}
93
94 %description x11
95 This is Atari 800, 800XL, 130XE and 5200 emulator.
96
97 This package contains Atari800 executable file configured for X11 with
98 sound and joystick support.
99
100 %description x11 -l pl
101 To jest emulator Atari 800, 800XL, 130XE i 5200.
102
103 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
104 obs³ug± d¼wiêku i joysticka.
105
106 %prep
107 %setup -q
108
109 %build
110 cd src
111
112 %configure2_13 svgalib <<EOF
113 n
114 y
115 y
116 y
117 y
118 n
119 y
120 n
121 y
122 n
123 n
124 y
125 y
126 y
127 y
128 n
129 y
130 n
131 n
132 n
133 y
134 y
135 EOF
136 %{__make} \
137         CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
138         LDFLAGS="%{rpmldflags}"
139 mv -f atari800 atari800-svga
140
141 %{__make} clean
142
143 %configure2_13 x11-shm <<EOF
144 n
145 y
146 y
147 y
148 y
149 n
150 n
151 n
152 y
153 y
154 y
155 y
156 y
157 y
158 n
159 n
160 EOF
161 %{__make} \
162         CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include" \
163         LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
164 mv -f atari800 atari800-x11
165
166 sed s@/usr/local/lib/atari@%{_datadir}/atari800@g atari800.man >atari800.1
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir}} \
171         $RPM_BUILD_ROOT{%{_datadir}/atari800,%{_mandir}/man1}
172
173 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
174 install src/atari800-x11 $RPM_BUILD_ROOT%{_xbindir}
175 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
176 install src/atari800.1 $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
177
178 %if %{?_with_license_agreement:1}%{!?_with_license_agreement:0}
179 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
180 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
181 %else
182 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
183 %endif
184
185 gzip -9nf DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST \
186         DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt,usage1}
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %if %{?_with_license_agreement:0}%{!?_with_license_agreement:1}
192 %post common
193 cd %{_datadir}/atari800
194 unzip -q -L xf25.zip
195 %endif
196
197 %files common
198 %defattr(644,root,root,755)
199 %doc  *.gz DOC/*.gz
200 %{_datadir}/atari800
201 %{_mandir}/man1/atari800.1*
202 %attr(755,root,root) %{_bindir}/atari800
203
204 %files svga
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_bindir}/atari800-svga
207
208 %files x11
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_xbindir}/atari800-x11
This page took 0.05534 seconds and 3 git commands to generate.