]> git.pld-linux.org Git - packages/A3Com.git/blob - A3Com.spec
b1dd2552bc7f2b1cb9199e4bbab1233587fd0e09
[packages/A3Com.git] / A3Com.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A3Com - manipulation of 3Com SuperStack II
3 Summary(pl):    A3Com - manipulacje 3Com SuperStack II
4 Name:           A3Com
5 Version:        0.2.3
6 Release:        1
7 License:        GPL v2
8 Group:          Networking/Utilities
9 Source0:        http://www.kernel.org/pub/software/admin/A3Com/%{name}-%{version}.tar.bz2
10 URL:            http://www.kernel.org/software/A3Com/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 A3Com is a set of Perl 5 modules which allow manipulation of 3Com
15 SuperStack II 3900/9300 and CoreBuilder 3500 LAN switches. Currently
16 there are modules which can use either the SNMP or telnet interface
17 to:
18
19     - -dump the ARP tables
20     - -dump bridge tables
21     - -search switches for a MAC address, IP address, or hostname
22     - -change admin passwords in batch mode
23     - -save and restore switch configurations via SNMP
24     - -upload new firmware via SNMP (batch mode)
25     - -and collect per-port ethernet details like current autonegotiation
26       mode and duplex settings
27     - -keep global caches of ARP and bridge tables for fast searches
28     - -keep global ARP history as a merged ARP database from
29
30 %description -l pl
31
32 %prep
33 %setup -q
34
35 %build
36 # Change path for perl:
37 for i in tools/*; do
38         cat $i | sed -e "s/\/usr\/local\/bin/\%{_prefix}\/bin/" > tmp
39         mv tmp $i
40 done
41 # Change location of config:
42 for i in A3Com/*; do
43         cat $i | sed -e "s/\/usr\/local\/etc/\/etc/" > tmp
44         mv tmp $i
45 done
46
47 # Make modules:
48 perl Makefile.PL
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/A3Com,%{_sysconfdir}}
54
55 %{__make} DESTDIR=$RPM_BUILD_ROOT install
56
57 install tools/*         $RPM_BUILD_ROOT%{_bindir}
58
59 cat << EOF >$RPM_BUILD_ROOT%{_sysconfdir}/a3com.conf
60 GLOBALCACHEDIR = /var/lib/A3Com
61 EOF
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CHANGELOG TODO README test.pl
69 %attr(777,root,root) %dir /var/lib/A3Com
70 %attr(644,root,root) %{_sysconfdir}/a3com.conf
71 %attr(755,root,root) %{_bindir}/*
72 %{perl_sitelib}/A3Com/*.pm
This page took 0.055317 seconds and 2 git commands to generate.