]> git.pld-linux.org Git - packages/yaml-cpp.git/blame_incremental - yaml-cpp.spec
- updated cmake version
[packages/yaml-cpp.git] / yaml-cpp.spec
... / ...
CommitLineData
1Summary: YAML parser and emitter for C++
2Summary(pl.UTF-8): Biblioteka C++ analizująca i generująca YAML
3Name: yaml-cpp
4Version: 0.7.0
5Release: 1
6License: MIT
7Group: Libraries
8#Source0Download: https://github.com/jbeder/yaml-cpp/releases
9Source0: https://github.com/jbeder/yaml-cpp/archive/%{name}-%{version}.tar.gz
10# Source0-md5: 74d646a3cc1b5d519829441db96744f0
11Patch0: %{name}-gtest-no-install.patch
12Patch1: %{name}-cmake-config.patch
13URL: https://github.com/jbeder/yaml-cpp/
14BuildRequires: cmake >= 3.4
15BuildRequires: libstdc++-devel >= 6:4.7
16BuildRequires: rpmbuild(macros) >= 1.605
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20YAML parser and emitter for C++.
21
22%description -l pl.UTF-8
23Biblioteka C++ analizująca i generująca YAML.
24
25%package devel
26Summary: Header files for yaml-cpp library
27Summary(pl.UTF-8): Pliki nagłówkowe biblioteki yaml-cpp
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30Requires: libstdc++-devel >= 6:4.7
31
32%description devel
33Header files for yaml-cpp library.
34
35%description devel -l pl.UTF-8
36Pliki nagłówkowe biblioteki yaml-cpp.
37
38%prep
39%setup -q -n %{name}-%{name}-%{version}
40%patch0 -p1
41%patch1 -p1
42
43%build
44install -d build
45cd build
46# .pc file requires relative INCLUDEDIR, LIBDIR
47# DATADIR is used for arch-dependent .pc and cmake files
48%cmake .. \
49 -DCMAKE_INSTALL_INCLUDEDIR=include \
50 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
51 -DCMAKE_INSTALL_DATADIR=%{_lib}
52%{__make}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57%{__make} -C build install \
58 DESTDIR=$RPM_BUILD_ROOT
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%post -p /sbin/ldconfig
64%postun -p /sbin/ldconfig
65
66%files
67%defattr(644,root,root,755)
68%doc LICENSE README.md
69%attr(755,root,root) %{_libdir}/libyaml-cpp.so.*.*.*
70%attr(755,root,root) %ghost %{_libdir}/libyaml-cpp.so.0.7
71
72%files devel
73%defattr(644,root,root,755)
74%attr(755,root,root) %{_libdir}/libyaml-cpp.so
75%{_includedir}/yaml-cpp
76%{_pkgconfigdir}/yaml-cpp.pc
77%{_libdir}/cmake/yaml-cpp
This page took 0.125036 seconds and 4 git commands to generate.