]> git.pld-linux.org Git - packages/wordpress.git/blame_incremental - wordpress.spec
- converted to UTF-8
[packages/wordpress.git] / wordpress.spec
... / ...
CommitLineData
1# TODO
2# - put config files to %{_sysconfdir}!
3Summary: Personal publishing system
4Summary(pl.UTF-8): Osobisty system publikacji
5Name: wordpress
6Version: 2.0.7
7Release: 1
8License: GPL
9Group: Applications/Publishing
10Source0: http://wordpress.org/latest.tar.gz
11# Source0-md5: e377fa9389d1a06a700ac349582f498c
12Source1: wp-secure.sh
13Source2: wp-setup.sh
14Source3: wp-setup.txt
15Source4: %{name}.conf
16URL: http://wordpress.org/
17Requires: php(gettext)
18Requires: php(mysql)
19Requires: php(pcre)
20Requires: php(xml)
21Requires: php(xmlrpc)
22Requires: webapps
23Requires: webserver(php) >= 5.0
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define _appdir %{_datadir}/%{name}
28%define _webapps /etc/webapps
29%define _webapp %{name}
30%define _sysconfdir %{_webapps}/%{_webapp}
31
32%description
33WordPress is a state-of-the-art semantic personal publishing platform
34with a focus on aesthetics, web standards, and usability. WordPress
35was born out of a desire for an elegant, well-architectured personal
36publishing system (also called blog or weblog) built on PHP and MySQL
37and licensed under the GPL. It is the official successor of
38b2/cafelog. WordPress is fresh software, but its roots and development
39go back to 2001.
40
41%description -l pl.UTF-8
42WordPress jest technologicznie dopracowaną, semantyczną, osobistą
43platformą do publikacji kładącą nacisk na standardy WWW oraz
44użyteczność. WordPress został stworzony w wyniku potrzeby
45eleganckiego, dobrze zaprojektowanego, osobistego systemu publikacji
46(nazywanego również blogiem czy weblogiem). Jest to system oparty o
47PHP i MySQL oraz na licencji GPL. Jest oficjalnym następcą b2/cafelog.
48WordPress jest nowym oprogramowaniem, ale jego korzenie i rozwój
49sięgają 2001 roku.
50
51%prep
52%setup -q -n %{name}
53cp %{SOURCE1} %{SOURCE2} %{SOURCE3} .
54rm -f license.txt
55
56%install
57rm -rf $RPM_BUILD_ROOT
58install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_sysconfdir}}
59
60cp -R * $RPM_BUILD_ROOT%{_appdir}
61rm -f $RPM_BUILD_ROOT%{_appdir}/readme.html
62rm -f $RPM_BUILD_ROOT%{_appdir}/wp-setup.txt
63ln -sf %{_appdir}/wp-setup.sh $RPM_BUILD_ROOT%{_bindir}/wp-setup
64ln -sf %{_appdir}/wp-secure.sh $RPM_BUILD_ROOT%{_bindir}/wp-secure
65
66install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
67install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post
73if [ ! -f %{_appdir}/wp-config.php ]; then
74 install -uroot -ghttp -m640 %{_appdir}/wp-config-sample.php > %{_appdir}/wp-config.php
75
76 %banner -e %{name} <<-EOF
77 To finish your configuration DO NOT FORGET to:
78
79 1) Create some MySQL database owned by some user
80 2) Edit the file: %{_appdir}/wp-config.php
81 3) Run a browser and visit: http://`hostname`/wordpress/wp-admin/install.php
82EOF
83fi
84
85%triggerin -- apache1 < 1.3.37-3, apache1-base
86%webapp_register apache %{_webapp}
87
88%triggerun -- apache1 < 1.3.37-3, apache1-base
89%webapp_unregister apache %{_webapp}
90
91%triggerin -- apache < 2.2.0, apache-base
92%webapp_register httpd %{_webapp}
93
94%triggerun -- apache < 2.2.0, apache-base
95%webapp_unregister httpd %{_webapp}
96
97%files
98%defattr(644,root,root,755)
99%doc readme.html wp-setup.txt
100%dir %attr(750,root,http) %{_sysconfdir}
101%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
102%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
103
104%dir %{_appdir}
105%dir %attr(750,root,http) %{_appdir}/wp-content
106%dir %attr(750,root,http) %{_appdir}/wp-content/plugins
107%dir %attr(750,root,http) %{_appdir}/wp-content/themes
108%dir %attr(750,root,http) %{_appdir}/wp-content/themes/classic
109%dir %attr(750,root,http) %{_appdir}/wp-content/themes/default
110%attr(640,root,http) %{_appdir}/wp-content/plugins/*.php
111%attr(640,root,http) %{_appdir}/wp-content/plugins/akismet
112%attr(640,root,http) %{_appdir}/wp-content/themes/classic/*
113%attr(640,root,http) %{_appdir}/wp-content/themes/default/*.php
114%attr(640,root,http) %{_appdir}/wp-content/themes/default/*.css
115%attr(640,root,http) %{_appdir}/wp-content/themes/default/images/*
116%{_appdir}/wp-admin
117%{_appdir}/wp-includes
118%{_appdir}/*.php
119%{_appdir}/wp-secure.sh
120%{_appdir}/wp-setup.sh
121%attr(755,root,root) %{_bindir}/wp-secure
122%attr(755,root,root) %{_bindir}/wp-setup
This page took 0.275636 seconds and 4 git commands to generate.