]> git.pld-linux.org Git - packages/wesnoth.git/blame_incremental - wesnoth.spec
- rebuild with boost 1.56.0
[packages/wesnoth.git] / wesnoth.spec
... / ...
CommitLineData
1# TODO
2# - unpackaged language files
3#
4# Conditional build
5%bcond_without server # without server
6%bcond_without tools # without tools
7%bcond_without fribidi # without Bidirectional language support
8
9Summary: Strategy game with a fantasy theme
10Summary(hu.UTF-8): Fantasy környezetben játszódó stratégiai játék
11Summary(pl.UTF-8): Strategiczna gra z motywem fantasy
12Name: wesnoth
13Version: 1.10.4
14Release: 9
15Epoch: 1
16License: GPL v2+
17Group: X11/Applications/Games/Strategy
18Source0: http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
19# Source0-md5: 1a673f12e4521fc66e60ec584fa7c98f
20Source1: %{name}d.init
21Source2: %{name}.tmpfiles
22Patch0: %{name}-desktop.patch
23Patch1: %{name}-locale_dir.patch
24URL: http://www.wesnoth.org/
25BuildRequires: SDL-devel >= 1.2.14-4
26BuildRequires: SDL_image-devel >= 1.2
27BuildRequires: SDL_mixer-devel >= 1.2
28BuildRequires: SDL_net-devel >= 1.2
29BuildRequires: SDL_ttf-devel >= 2.0.8
30BuildRequires: asciidoc
31BuildRequires: boost-devel >= 1.33
32BuildRequires: cmake >= 2.4
33BuildRequires: dbus-devel
34%{?with_fribidi:BuildRequires: fribidi-devel}
35BuildRequires: gettext-devel
36BuildRequires: libpng-devel
37BuildRequires: libstdc++-devel
38BuildRequires: libvorbis-devel
39BuildRequires: lua51-devel
40BuildRequires: pango-devel
41BuildRequires: pkgconfig
42BuildRequires: rpm-pythonprov
43BuildRequires: rpmbuild(macros) >= 1.600
44BuildRequires: sed >= 4.0
45BuildRequires: zlib-devel
46Requires: %{name}-data = %{epoch}:%{version}
47Requires: SDL >= 1.2.14-4
48# sr@Latn vs. sr@latin
49Conflicts: glibc-misc < 6:2.7
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53Battle for Wesnoth is a fantasy strategy game. Battle for control of
54villages, using variety of units which have advantages and
55disadvantages in different types of terrains and against different
56types of attacks. Units gain experience and advance levels, and are
57carried over from one scenario to the next campaign.
58
59%description -l hu.UTF-8
60Battle for Wesnoth (Harc Wesnothért) egy fantasy környezetben játszódó
61stratégiai játék. Harc a falvak megszerzéséért, különböző egységek
62felhasználásával, amelyeknek különböző előnyeik és hátrányaik vannak a
63különféle terepeken és a különböző támadási stílusok ellen. Az
64egységek tapasztalatot gyűjtenek, és fejlődnek, amelyek átvihetők a
65következő pályára.
66
67%description -l pl.UTF-8
68Bitwa o Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę nad
69wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę lub
70jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym sposobom
71ataku. Oddziały zdobywają doświadczenie i poziomy zaawansowania i są
72przenoszone z jednej scenerii do następnej kampanii.
73
74%package server
75Summary: Network server for Wesnoth
76Summary(hu.UTF-8): Hálózati szerver Wesnoth-hoz
77Summary(pl.UTF-8): Sieciowy serwer dla Wesnoth
78Group: X11/Applications/Games/Strategy
79Requires(post,preun): /sbin/chkconfig
80Requires(postun): /usr/sbin/groupdel
81Requires(postun): /usr/sbin/userdel
82Requires(pre): /usr/sbin/groupadd
83Requires(pre): /usr/sbin/useradd
84Requires: rc-scripts >= 0.4.0.17
85Provides: group(wesnothd)
86Provides: user(wesnothd)
87# sr@Latn vs. sr@latin
88Conflicts: glibc-misc < 6:2.7
89
90%description server
91Server for playing networked games of Wesnoth.
92
93%description server -l hu.UTF-8
94Szerver a Wesnoth hálózati játékához.
95
96%description server -l pl.UTF-8
97Serwer do prowadzenia sieciowych gier Wesnoth.
98
99%package tools
100Summary: Tools for Wesnoth
101Summary(hu.UTF.8): Eszközök a Wesnoth-hoz
102Summary(pl.UTF-8): Narzędzia dla Wesnoth
103Group: X11/Applications/Games/Strategy
104Requires: %{name} = %{epoch}:%{version}-%{release}
105
106%description tools
107Map editor and translations tools.
108
109%description tools -l hu.UTF-8
110Pályaszerkesztők és fordítási eszközök.
111
112%description tools -l pl.UTF-8
113Edytor map i narzędzia do tłumaczeń.
114
115%package data
116Summary: Strategy game with a fantasy theme
117Group: Applications/Games
118%if "%{_rpmversion}" >= "5"
119BuildArch: noarch
120%endif
121
122%description data
123This package contains the data files for Wesnoth.
124
125%prep
126%setup -q
127%patch0 -p1
128%patch1 -p1
129
130# don't install locales in %{_datadir}/%{name}
131%{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
132
133%build
134install -d build
135cd build
136%cmake \
137 .. \
138 -DENABLE_STRICT_COMPILATION="off" \
139 -DBINDIR="%{_bindir}" \
140 -DMANDIR="%{_mandir}" \
141 -DLOCALEDIR="%{_localedir}" \
142 %{!?with_server:-DENABLE_SERVER="off"} \
143 %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
144 %{!?with_tools:-DENABLE_EDITOR="off"} \
145 %{?with_tools:-DENABLE_TOOLS="on"} \
146 %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
147
148%{__make}
149
150%install
151rm -rf $RPM_BUILD_ROOT
152install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d} \
153 $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{_docdir}/%{name}-%{version}}
154
155%{__make} -C build install \
156 DESTDIR=$RPM_BUILD_ROOT
157
158# install additional docs
159cp -p changelog README $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
160gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
161
162%if %{with server}
163cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
164cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
165%endif
166
167mv -f $RPM_BUILD_ROOT%{_localedir}/nb{_NO,}
168mv -f $RPM_BUILD_ROOT%{_localedir}/fur{_IT,}
169
170# unsupported(?)
171%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ang@latin
172%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ca_ES@valencia
173%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/la
174%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/racv
175%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@shaw
176%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavian
177%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavianlatin
178%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
179%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
180%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
181
182# the same as manuals from %{_mandir}/man?
183%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
184
185%find_lang %{name} --all-name
186
187%clean
188rm -rf $RPM_BUILD_ROOT
189
190%pre server
191%groupadd -P %{name}-server -g 178 wesnothd
192%useradd -P %{name}-server -u 178 -d /var/run/wesnothd -c "Wesnothd User" -g wesnothd wesnothd
193
194%post server
195/sbin/chkconfig --add wesnothd
196%service wesnothd restart
197
198%preun server
199if [ "$1" = "0" ]; then
200 %service wesnothd stop
201 /sbin/chkconfig --del wesnothd
202 %userremove wesnothd
203 %groupremove wesnothd
204fi
205
206%files -f %{name}.lang
207%defattr(644,root,root,755)
208%doc %{_docdir}/%{name}-%{version}
209%attr(755,root,root) %{_bindir}/wesnoth
210%{_mandir}/man6/wesnoth.6*
211%lang(cs) %{_mandir}/cs/man6/wesnoth.6*
212%lang(de) %{_mandir}/de/man6/wesnoth.6*
213%lang(et) %{_mandir}/et/man6/wesnoth.6*
214%lang(es) %{_mandir}/es/man6/wesnoth.6*
215%lang(fi) %{_mandir}/fi/man6/wesnoth.6*
216%lang(fr) %{_mandir}/fr/man6/wesnoth.6*
217%lang(gl) %{_mandir}/gl/man6/wesnoth.6*
218%lang(hu) %{_mandir}/hu/man6/wesnoth.6*
219%lang(id) %{_mandir}/id/man6/wesnoth.6*
220%lang(it) %{_mandir}/it/man6/wesnoth.6*
221%lang(lt) %{_mandir}/lt/man6/wesnoth.6*
222%lang(pl) %{_mandir}/pl/man6/wesnoth.6*
223%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
224%lang(sk) %{_mandir}/sk/man6/wesnoth.6*
225%lang(sr) %{_mandir}/sr/man6/wesnoth.6*
226%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
227%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
228%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
229%{_desktopdir}/*.desktop
230%{_pixmapsdir}/*-icon.png
231
232%if %{with server}
233%files server
234%defattr(644,root,root,755)
235%attr(755,root,root) %{_bindir}/campaignd
236%attr(755,root,root) %{_bindir}/wesnothd
237%attr(754,root,root) /etc/rc.d/init.d/wesnothd
238%{_mandir}/man6/wesnothd.6*
239%lang(cs) %{_mandir}/cs/man6/wesnothd.6*
240%lang(de) %{_mandir}/de/man6/wesnothd.6*
241%lang(es) %{_mandir}/es/man6/wesnothd.6*
242%lang(et) %{_mandir}/et/man6/wesnothd.6*
243%lang(fi) %{_mandir}/fi/man6/wesnothd.6*
244%lang(fr) %{_mandir}/fr/man6/wesnothd.6*
245%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
246%lang(hu) %{_mandir}/hu/man6/wesnothd.6*
247%lang(id) %{_mandir}/id/man6/wesnothd.6*
248%lang(it) %{_mandir}/it/man6/wesnothd.6*
249%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
250%lang(lt) %{_mandir}/lt/man6/wesnothd.6*
251%lang(pl) %{_mandir}/pl/man6/wesnothd.6*
252%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
253%lang(ru) %{_mandir}/ru/man6/wesnothd.6*
254%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
255%lang(sr) %{_mandir}/sr/man6/wesnothd.6*
256%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
257%lang(tr) %{_mandir}/tr/man6/wesnothd.6*
258%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
259%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
260%attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
261%{systemdtmpfilesdir}/%{name}.conf
262%endif
263
264%if %{with tools}
265%files tools
266%defattr(644,root,root,755)
267%attr(755,root,root) %{_bindir}/cutter
268%attr(755,root,root) %{_bindir}/exploder
269%endif
270
271%files data
272%defattr(644,root,root,755)
273%{_datadir}/%{name}
This page took 0.025027 seconds and 4 git commands to generate.