]> git.pld-linux.org Git - packages/ufoai.git/blame_incremental - ufoai.spec
- release 6 (rebuild against libpng-1.5)
[packages/ufoai.git] / ufoai.spec
... / ...
CommitLineData
1Summary: "UFO: Alien Invasion" - squad-based tactical strategy game in the tradition of the old X-COM PC games
2Summary(pl.UTF-8): "UFO: Alien Invasion" - gra strategiczna utrzymana w tradycji starych gier X-COM z PC
3Name: ufoai
4Version: 2.3.1
5Release: 6
6License: GPL
7Group: X11/Applications/Games/Strategy
8Source0: http://downloads.sourceforge.net/ufoai/%{name}-%{version}-source.tar.bz2
9# Source0-md5: 87b3e1bf3439dc6e5413936034f47d17
10Source1: %{name}.desktop
11Patch0: %{name}-link.patch
12Patch1: %{name}-libpng15.patch
13URL: http://ufoai.sourceforge.net/
14BuildRequires: OpenAL-devel
15BuildRequires: OpenGL-GLU-devel
16BuildRequires: SDL-devel
17BuildRequires: SDL_image-devel
18BuildRequires: SDL_mixer-devel
19BuildRequires: SDL_ttf-devel
20BuildRequires: curl-devel
21BuildRequires: gettext-devel
22BuildRequires: gtkglext-devel
23BuildRequires: gtksourceview2-devel
24BuildRequires: libjpeg-devel
25BuildRequires: libogg-devel
26BuildRequires: libpng-devel
27BuildRequires: libtheora-devel
28BuildRequires: libvorbis-devel
29BuildRequires: ncurses-devel
30BuildRequires: p7zip-standalone
31BuildRequires: pkgconfig
32BuildRequires: xvid-devel
33BuildRequires: zlib-devel
34Requires: ufoai-data = %{version}
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38It is the year 2084. You control a secret organisation charged with
39defending Earth from a brutal alien enemy. Build up your bases,
40prepare your team, and dive head-first into the fast and flowing
41turn-based combat.
42
43"UFO: Alien Invasion" is a squad-based tactical strategy game in the
44tradition of the old X-COM PC games, but with a twist. This game
45combines military realism with hard science-fiction and the weirdness
46of an alien invasion. The carefully constructed turn-based system
47gives you pin-point control of your squad while maintaining a sense of
48pace and danger.
49
50Over the long term you will need to conduct research into the alien
51threat to figure out their mysterious goals and use their powerful
52weapons for your own ends. You will produce unique items and use them
53in combat against your enemies. If you like, you can even use them
54against your friends with multiplayer functionality.
55
56"UFO: Alien Invasion". Endless hours of gameplay -- absolutely free.
57
58%description -l pl.UTF-8
59Jest rok 2084. Kierujesz tajną organizacją, która ma obronić Ziemię
60przed brutalnymi wrogami. Buduj swoje bazy, przygotuj swój zespół i
61rzuć się w wir szybkiej turowej walki.
62
63"UFO: Alien Invasion" to oparta o oddziały gra strategiczna utrzymana
64w tradycji starych gier X-COM z PC, ale z pewnymi zmianami. Gra łączy
65realizm militarny z ciężkim science-fiction i dziwnością inwazji
66wroga. Uważnie skonstruowany system turowy daje kontrolę nad oddziałem
67zachowując poczucie kroku i niebezpieczeństwa.
68
69W ciągu długiego czasu gracz musi prowadzić badania narażając się
70wrogom, aby odkryć ich tajemnicze cele i użyć ich potężnych broni dla
71własnych potrzeb. Gracz wytworzy unikalne przedmioty i wykorzysta je w
72walce przeciwko swoim wrogom. Można także używać ich przeciwko
73przyjaciołom w przypadku gry dla wielu graczy.
74
75"UFO: Alien Invasion" to niekończące się godziny gry całkowicie za
76darmo.
77
78%prep
79%setup -q -n %{name}-%{version}-source
80%patch0 -p1
81%patch1 -p1
82
83# needed to build properly
84mkdir base
85
86%build
87CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
88%configure \
89 --with-curses
90%{__make} \
91 RADIANT_LIBS="-ltinfo"
92%{__make} lang
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/base,%{_datadir}/%{name}/base/i18n,%{_pixmapsdir},%{_desktopdir}}
98install base/game.so $RPM_BUILD_ROOT%{_libdir}/%{name}/base/game.so
99install ufo $RPM_BUILD_ROOT%{_libdir}/%{name}/ufoai
100install ufoded $RPM_BUILD_ROOT%{_libdir}/%{name}/ufoaided
101install ufo2map $RPM_BUILD_ROOT%{_bindir}/ufoai2map
102cp -a base/i18n $RPM_BUILD_ROOT%{_datadir}/%{name}/base
103
104cat > ufoai << 'EOF'
105#!/bin/sh
106cd %{_libdir}/%{name}
107exec ./ufoai
108EOF
109cat > ufoaided << 'EOF'
110#!/bin/sh
111cd %{_libdir}/%{name}
112exec ./ufoaided
113EOF
114
115install ufoai $RPM_BUILD_ROOT%{_bindir}/ufoai
116install ufoaided $RPM_BUILD_ROOT%{_bindir}/ufoaided
117
118ln -s %{_datadir}/%{name}/base/i18n $RPM_BUILD_ROOT%{_libdir}/%{name}/base/i18n
119for i in base maps materials media models music pics shaders snd ufos; do
120 ln -s %{_datadir}/%{name}/base/0$i.pk3 $RPM_BUILD_ROOT%{_libdir}/%{name}/base/0$i.pk3
121done
122
123# install icon and desktop file
124install debian/ufoai.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.xpm
125install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files
131%defattr(644,root,root,755)
132%attr(755,root,root) %{_bindir}/ufoai
133%attr(755,root,root) %{_bindir}/ufoaided
134%attr(755,root,root) %{_bindir}/ufoai2map
135%dir %{_libdir}/%{name}
136%attr(755,root,root) %{_libdir}/%{name}/ufoai
137%attr(755,root,root) %{_libdir}/%{name}/ufoaided
138%dir %{_libdir}/%{name}/base
139%attr(755,root,root) %{_libdir}/%{name}/base/game.so
140%attr(755,root,root) %{_libdir}/%{name}/base/i18n
141%attr(755,root,root) %{_libdir}/%{name}/base/0*.pk3
142%dir %{_datadir}/%{name}
143%dir %{_datadir}/%{name}/base
144%{_datadir}/%{name}/base/i18n
145%{_pixmapsdir}/%{name}.xpm
146%{_desktopdir}/%{name}.desktop
This page took 0.074492 seconds and 4 git commands to generate.