]> git.pld-linux.org Git - packages/subversion.git/blame_incremental - subversion.spec
fix ruby packaging with vendordir support
[packages/subversion.git] / subversion.spec
... / ...
CommitLineData
1# TODO:
2# - serf as default: https://subversion.apache.org/docs/release-notes/1.7.html#serf
3#
4# Conditional build:
5%bcond_with net_client_only # build only net client
6%bcond_without neon # use serf instead of neon
7%bcond_without swig # disable bindings generation with Swig
8%bcond_without python # build without Python bindings (broken)
9%bcond_without csvn # build Python csvn bindings
10%bcond_without perl # build without Perl bindings
11%bcond_without ruby # build without Ruby bindings
12%bcond_without apache # build without Apache support (webdav, etc)
13%bcond_without javahl # build without javahl support (Java high-level bindings)
14%bcond_without tests # don't perform "make check"
15%bcond_without kwallet # build without kde4 wallet support
16%bcond_without kde # build without kde4 support (alias for kwallet)
17%bcond_without gnome # build without gnome keyring support
18%bcond_without db # disable Subversion Berkeley DB based filesystem library
19
20# for AC: --without csvn,gnome,javahl,kde,ruby
21
22%if %{with net_client_only}
23%undefine with_apache
24%undefine with_db
25%undefine with_swig
26%undefine with_javahl
27%endif
28
29%if %{without swig}
30%undefine with_perl
31%undefine with_python
32%undefine with_ruby
33%endif
34
35%if %{without kde}
36%undefine with_kwallet
37%endif
38
39%if %{without python} && %{without perl} && %{without ruby}
40%undefine with_swig
41%endif
42
43%define apxs /usr/sbin/apxs
44%define pdir SVN
45%define pnam _Core
46
47%if %{with neon}
48%define webdavlib neon
49%else
50%define webdavlib serf
51%endif
52%{?with_perl:%include /usr/lib/rpm/macros.perl}
53Summary: A Concurrent Versioning system similar to but better than CVS
54Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
55Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
56Name: subversion
57Version: 1.7.9
58Release: 1
59License: Apache v2.0
60Group: Development/Version Control
61Source0: http://www.idg.pl/mirrors/apache/subversion/%{name}-%{version}.tar.bz2
62# Source0-md5: 8d532025771a67c06c23f299699f056f
63Source1: %{name}-dav_svn.conf
64Source2: %{name}-authz_svn.conf
65Source3: %{name}-svnserve.init
66Source4: %{name}-svnserve.sysconfig
67# current subversion tarball has correct *.swg files
68# but after regeneration these are broken again, so
69# we still need this script
70Source5: %{name}-convert-typemaps-to-ifdef.py
71Patch0: %{name}-home_etc.patch
72Patch1: %{name}-DESTDIR.patch
73Patch2: %{name}-ruby-datadir-path.patch
74Patch3: %{name}-tests.patch
75Patch4: subversion-1.7.2-ruby19.patch
76URL: http://subversion.apache.org/
77%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
78BuildRequires: apr-devel >= 1:1.0.0
79BuildRequires: apr-util-devel >= 1:1.2.8-3
80BuildRequires: autoconf >= 2.59
81BuildRequires: automake
82BuildRequires: bison
83BuildRequires: cyrus-sasl-devel
84%if %{with kwallet} || %{with gnome}
85BuildRequires: dbus-devel
86%endif
87BuildRequires: db-devel >= 4.1.25
88BuildRequires: expat-devel
89BuildRequires: gettext-devel
90%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
91%{?with_gnome:BuildRequires: libgnome-keyring-devel}
92BuildRequires: libmagic-devel
93BuildRequires: libtool >= 1.4-9
94BuildRequires: pkgconfig
95%{?with_csvn:BuildRequires: python-ctypesgen}
96BuildRequires: rpm-pythonprov
97BuildRequires: rpmbuild(macros) >= 1.656
98BuildRequires: sed >= 4.0
99BuildRequires: sqlite3-devel >= 3.6.18
100BuildRequires: texinfo
101BuildRequires: which
102%if %{with neon}
103BuildRequires: neon-devel >= 0.26.0
104%else
105BuildRequires: serf-devel >= 0.7.1
106%endif
107%if %{with javahl}
108BuildRequires: jdk >= 1.5
109BuildRequires: libstdc++-devel
110%endif
111%if %{with perl}
112BuildRequires: perl-devel >= 1:5.8.0
113BuildRequires: rpm-perlprov >= 4.1-13
114BuildRequires: swig-perl >= 1.3.24
115%endif
116%if %{with python}
117BuildRequires: python-devel >= 1:2.4
118BuildRequires: swig-python >= 1.3.24
119%endif
120%if %{with ruby}
121BuildRequires: ruby-devel >= 1:1.8.2
122BuildRequires: ruby-rubygems
123BuildRequires: swig-ruby >= 1.3.24
124%endif
125Requires: %{name}-libs = %{version}-%{release}
126%requires_ge sqlite3
127BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129%define _libexecdir %{_libdir}/svn
130%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
131%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
132
133%define skip_post_check_so libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
134
135%description
136The goal of the Subversion project is to build a version control
137system that is a compelling replacement for CVS in the open source
138community.
139
140Our goals are:
141- All current CVS features.
142- Directories, renames, and file meta-data are versioned.
143- Symbolic links, etc, are supported
144- Commits are truly atomic.
145- Branching and tagging are cheap (constant time) operations
146- Repeated merges are handled gracefully
147- Support for plug-in client side diff programs
148- Natively client/server
149- Client/server protocol sends diffs in both directions
150- Costs are proportional to change size, not project size
151- Internationalization
152- Progressive multi-lingual support
153
154%description -l pl.UTF-8
155Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
156zamiennika dla CVS.
157
158Cele projektu to:
159- Wszystkie aktualne możliwości CVS.
160- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
161- Obsługa dowiązań symbolicznych itp.
162- Commity są w pełni atomowe.
163- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
164- Dobra obsługa powtarzanego łączenia (merge).
165- Obsługa wtyczek diff po stronie klienta.
166- Natywny klient/serwer.
167- Klient/Serwer przesyłają diffy w obu kierunkach.
168- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
169- Internacjonalizacja.
170- Postępujące wsparcie dla wielu języków.
171
172%description -l pt_BR.UTF-8
173O objetivo do projeto Subversion é construir um sistema de controle de
174versões que seja um substituto para o CVS (Concurrent Versioning
175System) na comunidade opensource, fornecendo grandes melhorias.
176
177%package libs
178Summary: Subversion libraries and modules
179Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
180Group: Libraries
181%if %{with neon}
182Requires: neon >= 0.26.0
183%else
184Requires: serf >= 0.7.1
185%endif
186Obsoletes: libsubversion0
187
188%description libs
189Subversion libraries and modules.
190
191%description libs -l pl.UTF-8
192Biblioteka subversion oraz ładowalne moduły.
193
194%package devel
195Summary: Header files and develpment documentation for subversion
196Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
197Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
198Group: Development/Libraries
199Requires: %{name}-libs = %{version}-%{release}
200Requires: apr-util-devel >= 1:1.0.0
201%{?with_neon:Requires: neon-devel >= 0.26.0}
202Obsoletes: libsubversion0-devel
203
204%description devel
205Header files and develpment documentation for subversion.
206
207%description devel -l pl.UTF-8
208Pliki nagłówkowe i dokumetacja do subversion.
209
210%description devel -l pt_BR.UTF-8
211Este pacote provê os arquivos necessários para desenvolvedores
212interagirem com o Subversion.
213
214%package static
215Summary: Static subversion library
216Summary(pl.UTF-8): Biblioteka statyczna subversion
217Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
218Group: Development/Libraries
219Requires: %{name}-devel = %{version}
220Obsoletes: libsubversion0-static-devel
221
222%description static
223Static subversion library.
224
225%description static -l pl.UTF-8
226Biblioteka statyczna subversion.
227
228%description static -l pt_BR.UTF-8
229Este pacote provê um cliente estático do subversion.
230
231%package svnserve
232Summary: Subversion svnserve
233Summary(pl.UTF-8): Subversion svnserve
234Group: Networking/Daemons
235Requires(post,preun): /sbin/chkconfig
236Requires(postun): /usr/sbin/groupdel
237Requires(postun): /usr/sbin/userdel
238Requires(pre): /bin/id
239Requires(pre): /usr/bin/getgid
240Requires(pre): /usr/lib/rpm/user_group.sh
241Requires(pre): /usr/sbin/groupadd
242Requires(pre): /usr/sbin/useradd
243Requires(pre): /usr/sbin/usermod
244Requires: %{name} = %{version}-%{release}
245Requires: rc-scripts
246Provides: group(svn)
247Provides: user(svn)
248
249%description svnserve
250Subversion svnserve server.
251
252%description svnserve -l pl.UTF-8
253Serwer subversion svnserve.
254
255%package tools
256Summary: Subversion tools and scripts
257Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
258Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
259Group: Applications
260Requires: %{name} = %{version}-%{release}
261Requires: python
262Requires: python-subversion = %{version}
263
264%description tools
265Subversion tools and scripts.
266
267%description tools -l pl.UTF-8
268Narzędzia oraz skrypty dla subversion.
269
270%package -n bash-completion-subversion
271Summary: bash completion for subversion
272Summary(pl.UTF-8): Dopełnienia basha dla subversion
273Group: Applications/Shells
274Requires: %{name} = %{version}-%{release}
275Requires: bash-completion
276Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
277
278%description -n bash-completion-subversion
279Bash completion for subversion.
280
281%description -n bash-completion-subversion -l pl.UTF-8
282Dopełnienia basha dla subversion.
283
284%package -n java-subversion
285Summary: Subversion Java bindings
286Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
287Group: Development/Languages/Java
288Requires: %{name}-libs = %{version}-%{release}
289
290%description -n java-subversion
291This is a set of Java classes which provide the functionality of
292subversion-libs, the Subversion libraries. It is useful if you want
293to, for example, write a Java class that manipulates a Subversion
294repository or working copy. See the 'subversion' package for more
295information.
296
297%description -n java-subversion -l pl.UTF-8
298Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
299subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
300pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
301roboczą. Więcej informacji w pakiecie subversion.
302
303%package -n python-subversion
304Summary: Subversion Python bindings
305Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
306Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
307Group: Development/Languages/Python
308Requires: %{name}-libs = %{version}-%{release}
309Requires: python
310Obsoletes: subversion-python
311
312%description -n python-subversion
313Subversion Python bindings.
314
315%description -n python-subversion -l pl.UTF-8
316Dowiązania do Subversion dla Pythona.
317
318%description -n python-subversion -l pt_BR.UTF-8
319Módulos Python para acessar os recursos do Subversion.
320
321%package -n python-csvn
322Summary: CTypes Subversion Python bindings
323Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
324Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
325Group: Development/Languages/Python
326Requires: %{name}-libs = %{version}-%{release}
327Requires: python
328
329%description -n python-csvn
330Subversion CTypes Python bindings.
331
332%description -n python-csvn -l pl.UTF-8
333Dowiązania do Subversion dla Pythona używające CTypes.
334
335%description -n python-csvn -l pt_BR.UTF-8
336Módulos Python para acessar os recursos do Subversion.
337
338%package -n perl-subversion
339Summary: Subversion Perl bindings
340Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
341Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
342Group: Development/Languages/Perl
343Requires: %{name}-libs = %{version}-%{release}
344Obsoletes: subversion-perl
345
346%description -n perl-subversion
347Subversion Perl bindings.
348
349%description -n perl-subversion -l pl.UTF-8
350Dowiązania do Subversion dla Perla.
351
352%description -n perl-subversion -l pt_BR.UTF-8
353Módulos Perl para acessar os recursos do Subversion.
354
355%package -n ruby-subversion
356Summary: Subversion Ruby bindings
357Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
358Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
359Group: Development/Languages
360Requires: %{name}-libs = %{version}-%{release}
361Obsoletes: subversion-ruby
362
363%description -n ruby-subversion
364Subversion Ruby bindings.
365
366%description -n ruby-subversion -l pl.UTF-8
367Dowiązania do Subversion dla języka Ruby.
368
369%description -n ruby-subversion -l pt_BR.UTF-8
370Módulos Ruby para acessar os recursos do Subversion.
371
372%package -n apache-mod_dav_svn
373Summary: Apache module: Subversion Server
374Summary(pl.UTF-8): Moduł Apache'a: serwer Subversion
375Group: Networking/Daemons
376Requires: %{name} = %{version}-%{release}
377Requires: apache(modules-api) = %apache_modules_api
378Requires: apache-mod_dav
379
380%description -n apache-mod_dav_svn
381Apache module: Subversion Server.
382
383%description -n apache-mod_dav_svn -l pl.UTF-8
384Moduł Apache'a: serwer Subversion.
385
386%package -n apache-mod_authz_svn
387Summary: Apache module: Subversion Server - path-based authorization
388Summary(pl.UTF-8): Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
389Group: Networking/Daemons
390Requires: %{name}-libs = %{version}-%{release}
391Requires: apache(modules-api) = %apache_modules_api
392Requires: apache-mod_dav_svn = %{version}-%{release}
393
394%description -n apache-mod_authz_svn
395Apache module: Subversion Server - path-based authorization.
396
397%description -n apache-mod_authz_svn -l pl.UTF-8
398Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
399Subversion.
400
401%package -n apache-mod_dontdothat_svn
402Summary: Apache module: Allows you to block specific svn requests
403Summary(pl.UTF-8): Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
404Group: Networking/Daemons
405Requires: %{name}-libs = %{version}-%{release}
406Requires: apache(modules-api) = %apache_modules_api
407Requires: apache-mod_dav_svn = %{version}-%{release}
408
409%description -n apache-mod_dontdothat_svn
410Apache module: Allows you to block specific svn requests.
411
412%description -n apache-mod_dontdothat_svn -l pl.UTF-8
413Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
414
415%package -n gnome-keyring-subversion
416Summary: GNOME Keyring authentication provider for Subversion
417Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Subversion
418Group: X11/Applications
419Requires: %{name}-libs = %{version}-%{release}
420
421%description -n gnome-keyring-subversion
422Authentication provider module for Subversion which allows SVN client
423to authenticate using GNOME Keyring.
424
425%description -n gnome-keyring-subversion -l pl.UTF-8
426Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
427uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
428
429%package -n kde4-kwallet-subversion
430Summary: KDE Wallet authentication provider for Subversion
431Summary(pl.UTF-8): Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
432Group: X11/Applications
433Requires: %{name}-libs = %{version}-%{release}
434
435%description -n kde4-kwallet-subversion
436Authentication provider module for Subversion which allows SVN client
437to authenticate using KDE Wallet.
438
439%description -n kde4-kwallet-subversion -l pl.UTF-8
440Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
441uwierzytelniać się przy użyciu Portfela KDE.
442
443%prep
444%setup -q
445%patch0 -p0
446%patch1 -p1
447%patch2 -p0
448%patch3 -p1
449%patch4 -p1
450
451sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
452
453# serf.m4 macro is broken and ignores --without serf
454%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
455
456%build
457# disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
458#%{__rm} subversion/bindings/swig/proxy/*.swg
459#cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
460chmod +x ./autogen.sh && ./autogen.sh
461%{__libtoolize}
462%configure \
463 --with-editor=vi \
464 --with-zlib=%{_libdir} \
465 --disable-runtime-module-search \
466 --disable-mod-activation \
467%if %{with db}
468 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
469%else
470 --without-berkeley-db \
471%endif
472%if %{with apache}
473 --with-apxs=%{_sbindir}/apxs \
474%else
475 --without-apxs \
476%endif
477%if %{without swig}
478 --without-swig \
479%endif
480%if %{with ruby}
481 svn_cv_ruby_sitedir_libsuffix="" \
482 svn_cv_ruby_sitedir_archsuffix="" \
483 --with-ruby-sitedir=%{ruby_vendorarchdir} \
484%else
485 ac_cv_path_RUBY=none \
486%endif
487%if %{with csvn}
488 --with-ctypesgen=%{_bindir}/ctypesgen.py \
489%endif
490%if %{with javahl}
491 --enable-javahl \
492 --with-jdk="%{java_home}" \
493 --without-jikes \
494%else
495 --disable-javahl \
496%endif
497%if %{with neon}
498 --without-serf \
499 --with-neon=%{_prefix} \
500 --disable-neon-version-check \
501%else
502 --with-serf=%{_prefix} \
503 --without-neon \
504%endif
505 --with-apr=%{_bindir}/apr-1-config \
506 --with-apr-util=%{_bindir}/apu-1-config \
507%if %{with kwallet}
508 --with-kwallet \
509%endif
510%if %{with gnome}
511 --with-gnome-keyring
512%endif
513
514%{__make} -j1
515
516%{__make} tools
517
518%if %{with csvn}
519# Python ctypes bindings
520%{__make} ctypes-python
521%endif
522%if %{with python}
523# Python swig bindings
524%{__make} swig-py \
525 swig_pydir=%{py_sitedir}/libsvn \
526 swig_pydir_extra=%{py_sitedir}/svn
527%endif
528%if %{with perl}
529# Perl swig bindings
530%{__make} -j1 swig-pl-lib
531cd subversion/bindings/swig/perl/native
532%{__perl} Makefile.PL INSTALLDIRS=vendor
533%{__make} -j1
534cd -
535%endif
536%if %{with javahl}
537%{__make} -j1 javahl \
538 javahl_javadir="%{_javadir}"
539%endif
540# ruby
541%if %{with ruby}
542%{__make} swig-rb
543%endif
544
545%if %{with tests}
546%{__make} -j1 check
547%if %{with csvn}
548%{__make} -j1 check-ctypes-python
549%endif
550%if %{with python}
551%{__make} -j1 check-swig-py
552%endif
553%if %{with perl}
554%{__make} -j1 check-swig-pl
555%endif
556%if %{with ruby}
557# disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
558#%{__make} check-swig-rb
559%endif
560%endif
561
562%install
563rm -rf $RPM_BUILD_ROOT
564install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
565 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
566 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
567 $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
568 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
569
570%{__make} install -j1 \
571 toolsdir=%{_bindir} \
572 DESTDIR=$RPM_BUILD_ROOT \
573 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
574%if %{with javahl}
575 install-javahl \
576 javahl_javadir="%{_javadir}" \
577%endif
578%if %{with python}
579 install-swig-py \
580 swig_pydir=%{py_sitedir}/libsvn \
581 swig_pydir_extra=%{py_sitedir}/svn \
582%endif
583%if %{with csvn}
584 install-ctypes-python \
585%endif
586 install-tools
587
588%if %{with ruby}
589%{__make} install -j1 \
590 DESTDIR=$RPM_BUILD_ROOT \
591 install-swig-rb install-swig-rb-doc \
592
593# not our package
594%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
595%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
596%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
597%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
598%endif
599
600%if %{with perl}
601%{__make} install-swig-pl-lib \
602 DESTDIR=$RPM_BUILD_ROOT
603%{__make} -C subversion/bindings/swig/perl/native install \
604 DESTDIR=$RPM_BUILD_ROOT \
605 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
606 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
607%endif
608
609%if %{with apache}
610cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
611cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
612cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
613install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
614%endif
615
616%if %{without net_client_only}
617install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
618%endif
619
620# rename not to conflict with standard packages. (are these needed at all?)
621mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
622mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
623mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
624
625%if %{with python} || %{with csvn}
626%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
627%py_comp $RPM_BUILD_ROOT%{py_sitedir}
628%py_postclean
629%endif
630%if %{with python}
631%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
632# .a created on ac only
633%{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
634cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
635%endif
636
637cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
638cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
639
640%if %{with javahl}
641%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
642%endif
643%if %{with swig}
644%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
645%if %{with ruby}
646%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
647%endif
648%endif
649%if %{with gnome} || %{with kwallet}
650# dlopened by soname (libsvn_auth_*-1.so.0)
651%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
652%endif
653
654%find_lang %{name}
655
656%clean
657rm -rf $RPM_BUILD_ROOT
658
659%pre svnserve
660%groupadd -g 86 svn
661%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
662
663%post libs -p /sbin/ldconfig
664%postun libs -p /sbin/ldconfig
665
666%post devel -p /sbin/postshell
667-/usr/sbin/fix-info-dir -c %{_infodir}
668
669%postun devel -p /sbin/postshell
670-/usr/sbin/fix-info-dir -c %{_infodir}
671
672%post -n java-subversion -p /sbin/ldconfig
673%postun -n java-subversion -p /sbin/ldconfig
674
675%post -n perl-subversion -p /sbin/ldconfig
676%postun -n perl-subversion -p /sbin/ldconfig
677
678%post -n python-subversion -p /sbin/ldconfig
679%postun -n python-subversion -p /sbin/ldconfig
680
681%post -n ruby-subversion -p /sbin/ldconfig
682%postun -n ruby-subversion -p /sbin/ldconfig
683
684%post -n gnome-keyring-subversion -p /sbin/ldconfig
685%postun -n gnome-keyring-subversion -p /sbin/ldconfig
686
687%post -n kde4-kwallet-subversion -p /sbin/ldconfig
688%postun -n kde4-kwallet-subversion -p /sbin/ldconfig
689
690%post svnserve
691/sbin/chkconfig --add svnserve
692%service svnserve restart "svnserve daemon"
693
694%preun svnserve
695if [ "$1" = "0" ]; then
696 %service svnserve stop
697 /sbin/chkconfig --del svnserve
698fi
699
700%postun svnserve
701if [ "$1" = "0" ]; then
702 %userremove svn
703 %groupremove svn
704fi
705
706%post -n apache-mod_dav_svn
707%service -q httpd restart
708
709%postun -n apache-mod_dav_svn
710if [ "$1" = "0" ]; then
711 %service -q httpd restart
712fi
713
714%post -n apache-mod_authz_svn
715%service -q httpd restart
716
717%postun -n apache-mod_authz_svn
718if [ "$1" = "0" ]; then
719 %service -q httpd restart
720fi
721
722%post -n apache-mod_dontdothat_svn
723%service -q httpd restart
724
725%postun -n apache-mod_dontdothat_svn
726if [ "$1" = "0" ]; then
727 %service -q httpd restart
728fi
729
730%files
731%defattr(644,root,root,755)
732%doc BUGS CHANGES INSTALL README
733%doc doc/*/*.html
734%doc tools/hook-scripts/*.{pl,py,example}
735%doc tools/hook-scripts/mailer/*.{py,example}
736%doc tools/xslt/*
737%attr(755,root,root) %{_bindir}/svn
738%attr(755,root,root) %{_bindir}/svnadmin
739%attr(755,root,root) %{_bindir}/svndumpfilter
740%attr(755,root,root) %{_bindir}/svnrdump
741%attr(755,root,root) %{_bindir}/svnlook
742%attr(755,root,root) %{_bindir}/svnsync
743%attr(755,root,root) %{_bindir}/svnversion
744%{_mandir}/man1/svn.1*
745%{_mandir}/man1/svnadmin.1*
746%{_mandir}/man1/svndumpfilter.1*
747%{_mandir}/man1/svnrdump.1*
748%{_mandir}/man1/svnlook.1*
749%{_mandir}/man1/svnsync.1*
750%{_mandir}/man1/svnversion.1*
751
752%files libs -f %{name}.lang
753%defattr(644,root,root,755)
754%dir %{_sysconfdir}/%{name}
755%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
756%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
757%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
758%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
759%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
760%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
761%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
762%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
763%if %{without net_client_only}
764%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
765%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
766%endif
767%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
768%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
769%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
770%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
771%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
772%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
773%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
774%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
775%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
776%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
777%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
778%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
779%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
780%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
781%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
782%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
783%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
784%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
785
786%files devel
787%defattr(644,root,root,755)
788%attr(755,root,root) %{_libdir}/libsvn_client-1.so
789%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
790%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
791%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
792%if %{without net_client_only}
793%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
794%endif
795%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
796%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
797%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
798%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
799%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
800%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
801%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
802%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
803%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
804%{_libdir}/libsvn_client-1.la
805%{_libdir}/libsvn_delta-1.la
806%{_libdir}/libsvn_diff-1.la
807%{_libdir}/libsvn_fs-1.la
808%if %{without net_client_only}
809%{_libdir}/libsvn_fs_base-1.la
810%endif
811%{_libdir}/libsvn_fs_fs-1.la
812%{_libdir}/libsvn_fs_util-1.la
813%{_libdir}/libsvn_ra-1.la
814%{_libdir}/libsvn_ra_local-1.la
815%{_libdir}/libsvn_ra_%{webdavlib}-1.la
816%{_libdir}/libsvn_ra_svn-1.la
817%{_libdir}/libsvn_repos-1.la
818%{_libdir}/libsvn_subr-1.la
819%{_libdir}/libsvn_wc-1.la
820%{_includedir}/%{name}-1
821%{_examplesdir}/%{name}-%{version}
822
823%files static
824%defattr(644,root,root,755)
825%{_libdir}/libsvn_client-1.a
826%{_libdir}/libsvn_delta-1.a
827%{_libdir}/libsvn_diff-1.a
828%{_libdir}/libsvn_fs-1.a
829%if %{without net_client_only}
830%{_libdir}/libsvn_fs_base-1.a
831%endif
832%{_libdir}/libsvn_fs_fs-1.a
833%{_libdir}/libsvn_fs_util-1.a
834%{_libdir}/libsvn_ra-1.a
835%{_libdir}/libsvn_ra_local-1.a
836%{_libdir}/libsvn_ra_%{webdavlib}-1.a
837%{_libdir}/libsvn_ra_svn-1.a
838%{_libdir}/libsvn_repos-1.a
839%{_libdir}/libsvn_subr-1.a
840%{_libdir}/libsvn_wc-1.a
841
842%if %{with gnome}
843%files -n gnome-keyring-subversion
844%defattr(644,root,root,755)
845%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
846%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
847%endif
848
849%if %{with kwallet}
850%files -n kde4-kwallet-subversion
851%defattr(644,root,root,755)
852%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
853%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
854%endif
855
856%if %{without net_client_only}
857%files svnserve
858%defattr(644,root,root,755)
859%attr(755,root,root) %{_bindir}/svnserve
860%{_mandir}/man5/svnserve.conf.5*
861%{_mandir}/man8/svnserve.8*
862%dir %attr(750,svn,svn) /home/services/subversion
863%dir %attr(750,svn,svn) /home/services/subversion/repos
864%if %{with apache}
865%attr(754,root,root) /etc/rc.d/init.d/svnserve
866%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
867%endif
868
869%files tools
870%defattr(644,root,root,755)
871# tools/backup/hot-backup.py
872%attr(755,root,root) %{_bindir}/svn-hot-backup
873
874# tools/diff
875%attr(755,root,root) %{_bindir}/svndiff
876%attr(755,root,root) %{_bindir}/svndiff3
877%attr(755,root,root) %{_bindir}/svndiff4
878
879# tools/server-side
880%attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
881%attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
882%attr(755,root,root) %{_bindir}/svnauthz-validate
883
884# tools/client-side/svnmucc
885%attr(755,root,root) %{_bindir}/svnmucc
886# tools/dev/svnraisetreeconflict
887%attr(755,root,root) %{_bindir}/svnraisetreeconflict
888
889%files -n bash-completion-subversion
890%defattr(644,root,root,755)
891/etc/bash_completion.d/%{name}
892
893%endif # net_client_only
894
895%if %{with javahl}
896%files -n java-subversion
897%defattr(644,root,root,755)
898%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
899%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
900%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
901%{_javadir}/svn-javahl.jar
902%endif
903
904%if %{with python}
905%files -n python-subversion
906%defattr(644,root,root,755)
907%doc tools/backup/*.py
908%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
909%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
910%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
911%dir %{py_sitedir}/libsvn
912%attr(755,root,root) %{py_sitedir}/libsvn/_*.so
913%{py_sitedir}/libsvn/*.py[co]
914%dir %{py_sitedir}/svn
915%{py_sitedir}/svn/*.py[co]
916%{_examplesdir}/python-%{name}-%{version}
917%endif
918
919%if %{with csvn}
920%files -n python-csvn
921%defattr(644,root,root,755)
922%doc subversion/bindings/ctypes-python/{README,TODO}
923%doc subversion/bindings/ctypes-python/examples/*.py
924%dir %{py_sitescriptdir}/csvn
925%{py_sitescriptdir}/csvn/*.py[co]
926%dir %{py_sitescriptdir}/csvn/core
927%{py_sitescriptdir}/csvn/core/*.py[co]
928%dir %{py_sitescriptdir}/csvn/ext
929%{py_sitescriptdir}/csvn/ext/*.py[co]
930%{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
931%endif
932
933%if %{with perl}
934%files -n perl-subversion
935%defattr(644,root,root,755)
936%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
937%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
938%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
939%{perl_vendorarch}/SVN
940%dir %{perl_vendorarch}/auto/SVN
941%dir %{perl_vendorarch}/auto/SVN/*
942%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
943%{perl_vendorarch}/auto/SVN/*/*.bs
944%{_mandir}/man3/*.3pm*
945%endif
946
947%if %{with ruby}
948%files -n ruby-subversion
949%defattr(644,root,root,755)
950%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
951%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
952%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
953%dir %{ruby_vendorarchdir}/svn
954%{ruby_vendorarchdir}/svn/*.rb
955%dir %{ruby_vendorarchdir}/svn/ext
956%attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
957%{ruby_ridir}/Svn
958%endif
959
960%if %{with apache}
961%files -n apache-mod_dav_svn
962%defattr(644,root,root,755)
963%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
964%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
965
966%files -n apache-mod_authz_svn
967%defattr(644,root,root,755)
968%doc subversion/mod_authz_svn/INSTALL
969%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
970%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
971
972%files -n apache-mod_dontdothat_svn
973%defattr(644,root,root,755)
974%doc tools/server-side/mod_dontdothat/README
975%attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
976%endif
This page took 0.041454 seconds and 4 git commands to generate.