]> git.pld-linux.org Git - packages/subversion.git/blame_incremental - subversion.spec
up to 1.11.0
[packages/subversion.git] / subversion.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with net_client_only # build only net client
4%bcond_without swig # disable bindings generation with Swig
5%bcond_without python # build without Python bindings (broken)
6%bcond_without csvn # build Python csvn bindings
7%bcond_without perl # build without Perl bindings
8%bcond_without ruby # build without Ruby bindings
9%bcond_without apache # build without Apache support (webdav, etc)
10%bcond_without java # build without javahl support (Java high-level bindings)
11%bcond_with tests # don't perform "make check"
12%bcond_without kwallet # build without kde5 wallet support
13%bcond_without kde # build without kde5 support (alias for kwallet)
14%bcond_without gnome # build without gnome keyring support
15%bcond_without db # disable Subversion Berkeley DB based filesystem library
16%bcond_with db6 # allow BDB6 (not tested by upstream, released on AGPL)
17
18# for AC: --without csvn,gnome,java,kde,ruby
19
20%if %{with net_client_only}
21%undefine with_apache
22%undefine with_db
23%undefine with_swig
24%undefine with_java
25%undefine with_csvn
26%undefine with_gnome
27%undefine with_kde
28%endif
29
30%if %{without swig}
31%undefine with_perl
32%undefine with_python
33%undefine with_ruby
34%endif
35
36%if %{without kde}
37%undefine with_kwallet
38%endif
39
40%if %{without python} && %{without perl} && %{without ruby}
41%undefine with_swig
42%endif
43
44%define apxs /usr/sbin/apxs
45%define pdir SVN
46%define pnam _Core
47
48%{?with_perl:%include /usr/lib/rpm/macros.perl}
49Summary: A Concurrent Versioning system similar to but better than CVS
50Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
51Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
52Name: subversion
53Version: 1.11.0
54Release: 1
55License: Apache v2.0
56Group: Development/Version Control
57Source0: http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
58# Source0-md5: b0401a17fe9f4a769e36fcfcfad93461
59Source1: %{name}-dav_svn.conf
60Source2: %{name}-authz_svn.conf
61Source3: %{name}-svnserve.init
62Source4: %{name}-svnserve.sysconfig
63# current subversion tarball has correct *.swg files
64# but after regeneration these are broken again, so
65# we still need this script
66Source5: %{name}-convert-typemaps-to-ifdef.py
67Patch0: %{name}-home_etc.patch
68Patch1: %{name}-DESTDIR.patch
69Patch2: %{name}-ruby-datadir-path.patch
70Patch3: %{name}-tests.patch
71Patch4: x32-libdir.patch
72URL: http://subversion.apache.org/
73%{?with_apache:BuildRequires: apache-devel >= 2.4.14}
74BuildRequires: apr-devel >= 1:1.3
75BuildRequires: apr-util-devel >= 1:1.3
76BuildRequires: apr-util-crypto-openssl
77BuildRequires: autoconf >= 2.59
78BuildRequires: automake
79BuildRequires: bison
80BuildRequires: cyrus-sasl-devel
81%if %{with kwallet} || %{with gnome}
82BuildRequires: dbus-devel
83%endif
84%{!?with_db6:BuildRequires: db-devel < 6}
85BuildRequires: db-devel >= 4.1.25
86BuildRequires: expat-devel
87BuildRequires: gettext-tools
88%{?with_gnome:BuildRequires: glib2-devel >= 2.0}
89%{?with_kde:BuildRequires: kf5-kdelibs4support-devel}
90%{?with_kwallet:BuildRequires: kf5-kwallet-devel}
91%{?with_gnome:BuildRequires: libgnome-keyring-devel}
92%{?with_gnome:BuildRequires: libsecret-devel}
93BuildRequires: libmagic-devel
94BuildRequires: libtool >= 1.4-9
95BuildRequires: libutf8proc-devel >= 1.3.1-4
96BuildRequires: lz4-devel
97BuildRequires: pkgconfig
98%{?with_csvn:BuildRequires: python-ctypesgen}
99BuildRequires: rpm-pythonprov
100BuildRequires: rpmbuild(macros) >= 1.656
101BuildRequires: sed >= 4.0
102BuildRequires: serf-devel >= 1.3.4
103BuildRequires: sqlite3-devel >= 3.8.11.1
104BuildRequires: texinfo
105BuildRequires: which
106BuildRequires: zlib-devel >= 1.2
107%if %{with java}
108BuildRequires: jdk >= 1.8
109BuildRequires: libstdc++-devel
110%endif
111%if %{with perl}
112BuildRequires: perl-devel >= 1:5.8.0
113BuildRequires: rpm-perlprov >= 4.1-13
114BuildRequires: swig-perl >= 1.3.24
115%endif
116%if %{with python}
117BuildRequires: python-devel >= 1:2.4
118BuildRequires: swig-python >= 1.3.24
119%endif
120%if %{with ruby}
121BuildRequires: rpm-rubyprov
122BuildRequires: ruby-devel >= 1:1.8.2
123BuildRequires: ruby-irb
124BuildRequires: ruby-rubygems
125BuildRequires: swig-ruby >= 1.3.24
126%endif
127Requires: %{name}-libs = %{version}-%{release}
128%requires_ge sqlite3
129BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
130
131%define _libexecdir %{_libdir}/svn
132%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
133%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
134
135%define skip_post_check_so libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.* libsvn_fs_x-1.so.*
136
137%description
138The goal of the Subversion project is to build a version control
139system that is a compelling replacement for CVS in the open source
140community.
141
142Our goals are:
143- All current CVS features.
144- Directories, renames, and file meta-data are versioned.
145- Symbolic links, etc, are supported
146- Commits are truly atomic.
147- Branching and tagging are cheap (constant time) operations
148- Repeated merges are handled gracefully
149- Support for plug-in client side diff programs
150- Natively client/server
151- Client/server protocol sends diffs in both directions
152- Costs are proportional to change size, not project size
153- Internationalization
154- Progressive multi-lingual support
155
156%description -l pl.UTF-8
157Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
158zamiennika dla CVS.
159
160Cele projektu to:
161- Wszystkie aktualne możliwości CVS.
162- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
163- Obsługa dowiązań symbolicznych itp.
164- Commity są w pełni atomowe.
165- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
166- Dobra obsługa powtarzanego łączenia (merge).
167- Obsługa wtyczek diff po stronie klienta.
168- Natywny klient/serwer.
169- Klient/Serwer przesyłają diffy w obu kierunkach.
170- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
171- Internacjonalizacja.
172- Postępujące wsparcie dla wielu języków.
173
174%description -l pt_BR.UTF-8
175O objetivo do projeto Subversion é construir um sistema de controle de
176versões que seja um substituto para o CVS (Concurrent Versioning
177System) na comunidade opensource, fornecendo grandes melhorias.
178
179%package libs
180Summary: Subversion libraries and modules
181Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
182Group: Libraries
183Requires: apr >= 1:1.3
184Requires: apr-util >= 1:1.3
185Requires: serf >= 1.3.4
186Requires: zlib >= 1.2
187Obsoletes: libsubversion0
188
189%description libs
190Subversion libraries and modules.
191
192%description libs -l pl.UTF-8
193Biblioteka subversion oraz ładowalne moduły.
194
195%package devel
196Summary: Header files and develpment documentation for subversion
197Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
198Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
199Group: Development/Libraries
200Requires: %{name}-libs = %{version}-%{release}
201Requires: apr-util-devel >= 1:1.3
202Requires: serf-devel >= 1.3.4
203Obsoletes: libsubversion0-devel
204
205%description devel
206Header files and develpment documentation for subversion.
207
208%description devel -l pl.UTF-8
209Pliki nagłówkowe i dokumetacja do subversion.
210
211%description devel -l pt_BR.UTF-8
212Este pacote provê os arquivos necessários para desenvolvedores
213interagirem com o Subversion.
214
215%package static
216Summary: Static subversion library
217Summary(pl.UTF-8): Biblioteka statyczna subversion
218Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
219Group: Development/Libraries
220Requires: %{name}-devel = %{version}
221Obsoletes: libsubversion0-static-devel
222
223%description static
224Static subversion library.
225
226%description static -l pl.UTF-8
227Biblioteka statyczna subversion.
228
229%description static -l pt_BR.UTF-8
230Este pacote provê um cliente estático do subversion.
231
232%package svnserve
233Summary: Subversion svnserve
234Summary(pl.UTF-8): Subversion svnserve
235Group: Networking/Daemons
236Requires(post,preun): /sbin/chkconfig
237Requires(postun): /usr/sbin/groupdel
238Requires(postun): /usr/sbin/userdel
239Requires(pre): /bin/id
240Requires(pre): /usr/bin/getgid
241Requires(pre): /usr/lib/rpm/user_group.sh
242Requires(pre): /usr/sbin/groupadd
243Requires(pre): /usr/sbin/useradd
244Requires(pre): /usr/sbin/usermod
245Requires: %{name} = %{version}-%{release}
246Requires: rc-scripts
247Provides: group(svn)
248Provides: user(svn)
249
250%description svnserve
251Subversion svnserve server.
252
253%description svnserve -l pl.UTF-8
254Serwer subversion svnserve.
255
256%package tools
257Summary: Subversion tools and scripts
258Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
259Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
260Group: Applications
261Requires: %{name} = %{version}-%{release}
262Requires: python
263Requires: python-subversion = %{version}
264
265%description tools
266Subversion tools and scripts.
267
268%description tools -l pl.UTF-8
269Narzędzia oraz skrypty dla subversion.
270
271%package -n bash-completion-subversion
272Summary: bash completion for subversion
273Summary(pl.UTF-8): Dopełnienia basha dla subversion
274Group: Applications/Shells
275Requires: %{name} = %{version}-%{release}
276Requires: bash-completion
277Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
278%if "%{_rpmversion}" >= "5"
279BuildArch: noarch
280%endif
281
282%description -n bash-completion-subversion
283Bash completion for subversion.
284
285%description -n bash-completion-subversion -l pl.UTF-8
286Dopełnienia basha dla subversion.
287
288%package -n java-subversion
289Summary: Subversion Java bindings
290Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
291Group: Development/Languages/Java
292Requires: %{name}-libs = %{version}-%{release}
293
294%description -n java-subversion
295This is a set of Java classes which provide the functionality of
296subversion-libs, the Subversion libraries. It is useful if you want
297to, for example, write a Java class that manipulates a Subversion
298repository or working copy. See the 'subversion' package for more
299information.
300
301%description -n java-subversion -l pl.UTF-8
302Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
303subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
304pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
305roboczą. Więcej informacji w pakiecie subversion.
306
307%package -n python-subversion
308Summary: Subversion Python bindings
309Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
310Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
311Group: Development/Languages/Python
312Requires: %{name}-libs = %{version}-%{release}
313Requires: python
314Obsoletes: subversion-python
315
316%description -n python-subversion
317Subversion Python bindings.
318
319%description -n python-subversion -l pl.UTF-8
320Dowiązania do Subversion dla Pythona.
321
322%description -n python-subversion -l pt_BR.UTF-8
323Módulos Python para acessar os recursos do Subversion.
324
325%package -n python-csvn
326Summary: CTypes Subversion Python bindings
327Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
328Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
329Group: Development/Languages/Python
330Requires: %{name}-libs = %{version}-%{release}
331Requires: python
332
333%description -n python-csvn
334Subversion CTypes Python bindings.
335
336%description -n python-csvn -l pl.UTF-8
337Dowiązania do Subversion dla Pythona używające CTypes.
338
339%description -n python-csvn -l pt_BR.UTF-8
340Módulos Python para acessar os recursos do Subversion.
341
342%package -n perl-subversion
343Summary: Subversion Perl bindings
344Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
345Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
346Group: Development/Languages/Perl
347Requires: %{name}-libs = %{version}-%{release}
348Obsoletes: subversion-perl
349
350%description -n perl-subversion
351Subversion Perl bindings.
352
353%description -n perl-subversion -l pl.UTF-8
354Dowiązania do Subversion dla Perla.
355
356%description -n perl-subversion -l pt_BR.UTF-8
357Módulos Perl para acessar os recursos do Subversion.
358
359%package -n ruby-subversion
360Summary: Subversion Ruby bindings
361Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
362Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
363Group: Development/Languages
364Requires: %{name}-libs = %{version}-%{release}
365Obsoletes: subversion-ruby
366
367%description -n ruby-subversion
368Subversion Ruby bindings.
369
370%description -n ruby-subversion -l pl.UTF-8
371Dowiązania do Subversion dla języka Ruby.
372
373%description -n ruby-subversion -l pt_BR.UTF-8
374Módulos Ruby para acessar os recursos do Subversion.
375
376%package -n apache-mod_dav_svn
377Summary: Apache module: Subversion Server
378Summary(pl.UTF-8): Moduł Apache'a: serwer Subversion
379Group: Networking/Daemons
380Requires: %{name} = %{version}-%{release}
381Requires: apache(modules-api) = %apache_modules_api
382Requires: apache-mod_dav
383
384%description -n apache-mod_dav_svn
385Apache module: Subversion Server.
386
387%description -n apache-mod_dav_svn -l pl.UTF-8
388Moduł Apache'a: serwer Subversion.
389
390%package -n apache-mod_authz_svn
391Summary: Apache module: Subversion Server - path-based authorization
392Summary(pl.UTF-8): Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
393Group: Networking/Daemons
394Requires: %{name}-libs = %{version}-%{release}
395Requires: apache(modules-api) = %apache_modules_api
396Requires: apache-mod_dav_svn = %{version}-%{release}
397
398%description -n apache-mod_authz_svn
399Apache module: Subversion Server - path-based authorization.
400
401%description -n apache-mod_authz_svn -l pl.UTF-8
402Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
403Subversion.
404
405%package -n apache-mod_dontdothat_svn
406Summary: Apache module: Allows you to block specific svn requests
407Summary(pl.UTF-8): Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
408Group: Networking/Daemons
409Requires: %{name}-libs = %{version}-%{release}
410Requires: apache(modules-api) = %apache_modules_api
411Requires: apache-mod_dav_svn = %{version}-%{release}
412
413%description -n apache-mod_dontdothat_svn
414Apache module: Allows you to block specific svn requests.
415
416%description -n apache-mod_dontdothat_svn -l pl.UTF-8
417Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
418
419%package -n gnome-keyring-subversion
420Summary: GNOME Keyring authentication provider for Subversion
421Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Subversion
422Group: X11/Applications
423Requires: %{name}-libs = %{version}-%{release}
424
425%description -n gnome-keyring-subversion
426Authentication provider module for Subversion which allows SVN client
427to authenticate using GNOME Keyring.
428
429%description -n gnome-keyring-subversion -l pl.UTF-8
430Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
431uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
432
433%package -n kde5-kwallet-subversion
434Summary: KDE Wallet authentication provider for Subversion
435Summary(pl.UTF-8): Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
436Group: X11/Applications
437Requires: %{name}-libs = %{version}-%{release}
438
439%description -n kde5-kwallet-subversion
440Authentication provider module for Subversion which allows SVN client
441to authenticate using KDE Wallet.
442
443%description -n kde5-kwallet-subversion -l pl.UTF-8
444Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
445uwierzytelniać się przy użyciu Portfela KDE.
446
447%prep
448%setup -q
449%patch0 -p0
450%patch1 -p1
451%patch2 -p0
452%patch3 -p1
453%patch4 -p1
454
455sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
456
457%build
458# disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
459#%{__rm} subversion/bindings/swig/proxy/*.swg
460#cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
461chmod +x ./autogen.sh && ./autogen.sh
462%{__libtoolize}
463%configure \
464 --with-editor=vi \
465 --with-zlib=%{_libdir} \
466 --disable-runtime-module-search \
467 --disable-mod-activation \
468%if %{with db}
469 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
470 %{?with_db6:--enable-bdb6} \
471%else
472 --without-berkeley-db \
473%endif
474%if %{with apache}
475 --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
476 --with-apxs=%{_sbindir}/apxs \
477%else
478 --without-apxs \
479%endif
480%if %{without swig}
481 --without-swig \
482%endif
483%if %{with ruby}
484 svn_cv_ruby_sitedir_libsuffix="" \
485 svn_cv_ruby_sitedir_archsuffix="" \
486 --with-ruby-sitedir=%{ruby_vendorarchdir} \
487%else
488 ac_cv_path_RUBY=none \
489%endif
490%if %{with csvn}
491 --with-ctypesgen=%{_bindir}/ctypesgen.py \
492%endif
493%if %{with java}
494 --enable-javahl \
495 --with-jdk="%{java_home}" \
496 --without-jikes \
497%else
498 --disable-javahl \
499%endif
500 --with-serf=%{_prefix} \
501 --with-apr=%{_bindir}/apr-1-config \
502 --with-apr-util=%{_bindir}/apu-1-config \
503%if %{with kwallet}
504 --with-kwallet \
505%endif
506%if %{with gnome}
507 --with-gnome-keyring
508%endif
509
510%{__make} -j1
511
512%{__make} tools
513
514%if %{with csvn}
515# Python ctypes bindings
516%{__make} ctypes-python
517%endif
518%if %{with python}
519# Python swig bindings
520%{__make} swig-py \
521 swig_pydir=%{py_sitedir}/libsvn \
522 swig_pydir_extra=%{py_sitedir}/svn
523%endif
524%if %{with perl}
525# Perl swig bindings
526%{__make} -j1 swig-pl-lib
527cd subversion/bindings/swig/perl/native
528%{__perl} Makefile.PL INSTALLDIRS=vendor
529%{__make} -j1
530cd -
531%endif
532%if %{with java}
533%{__make} -j1 javahl \
534 javahl_javadir="%{_javadir}"
535%endif
536# ruby
537%if %{with ruby}
538%{__make} swig-rb
539%endif
540
541%if %{with tests}
542%{__make} -j1 check
543%if %{with csvn}
544%{__make} -j1 check-ctypes-python
545%endif
546%if %{with python}
547%{__make} -j1 check-swig-py
548%endif
549%if %{with perl}
550%{__make} -j1 check-swig-pl
551%endif
552%if %{with ruby}
553# disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
554#%{__make} check-swig-rb
555%endif
556%endif
557
558%install
559rm -rf $RPM_BUILD_ROOT
560install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
561 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
562 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
563 $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
564 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
565
566%{__make} -j1 install \
567 pkgconfig_dir=%{_pkgconfigdir} \
568 toolsdir=%{_bindir} \
569 DESTDIR=$RPM_BUILD_ROOT \
570 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
571%if %{with java}
572 install-javahl \
573 javahl_javadir="%{_javadir}" \
574%endif
575%if %{with python}
576 install-swig-py \
577 swig_pydir=%{py_sitedir}/libsvn \
578 swig_pydir_extra=%{py_sitedir}/svn \
579%endif
580 install-tools
581
582%if %{with csvn}
583# manually execute install-ctypes-python target
584cd subversion/bindings/ctypes-python
585%py_install
586cd ../../..
587%endif
588
589%if %{with ruby}
590%{__make} -j1 install-swig-rb install-swig-rb-doc \
591 SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
592 DESTDIR=$RPM_BUILD_ROOT
593
594# not our package
595%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
596%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
597%if "%{ruby_abi}" >= "2.0"
598%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
599%endif
600%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
601%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
602%endif
603
604%if %{with perl}
605%{__make} install-swig-pl-lib \
606 DESTDIR=$RPM_BUILD_ROOT
607%{__make} -C subversion/bindings/swig/perl/native install \
608 DESTDIR=$RPM_BUILD_ROOT \
609 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
610 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
611%endif
612
613%if %{with apache}
614cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
615cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
616cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
617install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
618%endif
619
620%if %{without net_client_only}
621install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
622%endif
623
624# rename not to conflict with standard packages. (are these needed at all?)
625%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
626%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
627%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
628
629%if %{with python} || %{with csvn}
630%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
631%py_comp $RPM_BUILD_ROOT%{py_sitedir}
632%py_postclean
633%endif
634%if %{with python}
635%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
636# .a created on ac only
637%{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
638cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
639%endif
640
641cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
642cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
643
644%if %{with java}
645%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
646%endif
647%if %{with swig}
648%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
649%if %{with ruby}
650%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
651%endif
652%endif
653%if %{with gnome} || %{with kwallet}
654# dlopened by soname (libsvn_auth_*-1.so.0)
655%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la}
656%endif
657
658%find_lang %{name}
659
660%clean
661rm -rf $RPM_BUILD_ROOT
662
663%pre svnserve
664%groupadd -g 86 svn
665%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
666
667%post libs -p /sbin/ldconfig
668%postun libs -p /sbin/ldconfig
669
670%post devel -p /sbin/postshell
671-/usr/sbin/fix-info-dir -c %{_infodir}
672
673%postun devel -p /sbin/postshell
674-/usr/sbin/fix-info-dir -c %{_infodir}
675
676%post -n java-subversion -p /sbin/ldconfig
677%postun -n java-subversion -p /sbin/ldconfig
678
679%post -n perl-subversion -p /sbin/ldconfig
680%postun -n perl-subversion -p /sbin/ldconfig
681
682%post -n python-subversion -p /sbin/ldconfig
683%postun -n python-subversion -p /sbin/ldconfig
684
685%post -n ruby-subversion -p /sbin/ldconfig
686%postun -n ruby-subversion -p /sbin/ldconfig
687
688%post -n gnome-keyring-subversion -p /sbin/ldconfig
689%postun -n gnome-keyring-subversion -p /sbin/ldconfig
690
691%post -n kde5-kwallet-subversion -p /sbin/ldconfig
692%postun -n kde5-kwallet-subversion -p /sbin/ldconfig
693
694%post svnserve
695/sbin/chkconfig --add svnserve
696%service svnserve restart "svnserve daemon"
697
698%preun svnserve
699if [ "$1" = "0" ]; then
700 %service svnserve stop
701 /sbin/chkconfig --del svnserve
702fi
703
704%postun svnserve
705if [ "$1" = "0" ]; then
706 %userremove svn
707 %groupremove svn
708fi
709
710%post -n apache-mod_dav_svn
711%service -q httpd restart
712
713%postun -n apache-mod_dav_svn
714if [ "$1" = "0" ]; then
715 %service -q httpd restart
716fi
717
718%post -n apache-mod_authz_svn
719%service -q httpd restart
720
721%postun -n apache-mod_authz_svn
722if [ "$1" = "0" ]; then
723 %service -q httpd restart
724fi
725
726%post -n apache-mod_dontdothat_svn
727%service -q httpd restart
728
729%postun -n apache-mod_dontdothat_svn
730if [ "$1" = "0" ]; then
731 %service -q httpd restart
732fi
733
734%files
735%defattr(644,root,root,755)
736%doc BUGS CHANGES INSTALL README
737%doc doc/*/*.html
738%doc tools/hook-scripts/*.{pl,py,example}
739%doc tools/hook-scripts/mailer/*.{py,example}
740%doc tools/xslt/*
741%attr(755,root,root) %{_bindir}/fsfs-stats
742%attr(755,root,root) %{_bindir}/svn
743%attr(755,root,root) %{_bindir}/svn-mergeinfo-normalizer
744%attr(755,root,root) %{_bindir}/svnadmin
745%attr(755,root,root) %{_bindir}/svnconflict
746%attr(755,root,root) %{_bindir}/svndumpfilter
747%attr(755,root,root) %{_bindir}/svnlook
748%attr(755,root,root) %{_bindir}/svnmover
749%attr(755,root,root) %{_bindir}/svnmucc
750%attr(755,root,root) %{_bindir}/svnrdump
751%attr(755,root,root) %{_bindir}/svnsync
752%attr(755,root,root) %{_bindir}/svnversion
753%{_mandir}/man1/svn.1*
754%{_mandir}/man1/svnadmin.1*
755%{_mandir}/man1/svndumpfilter.1*
756%{_mandir}/man1/svnrdump.1*
757%{_mandir}/man1/svnlook.1*
758%{_mandir}/man1/svnmucc.1*
759%{_mandir}/man1/svnsync.1*
760%{_mandir}/man1/svnversion.1*
761
762%files libs -f %{name}.lang
763%defattr(644,root,root,755)
764%dir %{_sysconfdir}/%{name}
765%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
766%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
767%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
768%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
769%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
770%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
771%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
772%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
773%if %{without net_client_only}
774%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
775%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
776%endif
777%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
778%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
779%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
780%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
781%attr(755,root,root) %{_libdir}/libsvn_fs_x-1.so.*.*.*
782%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_x-1.so.0
783%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
784%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
785%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
786%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
787%attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so.*.*.*
788%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_serf-1.so.0
789%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
790%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
791%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
792%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
793%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
794%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
795%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
796%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
797
798%files devel
799%defattr(644,root,root,755)
800%attr(755,root,root) %{_libdir}/libsvn_client-1.so
801%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
802%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
803%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
804%if %{without net_client_only}
805%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
806%endif
807%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
808%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
809%attr(755,root,root) %{_libdir}/libsvn_fs_x-1.so
810%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
811%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
812%attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
813%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
814%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
815%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
816%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
817%{_libdir}/libsvn_client-1.la
818%{_libdir}/libsvn_delta-1.la
819%{_libdir}/libsvn_diff-1.la
820%{_libdir}/libsvn_fs-1.la
821%if %{without net_client_only}
822%{_libdir}/libsvn_fs_base-1.la
823%endif
824%{_libdir}/libsvn_fs_fs-1.la
825%{_libdir}/libsvn_fs_util-1.la
826%{_libdir}/libsvn_fs_x-1.la
827%{_libdir}/libsvn_ra-1.la
828%{_libdir}/libsvn_ra_local-1.la
829%{_libdir}/libsvn_ra_serf-1.la
830%{_libdir}/libsvn_ra_svn-1.la
831%{_libdir}/libsvn_repos-1.la
832%{_libdir}/libsvn_subr-1.la
833%{_libdir}/libsvn_wc-1.la
834%if %{with gnome}
835# only for feature check, linking will fail (no libsvn_auth_gnome_keyring.so)
836%{_pkgconfigdir}/libsvn_auth_gnome_keyring.pc
837%endif
838%if %{with kwallet}
839# only for feature check, linking will fail (no libsvn_auth_kwallet.so)
840%{_pkgconfigdir}/libsvn_auth_kwallet.pc
841%endif
842%{_pkgconfigdir}/libsvn_client.pc
843%{_pkgconfigdir}/libsvn_delta.pc
844%{_pkgconfigdir}/libsvn_diff.pc
845%{_pkgconfigdir}/libsvn_fs.pc
846%if %{without net_client_only}
847%{_pkgconfigdir}/libsvn_fs_base.pc
848%endif
849%{_pkgconfigdir}/libsvn_fs_fs.pc
850%{_pkgconfigdir}/libsvn_fs_util.pc
851%{_pkgconfigdir}/libsvn_fs_x.pc
852%{_pkgconfigdir}/libsvn_ra.pc
853%{_pkgconfigdir}/libsvn_ra_local.pc
854%{_pkgconfigdir}/libsvn_ra_serf.pc
855%{_pkgconfigdir}/libsvn_ra_svn.pc
856%{_pkgconfigdir}/libsvn_repos.pc
857%{_pkgconfigdir}/libsvn_subr.pc
858%{_pkgconfigdir}/libsvn_wc.pc
859%{_includedir}/%{name}-1
860%{_examplesdir}/%{name}-%{version}
861
862%files static
863%defattr(644,root,root,755)
864%{_libdir}/libsvn_client-1.a
865%{_libdir}/libsvn_delta-1.a
866%{_libdir}/libsvn_diff-1.a
867%{_libdir}/libsvn_fs-1.a
868%if %{without net_client_only}
869%{_libdir}/libsvn_fs_base-1.a
870%endif
871%{_libdir}/libsvn_fs_fs-1.a
872%{_libdir}/libsvn_fs_util-1.a
873%{_libdir}/libsvn_fs_x-1.a
874%{_libdir}/libsvn_ra-1.a
875%{_libdir}/libsvn_ra_local-1.a
876%{_libdir}/libsvn_ra_serf-1.a
877%{_libdir}/libsvn_ra_svn-1.a
878%{_libdir}/libsvn_repos-1.a
879%{_libdir}/libsvn_subr-1.a
880%{_libdir}/libsvn_wc-1.a
881
882%if %{with gnome}
883%files -n gnome-keyring-subversion
884%defattr(644,root,root,755)
885%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
886%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
887# does anything use it? requires libsvn_auth_gnome_keyring.so
888#%{_pkgconfigdir}/libsvn_auth_gnome_keyring.pc
889%endif
890
891%if %{with kwallet}
892%files -n kde5-kwallet-subversion
893%defattr(644,root,root,755)
894%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
895%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
896# does anything use it? requires libsvn_auth_kwallet.so
897#%{_pkgconfigdir}/libsvn_auth_kwallet.pc
898%endif
899
900%if %{without net_client_only}
901%files svnserve
902%defattr(644,root,root,755)
903%attr(755,root,root) %{_bindir}/svnserve
904%{_mandir}/man5/svnserve.conf.5*
905%{_mandir}/man8/svnserve.8*
906%dir %attr(750,svn,svn) /home/services/subversion
907%dir %attr(750,svn,svn) /home/services/subversion/repos
908%if %{with apache}
909%attr(754,root,root) /etc/rc.d/init.d/svnserve
910%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
911%endif
912
913%files tools
914%defattr(644,root,root,755)
915# tools/backup/hot-backup.py
916%attr(755,root,root) %{_bindir}/svn-hot-backup
917
918# tools/diff
919%attr(755,root,root) %{_bindir}/svndiff
920%attr(755,root,root) %{_bindir}/svndiff3
921%attr(755,root,root) %{_bindir}/svndiff4
922
923# tools/server-side
924%attr(755,root,root) %{_bindir}/svnfsfs
925%attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
926%attr(755,root,root) %{_bindir}/svnauthz
927%attr(755,root,root) %{_bindir}/svnauthz-validate
928
929# tools/client-side
930%attr(755,root,root) %{_bindir}/svnbench
931
932# tools/dev/svnraisetreeconflict
933%attr(755,root,root) %{_bindir}/svnraisetreeconflict
934
935# tools/dev/
936%attr(755,root,root) %{_bindir}/fsfs-access-map
937%attr(755,root,root) %{_bindir}/x509-parser
938
939%files -n bash-completion-subversion
940%defattr(644,root,root,755)
941/etc/bash_completion.d/%{name}
942
943%endif # net_client_only
944
945%if %{with java}
946%files -n java-subversion
947%defattr(644,root,root,755)
948%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
949%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
950%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
951%{_javadir}/svn-javahl.jar
952%endif
953
954%if %{with python}
955%files -n python-subversion
956%defattr(644,root,root,755)
957%doc tools/backup/*.py
958%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
959%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
960%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
961%dir %{py_sitedir}/libsvn
962%attr(755,root,root) %{py_sitedir}/libsvn/_*.so
963%{py_sitedir}/libsvn/*.py[co]
964%dir %{py_sitedir}/svn
965%{py_sitedir}/svn/*.py[co]
966%{_examplesdir}/python-%{name}-%{version}
967%endif
968
969%if %{with csvn}
970%files -n python-csvn
971%defattr(644,root,root,755)
972%doc subversion/bindings/ctypes-python/{README,TODO}
973%doc subversion/bindings/ctypes-python/examples/*.py
974%dir %{py_sitescriptdir}/csvn
975%{py_sitescriptdir}/csvn/*.py[co]
976%dir %{py_sitescriptdir}/csvn/core
977%{py_sitescriptdir}/csvn/core/*.py[co]
978%dir %{py_sitescriptdir}/csvn/ext
979%{py_sitescriptdir}/csvn/ext/*.py[co]
980%{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
981%endif
982
983%if %{with perl}
984%files -n perl-subversion
985%defattr(644,root,root,755)
986%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
987%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
988%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
989%{perl_vendorarch}/SVN
990%dir %{perl_vendorarch}/auto/SVN
991%dir %{perl_vendorarch}/auto/SVN/*
992%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
993%{_mandir}/man3/*.3pm*
994%endif
995
996%if %{with ruby}
997%files -n ruby-subversion
998%defattr(644,root,root,755)
999%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
1000%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
1001%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
1002%dir %{ruby_vendorarchdir}/svn
1003%{ruby_vendorarchdir}/svn/*.rb
1004%dir %{ruby_vendorarchdir}/svn/ext
1005%attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
1006%{ruby_ridir}/Svn
1007%endif
1008
1009%if %{with apache}
1010%files -n apache-mod_dav_svn
1011%defattr(644,root,root,755)
1012%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
1013%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
1014
1015%files -n apache-mod_authz_svn
1016%defattr(644,root,root,755)
1017%doc subversion/mod_authz_svn/INSTALL
1018%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
1019%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
1020
1021%files -n apache-mod_dontdothat_svn
1022%defattr(644,root,root,755)
1023%doc tools/server-side/mod_dontdothat/README
1024%attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
1025%endif
This page took 0.039125 seconds and 4 git commands to generate.