]> git.pld-linux.org Git - packages/subversion.git/blame_incremental - subversion.spec
add BR: sqlite3-devel
[packages/subversion.git] / subversion.spec
... / ...
CommitLineData
1# TODO:
2# - fix java build with java-gcj-compat and s/java-sun/jdk/
3# - remove net_client_only and add db bcond (then without apache and
4# without db => net_client_only - spec will be more simpler, I think)
5# - finish ruby
6#
7# Conditional build:
8%bcond_with net_client_only # build only net client
9%bcond_without neon # use serf instead of neon
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
12%bcond_without ruby # build without ruby bindings
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
16#
17%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
18%undefine with_javahl
19%endif
20#
21%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
22%define apxs /usr/sbin/apxs
23%define pdir SVN
24%define pnam _Core
25#
26%if %{with neon}
27%define webdavlib neon
28%else
29%define webdavlib serf
30%endif
31#
32Summary: A Concurrent Versioning system similar to but better than CVS
33Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
34Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
35Name: subversion
36Version: 1.6.0
37Release: 0.1
38License: Apache/BSD-like
39Group: Development/Version Control
40Source0: http://subversion.tigris.org/downloads/%{name}-%{version}-rc3.tar.bz2
41# Source0-md5: 58473cb07611fd7567b6ce99461009e1
42Source1: %{name}-dav_svn.conf
43Source2: %{name}-authz_svn.conf
44Source3: %{name}-svnserve.init
45Source4: %{name}-svnserve.sysconfig
46# current subversion tarball has correct *.swg files
47# but after regeneration these are broken again, so
48# we still need this script
49Source5: %{name}-convert-typemaps-to-ifdef.py
50Patch0: %{name}-home_etc.patch
51Patch1: %{name}-DESTDIR.patch
52Patch2: %{name}-ruby-datadir-path.patch
53URL: http://subversion.tigris.org/
54%if %{with net_client_only}
55%global apache_modules_api 0
56%else
57%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
58BuildRequires: automake
59BuildRequires: db-devel >= 4.1.25
60BuildRequires: rpmbuild(macros) >= 1.268
61%if %{with perl}
62BuildRequires: perl-devel >= 1:5.8.0
63BuildRequires: rpm-perlprov >= 4.1-13
64BuildRequires: swig-perl >= 1.3.24
65%endif
66%{?with_javahl:BuildRequires: java-sun}
67%endif
68BuildRequires: apr-devel >= 1:1.0.0
69BuildRequires: apr-util-devel >= 1:1.2.8-3
70BuildRequires: autoconf >= 2.59
71BuildRequires: bison
72BuildRequires: cyrus-sasl-devel
73BuildRequires: expat-devel
74BuildRequires: gettext-devel
75BuildRequires: gnome-keyring-devel
76BuildRequires: kde4-kdelibs-devel
77BuildRequires: libtool >= 1.4-9
78BuildRequires: sed >= 4.0
79BuildRequires: sqlite3-devel >= 3.6.11
80BuildRequires: texinfo
81BuildRequires: which
82%if %{with neon}
83BuildRequires: neon-devel >= 0.26.0
84%else
85BuildRequires: serf-devel
86%endif
87BuildRequires: python >= 2.2
88BuildRequires: python-modules >= 2.2
89%if %{with python}
90BuildRequires: python-ctypesgen
91BuildRequires: python-devel >= 2.2
92BuildRequires: swig-python >= 1.3.24
93%endif
94%if %{with ruby}
95BuildRequires: ruby-devel
96BuildRequires: swig-ruby >= 1.3.24
97%endif
98Requires: %{name}-libs = %{version}-%{release}
99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101%define _libexecdir %{_libdir}/svn
102%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
103%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
104
105%description
106The goal of the Subversion project is to build a version control
107system that is a compelling replacement for CVS in the open source
108community.
109
110Our goals are:
111- All current CVS features.
112- Directories, renames, and file meta-data are versioned.
113- Symbolic links, etc, are supported
114- Commits are truly atomic.
115- Branching and tagging are cheap (constant time) operations
116- Repeated merges are handled gracefully
117- Support for plug-in client side diff programs
118- Natively client/server
119- Client/server protocol sends diffs in both directions
120- Costs are proportional to change size, not project size
121- Internationalization
122- Progressive multi-lingual support
123
124%description -l pl.UTF-8
125Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
126zamiennika dla CVS.
127
128Cele projektu to:
129- Wszystkie aktualne możliwości CVS.
130- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
131- Obsługa dowiązań symbolicznych itp.
132- Commity są w pełni atomowe.
133- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
134- Dobra obsługa powtarzanego łączenia (merge).
135- Obsługa wtyczek diff po stronie klienta.
136- Natywny klient/serwer.
137- Klient/Serwer przesyłają diffy w obu kierunkach.
138- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
139- Internacjonalizacja.
140- Postępujące wsparcie dla wielu języków.
141
142%description -l pt_BR.UTF-8
143O objetivo do projeto Subversion é construir um sistema de controle de
144versões que seja um substituto para o CVS (Concurrent Versioning
145System) na comunidade opensource, fornecendo grandes melhorias.
146
147%package libs
148Summary: Subversion libraries and modules
149Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
150Group: Libraries
151%{?with_neon:Requires: neon >= 0.26.0}
152Obsoletes: libsubversion0
153
154%description libs
155Subversion libraries and modules.
156
157%description libs -l pl.UTF-8
158Biblioteka subversion oraz ładowalne moduły.
159
160%package devel
161Summary: Header files and develpment documentation for subversion
162Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
163Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
164Group: Development/Libraries
165Requires: %{name}-libs = %{version}-%{release}
166Requires: apr-util-devel >= 1:1.0.0
167%{?with_neon:Requires: neon-devel >= 0.26.0}
168Obsoletes: libsubversion0-devel
169
170%description devel
171Header files and develpment documentation for subversion.
172
173%description devel -l pl.UTF-8
174Pliki nagłówkowe i dokumetacja do subversion.
175
176%description devel -l pt_BR.UTF-8
177Este pacote provê os arquivos necessários para desenvolvedores
178interagirem com o Subversion.
179
180%package static
181Summary: Static subversion library
182Summary(pl.UTF-8): Biblioteka statyczna subversion
183Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
184Group: Development/Libraries
185Requires: %{name}-devel = %{version}
186Obsoletes: libsubversion0-static-devel
187
188%description static
189Static subversion library.
190
191%description static -l pl.UTF-8
192Biblioteka statyczna subversion.
193
194%description static -l pt_BR.UTF-8
195Este pacote provê um cliente estático do subversion.
196
197%package svnserve
198Summary: Subversion svnserve
199Summary(pl.UTF-8): Subversion svnserve
200Group: Networking/Daemons
201Requires(post,preun): /sbin/chkconfig
202Requires(postun): /usr/sbin/groupdel
203Requires(postun): /usr/sbin/userdel
204Requires(pre): /bin/id
205Requires(pre): /usr/bin/getgid
206Requires(pre): /usr/lib/rpm/user_group.sh
207Requires(pre): /usr/sbin/groupadd
208Requires(pre): /usr/sbin/useradd
209Requires(pre): /usr/sbin/usermod
210Requires: %{name} = %{version}-%{release}
211Requires: rc-scripts
212Provides: group(svn)
213Provides: user(svn)
214
215%description svnserve
216Subversion svnserve server.
217
218%description svnserve -l pl.UTF-8
219Serwer subversion svnserve.
220
221%package tools
222Summary: Subversion tools and scripts
223Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
224Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
225Group: Applications
226%pyrequires_eq python
227Requires: %{name} = %{version}-%{release}
228Requires: python-rcsparse >= 0.1-0.20031026.0
229Requires: python-subversion = %{version}
230
231%description tools
232Subversion tools and scripts.
233
234%description tools -l pl.UTF-8
235Narzędzia oraz skrypty dla subversion.
236
237%package -n bash-completion-subversion
238Summary: bash completion for subversion
239Summary(pl.UTF-8): Dopełnienia basha dla subversion
240Group: Applications/Shells
241Requires: %{name} = %{version}-%{release}
242Requires: bash-completion
243Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
244
245%description -n bash-completion-subversion
246Bash completion for subversion.
247
248%description -n bash-completion-subversion -l pl.UTF-8
249Dopełnienia basha dla subversion.
250
251%package -n java-subversion
252Summary: Subversion Java bindings
253Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
254Group: Development/Languages/Java
255Requires: %{name}-libs = %{version}-%{release}
256
257%description -n java-subversion
258This is a set of Java classes which provide the functionality of
259subversion-libs, the Subversion libraries. It is useful if you want
260to, for example, write a Java class that manipulates a Subversion
261repository or working copy. See the 'subversion' package for more
262information.
263
264%description -n java-subversion -l pl.UTF-8
265Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
267pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268roboczą. Więcej informacji w pakiecie subversion.
269
270%package -n python-subversion
271Summary: Subversion Python bindings
272Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
273Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
274Group: Development/Languages/Python
275%pyrequires_eq python
276Requires: %{name}-libs = %{version}-%{release}
277Obsoletes: subversion-python
278
279%description -n python-subversion
280Subversion Python bindings.
281
282%description -n python-subversion -l pl.UTF-8
283Dowiązania do Subversion dla Pythona.
284
285%description -n python-subversion -l pt_BR.UTF-8
286Módulos Python para acessar os recursos do Subversion.
287
288%package -n python-csvn
289Summary: CTypes Subversion Python bindings
290Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
291Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
292Group: Development/Languages/Python
293%pyrequires_eq python
294Requires: %{name}-libs = %{version}-%{release}
295
296%description -n python-csvn
297Subversion CTypes Python bindings.
298
299%description -n python-csvn -l pl.UTF-8
300Dowiązania do Subversion dla Pythona używające CTypes.
301
302%description -n python-csvn -l pt_BR.UTF-8
303Módulos Python para acessar os recursos do Subversion.
304
305%package -n perl-subversion
306Summary: Subversion Perl bindings
307Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
308Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
309Group: Development/Languages/Perl
310Requires: %{name}-libs = %{version}-%{release}
311Obsoletes: subversion-perl
312
313%description -n perl-subversion
314Subversion Perl bindings.
315
316%description -n perl-subversion -l pl.UTF-8
317Dowiązania do Subversion dla Perla.
318
319%description -n perl-subversion -l pt_BR.UTF-8
320Módulos Perl para acessar os recursos do Subversion.
321
322%package -n ruby-subversion
323Summary: Subversion Ruby bindings
324Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
325Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
326Group: Development/Languages
327Requires: %{name}-libs = %{version}-%{release}
328Obsoletes: subversion-ruby
329
330%description -n ruby-subversion
331Subversion Ruby bindings.
332
333%description -n ruby-subversion -l pl.UTF-8
334Dowiązania do Subversion dla języka Ruby.
335
336%description -n ruby-subversion -l pt_BR.UTF-8
337Módulos Ruby para acessar os recursos do Subversion.
338
339%package -n apache-mod_dav_svn
340Summary: Apache module: Subversion Server
341Summary(pl.UTF-8): Moduł apache: Serwer Subversion
342Group: Networking/Daemons
343Requires: %{name} = %{version}-%{release}
344Requires: apache(modules-api) = %apache_modules_api
345Requires: apache-mod_dav
346
347%description -n apache-mod_dav_svn
348Apache module: Subversion Server.
349
350%description -n apache-mod_dav_svn -l pl.UTF-8
351Moduł apache: Serwer Subversion.
352
353%package -n apache-mod_authz_svn
354Summary: Apache module: Subversion Server - path-based authorization
355Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
356Group: Networking/Daemons
357Requires: apache(modules-api) = %apache_modules_api
358Requires: apache-mod_dav_svn = %{version}-%{release}
359
360%description -n apache-mod_authz_svn
361Apache module: Subversion Server - path-based authorization.
362
363%description -n apache-mod_authz_svn -l pl.UTF-8
364Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
365
366%package -n gnome-keyring-subversion
367Summary: Subversion module for Gnome Keyring
368Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
369Group: X11/Applications
370
371%description -n gnome-keyring-subversion
372Subversion module for Gnome Keyring.
373
374%description -n gnome-keyring-subversion -l pl.UTF-8
375Moduł subversion dla zarządcy kluczy Gnome.
376
377%package -n kde4-kwallet-subversion
378Summary: Subversion module for KDE Wallet
379Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
380Group: X11/Applications
381
382%description -n kde4-kwallet-subversion
383Subversion module for KDE Wallet.
384
385%description -n kde4-kwallet-subversion -l pl.UTF-8
386Moduł subversion dla Portfela KDE.
387
388%prep
389%setup -q -n %{name}-%{version}-rc3
390rm -rf apr apr-util neon
391%patch0 -p0
392%patch1 -p1
393%patch2 -p0
394
395sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397# serf.m4 macro is broken and ignores --without serf
398%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
399
400%build
401rm subversion/bindings/swig/proxy/*.swg
402cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
403cp -f /usr/share/automake/config.sub ac-helpers
404chmod +x ./autogen.sh && ./autogen.sh
405
406%configure \
407 --with-editor=vi \
408 --with-zlib=%{_libdir} \
409%if %{with net_client_only}
410 --without-apache \
411 --without-swig \
412 --without-apxs \
413 --without-berkeley-db \
414%else
415 --disable-runtime-module-search \
416 --disable-mod-activation \
417%if %{with apache}
418 --with-apxs=%{_sbindir}/apxs \
419%else
420 --without-apache \
421 --without-apxs \
422 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
423%endif
424%if !%{with python} && !%{with perl} && !%{with ruby}
425 --without-swig \
426%endif
427 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
428 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
429%endif
430 --with-jdk="%{java_home}" \
431%if %{with neon}
432 --without-serf \
433 --with-neon=%{_prefix} \
434 --disable-neon-version-check \
435%else
436 --with-serf=%{_prefix} \
437 --without-neon \
438%endif
439 --with-apr=%{_bindir}/apr-1-config \
440 --with-apr-util=%{_bindir}/apu-1-config \
441 --with-kwallet \
442 --with-gnome-keyring
443
444%{__make} -j1
445
446%if !%{with net_client_only}
447# python
448%if %{with python}
449# ctypes bindings
450%{__make} ctypes-python
451# swig bindings
452%{__make} swig-py \
453 swig_pydir=%{py_sitedir}/libsvn \
454 swig_pydir_extra=%{py_sitedir}/svn
455%endif
456# perl
457%if %{with perl}
458%{__make} -j1 swig-pl-lib
459odir=$(pwd)
460cd subversion/bindings/swig/perl/native
461%{__perl} Makefile.PL INSTALLDIRS=vendor
462%{__make} -j1
463cd $odir
464%endif
465%if %{with javahl}
466%{__make} -j1 javahl \
467 javahl_javadir="%{_javadir}"
468%endif
469# ruby
470%if %{with ruby}
471%{__make} swig-rb
472%endif
473%endif
474
475%if %{with tests}
476%{__make} check
477%if %{with python}
478%{__make} check-ctypes-python
479%{__make} check-swig-py
480%endif
481%if %{with perl}
482%{__make} check-swig-pl
483%endif
484%if %{with ruby}
485%{__make} check-swig-rb
486%endif
487%endif
488
489%install
490rm -rf $RPM_BUILD_ROOT
491install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
492 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
493 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
494 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
495
496%{__make} install -j1 \
497%if %{with javahl}
498 install-javahl \
499 javahl_javadir="%{_javadir}" \
500%endif
501%if !%{with net_client_only}
502%if %{with python}
503 install-swig-py \
504 install-ctypes-python \
505%endif
506%if %{with ruby}
507 install-swig-rb install-swig-rb-doc \
508%endif
509%endif
510 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
511 DESTDIR=$RPM_BUILD_ROOT \
512 swig_pydir=%{py_sitedir}/libsvn \
513 swig_pydir_extra=%{py_sitedir}/svn
514
515%if !%{with net_client_only} && %{with perl}
516%{__make} install-swig-pl-lib \
517 DESTDIR=$RPM_BUILD_ROOT
518%{__make} -C subversion/bindings/swig/perl/native install \
519 DESTDIR=$RPM_BUILD_ROOT \
520 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
521 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
522%endif
523
524%if %{with apache}
525install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
526install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
527install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
528install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
529%endif
530
531%if !%{with net_client_only}
532install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
533%if %{with python}
534%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
535%py_comp $RPM_BUILD_ROOT%{py_sitedir}
536find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
537install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
538%endif
539%endif
540
541install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
542install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
543
544%find_lang %{name}
545
546rm $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
547rm $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
548
549%clean
550rm -rf $RPM_BUILD_ROOT
551
552%pre svnserve
553%groupadd -g 86 svn
554%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
555
556%post libs -p /sbin/ldconfig
557%postun libs -p /sbin/ldconfig
558
559%post devel -p /sbin/postshell
560-/usr/sbin/fix-info-dir -c %{_infodir}
561
562%postun devel -p /sbin/postshell
563-/usr/sbin/fix-info-dir -c %{_infodir}
564
565%post -n perl-subversion -p /sbin/ldconfig
566%postun -n perl-subversion -p /sbin/ldconfig
567
568%post -n python-subversion -p /sbin/ldconfig
569%postun -n python-subversion -p /sbin/ldconfig
570
571%post svnserve
572/sbin/chkconfig --add svnserve
573%service svnserve restart "svnserve daemon"
574
575%preun svnserve
576if [ "$1" = "0" ]; then
577 %service svnserve stop
578 /sbin/chkconfig --del svnserve
579fi
580
581%postun svnserve
582if [ "$1" = "0" ]; then
583 %userremove svn
584 %groupremove svn
585fi
586
587%post -n apache-mod_dav_svn
588%service -q httpd restart
589
590%preun -n apache-mod_dav_svn
591if [ "$1" = "0" ]; then
592 %service -q httpd restart
593fi
594
595%files
596%defattr(644,root,root,755)
597%doc BUGS CHANGES COPYING INSTALL README
598%doc doc/*/*.html
599%doc tools/hook-scripts/*.{pl,py,example}
600%doc tools/hook-scripts/mailer/*.{py,example}
601%doc tools/xslt/*
602%attr(755,root,root) %{_bindir}/svn
603%attr(755,root,root) %{_bindir}/svnadmin
604%attr(755,root,root) %{_bindir}/svndumpfilter
605%attr(755,root,root) %{_bindir}/svnlook
606%attr(755,root,root) %{_bindir}/svnsync
607%attr(755,root,root) %{_bindir}/svnversion
608%{_mandir}/man1/svn.1*
609%{_mandir}/man1/svnadmin.1*
610%{_mandir}/man1/svndumpfilter.1*
611%{_mandir}/man1/svnlook.1*
612%{_mandir}/man1/svnsync.1*
613%{_mandir}/man1/svnversion.1*
614
615%files libs -f %{name}.lang
616%defattr(644,root,root,755)
617%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
618%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
619%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
620%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
621%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
622%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
623%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
624%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
625%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
626%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
627%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
628%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
629%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
630%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
631%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
632%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
633%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
634%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
635%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
636%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
637%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
638%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
639%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
640%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
641%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
642%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
643%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
644%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
645
646%files devel
647%defattr(644,root,root,755)
648%attr(755,root,root) %{_libdir}/libsvn_client-1.so
649%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
650%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
651%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
652%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
653%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
654%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
655%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
656%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
657%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
658%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
659%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
660%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
661%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
662%{_libdir}/libsvn_client-1.la
663%{_libdir}/libsvn_delta-1.la
664%{_libdir}/libsvn_diff-1.la
665%{_libdir}/libsvn_fs-1.la
666%{_libdir}/libsvn_fs_base-1.la
667%{_libdir}/libsvn_fs_fs-1.la
668%{_libdir}/libsvn_fs_util-1.la
669%{_libdir}/libsvn_ra-1.la
670%{_libdir}/libsvn_ra_local-1.la
671%{_libdir}/libsvn_ra_%{webdavlib}-1.la
672%{_libdir}/libsvn_ra_svn-1.la
673%{_libdir}/libsvn_repos-1.la
674%{_libdir}/libsvn_subr-1.la
675%{_libdir}/libsvn_wc-1.la
676%{_includedir}/%{name}-1
677%{_examplesdir}/%{name}-%{version}
678
679%files static
680%defattr(644,root,root,755)
681%{_libdir}/libsvn_client-1.a
682%{_libdir}/libsvn_delta-1.a
683%{_libdir}/libsvn_diff-1.a
684%{_libdir}/libsvn_fs-1.a
685%{_libdir}/libsvn_fs_base-1.a
686%{_libdir}/libsvn_fs_fs-1.a
687%{_libdir}/libsvn_fs_util-1.a
688%{_libdir}/libsvn_ra-1.a
689%{_libdir}/libsvn_ra_local-1.a
690%{_libdir}/libsvn_ra_%{webdavlib}-1.a
691%{_libdir}/libsvn_ra_svn-1.a
692%{_libdir}/libsvn_repos-1.a
693%{_libdir}/libsvn_subr-1.a
694%{_libdir}/libsvn_wc-1.a
695
696%files -n gnome-keyring-subversion
697%defattr(644,root,root,755)
698%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
699%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
700
701%files -n kde4-kwallet-subversion
702%defattr(644,root,root,755)
703%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
704%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
705
706%if !%{with net_client_only}
707%files svnserve
708%defattr(644,root,root,755)
709%attr(755,root,root) %{_bindir}/svnserve
710%{_mandir}/man5/svnserve.conf.5*
711%{_mandir}/man8/svnserve.8*
712%dir %attr(750,svn,svn) /home/services/subversion
713%dir %attr(750,svn,svn) /home/services/subversion/repos
714%if %{with apache}
715%attr(754,root,root) /etc/rc.d/init.d/svnserve
716%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
717%endif
718
719%files tools
720%defattr(644,root,root,755)
721%attr(755,root,root) %{_bindir}/svn-hot-backup
722
723%files -n bash-completion-subversion
724%defattr(644,root,root,755)
725/etc/bash_completion.d/%{name}
726
727%if %{with javahl}
728%files -n java-subversion
729%defattr(644,root,root,755)
730%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
731%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
732%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
733%{_javadir}/svn-javahl.jar
734%endif
735
736%if %{with python}
737%files -n python-subversion
738%defattr(644,root,root,755)
739%doc tools/backup/*.py tools/examples/*.py
740%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
741%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
742%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
743%dir %{py_sitedir}/libsvn
744%{py_sitedir}/libsvn/*.py[co]
745%dir %{py_sitedir}/svn
746%{py_sitedir}/svn/*.py[co]
747%attr(755,root,root) %{py_sitedir}/libsvn/*.so
748%{_examplesdir}/python-%{name}-%{version}
749
750%files -n python-csvn
751%defattr(644,root,root,755)
752%doc subversion/bindings/ctypes-python/{README,TODO}
753%doc subversion/bindings/ctypes-python/examples/*.py
754%dir %{py_sitescriptdir}/csvn
755%{py_sitescriptdir}/csvn/*.py[co]
756%dir %{py_sitescriptdir}/csvn/core
757%{py_sitescriptdir}/csvn/core/*.py[co]
758%dir %{py_sitescriptdir}/csvn/ext
759%{py_sitescriptdir}/csvn/ext/*.py[co]
760%{py_sitescriptdir}/*.egg-info
761%endif
762
763%if %{with perl}
764%files -n perl-subversion
765%defattr(644,root,root,755)
766%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
767%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
768%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
769%{perl_vendorarch}/SVN
770%dir %{perl_vendorarch}/auto/SVN
771%dir %{perl_vendorarch}/auto/SVN/*
772%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
773%{perl_vendorarch}/auto/SVN/*/*.bs
774%{_mandir}/man3/*.3pm*
775%endif
776
777%if %{with ruby}
778%files -n ruby-subversion
779%defattr(644,root,root,755)
780%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
781%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
782%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
783%dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
784%dir %{_libdir}/ruby/site_ruby/*/svn
785%{_libdir}/ruby/site_ruby/*/svn/*.rb
786%dir %{_libdir}/ruby/site_ruby/*/*-*
787%dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
788%attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
789%{_datadir}/ri/*.*/system/OptionParser
790%{_datadir}/ri/*.*/system/Svn
791%{_datadir}/ri/*.*/system/Time
792%{_datadir}/ri/*.*/system/Uconv
793%{_datadir}/ri/*.*/system/*.rid
794%{_datadir}/ri/*.*/system/Kernel/*
795%endif
796
797%if %{with apache}
798%files -n apache-mod_dav_svn
799%defattr(644,root,root,755)
800%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
801%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
802
803%files -n apache-mod_authz_svn
804%defattr(644,root,root,755)
805%doc subversion/mod_authz_svn/INSTALL
806%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
807%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
808%endif
809
810%endif # net_client_only
This page took 0.039974 seconds and 4 git commands to generate.