]> git.pld-linux.org Git - packages/subversion.git/blame_incremental - subversion.spec
- up to 1.8.10 (fixes CVE-2014-3522, CVE-2014-3528)
[packages/subversion.git] / subversion.spec
... / ...
CommitLineData
1# Conditional build:
2%bcond_with net_client_only # build only net client
3%bcond_without swig # disable bindings generation with Swig
4%bcond_without python # build without Python bindings (broken)
5%bcond_without csvn # build Python csvn bindings
6%bcond_without perl # build without Perl bindings
7%bcond_without ruby # build without Ruby bindings
8%bcond_without apache # build without Apache support (webdav, etc)
9%bcond_without java # build without javahl support (Java high-level bindings)
10%bcond_without tests # don't perform "make check"
11%bcond_without kwallet # build without kde4 wallet support
12%bcond_without kde # build without kde4 support (alias for kwallet)
13%bcond_without gnome # build without gnome keyring support
14%bcond_without db # disable Subversion Berkeley DB based filesystem library
15%bcond_with db6 # allow BDB6 (not tested by upstream, released on AGPL)
16
17# for AC: --without csvn,gnome,java,kde,ruby
18
19%if %{with net_client_only}
20%undefine with_apache
21%undefine with_db
22%undefine with_swig
23%undefine with_java
24%undefine with_csvn
25%undefine with_gnome
26%undefine with_kde
27%endif
28
29%if %{without swig}
30%undefine with_perl
31%undefine with_python
32%undefine with_ruby
33%endif
34
35%if %{without kde}
36%undefine with_kwallet
37%endif
38
39%if %{without python} && %{without perl} && %{without ruby}
40%undefine with_swig
41%endif
42
43%define apxs /usr/sbin/apxs
44%define pdir SVN
45%define pnam _Core
46
47%{?with_perl:%include /usr/lib/rpm/macros.perl}
48Summary: A Concurrent Versioning system similar to but better than CVS
49Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
50Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
51Name: subversion
52Version: 1.8.10
53Release: 1
54License: Apache v2.0
55Group: Development/Version Control
56Source0: http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
57# Source0-md5: 3068256761b40863df96128834d6b71b
58Source1: %{name}-dav_svn.conf
59Source2: %{name}-authz_svn.conf
60Source3: %{name}-svnserve.init
61Source4: %{name}-svnserve.sysconfig
62# current subversion tarball has correct *.swg files
63# but after regeneration these are broken again, so
64# we still need this script
65Source5: %{name}-convert-typemaps-to-ifdef.py
66Patch0: %{name}-home_etc.patch
67Patch1: %{name}-DESTDIR.patch
68Patch2: %{name}-ruby-datadir-path.patch
69Patch3: %{name}-tests.patch
70URL: http://subversion.apache.org/
71%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
72BuildRequires: apr-devel >= 1:1.0.0
73BuildRequires: apr-util-devel >= 1:1.2.8-3
74BuildRequires: autoconf >= 2.59
75BuildRequires: automake
76BuildRequires: bison
77BuildRequires: cyrus-sasl-devel
78%if %{with kwallet} || %{with gnome}
79BuildRequires: dbus-devel
80%endif
81BuildRequires: db-devel >= 4.1.25
82BuildRequires: expat-devel
83BuildRequires: gettext-devel
84%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
85%{?with_gnome:BuildRequires: libgnome-keyring-devel}
86BuildRequires: libmagic-devel
87BuildRequires: libtool >= 1.4-9
88BuildRequires: pkgconfig
89%{?with_csvn:BuildRequires: python-ctypesgen}
90BuildRequires: rpm-pythonprov
91BuildRequires: rpmbuild(macros) >= 1.656
92BuildRequires: sed >= 4.0
93BuildRequires: serf-devel >= 1.2.1
94BuildRequires: sqlite3-devel >= 3.6.18
95BuildRequires: texinfo
96BuildRequires: which
97%if %{with java}
98BuildRequires: jdk >= 1.5
99BuildRequires: libstdc++-devel
100%endif
101%if %{with perl}
102BuildRequires: perl-devel >= 1:5.8.0
103BuildRequires: rpm-perlprov >= 4.1-13
104BuildRequires: swig-perl >= 1.3.24
105%endif
106%if %{with python}
107BuildRequires: python-devel >= 1:2.4
108BuildRequires: swig-python >= 1.3.24
109%endif
110%if %{with ruby}
111BuildRequires: rpm-rubyprov
112BuildRequires: ruby-devel >= 1:1.8.2
113BuildRequires: ruby-irb
114BuildRequires: ruby-rubygems
115BuildRequires: swig-ruby >= 1.3.24
116%endif
117Requires: %{name}-libs = %{version}-%{release}
118%requires_ge sqlite3
119BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121%define _libexecdir %{_libdir}/svn
122%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
123%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
124
125%define skip_post_check_so libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
126
127%description
128The goal of the Subversion project is to build a version control
129system that is a compelling replacement for CVS in the open source
130community.
131
132Our goals are:
133- All current CVS features.
134- Directories, renames, and file meta-data are versioned.
135- Symbolic links, etc, are supported
136- Commits are truly atomic.
137- Branching and tagging are cheap (constant time) operations
138- Repeated merges are handled gracefully
139- Support for plug-in client side diff programs
140- Natively client/server
141- Client/server protocol sends diffs in both directions
142- Costs are proportional to change size, not project size
143- Internationalization
144- Progressive multi-lingual support
145
146%description -l pl.UTF-8
147Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
148zamiennika dla CVS.
149
150Cele projektu to:
151- Wszystkie aktualne możliwości CVS.
152- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
153- Obsługa dowiązań symbolicznych itp.
154- Commity są w pełni atomowe.
155- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
156- Dobra obsługa powtarzanego łączenia (merge).
157- Obsługa wtyczek diff po stronie klienta.
158- Natywny klient/serwer.
159- Klient/Serwer przesyłają diffy w obu kierunkach.
160- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
161- Internacjonalizacja.
162- Postępujące wsparcie dla wielu języków.
163
164%description -l pt_BR.UTF-8
165O objetivo do projeto Subversion é construir um sistema de controle de
166versões que seja um substituto para o CVS (Concurrent Versioning
167System) na comunidade opensource, fornecendo grandes melhorias.
168
169%package libs
170Summary: Subversion libraries and modules
171Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
172Group: Libraries
173Requires: serf >= 1.2.1
174Obsoletes: libsubversion0
175
176%description libs
177Subversion libraries and modules.
178
179%description libs -l pl.UTF-8
180Biblioteka subversion oraz ładowalne moduły.
181
182%package devel
183Summary: Header files and develpment documentation for subversion
184Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
185Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
186Group: Development/Libraries
187Requires: %{name}-libs = %{version}-%{release}
188Requires: apr-util-devel >= 1:1.0.0
189Requires: serf-devel >= 1.2.1
190Obsoletes: libsubversion0-devel
191
192%description devel
193Header files and develpment documentation for subversion.
194
195%description devel -l pl.UTF-8
196Pliki nagłówkowe i dokumetacja do subversion.
197
198%description devel -l pt_BR.UTF-8
199Este pacote provê os arquivos necessários para desenvolvedores
200interagirem com o Subversion.
201
202%package static
203Summary: Static subversion library
204Summary(pl.UTF-8): Biblioteka statyczna subversion
205Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
206Group: Development/Libraries
207Requires: %{name}-devel = %{version}
208Obsoletes: libsubversion0-static-devel
209
210%description static
211Static subversion library.
212
213%description static -l pl.UTF-8
214Biblioteka statyczna subversion.
215
216%description static -l pt_BR.UTF-8
217Este pacote provê um cliente estático do subversion.
218
219%package svnserve
220Summary: Subversion svnserve
221Summary(pl.UTF-8): Subversion svnserve
222Group: Networking/Daemons
223Requires(post,preun): /sbin/chkconfig
224Requires(postun): /usr/sbin/groupdel
225Requires(postun): /usr/sbin/userdel
226Requires(pre): /bin/id
227Requires(pre): /usr/bin/getgid
228Requires(pre): /usr/lib/rpm/user_group.sh
229Requires(pre): /usr/sbin/groupadd
230Requires(pre): /usr/sbin/useradd
231Requires(pre): /usr/sbin/usermod
232Requires: %{name} = %{version}-%{release}
233Requires: rc-scripts
234Provides: group(svn)
235Provides: user(svn)
236
237%description svnserve
238Subversion svnserve server.
239
240%description svnserve -l pl.UTF-8
241Serwer subversion svnserve.
242
243%package tools
244Summary: Subversion tools and scripts
245Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
246Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
247Group: Applications
248Requires: %{name} = %{version}-%{release}
249Requires: python
250Requires: python-subversion = %{version}
251
252%description tools
253Subversion tools and scripts.
254
255%description tools -l pl.UTF-8
256Narzędzia oraz skrypty dla subversion.
257
258%package -n bash-completion-subversion
259Summary: bash completion for subversion
260Summary(pl.UTF-8): Dopełnienia basha dla subversion
261Group: Applications/Shells
262Requires: %{name} = %{version}-%{release}
263Requires: bash-completion
264Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
265%if "%{_rpmversion}" >= "5"
266BuildArch: noarch
267%endif
268
269%description -n bash-completion-subversion
270Bash completion for subversion.
271
272%description -n bash-completion-subversion -l pl.UTF-8
273Dopełnienia basha dla subversion.
274
275%package -n java-subversion
276Summary: Subversion Java bindings
277Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
278Group: Development/Languages/Java
279Requires: %{name}-libs = %{version}-%{release}
280
281%description -n java-subversion
282This is a set of Java classes which provide the functionality of
283subversion-libs, the Subversion libraries. It is useful if you want
284to, for example, write a Java class that manipulates a Subversion
285repository or working copy. See the 'subversion' package for more
286information.
287
288%description -n java-subversion -l pl.UTF-8
289Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
290subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
291pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
292roboczą. Więcej informacji w pakiecie subversion.
293
294%package -n python-subversion
295Summary: Subversion Python bindings
296Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
297Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
298Group: Development/Languages/Python
299Requires: %{name}-libs = %{version}-%{release}
300Requires: python
301Obsoletes: subversion-python
302
303%description -n python-subversion
304Subversion Python bindings.
305
306%description -n python-subversion -l pl.UTF-8
307Dowiązania do Subversion dla Pythona.
308
309%description -n python-subversion -l pt_BR.UTF-8
310Módulos Python para acessar os recursos do Subversion.
311
312%package -n python-csvn
313Summary: CTypes Subversion Python bindings
314Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
315Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
316Group: Development/Languages/Python
317Requires: %{name}-libs = %{version}-%{release}
318Requires: python
319
320%description -n python-csvn
321Subversion CTypes Python bindings.
322
323%description -n python-csvn -l pl.UTF-8
324Dowiązania do Subversion dla Pythona używające CTypes.
325
326%description -n python-csvn -l pt_BR.UTF-8
327Módulos Python para acessar os recursos do Subversion.
328
329%package -n perl-subversion
330Summary: Subversion Perl bindings
331Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
332Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
333Group: Development/Languages/Perl
334Requires: %{name}-libs = %{version}-%{release}
335Obsoletes: subversion-perl
336
337%description -n perl-subversion
338Subversion Perl bindings.
339
340%description -n perl-subversion -l pl.UTF-8
341Dowiązania do Subversion dla Perla.
342
343%description -n perl-subversion -l pt_BR.UTF-8
344Módulos Perl para acessar os recursos do Subversion.
345
346%package -n ruby-subversion
347Summary: Subversion Ruby bindings
348Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
349Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
350Group: Development/Languages
351Requires: %{name}-libs = %{version}-%{release}
352Obsoletes: subversion-ruby
353
354%description -n ruby-subversion
355Subversion Ruby bindings.
356
357%description -n ruby-subversion -l pl.UTF-8
358Dowiązania do Subversion dla języka Ruby.
359
360%description -n ruby-subversion -l pt_BR.UTF-8
361Módulos Ruby para acessar os recursos do Subversion.
362
363%package -n apache-mod_dav_svn
364Summary: Apache module: Subversion Server
365Summary(pl.UTF-8): Moduł Apache'a: serwer Subversion
366Group: Networking/Daemons
367Requires: %{name} = %{version}-%{release}
368Requires: apache(modules-api) = %apache_modules_api
369Requires: apache-mod_dav
370
371%description -n apache-mod_dav_svn
372Apache module: Subversion Server.
373
374%description -n apache-mod_dav_svn -l pl.UTF-8
375Moduł Apache'a: serwer Subversion.
376
377%package -n apache-mod_authz_svn
378Summary: Apache module: Subversion Server - path-based authorization
379Summary(pl.UTF-8): Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
380Group: Networking/Daemons
381Requires: %{name}-libs = %{version}-%{release}
382Requires: apache(modules-api) = %apache_modules_api
383Requires: apache-mod_dav_svn = %{version}-%{release}
384
385%description -n apache-mod_authz_svn
386Apache module: Subversion Server - path-based authorization.
387
388%description -n apache-mod_authz_svn -l pl.UTF-8
389Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
390Subversion.
391
392%package -n apache-mod_dontdothat_svn
393Summary: Apache module: Allows you to block specific svn requests
394Summary(pl.UTF-8): Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
395Group: Networking/Daemons
396Requires: %{name}-libs = %{version}-%{release}
397Requires: apache(modules-api) = %apache_modules_api
398Requires: apache-mod_dav_svn = %{version}-%{release}
399
400%description -n apache-mod_dontdothat_svn
401Apache module: Allows you to block specific svn requests.
402
403%description -n apache-mod_dontdothat_svn -l pl.UTF-8
404Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
405
406%package -n gnome-keyring-subversion
407Summary: GNOME Keyring authentication provider for Subversion
408Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Subversion
409Group: X11/Applications
410Requires: %{name}-libs = %{version}-%{release}
411
412%description -n gnome-keyring-subversion
413Authentication provider module for Subversion which allows SVN client
414to authenticate using GNOME Keyring.
415
416%description -n gnome-keyring-subversion -l pl.UTF-8
417Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
418uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
419
420%package -n kde4-kwallet-subversion
421Summary: KDE Wallet authentication provider for Subversion
422Summary(pl.UTF-8): Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
423Group: X11/Applications
424Requires: %{name}-libs = %{version}-%{release}
425
426%description -n kde4-kwallet-subversion
427Authentication provider module for Subversion which allows SVN client
428to authenticate using KDE Wallet.
429
430%description -n kde4-kwallet-subversion -l pl.UTF-8
431Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
432uwierzytelniać się przy użyciu Portfela KDE.
433
434%prep
435%setup -q
436%patch0 -p0
437%patch1 -p1
438%patch2 -p0
439%patch3 -p1
440
441sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
442
443%build
444# disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
445#%{__rm} subversion/bindings/swig/proxy/*.swg
446#cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
447chmod +x ./autogen.sh && ./autogen.sh
448%{__libtoolize}
449%configure \
450 --with-editor=vi \
451 --with-zlib=%{_libdir} \
452 --disable-runtime-module-search \
453 --disable-mod-activation \
454%if %{with db}
455 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
456 %{?with_db6:--enable-bdb6} \
457%else
458 --without-berkeley-db \
459%endif
460%if %{with apache}
461 --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
462 --with-apxs=%{_sbindir}/apxs \
463%else
464 --without-apxs \
465%endif
466%if %{without swig}
467 --without-swig \
468%endif
469%if %{with ruby}
470 svn_cv_ruby_sitedir_libsuffix="" \
471 svn_cv_ruby_sitedir_archsuffix="" \
472 --with-ruby-sitedir=%{ruby_vendorarchdir} \
473%else
474 ac_cv_path_RUBY=none \
475%endif
476%if %{with csvn}
477 --with-ctypesgen=%{_bindir}/ctypesgen.py \
478%endif
479%if %{with java}
480 --enable-javahl \
481 --with-jdk="%{java_home}" \
482 --without-jikes \
483%else
484 --disable-javahl \
485%endif
486 --with-serf=%{_prefix} \
487 --with-apr=%{_bindir}/apr-1-config \
488 --with-apr-util=%{_bindir}/apu-1-config \
489%if %{with kwallet}
490 --with-kwallet \
491%endif
492%if %{with gnome}
493 --with-gnome-keyring
494%endif
495
496%{__make} -j1
497
498%{__make} tools
499
500%if %{with csvn}
501# Python ctypes bindings
502%{__make} ctypes-python
503%endif
504%if %{with python}
505# Python swig bindings
506%{__make} swig-py \
507 swig_pydir=%{py_sitedir}/libsvn \
508 swig_pydir_extra=%{py_sitedir}/svn
509%endif
510%if %{with perl}
511# Perl swig bindings
512%{__make} -j1 swig-pl-lib
513cd subversion/bindings/swig/perl/native
514%{__perl} Makefile.PL INSTALLDIRS=vendor
515%{__make} -j1
516cd -
517%endif
518%if %{with java}
519%{__make} -j1 javahl \
520 javahl_javadir="%{_javadir}"
521%endif
522# ruby
523%if %{with ruby}
524%{__make} swig-rb
525%endif
526
527%if %{with tests}
528%{__make} -j1 check
529%if %{with csvn}
530%{__make} -j1 check-ctypes-python
531%endif
532%if %{with python}
533%{__make} -j1 check-swig-py
534%endif
535%if %{with perl}
536%{__make} -j1 check-swig-pl
537%endif
538%if %{with ruby}
539# disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
540#%{__make} check-swig-rb
541%endif
542%endif
543
544%install
545rm -rf $RPM_BUILD_ROOT
546install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
547 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
548 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
549 $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
550 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
551
552%{__make} install -j1 \
553 toolsdir=%{_bindir} \
554 DESTDIR=$RPM_BUILD_ROOT \
555 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
556%if %{with java}
557 install-javahl \
558 javahl_javadir="%{_javadir}" \
559%endif
560%if %{with python}
561 install-swig-py \
562 swig_pydir=%{py_sitedir}/libsvn \
563 swig_pydir_extra=%{py_sitedir}/svn \
564%endif
565%if %{with csvn}
566 install-ctypes-python \
567%endif
568 install-tools
569
570%if %{with ruby}
571%{__make} install -j1 \
572 SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
573 DESTDIR=$RPM_BUILD_ROOT \
574 install-swig-rb install-swig-rb-doc
575
576# not our package
577%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
578%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
579%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
580%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
581%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
582%endif
583
584%if %{with perl}
585%{__make} install-swig-pl-lib \
586 DESTDIR=$RPM_BUILD_ROOT
587%{__make} -C subversion/bindings/swig/perl/native install \
588 DESTDIR=$RPM_BUILD_ROOT \
589 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
590 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
591%endif
592
593%if %{with apache}
594cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
595cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
596cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
597install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
598%endif
599
600%if %{without net_client_only}
601install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
602%endif
603
604# rename not to conflict with standard packages. (are these needed at all?)
605mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
606mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
607mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
608
609%if %{with python} || %{with csvn}
610%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
611%py_comp $RPM_BUILD_ROOT%{py_sitedir}
612%py_postclean
613%endif
614%if %{with python}
615%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
616# .a created on ac only
617%{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
618cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
619%endif
620
621cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
622cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
623
624%if %{with java}
625%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
626%endif
627%if %{with swig}
628%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
629%if %{with ruby}
630%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
631%endif
632%endif
633%if %{with gnome} || %{with kwallet}
634# dlopened by soname (libsvn_auth_*-1.so.0)
635%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
636%endif
637
638%find_lang %{name}
639
640%clean
641rm -rf $RPM_BUILD_ROOT
642
643%pre svnserve
644%groupadd -g 86 svn
645%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
646
647%post libs -p /sbin/ldconfig
648%postun libs -p /sbin/ldconfig
649
650%post devel -p /sbin/postshell
651-/usr/sbin/fix-info-dir -c %{_infodir}
652
653%postun devel -p /sbin/postshell
654-/usr/sbin/fix-info-dir -c %{_infodir}
655
656%post -n java-subversion -p /sbin/ldconfig
657%postun -n java-subversion -p /sbin/ldconfig
658
659%post -n perl-subversion -p /sbin/ldconfig
660%postun -n perl-subversion -p /sbin/ldconfig
661
662%post -n python-subversion -p /sbin/ldconfig
663%postun -n python-subversion -p /sbin/ldconfig
664
665%post -n ruby-subversion -p /sbin/ldconfig
666%postun -n ruby-subversion -p /sbin/ldconfig
667
668%post -n gnome-keyring-subversion -p /sbin/ldconfig
669%postun -n gnome-keyring-subversion -p /sbin/ldconfig
670
671%post -n kde4-kwallet-subversion -p /sbin/ldconfig
672%postun -n kde4-kwallet-subversion -p /sbin/ldconfig
673
674%post svnserve
675/sbin/chkconfig --add svnserve
676%service svnserve restart "svnserve daemon"
677
678%preun svnserve
679if [ "$1" = "0" ]; then
680 %service svnserve stop
681 /sbin/chkconfig --del svnserve
682fi
683
684%postun svnserve
685if [ "$1" = "0" ]; then
686 %userremove svn
687 %groupremove svn
688fi
689
690%post -n apache-mod_dav_svn
691%service -q httpd restart
692
693%postun -n apache-mod_dav_svn
694if [ "$1" = "0" ]; then
695 %service -q httpd restart
696fi
697
698%post -n apache-mod_authz_svn
699%service -q httpd restart
700
701%postun -n apache-mod_authz_svn
702if [ "$1" = "0" ]; then
703 %service -q httpd restart
704fi
705
706%post -n apache-mod_dontdothat_svn
707%service -q httpd restart
708
709%postun -n apache-mod_dontdothat_svn
710if [ "$1" = "0" ]; then
711 %service -q httpd restart
712fi
713
714%files
715%defattr(644,root,root,755)
716%doc BUGS CHANGES INSTALL README
717%doc doc/*/*.html
718%doc tools/hook-scripts/*.{pl,py,example}
719%doc tools/hook-scripts/mailer/*.{py,example}
720%doc tools/xslt/*
721%attr(755,root,root) %{_bindir}/svn
722%attr(755,root,root) %{_bindir}/svnadmin
723%attr(755,root,root) %{_bindir}/svndumpfilter
724%attr(755,root,root) %{_bindir}/svnlook
725%attr(755,root,root) %{_bindir}/svnmucc
726%attr(755,root,root) %{_bindir}/svnrdump
727%attr(755,root,root) %{_bindir}/svnsync
728%attr(755,root,root) %{_bindir}/svnversion
729%{_mandir}/man1/svn.1*
730%{_mandir}/man1/svnadmin.1*
731%{_mandir}/man1/svndumpfilter.1*
732%{_mandir}/man1/svnrdump.1*
733%{_mandir}/man1/svnlook.1*
734%{_mandir}/man1/svnmucc.1*
735%{_mandir}/man1/svnsync.1*
736%{_mandir}/man1/svnversion.1*
737
738%files libs -f %{name}.lang
739%defattr(644,root,root,755)
740%dir %{_sysconfdir}/%{name}
741%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
742%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
743%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
744%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
745%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
746%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
747%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
748%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
749%if %{without net_client_only}
750%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
751%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
752%endif
753%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
754%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
755%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
756%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
757%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
758%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
759%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
760%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
761%attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so.*.*.*
762%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_serf-1.so.0
763%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
764%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
765%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
766%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
767%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
768%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
769%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
770%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
771
772%files devel
773%defattr(644,root,root,755)
774%attr(755,root,root) %{_libdir}/libsvn_client-1.so
775%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
776%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
777%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
778%if %{without net_client_only}
779%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
780%endif
781%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
782%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
783%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
784%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
785%attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
786%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
787%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
788%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
789%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
790%{_libdir}/libsvn_client-1.la
791%{_libdir}/libsvn_delta-1.la
792%{_libdir}/libsvn_diff-1.la
793%{_libdir}/libsvn_fs-1.la
794%if %{without net_client_only}
795%{_libdir}/libsvn_fs_base-1.la
796%endif
797%{_libdir}/libsvn_fs_fs-1.la
798%{_libdir}/libsvn_fs_util-1.la
799%{_libdir}/libsvn_ra-1.la
800%{_libdir}/libsvn_ra_local-1.la
801%{_libdir}/libsvn_ra_serf-1.la
802%{_libdir}/libsvn_ra_svn-1.la
803%{_libdir}/libsvn_repos-1.la
804%{_libdir}/libsvn_subr-1.la
805%{_libdir}/libsvn_wc-1.la
806%{_includedir}/%{name}-1
807%{_examplesdir}/%{name}-%{version}
808
809%files static
810%defattr(644,root,root,755)
811%{_libdir}/libsvn_client-1.a
812%{_libdir}/libsvn_delta-1.a
813%{_libdir}/libsvn_diff-1.a
814%{_libdir}/libsvn_fs-1.a
815%if %{without net_client_only}
816%{_libdir}/libsvn_fs_base-1.a
817%endif
818%{_libdir}/libsvn_fs_fs-1.a
819%{_libdir}/libsvn_fs_util-1.a
820%{_libdir}/libsvn_ra-1.a
821%{_libdir}/libsvn_ra_local-1.a
822%{_libdir}/libsvn_ra_serf-1.a
823%{_libdir}/libsvn_ra_svn-1.a
824%{_libdir}/libsvn_repos-1.a
825%{_libdir}/libsvn_subr-1.a
826%{_libdir}/libsvn_wc-1.a
827
828%if %{with gnome}
829%files -n gnome-keyring-subversion
830%defattr(644,root,root,755)
831%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
832%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
833%endif
834
835%if %{with kwallet}
836%files -n kde4-kwallet-subversion
837%defattr(644,root,root,755)
838%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
839%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
840%endif
841
842%if %{without net_client_only}
843%files svnserve
844%defattr(644,root,root,755)
845%attr(755,root,root) %{_bindir}/svnserve
846%{_mandir}/man5/svnserve.conf.5*
847%{_mandir}/man8/svnserve.8*
848%dir %attr(750,svn,svn) /home/services/subversion
849%dir %attr(750,svn,svn) /home/services/subversion/repos
850%if %{with apache}
851%attr(754,root,root) /etc/rc.d/init.d/svnserve
852%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
853%endif
854
855%files tools
856%defattr(644,root,root,755)
857# tools/backup/hot-backup.py
858%attr(755,root,root) %{_bindir}/svn-hot-backup
859
860# tools/diff
861%attr(755,root,root) %{_bindir}/svndiff
862%attr(755,root,root) %{_bindir}/svndiff3
863%attr(755,root,root) %{_bindir}/svndiff4
864
865# tools/server-side
866%attr(755,root,root) %{_bindir}/fsfs-stats
867%attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
868%attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
869%attr(755,root,root) %{_bindir}/svnauthz
870%attr(755,root,root) %{_bindir}/svnauthz-validate
871
872# tools/client-side
873%attr(755,root,root) %{_bindir}/svn-bench
874
875# tools/dev/svnraisetreeconflict
876%attr(755,root,root) %{_bindir}/svnraisetreeconflict
877
878# tools/dev/
879%attr(755,root,root) %{_bindir}/fsfs-access-map
880%attr(755,root,root) %{_bindir}/fsfs-reorg
881
882%files -n bash-completion-subversion
883%defattr(644,root,root,755)
884/etc/bash_completion.d/%{name}
885
886%endif # net_client_only
887
888%if %{with java}
889%files -n java-subversion
890%defattr(644,root,root,755)
891%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
892%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
893%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
894%{_javadir}/svn-javahl.jar
895%endif
896
897%if %{with python}
898%files -n python-subversion
899%defattr(644,root,root,755)
900%doc tools/backup/*.py
901%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
902%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
903%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
904%dir %{py_sitedir}/libsvn
905%attr(755,root,root) %{py_sitedir}/libsvn/_*.so
906%{py_sitedir}/libsvn/*.py[co]
907%dir %{py_sitedir}/svn
908%{py_sitedir}/svn/*.py[co]
909%{_examplesdir}/python-%{name}-%{version}
910%endif
911
912%if %{with csvn}
913%files -n python-csvn
914%defattr(644,root,root,755)
915%doc subversion/bindings/ctypes-python/{README,TODO}
916%doc subversion/bindings/ctypes-python/examples/*.py
917%dir %{py_sitescriptdir}/csvn
918%{py_sitescriptdir}/csvn/*.py[co]
919%dir %{py_sitescriptdir}/csvn/core
920%{py_sitescriptdir}/csvn/core/*.py[co]
921%dir %{py_sitescriptdir}/csvn/ext
922%{py_sitescriptdir}/csvn/ext/*.py[co]
923%{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
924%endif
925
926%if %{with perl}
927%files -n perl-subversion
928%defattr(644,root,root,755)
929%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
930%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
931%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
932%{perl_vendorarch}/SVN
933%dir %{perl_vendorarch}/auto/SVN
934%dir %{perl_vendorarch}/auto/SVN/*
935%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
936%{perl_vendorarch}/auto/SVN/*/*.bs
937%{_mandir}/man3/*.3pm*
938%endif
939
940%if %{with ruby}
941%files -n ruby-subversion
942%defattr(644,root,root,755)
943%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
944%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
945%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
946%dir %{ruby_vendorarchdir}/svn
947%{ruby_vendorarchdir}/svn/*.rb
948%dir %{ruby_vendorarchdir}/svn/ext
949%attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
950%{ruby_ridir}/Svn
951%endif
952
953%if %{with apache}
954%files -n apache-mod_dav_svn
955%defattr(644,root,root,755)
956%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
957%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
958
959%files -n apache-mod_authz_svn
960%defattr(644,root,root,755)
961%doc subversion/mod_authz_svn/INSTALL
962%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
963%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
964
965%files -n apache-mod_dontdothat_svn
966%defattr(644,root,root,755)
967%doc tools/server-side/mod_dontdothat/README
968%attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
969%endif
This page took 0.087136 seconds and 4 git commands to generate.