]> git.pld-linux.org Git - packages/stunnel.git/blame_incremental - stunnel.spec
- updated to 5.54
[packages/stunnel.git] / stunnel.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without systemd # systemd socket activation support
4
5Summary: Universal SSL tunnel
6Summary(pl.UTF-8): Uniwersalne narzędzie do bezpiecznego tunelowania
7Name: stunnel
8Version: 5.54
9Release: 1
10License: GPL v2+ with OpenSSL exception
11Group: Networking/Daemons
12Source0: ftp://ftp.stunnel.org/stunnel/%{name}-%{version}.tar.gz
13# Source0-md5: 788358cf84f71f9603e9fe93807c081d
14Source1: %{name}.init
15Source2: %{name}.sysconfig
16Source3: %{name}.inet
17Source4: %{name}.tmpfiles
18Patch0: %{name}-config.patch
19Patch1: stunnel-libwrap_srv_name_log.patch
20URL: http://www.stunnel.org/
21BuildRequires: autoconf >= 2.50
22BuildRequires: automake
23BuildRequires: libtool >= 2:2.0
24BuildRequires: libwrap-devel
25BuildRequires: openssl-devel >= 0.9.7d
26BuildRequires: openssl-tools >= 0.9.7d
27BuildRequires: rpmbuild(macros) >= 1.268
28%{?with_systemd:BuildRequires: systemd-devel}
29Requires(postun): /sbin/ldconfig
30Requires(postun): /usr/sbin/groupdel
31Requires(postun): /usr/sbin/userdel
32Requires(pre): /bin/id
33Requires(pre): /usr/bin/getgid
34Requires(pre): /usr/sbin/groupadd
35Requires(pre): /usr/sbin/useradd
36Provides: group(stunnel)
37Provides: user(stunnel)
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41The stunnel program is designed to work as SSL encryption wrapper
42between remote client and local (inetd-startable) or remote server.
43The concept is that having non-SSL aware daemons running on your
44system you can easily setup them to communicate with clients over
45secure SSL channel. stunnel can be used to add SSL functionality to
46commonly used inetd daemons like POP-2, POP-3 and IMAP servers without
47any changes in the programs' code.
48
49%description -l pl.UTF-8
50Stunnel umożliwia stawianie silnie kodowanych tuneli pomiędzy serwerem
51a komputerem klienta. Przy jego użyciu można łatwo zrealizować usługi
52pop3s lub HTTPS.
53
54%package standalone
55Summary: stunnel acts as standalone server
56Summary(pl.UTF-8): stunnel działający jako samodzielny serwer
57Group: Networking/Daemons
58Requires(post,preun): /sbin/chkconfig
59Requires: %{name} = %{version}-%{release}
60Requires: rc-scripts
61Obsoletes: stunnel-inetd
62
63%description standalone
64stunnel acts as standalone server.
65
66%description standalone -l pl.UTF-8
67stunnel działający jako samodzielny serwer.
68
69%package inetd
70Summary: stunnel acts as inetd service
71Summary(pl.UTF-8): stunnel działający jako usługa inetd
72Group: Networking/Daemons
73Requires: %{name} = %{version}-%{release}
74Requires: rc-inetd
75Obsoletes: stunnel-standalone
76
77%description inetd
78stunnel acts as inetd service.
79
80%description inetd -l pl.UTF-8
81stunnel działający jako usługa inetd.
82
83%prep
84%setup -q
85%patch0 -p1
86%patch1 -p1
87
88%build
89%{__libtoolize}
90%{__aclocal}
91%{__autoconf}
92%{__automake}
93%configure \
94 --disable-silent-rules \
95 %{!?with_systemd:--disable-systemd}
96%{__make}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig/rc-inetd},%{_mandir}/{pl,fr}/man8,%{_var}/run/stunnel} \
101 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106%{__mv} $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.pl.8 $RPM_BUILD_ROOT%{_mandir}/pl/man8/stunnel.8
107%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf-sample $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf
108
109install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/stunnel
110install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/stunnel
111install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/stunnel
112install %{SOURCE4} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
113
114%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/stunnel
115%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/stunnel
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%pre
121%groupadd -g 130 stunnel
122%useradd -u 130 -d /var/run/stunnel -s /bin/false -c "stunnel User" -g stunnel stunnel
123
124%post -p /sbin/ldconfig
125
126%postun
127/sbin/ldconfig
128if [ "$1" = "0" ]; then
129 %userremove stunnel
130 %groupremove stunnel
131fi
132
133%post standalone
134/sbin/chkconfig --add stunnel
135%service stunnel restart "stunnel daemon"
136
137%preun standalone
138if [ "$1" = "0" ]; then
139 %service stunnel stop
140 /sbin/chkconfig --del stunnel
141fi
142
143%post inetd
144%service -q rc-inetd reload
145
146%postun inetd
147if [ "$1" = "0" ]; then
148 %service -q rc-inetd reload
149fi
150
151%files
152%defattr(644,root,root,755)
153# note: this COPYING contains general information not GPL text
154%doc AUTHORS BUGS COPYING CREDITS ChangeLog NEWS PORTS README TODO doc/en/* doc/stunnel.html tools/{ca.*,importCA.*}
155%doc %lang(pl) doc/pl/* doc/stunnel.pl.html
156%attr(755,root,root) %{_bindir}/stunnel
157%attr(755,root,root) %{_bindir}/stunnel3
158%dir %{_sysconfdir}/stunnel
159%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/stunnel/stunnel.conf
160%attr(750,stunnel,stunnel) %{_var}/run/stunnel
161%{systemdtmpfilesdir}/%{name}.conf
162%{_mandir}/man8/stunnel.8*
163%lang(pl) %{_mandir}/pl/man8/stunnel.8*
164
165%files standalone
166%defattr(644,root,root,755)
167%attr(754,root,root) /etc/rc.d/init.d/stunnel
168%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/stunnel
169
170%files inetd
171%defattr(644,root,root,755)
172%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/stunnel
This page took 0.062981 seconds and 4 git commands to generate.