]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- updated to 1.5.0 (nfy); 1.4.x left on qemu-1.4 branch
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1# TODO:
2# - merge missing bits from qemu-kvm
3# - --enable-glusterfs when glusterfs 3.4 is out
4# - qemu-system-ppc -hda ac-ppc.img says:
5# qemu: could not open disk image ac-ppc.img: error "Success"
6# qemu-0.12.2-2.x86_64.rpm - broken
7# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
8# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
9# qemu-0.11.1-*.x86_64.rpm - OK
10#
11# Conditional build:
12%bcond_without sdl # SDL UI and audio support
13%bcond_without glx # OpenGL support
14%bcond_without ceph # Ceph/RBD support
15%bcond_with glusterfs # GlusterFS backend
16%bcond_without spice # SPICE support
17%bcond_with esd # EsounD audio support
18%bcond_without oss # OSS audio support
19%bcond_without pulseaudio # PulseAudio audio support
20%bcond_without xen # Xen backend driver support
21
22Summary: QEMU CPU Emulator
23Summary(pl.UTF-8): QEMU - emulator procesora
24Name: qemu
25Version: 1.5.0
26Release: 0.1
27License: GPL v2+
28Group: Applications/Emulators
29Source0: http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
30# Source0-md5: b6f3265b8ed39d77e8f354f35cc26e16
31Patch0: %{name}-cflags.patch
32Patch1: vgabios-widescreens.patch
33Patch2: %{name}-whitelist.patch
34Patch3: %{name}-system-libcacard.patch
35# Proof of concept, for reference, do not remove
36Patch4: %{name}-kde_virtual_workspaces_hack.patch
37URL: http://www.qemu-project.org/
38%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
39%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
40BuildRequires: alsa-lib-devel
41BuildRequires: bcc
42BuildRequires: bluez-libs-devel
43BuildRequires: brlapi-devel
44%{?with_ceph:BuildRequires: ceph-devel}
45BuildRequires: curl-devel
46BuildRequires: cyrus-sasl-devel >= 2
47%{?with_esd:BuildRequires: esound-devel}
48BuildRequires: glib2-devel >= 1:2.12
49%{?with_glusterfs:BuildRequires: glusterfs-devel >= 3.4}
50BuildRequires: gnutls-devel
51BuildRequires: libaio-devel
52BuildRequires: libcacard-devel
53BuildRequires: libcap-devel
54BuildRequires: libcap-ng-devel
55BuildRequires: libfdt-devel
56BuildRequires: libiscsi-devel
57BuildRequires: libjpeg-devel
58BuildRequires: libpng-devel
59BuildRequires: libseccomp-devel
60BuildRequires: libuuid-devel
61BuildRequires: ncurses-devel
62BuildRequires: nss-devel >= 3.12.8
63BuildRequires: perl-Encode
64BuildRequires: perl-tools-pod
65BuildRequires: pkgconfig
66%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
67BuildRequires: rpmbuild(macros) >= 1.202
68BuildRequires: sed >= 4.0
69%if %{with spice}
70BuildRequires: spice-protocol >= 0.12.0
71BuildRequires: spice-server-devel >= 0.12.0
72%endif
73BuildRequires: texi2html
74BuildRequires: texinfo
75BuildRequires: usbredir-devel >= 0.6
76BuildRequires: vde2-devel
77BuildRequires: which
78%{?with_xen:BuildRequires: xen-devel >= 3.4}
79BuildRequires: xfsprogs-devel
80BuildRequires: xorg-lib-libX11-devel
81BuildRequires: zlib-devel
82Requires: %{name}-img = %{version}-%{release}
83Requires: %{name}-system-alpha = %{version}-%{release}
84Requires: %{name}-system-arm = %{version}-%{release}
85Requires: %{name}-system-cris = %{version}-%{release}
86Requires: %{name}-system-lm32 = %{version}-%{release}
87Requires: %{name}-system-m68k = %{version}-%{release}
88Requires: %{name}-system-microblaze = %{version}-%{release}
89Requires: %{name}-system-mips = %{version}-%{release}
90Requires: %{name}-system-or32 = %{version}-%{release}
91Requires: %{name}-system-ppc = %{version}-%{release}
92Requires: %{name}-system-s390x = %{version}-%{release}
93Requires: %{name}-system-sh4 = %{version}-%{release}
94Requires: %{name}-system-sparc = %{version}-%{release}
95Requires: %{name}-system-unicore32 = %{version}-%{release}
96Requires: %{name}-system-x86 = %{version}-%{release}
97Requires: %{name}-system-xtensa = %{version}-%{release}
98Requires: %{name}-user = %{version}-%{release}
99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101%define systempkg_req \
102Requires: SDL >= 1.2.1 \
103Requires: usbredir >= 0.6
104
105# some PPC/SPARC boot image in ELF format
106%define _noautostrip .*%{_datadir}/qemu/.*-.*
107
108%description
109QEMU is a FAST! processor emulator. By using dynamic translation it
110achieves a reasonnable speed while being easy to port on new host
111CPUs. QEMU has two operating modes:
112
113- User mode emulation. In this mode, QEMU can launch Linux processes
114 compiled for one CPU on another CPU. Linux system calls are converted
115 because of endianness and 32/64 bit mismatches. Wine (Windows
116 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
117
118- Full system emulation. In this mode, QEMU emulates a full system,
119 including a processor and various peripherials. It can also be used to
120 provide virtual hosting of several virtual PC on a single server.
121
122%description -l pl.UTF-8
123QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
124tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
125aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
126
127- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
128 procesy linuksowe skompilowane dla jednego procesora na innym
129 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
130 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
131 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
132 cele QEMU.
133
134- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
135 włączając w to procesor i różne urządzenia peryferyjne. Może być także
136 używane do wirtualnego hostowania kilku wirtualnych pecetów na
137 pojedynczym serwerze.
138
139%package common
140Summary: QEMU common files needed by all QEMU targets
141Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
142Group: Development/Tools
143Requires: glib2 >= 1:2.12
144Requires(postun): /usr/sbin/groupdel
145Requires(postun): /usr/sbin/userdel
146Requires(pre): /bin/id
147Requires(pre): /usr/bin/getgid
148Requires(pre): /usr/sbin/groupadd
149Requires(pre): /usr/sbin/useradd
150Provides: group(qemu)
151Provides: user(qemu)
152Conflicts: qemu < 1.0-2
153
154%description common
155QEMU is a generic and open source processor emulator which achieves a
156good emulation speed by using dynamic translation.
157
158This package provides the common files needed by all QEMU targets.
159
160%description common -l pl.UTF-8
161QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
162dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
163
164Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
165środowiska QEMU.
166
167%package img
168Summary: QEMU command line tool for manipulating disk images
169Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
170Group: Development/Tools
171Conflicts: qemu < 1.0-2
172
173%description img
174This package provides a command line tool for manipulating disk
175images.
176
177%description img -l pl.UTF-8
178Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
179na obrazach dysków.
180
181%package user
182Summary: QEMU user mode emulation of qemu targets
183Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
184Group: Development/Tools
185Requires: %{name}-common = %{version}-%{release}
186
187%description user
188QEMU is a generic and open source processor emulator which achieves a
189good emulation speed by using dynamic translation.
190
191This package provides the user mode emulation of QEMU targets.
192
193%description user -l pl.UTF-8
194QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
195dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
196
197Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
198
199%package system-alpha
200Summary: QEMU system emulator for Alpha
201Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
202Group: Development/Tools
203Requires: %{name}-common = %{version}-%{release}
204%systempkg_req
205
206%description system-alpha
207QEMU is a generic and open source processor emulator which achieves a
208good emulation speed by using dynamic translation.
209
210This package provides the system emulator with Alpha CPU.
211
212%description system-alpha -l pl.UTF-8
213QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
214dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
215
216Ten pakiet zawiera emulator systemu z procesorem Alpha.
217
218%package system-arm
219Summary: QEMU system emulator for ARM
220Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
221Group: Development/Tools
222Requires: %{name}-common = %{version}-%{release}
223%systempkg_req
224
225%description system-arm
226QEMU is a generic and open source processor emulator which achieves a
227good emulation speed by using dynamic translation.
228
229This package provides the system emulator for ARM.
230
231%description system-arm -l pl.UTF-8
232QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
233dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
234
235Ten pakiet zawiera emulator systemu z procesorem ARM.
236
237%package system-cris
238Summary: QEMU system emulator for CRIS
239Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
240Group: Development/Tools
241Requires: %{name}-common = %{version}-%{release}
242%systempkg_req
243
244%description system-cris
245QEMU is a generic and open source processor emulator which achieves a
246good emulation speed by using dynamic translation.
247
248This package provides the system emulator with CRIS CPU.
249
250%description system-cris -l pl.UTF-8
251QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
252dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
253
254Ten pakiet zawiera emulator systemu z procesorem CRIS.
255
256%package system-lm32
257Summary: QEMU system emulator for LM32
258Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
259Group: Development/Tools
260Requires: %{name}-common = %{version}-%{release}
261%systempkg_req
262
263%description system-lm32
264QEMU is a generic and open source processor emulator which achieves a
265good emulation speed by using dynamic translation.
266
267This package provides the system emulator with LM32 CPU.
268
269%description system-lm32 -l pl.UTF-8
270QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
271dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
272
273Ten pakiet zawiera emulator systemu z procesorem LM32.
274
275%package system-m68k
276Summary: QEMU system emulator for m68k
277Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
278Group: Development/Tools
279Requires: %{name}-common = %{version}-%{release}
280%systempkg_req
281
282%description system-m68k
283QEMU is a generic and open source processor emulator which achieves a
284good emulation speed by using dynamic translation.
285
286This package provides the system emulator with m68k CPU.
287
288%description system-m68k -l pl.UTF-8
289QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
290dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
291
292Ten pakiet zawiera emulator systemu z procesorem m68k.
293
294%package system-microblaze
295Summary: QEMU system emulator for MicroBlaze
296Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
297Group: Development/Tools
298Requires: %{name}-common = %{version}-%{release}
299%systempkg_req
300
301%description system-microblaze
302QEMU is a generic and open source processor emulator which achieves a
303good emulation speed by using dynamic translation.
304
305This package provides the system emulator with MicroBlaze CPU.
306
307%description system-microblaze -l pl.UTF-8
308QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
309dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
310
311Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
312
313%package system-mips
314Summary: QEMU system emulator for MIPS
315Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
316Group: Development/Tools
317Requires: %{name}-common = %{version}-%{release}
318%systempkg_req
319
320%description system-mips
321QEMU is a generic and open source processor emulator which achieves a
322good emulation speed by using dynamic translation.
323
324This package provides the system emulator with MIPS CPU.
325
326%description system-mips -l pl.UTF-8
327QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
328dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
329
330Ten pakiet zawiera emulator systemu z procesorem MIPS.
331
332%package system-or32
333Summary: QEMU system emulator for OpenRISC
334Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
335Group: Development/Tools
336Requires: %{name}-common = %{version}-%{release}
337%systempkg_req
338
339%description system-or32
340QEMU is a generic and open source processor emulator which achieves a
341good emulation speed by using dynamic translation.
342
343This package provides the system emulator with OpenRISC CPU.
344
345%description system-or32 -l pl.UTF-8
346QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
347dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
348
349Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
350
351%package system-ppc
352Summary: QEMU system emulator for PowerPC
353Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
354Group: Development/Tools
355Requires: %{name}-common = %{version}-%{release}
356%systempkg_req
357
358%description system-ppc
359QEMU is a generic and open source processor emulator which achieves a
360good emulation speed by using dynamic translation.
361
362This package provides the system emulator with PowerPC CPU.
363
364%description system-ppc -l pl.UTF-8
365QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
366dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
367
368Ten pakiet zawiera emulator systemu z procesorem PowerPC.
369
370%package system-s390x
371Summary: QEMU system emulator for S390
372Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
373Group: Development/Tools
374Requires: %{name}-common = %{version}-%{release}
375%systempkg_req
376
377%description system-s390x
378QEMU is a generic and open source processor emulator which achieves a
379good emulation speed by using dynamic translation.
380
381This package provides the system emulator with S390 CPU.
382
383%description system-s390x -l pl.UTF-8
384QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
385dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
386
387Ten pakiet zawiera emulator systemu z procesorem S390.
388
389%package system-sh4
390Summary: QEMU system emulator for SH4
391Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
392Group: Development/Tools
393Requires: %{name}-common = %{version}-%{release}
394%systempkg_req
395
396%description system-sh4
397QEMU is a generic and open source processor emulator which achieves a
398good emulation speed by using dynamic translation.
399
400This package provides the system emulator with SH4 CPU.
401
402%description system-sh4 -l pl.UTF-8
403QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
404dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
405
406Ten pakiet zawiera emulator systemu z procesorem SH4.
407
408%package system-sparc
409Summary: QEMU system emulator for SPARC
410Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
411Group: Development/Tools
412Requires: %{name}-common = %{version}-%{release}
413%systempkg_req
414
415%description system-sparc
416QEMU is a generic and open source processor emulator which achieves a
417good emulation speed by using dynamic translation.
418
419This package provides the system emulator with SPARC/SPARC64 CPU.
420
421%description system-sparc -l pl.UTF-8
422QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
423dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
424
425Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
426
427%package system-unicore32
428Summary: QEMU system emulator for UniCore32
429Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
430Group: Development/Tools
431Requires: %{name}-common = %{version}-%{release}
432%systempkg_req
433
434%description system-unicore32
435QEMU is a generic and open source processor emulator which achieves a
436good emulation speed by using dynamic translation.
437
438This package provides the system emulator with UniCore32 CPU.
439
440%description system-unicore32 -l pl.UTF-8
441QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
442dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
443
444Ten pakiet zawiera emulator systemu z procesorem UniCore32.
445
446%package system-x86
447Summary: QEMU system emulator for x86
448Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
449Group: Development/Tools
450Requires: %{name}-common = %{version}-%{release}
451%systempkg_req
452
453%description system-x86
454QEMU is a generic and open source processor emulator which achieves a
455good emulation speed by using dynamic translation.
456
457%description system-x86 -l pl.UTF-8
458QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
459dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
460
461%package system-xtensa
462Summary: QEMU system emulator for Xtensa
463Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
464Group: Development/Tools
465Requires: %{name}-common = %{version}-%{release}
466%systempkg_req
467
468%description system-xtensa
469QEMU is a generic and open source processor emulator which achieves a
470good emulation speed by using dynamic translation.
471
472This package provides the system emulator with Xtensa CPU.
473
474%description system-xtensa -l pl.UTF-8
475QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
476dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
477
478Ten pakiet zawiera emulator systemu z procesorem Xtensa.
479
480%prep
481%setup -q
482%patch0 -p1
483%patch1 -p1
484%patch2 -p0
485%patch3 -p1
486
487%{__mv} libcacard libcacard-use-system-lib
488
489# workaround for conflict with alsa/error.h
490ln -s ../error.h qapi/error.h
491
492%build
493./configure \
494 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
495 --extra-ldflags="%{rpmldflags}" \
496 --prefix=%{_prefix} \
497 --sysconfdir=%{_sysconfdir} \
498 --cc="%{__cc}" \
499 --host-cc="%{__cc}" \
500 --disable-strip \
501 --enable-attr \
502 --enable-bluez \
503 --enable-brlapi \
504 --enable-cap-ng \
505 --enable-curl \
506 --enable-curses \
507 --enable-docs \
508 --enable-fdt \
509 %{__enable_disable glusterfs} \
510 --enable-libiscsi \
511 --enable-mixemu \
512 %{__enable_disable glx} \
513 %{__enable_disable ceph rbd} \
514 %{__enable_disable sdl} \
515 --enable-seccomp \
516 %{__enable_disable spice} \
517 --enable-smartcard-nss \
518 --enable-usb-redir \
519 --enable-uuid \
520 --enable-vde \
521 --enable-virtfs \
522 --enable-vnc-jpeg \
523 --enable-vnc-png \
524 --enable-vnc-sasl \
525 --enable-vnc-tls \
526 %{__enable_disable xen} \
527 --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
528 --interp-prefix=%{_libdir}/qemu/lib-%%M
529# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
530# --libexecdir in configure is nop
531%{__make} \
532 V=1 \
533 CONFIG_QEMU_HELPERDIR="%{_libdir}"
534
535# rebuild patched vesa tables with additional widescreen modes.
536%{__make} -C roms/vgabios stdvga-bios
537
538%install
539rm -rf $RPM_BUILD_ROOT
540
541%{__make} install \
542 DESTDIR=$RPM_BUILD_ROOT \
543 libexecdir=%{_libdir}
544
545install -d $RPM_BUILD_ROOT%{_sysconfdir}
546cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
547#!/bin/sh
548
549EOF
550
551# already packaged
552%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
553%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
554
555# install patched vesa tables with additional widescreen modes.
556cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
557
558%clean
559rm -rf $RPM_BUILD_ROOT
560
561%pre common
562%groupadd -g 276 qemu
563%useradd -u 276 -g qemu -c "QEMU User" qemu
564
565%postun common
566if [ "$1" = "0" ]; then
567 %userremove qemu
568 %groupremove qemu
569fi
570
571%files
572%defattr(644,root,root,755)
573
574%files common
575%defattr(644,root,root,755)
576%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
577%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
578%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
579%dir %{_sysconfdir}/qemu
580%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
581%attr(755,root,root) %{_bindir}/qemu-nbd
582%attr(755,root,root) %{_libdir}/qemu-bridge-helper
583%{_mandir}/man1/qemu.1*
584%{_mandir}/man1/virtfs-proxy-helper.1*
585%{_mandir}/man8/qemu-nbd.8*
586
587%dir %{_datadir}/qemu
588%{_datadir}/%{name}/keymaps
589%{_datadir}/%{name}/qemu-icon.bmp
590# various bios images
591%{_datadir}/%{name}/*.aml
592%{_datadir}/%{name}/*.bin
593%{_datadir}/%{name}/*.rom
594%{_datadir}/%{name}/*.dtb
595%{_datadir}/%{name}/openbios-ppc
596%{_datadir}/%{name}/openbios-sparc*
597%{_datadir}/%{name}/palcode-clipper
598
599%files img
600%defattr(644,root,root,755)
601%attr(755,root,root) %{_bindir}/qemu-img
602%{_mandir}/man1/qemu-img.1*
603
604%files user
605%defattr(644,root,root,755)
606%attr(755,root,root) %{_bindir}/qemu-alpha
607%attr(755,root,root) %{_bindir}/qemu-arm
608%attr(755,root,root) %{_bindir}/qemu-armeb
609%attr(755,root,root) %{_bindir}/qemu-cris
610%attr(755,root,root) %{_bindir}/qemu-ga
611%attr(755,root,root) %{_bindir}/qemu-i386
612%attr(755,root,root) %{_bindir}/qemu-io
613%attr(755,root,root) %{_bindir}/qemu-m68k
614%attr(755,root,root) %{_bindir}/qemu-microblaze
615%attr(755,root,root) %{_bindir}/qemu-microblazeel
616%attr(755,root,root) %{_bindir}/qemu-mips
617%attr(755,root,root) %{_bindir}/qemu-mipsel
618%attr(755,root,root) %{_bindir}/qemu-or32
619%attr(755,root,root) %{_bindir}/qemu-ppc
620%attr(755,root,root) %{_bindir}/qemu-ppc64
621%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
622%attr(755,root,root) %{_bindir}/qemu-s390x
623%attr(755,root,root) %{_bindir}/qemu-sh4
624%attr(755,root,root) %{_bindir}/qemu-sh4eb
625%attr(755,root,root) %{_bindir}/qemu-sparc
626%attr(755,root,root) %{_bindir}/qemu-sparc32plus
627%attr(755,root,root) %{_bindir}/qemu-sparc64
628%attr(755,root,root) %{_bindir}/qemu-unicore32
629%attr(755,root,root) %{_bindir}/qemu-x86_64
630
631%files system-alpha
632%defattr(644,root,root,755)
633%attr(755,root,root) %{_bindir}/qemu-system-alpha
634
635%files system-arm
636%defattr(644,root,root,755)
637%attr(755,root,root) %{_bindir}/qemu-system-arm
638
639%files system-cris
640%defattr(644,root,root,755)
641%attr(755,root,root) %{_bindir}/qemu-system-cris
642
643%files system-lm32
644%defattr(644,root,root,755)
645%attr(755,root,root) %{_bindir}/qemu-system-lm32
646
647%files system-m68k
648%defattr(644,root,root,755)
649%attr(755,root,root) %{_bindir}/qemu-system-m68k
650
651%files system-microblaze
652%defattr(644,root,root,755)
653%attr(755,root,root) %{_bindir}/qemu-system-microblaze
654%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
655
656%files system-mips
657%defattr(644,root,root,755)
658%attr(755,root,root) %{_bindir}/qemu-system-mips
659%attr(755,root,root) %{_bindir}/qemu-system-mipsel
660%attr(755,root,root) %{_bindir}/qemu-system-mips64
661%attr(755,root,root) %{_bindir}/qemu-system-mips64el
662
663%files system-or32
664%defattr(644,root,root,755)
665%attr(755,root,root) %{_bindir}/qemu-system-or32
666
667%files system-ppc
668%defattr(644,root,root,755)
669%attr(755,root,root) %{_bindir}/qemu-system-ppc
670%attr(755,root,root) %{_bindir}/qemu-system-ppc64
671%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
672
673%files system-s390x
674%defattr(644,root,root,755)
675%attr(755,root,root) %{_bindir}/qemu-system-s390x
676
677%files system-sh4
678%defattr(644,root,root,755)
679%attr(755,root,root) %{_bindir}/qemu-system-sh4
680%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
681
682%files system-sparc
683%defattr(644,root,root,755)
684%attr(755,root,root) %{_bindir}/qemu-system-sparc
685%attr(755,root,root) %{_bindir}/qemu-system-sparc64
686
687%files system-unicore32
688%defattr(644,root,root,755)
689%attr(755,root,root) %{_bindir}/qemu-system-unicore32
690
691%files system-x86
692%defattr(644,root,root,755)
693%attr(755,root,root) %{_bindir}/qemu-system-i386
694%attr(755,root,root) %{_bindir}/qemu-system-x86_64
695
696%files system-xtensa
697%defattr(644,root,root,755)
698%attr(755,root,root) %{_bindir}/qemu-system-xtensa
699%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.029655 seconds and 4 git commands to generate.