]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- begin update to 0.9.0
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4# - kqemu MODULE could be distributable if somebody bothers to contact qemu
5# author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
6# (but only in source form as distribution of linked module would be
7# violation of GPL)
8#
9# Conditional build:
10%bcond_without kqemu # disable QEMU ACCELERATOR support
11%bcond_with cflags_passing # with passing rpmcflags to Makefiles
12%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
13# Note that gcc4 build is very problematic and not supported by qemu team
14%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
15%bcond_without dist_kernel # without distribution kernel
16%bcond_with kernel # build kqemu KERNEL MODULES (see License)
17%bcond_without smp # don't build SMP module
18%bcond_without userspace # don't build userspace utilities
19#
20%define _kqemu_version 1.3.0pre9
21%define _rel 2
22Summary: QEMU CPU Emulator
23Summary(pl): QEMU - emulator procesora
24Name: qemu
25Version: 0.8.2
26Release: %{_rel}%{?with_kqemu:k}
27License: GPL
28Group: Applications/Emulators
29#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
30Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
31# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
32Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
33# NoSource1-md5: 27888c3220844ad360a6a23345fa1bcb
34NoSource: 1
35Patch0: %{name}-nostatic.patch
36Patch1: %{name}-cc.patch
37Patch2: %{name}-longjmp.patch
38Patch3: %{name}-dot.patch
39Patch4: %{name}-gcc4_x86.patch
40Patch5: %{name}-gcc4_ppc.patch
41Patch6: %{name}-nosdlgui.patch
42Patch7: %{name}-ifup.patch
43# Proof of concept, for reference, do not remove
44Patch8: %{name}-kde_virtual_workspaces_hack.patch
45# http://gwenole.beauchesne.info/en/projects/qemu
46Patch9: %{name}-0.8.0-gcc4-hacks.patch
47Patch10: %{name}-0.7.0-gcc4.patch
48Patch11: %{name}-0.7.2-gcc4-opts.patch
49Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
50URL: http://fabrice.bellard.free.fr/qemu/
51%if %{with kernel} && %{with dist_kernel}
52BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
53BuildRequires: rpmbuild(macros) >= 1.330
54%endif
55%if %{with userspace}
56BuildRequires: SDL-devel >= 1.2.1
57BuildRequires: alsa-lib-devel
58%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
59BuildRequires: perl-tools-pod
60BuildRequires: tetex
61BuildRequires: sed >= 4.0
62%endif
63Requires: SDL >= 1.2.1
64# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
65ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68# some SPARC boot image in ELF format
69%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
70
71%description
72QEMU is a FAST! processor emulator. By using dynamic translation it
73achieves a reasonnable speed while being easy to port on new host
74CPUs. QEMU has two operating modes:
75
76- User mode emulation. In this mode, QEMU can launch Linux processes
77 compiled for one CPU on another CPU. Linux system calls are converted
78 because of endianness and 32/64 bit mismatches. Wine (Windows
79 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
80
81- Full system emulation. In this mode, QEMU emulates a full system,
82 including a processor and various peripherials. It can also be used to
83 provide virtual hosting of several virtual PC on a single server.
84
85%description -l pl
86