]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- small patch to gcc33
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
5# Conditional build:
6%bcond_with kqemu # with QEMU accelerator module
7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
8%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
9%bcond_without dist_kernel # without distribution kernel
10%bcond_without kernel # don't build kernel modules
11%bcond_without smp # don't build SMP module
12%bcond_without userspace # don't build userspace utilities
13
14%define _kqemu_version 0.7.2
15#
16Summary: QEMU CPU Emulator
17Summary(pl): QEMU - emulator procesora
18Name: qemu
19Version: 0.8.0
20%define _rel 1
21Release: %{_rel}%{?with_kqemu:k}
22License: GPL
23Group: Applications/Emulators
24#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
25Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
26# Source0-md5: eb175b26583280706fe7e4d8910d320d
27%if %{with kqemu}
28Source1: http://fabrice.bellard.free.fr/qemu/kqemu-%{_kqemu_version}.tar.gz
29# NoSource1-md5: 02cfdecda90458d6393781496ec6b48b
30NoSource: 1
31%endif
32Patch0: %{name}-nostatic.patch
33Patch1: %{name}-DESTDIR.patch
34Patch2: %{name}-longjmp.patch
35Patch3: %{name}-dot.patch
36Patch4: %{name}-initrd_load_addr.patch
37Patch5: %{name}-gcc4_x86.patch
38Patch6: %{name}-gcc4_ppc.patch
39Patch7: %{name}-parallel.patch
40Patch8: %{name}-nosdlgui.patch
41Patch9: %{name}-ifup.patch
42URL: http://fabrice.bellard.free.fr/qemu/
43BuildRequires: SDL-devel >= 1.2.1
44%if %{with kqemu} && %{with dist_kernel}
45BuildRequires: kernel-module-build >= 2.6.7
46%endif
47BuildRequires: rpmbuild(macros) >= 1.217
48BuildRequires: sed >= 4.0
49Requires: SDL >= 1.2.1
50ExclusiveArch: %{ix86} %{x8664} ppc
51# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54# some SPARC boot image in ELF format
55%define _noautostrip .*%{_datadir}/qemu/proll.elf
56
57%if !%{with kqemu}
58%undefine with_kernel
59%endif
60
61%description
62QEMU is a FAST! processor emulator. By using dynamic translation it
63achieves a reasonnable speed while being easy to port on new host
64CPUs. QEMU has two operating modes:
65
66- User mode emulation. In this mode, QEMU can launch Linux processes
67 compiled for one CPU on another CPU. Linux system calls are converted
68 because of endianness and 32/64 bit mismatches. Wine (Windows
69 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
70
71- Full system emulation. In this mode, QEMU emulates a full system,
72 including a processor and various peripherials.
73 It can also be used to provide virtual hosting of several
74 virtual PC on a single server.
75
76%description -l pl
77