]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- added patch to fix crash when using qemu with NICs connected via socket
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
5# Conditional build:
6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
8%bcond_with dosguest # add special patch when use with DOS as guest os
9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
10# Note that gcc4 build is very problematic and not supported by qemu team
11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
12%bcond_without dist_kernel # without distribution kernel
13%bcond_without kernel # build kqemu KERNEL MODULES
14%bcond_without up # don't build up module
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
17#
18# no kernel kqemu module for ppc
19%ifarch ppc
20%undefine with_kqemu
21%undefine with_kernel
22%endif
23%define _kqemu_version 1.3.0pre11
24%define _rel 4
25Summary: QEMU CPU Emulator
26Summary(pl): QEMU - emulator procesora
27Name: qemu
28Version: 0.9.0
29Release: %{_rel}%{?with_kqemu:k}
30License: GPL
31Group: Applications/Emulators
32#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
33Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
34# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
35Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
36# Source1-md5: 970521874ef8b1ba4598925ace5936c3
37Patch0: %{name}-nostatic.patch
38Patch1: %{name}-cc.patch
39Patch3: %{name}-dot.patch
40Patch4: %{name}-gcc4_x86.patch
41Patch5: %{name}-gcc4_ppc.patch
42Patch6: %{name}-nosdlgui.patch
43Patch7: %{name}-ifup.patch
44# Proof of concept, for reference, do not remove
45Patch8: %{name}-kde_virtual_workspaces_hack.patch
46# http://gwenole.beauchesne.info/en/projects/qemu
47Patch9: %{name}-0.8.0-gcc4-hacks.patch
48Patch11: %{name}-0.7.2-gcc4-opts.patch
49#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
50Patch13: %{name}-dosguest.patch
51# Fix crash when using qemu instances with NICs connected via socket
52# This patch will be obsolete in versions after 0.9.0
53Patch14: %{name}-0.9.0-remove-iohandlers.patch
54URL: http://fabrice.bellard.free.fr/qemu/
55%if %{with kernel} && %{with dist_kernel}
56BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
57BuildRequires: rpmbuild(macros) >= 1.330
58%endif
59%if %{with userspace}
60BuildRequires: SDL-devel >= 1.2.1
61BuildRequires: alsa-lib-devel
62%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
63BuildRequires: perl-tools-pod
64BuildRequires: tetex
65BuildRequires: sed >= 4.0
66%endif
67Requires: SDL >= 1.2.1
68# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
69ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72# some SPARC boot image in ELF format
73%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
74
75%description
76QEMU is a FAST! processor emulator. By using dynamic translation it
77achieves a reasonnable speed while being easy to port on new host
78CPUs. QEMU has two operating modes:
79
80- User mode emulation. In this mode, QEMU can launch Linux processes
81 compiled for one CPU on another CPU. Linux system calls are converted
82 because of endianness and 32/64 bit mismatches. Wine (Windows
83 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
84
85- Full system emulation. In this mode, QEMU emulates a full system,
86 including a processor and various peripherials. It can also be used to
87 provide virtual hosting of several virtual PC on a single server.
88
89%description -l pl
90