]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- rel 3
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
5# Conditional build:
6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
8%bcond_with dosguest # add special patch when use with DOS as guest os
9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
10# Note that gcc4 build is very problematic and not supported by qemu team
11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
12%bcond_without dist_kernel # without distribution kernel
13%bcond_without kernel # build kqemu KERNEL MODULES
14%bcond_without up # don't build up module
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
17%bcond_with grsec_kernel # build for kernel-grsecurity
18
19%if %{without kernel}
20%undefine with_dist_kernel
21%endif
22%if %{with dist_kernel} && %{with grsec_kernel}
23%define alt_kernel grsecurity
24%endif
25
26# no kernel kqemu module for ppc
27%ifarch ppc
28%undefine with_kqemu
29%undefine with_kernel
30%endif
31
32%if "%{_alt_kernel}" != "%{nil}"
33%undefine with_userspace
34%endif
35
36%define kqemu_version 1.3.0pre11
37%define qemu_version 0.9.1
38%define pname qemu
39
40%define rel 3
41Summary: QEMU CPU Emulator
42Summary(pl): QEMU - emulator procesora
43Name: %{pname}%{_alt_kernel}
44Version: %{qemu_version}
45Release: %{rel}%{?with_kqemu:k}
46License: GPL
47Group: Applications/Emulators
48#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
49Source0: http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
50# Source0-md5: 6591df8e9270eb358c881de4ebea1262
51Source1: http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
52# Source1-md5: 970521874ef8b1ba4598925ace5936c3
53Patch0: %{pname}-nostatic.patch
54Patch1: %{pname}-cc.patch
55Patch3: %{pname}-dot.patch
56Patch4: %{pname}-gcc4_x86.patch
57Patch5: %{pname}-gcc4_ppc.patch
58Patch6: %{pname}-nosdlgui.patch
59Patch7: %{pname}-ifup.patch
60# Proof of concept, for reference, do not remove
61Patch8: %{pname}-kde_virtual_workspaces_hack.patch
62# http://gwenole.beauchesne.info/en/projects/qemu
63Patch9: %{pname}-0.8.0-gcc4-hacks.patch
64Patch11: %{pname}-0.7.2-gcc4-opts.patch
65#Patch12: %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
66Patch13: %{pname}-dosguest.patch
67Patch14: %{pname}-ppc_old_binutils.patch
68URL: http://fabrice.bellard.free.fr/qemu/
69%if %{with kernel}
70%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
71BuildRequires: rpmbuild(macros) >= 1.330
72%endif
73%if %{with userspace}
74BuildRequires: SDL-devel >= 1.2.1
75BuildRequires: alsa-lib-devel
76%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
77BuildRequires: perl-tools-pod
78BuildRequires: tetex
79BuildRequires: sed >= 4.0
80%endif
81Requires: SDL >= 1.2.1
82# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
83ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86# some SPARC boot image in ELF format
87%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
88
89%description
90QEMU is a FAST! processor emulator. By using dynamic translation it
91achieves a reasonnable speed while being easy to port on new host
92CPUs. QEMU has two operating modes:
93
94- User mode emulation. In this mode, QEMU can launch Linux processes
95 compiled for one CPU on another CPU. Linux system calls are converted
96 because of endianness and 32/64 bit mismatches. Wine (Windows
97 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
98
99- Full system emulation. In this mode, QEMU emulates a full system,
100 including a processor and various peripherials. It can also be used to
101 provide virtual hosting of several virtual PC on a single server.
102
103%description -l pl
104